none
Chkdsk incompatibility in Windows 7 Windows 8 dual boot..

    Question

  • I have been testing the Consumer Preview and Release Preview and this seems to happen in both. 

    When dual booting 7 and 8, and booting back into Windows 7 after running Windows 8, a Chkdsk is requested 80% of the time.

    Situation for this one test, 3 hard drives in GPT configuration.

    SSD Windows 7 UEFI install

    320 GB Windows 8 UEFI install

    2 TB Data drive.

    The system is setup with a parallel (independent) installs so the Windows 7 and Windows 8 drives have EFI system partitons.  I boot to Windows 7 by default and select the Windows 8 Boot Manager during the Boot Device Menu to boot Windows 8. 

    I have been running Windows 7, without the Windows 8 drive connected, fine for some time, and Chkdsk is never required.  Attaching the Windows 8 drive and booting into Windows 7 works most of the time.  Booting into Windows 8 worked fine, but the Windows 7 drive (SSD) was not visible

    I booted back into Windows 7 after shutting down, and a chkdsk was requested, which I cancelled.  After booting into Windows 7, the Windows 8 drive showed up fine, but when running a fsutil dirty query d: command I got the following:

    The file or directory is corrupted and unreadable.. 

    The command worked fine on my Windows 7 drive and the data drive.

    This has been happening for the entire time of the Windows 8 pre-releases.  I normally let the chkdsk run, but once my Windows 8 User Profile was corrupted.  A typical message I might see during a Chkdsk run would be:

    Inserting an index entry with Id 708 into index $SDH of file 9.  And messages such as this occur many times during the chkdsk.

    My assumption is that there is some compatibility issue with Windows 7/Windows 8 chkdsk.  If my setup is incorrect, or not allowed for some reason, please explain a way that will aleviate the chkdsk runs.

    Asus P8Z77-v Pro, i7 2600k, no overclock, 8 G memory

    Thanks

    Tuesday, September 18, 2012 9:18 PM

Answers

  • Hi,

    Windows 8 is designed to close and reopen by faster booting (Hybrid Boot), it has left your system in a hibernated state, with the drives mounted, open and ready to take off as soon as Windows 8 restarts. When a drive is mounted, a little piece of data is written to a standard place on the disk to show it is in use - it is called the "dirty bit".

    This means that the "dirty bit" on the disks that Windows 7 checks on startup is showing on the disks. And then, chkdsk is automatically run to check the integrity of the disks with the "dirty bit" set. Please check the following settings.

    1. Control Panel -> Power Plan
    2. Select "Choose what the power button does" on left hand side.
    3. Click on "Change settings that are currently unavailable".
    4. Uncheck "Turn on fast startup" under shutdown settings.


    Niki Han

    TechNet Community Support

    Thursday, September 20, 2012 7:31 AM
    Moderator

All replies

  • Hi,

    Windows 8 is designed to close and reopen by faster booting (Hybrid Boot), it has left your system in a hibernated state, with the drives mounted, open and ready to take off as soon as Windows 8 restarts. When a drive is mounted, a little piece of data is written to a standard place on the disk to show it is in use - it is called the "dirty bit".

    This means that the "dirty bit" on the disks that Windows 7 checks on startup is showing on the disks. And then, chkdsk is automatically run to check the integrity of the disks with the "dirty bit" set. Please check the following settings.

    1. Control Panel -> Power Plan
    2. Select "Choose what the power button does" on left hand side.
    3. Click on "Change settings that are currently unavailable".
    4. Uncheck "Turn on fast startup" under shutdown settings.


    Niki Han

    TechNet Community Support

    Thursday, September 20, 2012 7:31 AM
    Moderator
  • Thank you, this works for me! (After a long search for a solution [fsutil, chkntfs and so on).

    Avort


    • Edited by Avort Friday, July 26, 2013 5:04 PM wrong nickname
    Friday, July 26, 2013 4:07 PM