none
Windows 7 Cannot reliably access Windows XP Shares

    Question

  • I am hoping someone can provide a definitive solution to this issue.  I have seen many threads covering similar problems and have tried several of the recommendations summarized below.

    The environment..
    • I have several PCs connected to a router acquiring addresses via DHCP.  There is a mix of XP, Vista and Windows 7.
    • One XP Professional PC is used to provide shared folders.
    • Other XP and Vista PCs can connect to this host and access the shares without issue
    • The Windows 7 Professional PC cannot connect all the time to the XP Server (More later)
    • All PCs including Windows 7 can get to the internet through the router.
    • The Windows 7 PC has no problem seeing and using shares on a Vista Home Premium PC.

    Based on suggestions in other threads, I have tried:
    1. Changing the workgroup and changing it back.
    2. Accessing the XP Shares using an IP address (ie \\192.168.1.151\Data)
    3. Modifying Local Security Policies on the Windows 7 PC (LAN Manager authentication level, 128 bit Encryption..)
      http://www.tannerwilliamson.com/2009/09/windows-7-seven-network-file-sharing-fix-samba-smb/
    4. Turning off the Windows 7 “Home Group”

    Symptom:

    When Windows 7 cannot connect to the XP server via Start: \\Server\Share the error is “Windows cannot Access \\Server\Share.  Check the Spelling.  Otherwise there may be a problem with your network.  To try and identify and diagnose..”  The Diagnosis finds nothing.

    Results:

    Changing the workgroup and rebooting is sometimes effective, but not always.  Also, sometimes the XP server can be accessed via an IP address but not its name, but this is not 100% either.  I have no clue why changing the workgroup at times offers temporary relief.  But it is not permanent.  The next reboot can result in no ability to connect.

    Can anyone provide an explanation of what is happening and how to correct it

    Wednesday, February 09, 2011 12:22 AM

Answers

  • Hi,

    First, I suggest disabling both sides firewall for a test.

    Because to resolve the NetBIOS name need to use NetBIOS over TCP/IP, so maybe the option was unchecked.

    So follow the article below to check the both sides status.

    http://support.microsoft.com/kb/204279


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, February 11, 2011 3:40 AM
    Moderator
  • I wanted to close out this thread that I starte over a month ago.

    Disabling the firewall on the XP server worked for awhile but access from the Windows 7 client again became problematic.  (The Windows 7 client's firewall was never enabled Juke).  To fix the problem, I decided to define the XP server's IP address as static and place an entry in the Windows 7 lmhosts file.  This worked and was reliable.  (I could issue Start: \\Server\Share and connect to the XP Server from Windows 7, and make the connection persistent).  I then restored the Firewall on the XP server and enabled it on the Windows 7 client since neither impacted connectivity at this point.  All was good.

    I later found an article about enabling network discovery on Windows XP.

    http://technet.microsoft.com/en-us/library/cc749119(WS.10).aspx

    While this was not terribly important to me I figured that I tried so many other things, why not this.  I followed the directions for installation under XP SP3 which is further down in the thread.  While this should not have any impact on the name resolution issue, I removed the lmhosts entry and reconfigured the XP server as a dynamically assigned IP address.  To my delight, the name resolution was no longer an issue.  That was 2 weeks ago and I haven't had any issues since with Windows 7 connectivity to the XP server.

     

     

     

    • Marked as answer by Ed Derz Wednesday, March 23, 2011 1:14 AM
    Wednesday, March 23, 2011 1:12 AM

All replies

  • I am having the exact same problem.  I have 2 new win 7 laptops and both are showing the erratic behavior that you are describing.  I have done all the things you have tried except #3.  I have also turn off all windows firewalls.

    Any help would be appreciated.

    Wednesday, February 09, 2011 3:57 AM
  • Hi,

    First, I suggest disabling both sides firewall for a test.

    Because to resolve the NetBIOS name need to use NetBIOS over TCP/IP, so maybe the option was unchecked.

    So follow the article below to check the both sides status.

    http://support.microsoft.com/kb/204279


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, February 11, 2011 3:40 AM
    Moderator
  • I have read Juke Chou's reply and it is helpful to a point.  I believe I am getting closer to the problem resolution.  I also tried other items below as suggested..

    1. Verified Registry setting
          [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
           "LmCompatibilityLevel"=dword:00000001
    2. Verified that The Windows 7 PC adapters had the "Default" setting for WINS (IP4)
    3. Found Multiple Microsoft Hidden 6to24 adapters in device manager on the Win 7 client..
           According to MS, these are created when you restart without disabling "Virtual WiFi Adapter"
           I disabled them per instructions by starting in Safe mote and deleting them one by one
           I also removed the Microsoft ISATAP Adapters and Teredo Tunneling adapter.
           I then disabled the "Virtual WiFi Adapter"
           While this did not fix the Name Resolution issue, It made connection via IP address rock solid.
           (ie \\192.168.1.151\Data now works reliably, but still can's connect as \\MyXpServer\Data)

    In reading Juke's suggested thread, (http://support.microsoft.com/kb/204279 ) I found a difference in the Windows 7 and other clients.  The windows XP server supports NetbiosSmb device (which is the "NetBIOS-less" transport) and the NetBT_Tcpip device (which is the NetBIOS over TCP transport).  Vista also supports both, but the Windows 7 PC only supports NetBT_Tcpip device.

    I also took Juke's suggestion to temporarily turn off both firewalls as a test and I was able to connect from Windows 7 to XP using the server name..  So Perhaps there is an issue with the Windows firewall on XP not opening up all the ports required by windows over NetBIOS networking??  (137/UDP, 137/TCP, 138/UDP and 139/TCP)  I assume I can open those up.  It is also possible I got the Windows 7 support backwards and need to open up 445 (TCP and UDP) for Net Bios-less traffic.  However, Messing around with windows XP firewall settings seems to be a non-ideal solution..

    Note that I confirmed the Windows 7 IP4 adapter WINS settings are set to default which should permit both naming methods, but it appears to only be supporting NetBIOS networking.  Is there anything that can be configured on the Windows 7 client to support both (like Vista) so I don't have to modify the XP Firewall?

         C:\>net config redirector
         Workstation active on
            NetBT_Tcpip_{E04E6C20-3C2A-497E-AA24-A88A4940A3FE} (70F1A12B628D)
         Software version                     Windows 7 Professional

         C:\>net config redirector
         Workstation active on
            NetbiosSmb (000000000000)
            NetBT_Tcpip_{927949D0-32C1-4E84-B44C-EBAC3721AFA7} (002268AC3FD0)
         Software version                     Windows Vista (TM) Home Premium

    Any more advice short of modfiying the XP Firewall?

    -Ed

    Wednesday, February 16, 2011 12:51 AM
  • Hi,

    I would like to advise that Windows 7 support NetbiosSMB.

    Use "net config server" to check it.

    So according your description, this issue is caused by the firewall blocked the package.

    Try to open all the ports which the NetbiosSMB or Netbios_tcpip used in the firewall.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, February 16, 2011 2:42 AM
    Moderator
  • Juke,

    At this point I am confident I can open up ports on the XP's firewall so that Windows 7 will be able to resolve the workstation name.  I am wondering if this is the right fix though.

    Why are other XP and Vista Clients able to see the XP server wihout making firewall changes?  Do I need to change all the firewall settings on all potential XP servers?  I would think that it might be better to have the Windows 7 PC configured in a way that makes it behave like Vista.  I admit I'm confused about which protocol Windows 7 is using, but something is different.

    However, If I don't come up with a better answer soon, I'll make the firewall change.

    -Ed

     

     

     

    Wednesday, February 16, 2011 9:59 PM
  • Hi,

    Not only Windows XP's firewall blocks the packages, maybe the Windows 7 also blocks it.

    So you may turn off the Windows 7 's firewal for a test or add the ports in the Windows 7's firewall.

    Thanks.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, February 17, 2011 2:11 AM
    Moderator
  • I wanted to close out this thread that I starte over a month ago.

    Disabling the firewall on the XP server worked for awhile but access from the Windows 7 client again became problematic.  (The Windows 7 client's firewall was never enabled Juke).  To fix the problem, I decided to define the XP server's IP address as static and place an entry in the Windows 7 lmhosts file.  This worked and was reliable.  (I could issue Start: \\Server\Share and connect to the XP Server from Windows 7, and make the connection persistent).  I then restored the Firewall on the XP server and enabled it on the Windows 7 client since neither impacted connectivity at this point.  All was good.

    I later found an article about enabling network discovery on Windows XP.

    http://technet.microsoft.com/en-us/library/cc749119(WS.10).aspx

    While this was not terribly important to me I figured that I tried so many other things, why not this.  I followed the directions for installation under XP SP3 which is further down in the thread.  While this should not have any impact on the name resolution issue, I removed the lmhosts entry and reconfigured the XP server as a dynamically assigned IP address.  To my delight, the name resolution was no longer an issue.  That was 2 weeks ago and I haven't had any issues since with Windows 7 connectivity to the XP server.

     

     

     

    • Marked as answer by Ed Derz Wednesday, March 23, 2011 1:14 AM
    Wednesday, March 23, 2011 1:12 AM