Screen resolution Changes when Switching Users (2)


  •      Okay, I see that your problem is that you are most likely just a user account on the machines. You need to make sure that any changes you attempt are done using administrator-level priveleges, and that you are the owner of your own account under the c:\users directory! And why would you be using fast switching of accounts in a business environment anyways ? grant yourself the permissions you need and use the one account if you want everything to stay put ! and, by the way, I'm sure you got the right drivers from nvidia... but did you get the right ones from the makers of your processor's website for the motherboard's chipset which supports your graphics card ? no? then get them!

         "http://downloadcenter.intel.com ".

         "http://support.amd.com ".      They are free, but you need admin rights to install them.

    Then try MICROSOFT'S new, fully automated support center, which can help resolve most system misconfigurations and symptoms with only a few mouse clicks...and it is free to try and use, also!

          "http://support.microsoft.com/fixit/default.aspx ".

    "While there is NO SUCH THING as a WRONG QUESTION, the EASIEST THING TO GET in the world is a WRONG ANSWER!" 15 years of hands-on-how-to; I "DO" WINDOWS !!!
    Thursday, November 04, 2010 7:51 AM

All replies

  • I would like to get a word from Microsoft that they actually acknowledge the issue. Can't believe it takes many months since the issue has been made public in Microsoft's own forums and nothing has happened.
    Sunday, February 08, 2009 8:21 PM
  • As apparently posting here does not accomplish anything, would anyone know what the next steps might be?

    After purchasing vista you had 90 days or something where you could call them and get support, but that time has expired a long time ago.
    Saturday, February 21, 2009 1:00 PM
  • Been lurking, following this thread for months. Same problem with Vista Ultimate, ATI Radeon HD 2600 XT. My wife has given up on using our shared computer due to the inability to use Fast User Switching. And I can't log in remotely using Remote Desktop Connection because it also resets the resolution. I cannot count the number of times I've had to reinstall drivers.

    HELLO??? Is anyone listening???
    Monday, February 23, 2009 6:53 AM
  • Ditto here.

    Vista Home Premium SP1, fully up to date with an Nvidia 8800GTX card with up to date drivers.

    The resolution is randomly reset from 1920x1200 to 800x600 on switching users.

    I too have been lurking for some time and am amazed to see how little progress has been made or MS attention given. It seems we can only hope it is magically fixed by some other change in SP2.

    Monday, February 23, 2009 7:12 PM
  • I hope MS doesn't think they can sit on their thumbs and ignore this issue, then recommend Windows 7 as a fix when it comes out because the problem exists in their yet to be released OS!  Yeah, I've been battling this issue for a few weeks now with Windows 7 Ultimate Beta 2.

    My PC has a 8800 GTS 320MB using driver 181.20.  I have a 22" monitor and a 19" monitor connected (1680x1050 and 1280x1024).  I'm not using fast user switching, Windows 7 is on my work domain.  Sometimes when I lock my PC, it will change monitor #2 (the 22" which is set as primary) to 800x600.  This sounds like the same thing since bringing up the locked/logon screen is essentially the same screen as fast user switching uses.  I can set it to any resolution except the native 1680x1050.  If i set the color depth to 16bit, i can set it back to 1680x1050 but cannot set color depth back to 32bit with it dropping back to 800x600 or 1024x768.  Sometimes while using the computer, monitor #1 (the 19") will drop to 800x600. 

    Logging out and then back in will set the resolution back to native.  Or if I'm busy, I'll just set the color depth back to 16bit so i can get the native rez back to finish what i was doing... but have you seen how freakin bad the Windows 7 taskbar looks at 16bit color depth?!

    Also wanted to add when this happens, the wallpaper goes away and I'm left with a black background. 
    Tuesday, February 24, 2009 10:24 PM
  • Hi,

    Just to update you guys. I wrote to Microsoft gave this link. Here is the reply I got: 

    Thank you for contacting Microsoft Online Support Service. My name is Saber, and I am glad to work with you. 
    First, I would like to apologize for your support request being unexpectedly delayed. Please be assured you have successfully contacted the correct support team and I will be working with you to address your concerns as quickly as possible.
    From the problem description, I understand that the resolution of the computer will drop to 800*600 when we switch to another user account. If there has been any misunderstanding, please let me know.
    I understand the inconvenience you have experienced. Please be assured that I will do my best to help you.
    This issue can be caused by the conflict of the Video card driver. Please let me know the vendor and model of your video card. 
    Then take below steps to disable the TMM (Microsoft Transient Multi-Monitor Manager).
    Let’s try to disable this TMM to see if it helps or not.
    1, Go to “Start”, type in “Task Scheduler” and right click the “Task Scheduler” select “run as administrator”. Continue.
    2, Click on “Task Scheduler (local)”, the window will change. Look at the Active Tasks.
    3, Find the TMM, double click on it.
    4, We may find that the TMM is running, click on the TMM (high light it), we can find the option “Disable” on the right panel.
    5, Click on “Disable”.
    Can these help?
    If the issue persist, please help me collect your system information for further research. 

    Wednesday, February 25, 2009 9:33 AM
  •  I have tried the TMM suggestion, which I saw elsewhere. It has not fixed my problem.

    As I said above, I have an Nvidia card so this is not an ATI-specific problem.
    Wednesday, February 25, 2009 12:21 PM
  • I have the exact same problem too, has been driving me insane for months.
    I have experienced it with Vista on an NVidia 8800GT on both an AMD processor and an intel.

    After reading all comments on this and the previous thread, I do think that it is quite likely that we all share some common application that is running in the background and f-ing up our ability to use fast user switching without dropping to 800x600 at some point.

    If a few of us post a HijackThis running processes log, maybe we'll be able to find some common application that sticks out.

    Here's mine, I'll appreciate it if others experiencing this problem post theirs too so we'll have a chance of figuring this out:

    C:\Program Files\Windows Defender\MSASCui.exe
    C:\Program Files\Intel\Intel Matrix Storage Manager\IAAnotif.exe
    C:\Program Files\Kaspersky Lab\Kaspersky Anti-Virus 2009\avp.exe
    C:\Program Files\LogMeIn\x86\LogMeInSystray.exe
    C:\Program Files\Java\jre6\bin\jusched.exe
    C:\Program Files\Logitech\QuickCam10\QuickCam10.exe
    C:\Program Files\LogMeIn\x86\LMIGuardian.exe
    C:\Program Files\Common Files\LogiShrd\LComMgr\Communications_Helper.exe
    C:\Program Files\Windows Sidebar\sidebar.exe
    C:\Users\Ofer Tal\AppData\Roaming\SanDisk\Sansa Updater\SansaDispatch.exe
    C:\Program Files\Skype\Phone\Skype.exe
    C:\Program Files\Windows Media Player\wmpnscfg.exe
    C:\Program Files\Common Files\LogiShrd\LComMgr\LVComSX.exe
    C:\Program Files\Common Files\Logishrd\LQCVFX\COCIManager.exe
    C:\Program Files\Microsoft Office\Office12\OUTLOOK.EXE
    C:\Program Files\Siber Systems\AI RoboForm\RoboTaskBarIcon.exe
    C:\Users\Ofer Tal\AppData\Local\Plaxo\\PlaxoHelper_en.exe
    C:\Program Files\Mozilla Firefox\firefox.exe
    C:\Program Files\Common Files\Adobe\Updater6\Adobe_Updater.exe
    C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

    Tuesday, March 03, 2009 7:39 AM

  • Here's mine (Windows7): 

    C:\Program Files\Microsoft IntelliType Pro\itype.exe
    C:\Program Files\AVG\AVG8\avgtray.exe
    C:\Program Files\Realtek\Audio\HDA\RtHDVCpl.exe
    C:\Program Files\Windows Sidebar\sidebar.exe
    C:\Program Files\Internet Explorer\iexplore.exe
    C:\Program Files\Internet Explorer\iexplore.exe
    C:\Program Files\Internet Explorer\iexplore.exe
    C:\Program Files\Microsoft Office\Office12\OUTLOOK.EXE
    C:\Program Files\AVG\AVG8\avgcsrvx.exe
    C:\Program Files\Trillian\trillian.exe

    And for what it's worth, I find no mention of TMM in the task scheduler to disable.
    Thursday, March 05, 2009 5:14 PM
  • Hi,

    Update from Microsoft support:

    I understand that the issue still persist.
    Since this issue occurs when we switch to another user account, some startup programs may cause this issue too.
    This time let’s try to use the computer in the Clean Boot Mode to see if the issue persist or not.
    Boot in Clean Boot mode
    Please disable all startup items and third party services when booting to avoid:
    1. Click "Start", type: MSCONFIG in the search box and press Enter.
    Note: Please click "Continue" if the "User Account Control" window pops up.
    2. Click "Services", check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).
    3. Click "Startup", click "Disable All", click "OK" and restart your computer.
    Note: Temporarily disabling the Startup Group only prevents the startup programs from loading at startup. This shouldn't affect the system or other programs. We can manually run these programs later.
    Keep this computer in this mode to see if the issue will occur in this mode or not.
    To restore the computer to use a Normal Startup, repeat step 1 above. Then click "Normal Startup" on the General tab, click "OK", and then restart the computer.
    Thank you for your effort and patience. 

    I'm waiting for your reply.
    Best regards,
    Saber Fang

    Friday, March 06, 2009 6:00 PM
  • Disabling startup programs didnt solve it for me. Btw, nVidia thinks this must be something with the Monitor and its firmware. 
    Sunday, March 08, 2009 6:08 PM
  • Disabling startup items didn't fix this for me either.

    Is anyone have this issue that is only running a single monitor? 
    Monday, March 09, 2009 6:35 PM
  • Update from Microsoft support:

    According to our previous troubleshooting information, the issue can be caused by the following factors:

    1.   The display card driver is corrupted.

    2.   The BIOS or motherboard driver is not up to date.

    To further troubleshoot this issue, I suggest we try these steps:

    Uninstall and reinstall the display card driver


    Please according to the display card model you are using, refer to one of the following links to download and save the display card driver first.

    ATI: http://ati.amd.com/support/driver.html

    Intel: http://downloadcenter.intel.com/default.aspx

    nVidia: http://www.nvidia.com/Download/index.aspx?lang=en-us

    Please Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.

    1. Click Start Menu, type “devmgmt.msc” (without quotation marks) in the “Start Search” box and press Enter.

    2. Double click to expand "Display Adapters".

    3. Right click your display card and click "Uninstall".

    4. Restart the computer and reinstall it to check the issue.

    Thursday, March 12, 2009 7:35 PM
  • TMM tip by amdidi solved this for me. BUT the instructions were slightly wrong.

    TMM was on my Task Scheduler on MobilePC category, and you have to click on "end" first, and then disable. I also disabled this task from properties.

    After that the resolution did not change anymore (in my Vista 32-bit with nVidia 9500 M GS).

    Best Regards,


    Friday, March 13, 2009 6:18 AM
  • Hi guys,

    Good to know that TMM solved it for Mr VesaS. It didnt work for me. Out of frustration, I finally formatted my PC, installed everything fresh. And guess what, even that didnt solve my problem. So this can be a hardware issue? Microsoft has adviced me to update my Bios. So if you guys have tried everything else try a Bios update as well. 
    Sunday, March 15, 2009 4:10 AM
  • nVidia came out with another driver for Windows 7, 181.71.  I installed that and have noticed Windows and/or nVidia is handling the issue more gracefully (so far, at least). 

    When I have locked my workstation (Windows key-L) and the logon screen has dropped back to 800x600, but now the image of the logon screen is now in the upper left hand corner of my primary monitor, like the video signal is still 1680x1050, but the image is only 800x600; black areas on the right and bottom of the image.   Then after unlocking the workstation, everything is back to normal and working fine.
    Tuesday, March 17, 2009 2:33 PM
  • I posted a hijackthis process list a few weeks ago, and only had 1 person reply with his list. There were no obvious 3rd party applications common to both our lists. We were both runing the vista/win7 sidebar, so I disabled it on all accounts on my vista32 installation, that didn't stop the resolution from switching to 800x600 when switching users.

    I tried the TMM solution, and it seemed to work for a few days (usually, my resolution gets stuck at 800x600 at least once in 36 hours when multiple users are logged in) but I believe that was just coincidental, it started happening again.

    Last night I installed the latest nVidia whql drivers for my 8800GT (182.08) and had another "incident" just a few minutes ago.

    Apparently all of us have SOMETHING in common, either in our software or hardware configuration, we have to find out what it is.

    * posts have been made by people with Vista and with Win7
    * posts have been made by people with nVidia and ATI cards
    * posts have been made by people with multiple monitors as well as single displays (like me)
    * I have personally experienced this both on Intel based (Q6600) and on AMD based (Phenom 9550) system using (obviously) very different chipsets.
    * there is no obvious common process running in hijackthis output (very small sample though...)

    What's left???
    Monitor?? I'm using a dell E228WFP what do others experiencing this use?
    Memory?? I'm using 2 gigs Crucial RAM underclocked (SPD is 4-4-4-12, I'm running it at 5-5-5-18 just to take it out of the equation, passed 8 passes of memtest86+)
    Power supply?? I personally had this happen on my system with an Antec EarthWatts and currently with a CoolerMaster Real Power Pro
    Antivirus?? I have had this occur both with BitDefender, and currently with Kaspersky 2009

    This has to be a windows issue... why otherwise would it only happen when switching users (or occasionally when switching to "administrator" mode - UAC) I have never seen it happen on other occasions.   I can run prime95 and 3DMark as long as I want and my system is rock stable.
    Then switch users and it all F-s up...

    Friday, March 20, 2009 3:39 AM
  • Hmmm...
    Looking again at the HijackThis lists I noticed one thing --
    Both My system and Hemi345 are running RtHDVCpl.exe (TealTek HD Audio related)

    Come to think about it, both my current board (GigaByte EP45-UD3R) and my previous board (Asus M3A) use a realtek integrated audio:
    Asus M3A: Realtek® ALC883 8-channel High Definition Audio CODEC
    Gigabyte EP45-UD3R: Realtek ALC889A codec

    Is this the smoking gun???
    Can others experiencing this issue share what audio chip their system uses?

    Friday, March 20, 2009 3:49 AM
  •  My Bios update didnt work! Btw I have realtek integrated audio as well.
    Friday, March 20, 2009 4:02 AM
  • Hi guys,

    I got another email from Microsoft support today. It says:

    I find that you have Kaspersky Anti-Virus 7.0 installed. According to Microsoft Knowledge Base and Kaspersky Knowledge Base, this Antivirus program can cause this issue. I suggested you uninstall the Antivirus program to test the issue

    Disable the Registry Guard


             Open KIS

             Go to settings

             Click Proactive Defense

             Uncheck Enable Registry Guard

             Click Apply

             Click Ok

             Restart your PC


    So guys, do we all have Kasperky antivirus?

    Friday, March 20, 2009 6:33 PM
  • As evident from the HijackThis lists posted earlier, I run Kasperski AV 2009 (and sure -- I'll try at least temporarily to disable their registry guard next) but Hemi is running AVG and experiencing the same issue.
    I also had the same problem in my previous installation of windows when I was running BitDefender as my AV rather than Kasperski.

    I don't have too many hopes for this one, but it's worth a try.

    In the meantime, I updated my RealTek sound drivers to the latest I could find at my mobo manyfacturer's site.

    Saturday, March 21, 2009 5:32 AM
  • I'm using Avast and have this problem, so it is not Kaspersy Anti-Virus that causes it.
    Saturday, March 21, 2009 8:46 PM
  • I have a couple of things to say on this topic:

    (1)  I'm concerned that I've been following this thread (and its predecesor) for 6 months now, and despite many people reporting the same issue with all kinds of different video cards and usage scenarios, I haven't seen one post from Microsoft to say that it is being looked into, etc.  How do we get their attention?

    (2)  Is there maybe a workaround in which one would edit the supported display modes for the video adapter and/or monitor, to removed everything else except the desired resolution, color depth, frequency combo.  For example, I'd like to remove everything except 1920x1200, 32-bit, 60 Hz so that it would never switch to a lower resolution.  Maybe that's just a crazy idea.  Anyone have thoughts on this?

    Sunday, March 22, 2009 12:33 AM
  • Hi All,

    I've been following these threads now for a while and someone previously raised the possibility of this being memory related.

    My wife and I have separate logins on Windows Vista and we both dropped our background (desktop) images (actually I've dropped mine, my wife has a small 300kb image now)...

    so far 2 weeks on, we've not seen the problem...

    Personally, I really DO think this is a Vista bug with it storing/caching off the users display somewhere in mem... and then not being able to restore that image/or re-allocate the memory after switching users.

    So, yes I can't have hi-res photo's of my daughter on my desktop... but it seems to have worked around (or at least reduced the frequency of) this problem fo us :)

    Can anyone confirm/deny this workaround?

    Sunday, March 22, 2009 11:05 PM
  • Hi all,

    I've also problems with this screen resolution change on my HP XW8400 with NVidia Quadro FX1500, two 1920x1200 monitors and Vista SP1 32-bit and McAfee virus scanner and all the latest drivers and patches (and also a hi-res picture as desktop background).

    Few times in a week I use the Remote Desktop connection from my laptop (with 1400x1050 screen). When I login back to my desktop, sometimes one or both monitors have switched to 800x600 resolution. This happens every second week or so and usually requires a reboot to recover.

    Some details: if the second monitor (extended desktop on the right side) switches to 800x600, it also has switched its desktop to the left side of the main monitor. And trying to change the resolution back to 1920x1200 from Display Settings does not work (it lets you to select the higher resolution, but after OK nothing happens).

    I've also tried that TMM tip but it does not help in my case.

    I typically log on to this computer only once and otherwise either keep it locked or in sleep. The screen resolution has never changed after unlock or wake-up. Only the remote desktop connection from my laptop has made the screen(s) to change resolution.

    So it's not only the Switch User operation that does it, but also Remote Desktop connection from other computer could cause this problem. And perhaps it also requires that the user has been logged on for several days (i.e. some memory or resource leak somewhere in Vista or display driver?).

    Tuesday, March 24, 2009 8:03 AM
  • Jari S said:

    Hi all,

    I've also problems with this screen resolution change on my HP XW8400 with NVidia Quadro FX1500, two 1920x1200 monitors and Vista SP1 32-bit and McAfee virus scanner and all the latest drivers and patches (and also a hi-res picture as desktop background).

    Few times in a week I use the Remote Desktop connection from my laptop (with 1400x1050 screen). When I login back to my desktop, sometimes one or both monitors have switched to 800x600 resolution. This happens every second week or so and usually requires a reboot to recover.

    Some details: if the second monitor (extended desktop on the right side) switches to 800x600, it also has switched its desktop to the left side of the main monitor. And trying to change the resolution back to 1920x1200 from Display Settings does not work (it lets you to select the higher resolution, but after OK nothing happens).

    I've also tried that TMM tip but it does not help in my case.

    I typically log on to this computer only once and otherwise either keep it locked or in sleep. The screen resolution has never changed after unlock or wake-up. Only the remote desktop connection from my laptop has made the screen(s) to change resolution.

    So it's not only the Switch User operation that does it, but also Remote Desktop connection from other computer could cause this problem. And perhaps it also requires that the user has been logged on for several days (i.e. some memory or resource leak somewhere in Vista or display driver?).


    I also remote desktop into my machine a lot.  Is this something we all have in common?

    I have found that after it goes to 800x600, switching to 16-bit color allows me to get back to 1920x1200.  It has been stable that way for a few days now, but is not ideal.  I wish there was a real fix for this problem!

    Tuesday, March 24, 2009 8:34 PM
  • I also run into this problem on a very regular basis, but only when switching users, not when logging in remotely (through RDP).

    My configuration is relatively simple:
    - a "standard" desktop PC (E8400, 4GB RAM), Asus P5Q-E MOBO
    - an ATI Radeon 4870 (Sapphire) video card with the latest Catalyst drivers
    - a single Dell monitor (1600x1200) connected via DVI
    - Vista SP1
    - Norton Internet Security 2009 (nice, actually!)

    I am also running a special piece of software that could theoretically cause problems: XPunlimited (which allows me, through RDP, to log into an already open "console" session - i.e. the session I get when I log on locally). But since nobody else seems to be using XPunlimited, I'll assume it has nothing to do with our problem.

    As a longtime software developer, I have tried to investigate the problem as thoroughly as I could, but I must say I haven't found anything so far.

    Here are a few ideas to try out:
    - connect via VGA, in case it's a monitor-related issue (resoution signalling is apparently different between VGA and DVI)
    - once resolution drops to 800x600, try to connect through RDP requesting a 1600x1200x32 resolution (something I can't try myself for lack of an additional 1600x1200 monitor)

    I noticed that several of us are using a Dell monitor. Are some using a monitor from another brand?
    Wednesday, March 25, 2009 4:30 PM
  • My system with the updated drivers did the res change again, so it definately isn't fixed.
    I think you all might be onto something with regards to the wallpaper.  I've noticed that when the res drops to 800x600, the wallpaper also disappears.  A few times I have I unlocked my computer and my wallpaper is gone and the background is black but the res is still okay on both monitors.  But I know that the next time I am going to lock/unlock, one of the monitors is going to drop to 800x600. 

    Something else to note is that when everything was working fine, I purposely disabled the wallpaper and the default color is blue.  But when the wallpaper was disappearing, the background was black.... 

    I am now using a simple wallpaper (<1MB) and I disabled Win7's rotation feature for changing the wallpaper every x minutes.  I haven't had the issue in the last few days. 
    Wednesday, March 25, 2009 4:36 PM
  • Defi said:

    I noticed that several of us are using a Dell monitor. Are some using a monitor from another brand?

    I have an Acer monitor and nVidia GEForce 8800 GTS video card.  I have updated the drivers on both many times without any effect on this problem.

    Thursday, March 26, 2009 12:54 AM
  • Unfortunately, changing the wallpaper (for all users) to a uniform color did not resolve the issue.

    Note that when you think the wallpaper is replaced with black, it is actually a different phenomenon: the screen simply does not refresh.
    It definitely looks like a resource issue.

    Strangely, sometimes when the resolution reverts to 800x600 I can switch back to 1600x1200. It usually doesn't last long though: the next user switch will go back to 800x600.

    What I don't understand is why Microsoft doesn't get involved in this discussion. I wish I still had access to Microsoft's technical support. At least they are not allowed to drop the case until they either recognize the bug or find a solution.

    Another idea: did anyone disable UAC? I personally didn't.
    Tuesday, March 31, 2009 7:06 PM
  • I read somewhere on this thread that the problem appeared with SP1 of Vista. Unfortunately, I've found elsewhere a post dating back to August 2007 from a user experiencing the exact same problem we're facing. And SP1 wasn't out yet back then.

    So this problem is not new to SP1. And therefore unlikely to be fixed in Seven.
    Tuesday, March 31, 2009 7:14 PM
  • Two additional findings:
    1) when you try to switch back to the original resolution, the actual error codereturned by ChangeDisplaySettings is DISP_CHANGE_BADMODE which, according to MSDN, means "The graphics mode is not supported".
    2) sometimes, if you wait a little while, the 1600x1200x32 resolution becomes available again. It's as if some sort of "garbage collection" was taking place. It certainly looks like a GDI resource issue of some sort.
    Tuesday, March 31, 2009 7:50 PM
  • Using a simple wallpaper didn't fix it for me... just helped delay the wallpaper issue and now create new symptoms.  I haven't had the resolution drop back or the wallpaper disappear (PC is on all the time, never reboot it unless there are patches) for about 2 weeks.  Today, the wallpaper will disappear and then both screens went black and I see the cursor changing rapidly from the arrow to the working icon for about 10 seconds.  Finally the desktop comes back sans wallpaper back but then the applications I had open start crashing one by one till nothing but the OS is running so I rebooted. 

    I ran MemTest86 when I first built this PC and everything checked out, but I'll run it again to see if possibly a memory stick is now failing.

    Edit: 4 complete passes of memtest, so the memory checks out fine...
    Thursday, April 09, 2009 3:35 PM
  • Another user with same problem.  Appeared after SP1 install.

    Dell XPS410, single dell 2407WFP monitor with native 1920x1200 resolution.   After switching users it will sometimes change to 1776x1000.  Attempts to set it to either higher value will force the display into 800x600.  Sometimes after it ends up there, it can then be moved back to 1920x1200.  Sometimes not.

    Video card:  Nvidia GeFroce 7900GS.

    This is amazingly annoying and frustrating.

    Thursday, April 16, 2009 1:26 AM
  • I too have a DellXPS 410 running vista sp1 ultimate, Dell 2407WFP monitor with a nvidia GeForce 8600gt running 1920x1200.
    It seems to occur after user switching users and the pc hibernating.  Sometimes both users will be downgraded to 800x600 - sometimes only one.
    Sometimes the select user screen for login will change from that nice blue to a wierd orangish color instead of showning a screen saver - like a pin on the video cable is loose- but moving the mouse switches it out and everything is colored normal again.  Sometimes the UAC security prompt will turn the entire screen black & mousing over the buttons & password edit box will display them.
    The wierdest part tho is that when I go to the display settings to turn it all back from 800x600 to 1920x1200, it shows as 1920x1200 after the refresh - but it looks 800x600.  And other mode works fine.  It's just the top end mode that is borked.

    I noticed it sometime after I upgraded to SP1 and/or I was installing a bunch of VNC clients - but I was unable to rollback because I was low on disk space and the automatic restore cleaned up the snapshots :(
    Saturday, April 25, 2009 8:54 PM
  • Seems like Microsoft is basically ignoring the issue. If there is a fault in a product (as clearly is the case here) consumer can return the faulty product and get his moneys back (depending on the country where the purchase was made of course). That's what I'm gonna do when Windows 7 is released. If the fault is still in Windows 7 I'm f****d.
    Sunday, April 26, 2009 7:24 PM
  • I have been tracking this for months and I thought that I would speak up as well.

    I am having the exact same problem that everyone else is complaining about (Vista Ultimate SP1, NVIDIA 8600GT, dual monitor).  I have tried many video drivers including the latest versions with modified INF files ... no difference.  Usually I have to manually change my resolution EVERY DAY, but frequently I will be forced to reboot to solve the problem.  Seeing as I only ever hibernate my laptop, I am now forced to run at 1920x1200 16-bit color on my main screen (1280x1024 on secondary) and can't use Aero Glass until I shut everything down and reboot.  This is not acceptable.

    Something new?   When running at 1920x1200 16-bit, I can only display backgrounds either centered or tiled.  If I try and do any stretching, the background doesn't show up (even though Windows thinks that it is displaying it).

    I wish that Microsoft would get off their bloated butts and fix this problem... I pay a lot for MSDN and expect some sort of action.  I find it amazing that if this was an issue on an open source project it would have been fixed probably about 3 days after it was revealed.
    Wednesday, April 29, 2009 6:17 PM
  • It's so *** frustrating that whenever I need to use the computer I use the first 10 minutes trying to set the resolution, because sometimes the native resolution works after a few (5-20) tries, but usually after 10 minutes I give up and reboot (which then takes at lest 5 minutes). Is the reason this is not fixed yet that information does not reach someone who knows about something, or the retarded test/project managers don't give a ____?
    Wednesday, April 29, 2009 8:29 PM
  • I keep checking here every few days. It is amazing that such a basic problem is being allowed to fester. As Dude said above, this would have been resolved in days, if not hours with an open source project.
    Thursday, April 30, 2009 8:12 AM
  • I have same problem as well. Started after SP1, I am using nvidia cards.

    Tried re-install of VISA ultimate, problem still returned.

    Just tried buying a new Video card with 1GB video memory using different drivers. Still same issue. Occurs after switch users, then cannot get screen back into 1920x1200, will go back into 1920x1080.

    Does seem like a resource issue as after continual use / switch users, it then wont even stay in 1920x1080 but will only work in a lower resolutions. Of course rebooting allows return back to 1920/1200

    Hello Microsoft????

    Wednesday, May 13, 2009 3:18 PM
  • *bump*

    Almost a year since the issue was brought to Microsoft's attention, and still there is no fix. Are the mods/experts in this forum even working for Microsoft, because if they were, they should've escalated the issue to department(s) that handle these problems already.

    This is the most frustrating issue I've ever had with computers, and I've been using them for 25 years.

    What are the other methods of letting MS know their software has a bug? Because I just can't believe they are so incompetent that they can't fix it, the only possible explanation must be that this forum is a joke and is just for some random reason hosted by MS, and they don't read this themselves at all.
    Sunday, May 17, 2009 12:25 PM
  • Hello,

    I seem to be a bit late in this thread, but I've been experiencing this same problem for the past few years as well, on several re-installations of Windows XP Pro and Vista Business, both before and after Vista SP1. The platforms with which I've had problems:
    Intel Pentium 4 2GHz
    640MB PC133 RAM
    Nvidia GeForce 2 Ti
    Windows XP Pro

    Dual Intel Xeon 2.4GHz processors
    ATI Radeon 2600XT
    Windows Vista Business

    Intel Q9450
    4GB DDR2 RAM
    Nvidia GeForce 9600GSO
    Windows Vista Business

    I use Fast User Switching to share the computer with 2 other people. Locking happens via windows key + L or automatic locking after a screen saver. UAC is disabled, so I haven't had this problem with switching to administrator mode. We have an average of 3 user switches per day, and resolution drops back about once a week.

    Red line through all my systems so far is:
    Avira Antivir Personal Edition
    A MMORPG bot written in VB6 (The helpful kind, not the resource gathering kind)
    Apache Webserver

    I'm also an occasional user of Remote Desktop, though there doesn't seem to be correlation between when I used RDC and when my resolution dropped.

    I'm not sure if the XP problem is the same as the Vista one, but the symptoms sure are identical. Unfortunately I'm no longer using Windows XP anymore, so I can't test comparatively. http://support.microsoft.com/default.aspx/kb/832295/en-us seems promising, though fixed in SP2? I had SP2 installed yet the problem persisted.

    I've noticed the resolution drop occurs when you go from the locked state to the user selection screen. However, with some luck, if I log back in to the last user who was logged in, and switch users again a few times, the resolution pops back. I've also experienced that I can set the resolution back manually, if I choose one step smaller. This works about 2 in 3 times.
    At the moment I'm trying the TMM Disable trick. I'll let you know if it improves any.

    edit: Problem reoccurred about 4 hours after posting. Looks like disabling TMM isn't the way to go for me.
    • Edited by Tsjoepie Thursday, May 21, 2009 4:22 PM
    Tuesday, May 19, 2009 11:41 AM
  • Problem still here too :(

    As for others TMM "fix" does not work.

    A lot of the time logging a user off and back on again, may fix it, but not always. Also, sometimes you can manually change resolution back, but sometimes that fails too, with no error (it simply asks if you want to keep the new resolution, although the resolution has not changed, if you say "OK" sliders move back to 800x600 :().

    If all else fails, a reboot is needed!

    Surely this silly little problem cannot be sn unresolvable bug!!!
    Friday, May 22, 2009 11:09 AM
  • Anyone have any reason to believe that Service Pack 2 will fix this?  I just installed it, so it's too early to tell in my case.  It would be nice...
    Friday, May 29, 2009 5:52 PM
  • It's not fixed in the SP2.
    Saturday, May 30, 2009 3:56 PM
  • I've noted this or a similar issue for some time.
    I have dual monitors one at 1900x1200x32bit and one at 1600x1200x32bit.
    After connecting with RDB a few times with a lower resolution and bit depth the primary monitor will go to 800x600.
    Now I can only go up to 1900x1080.
    The desktop icons will be gone or intermittent as well.
    Keep at this a while longer and the logon screen will be all black, with just a mouse pointer, or possibly blocks of color.
    Keep connecting and disconecting with RDP and logging on locally and eventually the monitors will reverse.
    Time to reboot.
    Not fixed in sp2. Not fixed with updated ATI drivers.
    No-repro from a bug on the SP2 beta.
    I was going to go to W7RC1 to see if that helps.
    Friday, June 05, 2009 9:32 PM
  • Ok, I've been reading through this thread and the old one, and I think I am going to hazard a guess as to what is the common denominator here.. I have only ever experienced this bug while using a flatscreen monitor with a hdmi connector.. Anyone here NOT using a digital output?

    I had huge problems installing windows when I bought this lcd (Samsung Syncmaster 226BW) because the screen refused to go from analog to digital just as windows logonscreen was supposed to pop up.. My guess is that it is a driverproblem but whether in Vista or Graphicscard I couldn't say (Nvidia 8800GT btw). There seems to be a problem with the HDMI-signal when swapping between analog/digital mode. If you have the function, watch the upper left corner of the screen when logging in and out and you will see the digital/analog signal indicator light up, and that's where it effs up for me. Sometimes the screen even goes all black while everything goes on as normal (and my screen still has a signal) which is even more weird..

    Another thing that happens at the same time quite often (which is why I think it is not only Vista OR Nvidia but both) is that my multiple desktops get switched around and sometimes the Vista sidebar is on my monitor desktop while startmenu and explorer is on my other desktop (TV). So it's a weird problem, but I never ever saw it on a fat-screen with a VGA-cable..

    My two cents..
    Tuesday, June 09, 2009 9:09 AM
  • No, unfortunately I've had this issue both with two different CRT monitors, and a LCD flat panel all connected via the VGA output. I'm curious about the influence of remote desktop usage, though.
    I've experienced some of Iteska's issues too, namely the all-black login screen that reveals itself as you mouse over/select elements.
    Tuesday, June 09, 2009 11:40 AM
  • I've experienced some of Iteska's issues too, namely the all-black login screen that reveals itself as you mouse over/select elements.

    Yes, I get this frequently too. And a login screen where some parts of the screen are visible and some black. Even parts of the background may be visible, yet some of it black.

    What is really odd is the way sometimes you can simply change the screen resolution and it will work. Other times it will say it has changed the resolution but in fact it is still 800x600 and when you accept it the slider in the control panel reverts to 800x600. And when this happens sometimes simply trying again will work, or logging off may work, but not always! Logging onto another account may also work, but not always! Normally flicking around trying all these different things will eventually work. Sometimes only a reboot will fix things. It is very unpredictable and seemingly random!
    Wednesday, June 10, 2009 11:13 AM
  • I have all of these symptoms as well (parts of login screen being black, resolution slider not really changing resolution, sometimes being able to change it but sometimes having to reboot, etc.).  It's very strange how random it is.  Although maybe it's not random because it seems to get worse the longer it has been since I rebooted the computer.

    In response to the recent post, I have a flatscreen connected by DVI, so still digital.  I do use remote desktop a lot.  It would be nice to find something we all have in common, because it seems there are many different brands and models of video cards and monitors represented.  I do not think it is a driver problem, which is the standard response to this problem.

    And in response to my last post, it was not fixed in SP2.  I still have the issue :-(
    Wednesday, June 10, 2009 3:29 PM
  • If it helps. I never use Remote Desktop.

    I do use Kaspersky, which was mentioned earlier as a possible factor.
    Wednesday, June 10, 2009 4:36 PM
  • This has been happening to me too.  I have 2 dell 30" monitors, with the one on the right being the secondary.  I'm using an nvidia 7900gs.  No driver change or OS reinstall has changed the symptoms.  The secondary switches to 800x600 quite frequently after my wife or I switch accounts.  The primary monitor usually doesn't have resolution issues when this happens, but it occassionally has been an issue.

    Does anyone that has this issue, run their secondary monitor in a position OTHER than directly to the right of the primary?  Something on the ultramon support site (i don't run ultra mon but was wondering if it could help) said they saw similar behavior if the secondary sits to the right of the primary.
    Monday, June 15, 2009 1:09 AM
  • I've got Symantec SEP 11, no Kaspersky.
    I do use DVI to connect the monitors (older ATI X1300 series card)
    A number of my co-workers have the same issue.

    We all use dual monitors and RDP, so we assumed that to be a common thread, but it may not be.

    Monday, June 15, 2009 9:33 PM
  • I've got one monitor -- a 22" LCD (DVI) at 1680x1050.

    I get the problem where the resolution will drop down to 800x600.  It usually happens after switching between users.  Sometimes it happens after exiting a fullscreen game (I've seen this with Fallout 3 and with Peggle).

    To spare the hassle of going into Display Settings to fix this, I wrote a little program that calls the win32 'ChangeDisplaySettings ()' function to restore the rez to 800x600.  Sometimes this works right away, but sometimes I have to run it a bunch of times until it works.  Sometimes I have to wait awhile and then it will work.  Sometimes it never works.  It's no better or worse than going to the Display Settings screen.  Just more convenient.

    I also get the problem where the login screen will be black, but controls (buttons, textboxes) will eventually appear once my mouse cursor passes over them.  I also get this problem in UAC confirmation screens.

    I'm using a GeForce 8800GTS with up-to-date WHQL drivers.  I've tried the newest NVidia drivers too.  I don't recall ever seeing this problem before Vista SP1.

    I use AVG for antivirus.
    I seldom use RDP from my PC, and never use it to access my PC.

    FWIW, I'm astonished and disgusted that this problem has been around for so long and MS can't or won't fix it.  Can anybody confirm that they're even aware of it or working on it?  If it'll help, I'll gladly run any kind of diagnostics or software on my PC to help gather data to sort this out.  With this problem persisting, I've got no motivation to stick with Vista, let alone consider 'upgrading' to Win7.

    Thursday, June 18, 2009 4:08 AM
  • By the way it may be of interest here that when this happens I can change my screen resolution to ANYTHING but the resolution I was using when the problem occurs. I.e. I use 1920x1200 32-bit. I can change it to 1920s1080 32-bit and it is always accepted. I can change it to 1920x1200 16-bit and that too is always accepted. But if i try to change it to 1920x1200 32-bit (I.e. the resolution in use before it went back to 800x600) it just reverts back to 800x600. It is almost like it thinks the timings for 1920x1200 32-bit (and only these) are the timings for 800x600. Very odd.
    Saturday, June 20, 2009 3:25 PM
  • Same here. But always only to a lower resolution. I suspect its a memory leak somewhere.

    I hope someone has the time to officially report this to microsoft and get it resolved.
    • Proposed as answer by AlmereIan Tuesday, July 14, 2009 7:34 AM
    • Unproposed as answer by amdidi Saturday, October 24, 2009 3:16 PM
    Saturday, June 20, 2009 11:04 PM
  • Same here. But always only to a lower resolution. I suspect its a memory leak somewhere.

    I hope someone has the time to officially report this to microsoft and get it resolved.
    Umm, how does this answer the question?
    Tuesday, July 14, 2009 3:05 PM
  • Forum moderator, please ban this AlmereIan immediately, and mark the thread as unanswered.
    Wednesday, July 15, 2009 5:11 AM
  • So following this for a while, I get this email from a buddy of mine stating could it be something as simple as sign monitor drivers.  As TMM did not work for me, I tried it.  I found VX2235wm Microsoft Signed drivers.  This worked, I have had no issues for the last 3 days.  I am connected via DVI, ATI 4870 card, Vista sp1 had issues with my display going to 800x600 and not being able to change back to 1680x1050 even though I could change it to a lower setting before.  Ohh and a side note, once i installed the VX2235wm Microsoft Signed drivers, I was able to change from 800x600 to 1680x1050 without having restarted yet.  Since I have restarted my comp twice and switch users many times and no issues so far.  
    Friday, July 17, 2009 8:40 PM
  • Im using a custom made PC with following specs

    Intel DP45 Motherboard with Intel quad core 2.33ghz
    DDR 3 1333 MHZ 2x2 GB
    Asus Nvidia 9400GT 1GB
    Samsung Sync Master 933SN 19inch Wide Screen

    Windows Vista Service Pack 2

    Every time I log into my account My display settings change to 1024x768 from 1360x768 .

    It was less frequent before but now every time I log it happens.

    Windows Updated
    BIOS Updated
    Latest VGA Drivers

    Sunday, July 19, 2009 9:09 AM
  • Good...or errr, bad to see we're not along...
    been seeing this with a few of our users.
    same scenarios as listed by others on here.
    we too have been looking for that elusive common thread and none of the fixes I've read about out there have helped...

    So...based on Devorac's comment...here's the other common thread he made me think about, and so far this is one thing we've found that seperates the folks that do and don't have the issues....

    Show of hands....how many of you out there in your device manager under monitors have something other than generic pnp monitor (this is for the monitors, not the display driver)?

    I've uninstalled the driver from all of our affected people today, and we're gonna see if this helps, but would like to see if you folks can also see if this is a common thread...and if so, if removing the monitor driver helps.
    Wednesday, July 22, 2009 10:26 PM
  • Another thing worth adding, on the topic of resource exhaustion...
    though I've seen these entries even on systems that don't seem to have the other problems...
    look in your event logs, under Applications and Services Logs\Microsoft\Diagnostics-Performance
    click on operational, and you'll likely see a bunch of event id 501 and 500, indicating resource issues with the graphics subsystem.

    Could be that all machines have this happen but for some reason, some machines can recovery from it easier and quicker...

    Wednesday, July 22, 2009 11:02 PM
  • I have not seen this issue after installing: KB972182.
    This updates win32k.sys.

    Monday, July 27, 2009 11:05 PM
  • I dont have the problem for a while dont know whether its the update or not coz i couldnt find KB972182 in my list of updates but I did one change.. I had Graw 2 Installed so I went to compatibility mode and selected to work as XP SP2. I dont see any issues afterwards so my doubt is its the programs which are not designed for Vista brings the issues.. whatever the 3rd party old softwares u install make sure u change the compatibility thing :)
    Tuesday, July 28, 2009 7:42 AM
  • Hmm, well we asked and looks like MS has pulled that hotfix, and won't give it up for now.

    As for older apps, that could be, but can't say at least we've found a common app among the folks having issues.

    The removal of the montior driver has helped to some extent, but after a while the issues seem to come back, they seem to go away faster and without need for a reboot.

    The other item of interest, though not sure yet how is related if at all....
    we all have office 07 with Onenote. Onenote has a screen capture capability in it. though I dont' think this is the cause, it breaks when these problems surface and doesnt' fix until reboot. instead of capturing a screen, just returns a black square to onenote.

    I have ticket open with MS on this now, so the more info we can all pull together on this the better.
    we're watching the display heap but tests so far don't seem to indicate that as a problem, at least not yet fromearly testing.
    Tuesday, July 28, 2009 8:58 PM
  • Lynn,

    How did you get KB972182 hotfix installed? according to the kb page MS didn't provide a public download link yet .

    If you happen to be using Vista on x64 (64 bit), someone uploaded the hotfix file to "thehotfixshare.com":

    (use at your own risk... I don't know who put it there and if the file is genuine)

    I unfortunately am using x86 (32 bit) and couldn't find a download.
    If anyone has already obtained it from MS, mind uploading it somewhere and posting a link??

    Sunday, August 02, 2009 11:04 PM
  • Orgwizard,

    Thanks for opening a ticket with MS on this issue, I am quite amazed they don't let you at least try the KB972182 hotfix...

    I don't know if it helps, but for me one of the few things that seemed to help (but not completely solve this issue) was using a different monitor. Believe me, I have tried at this point replacing EVERYTHING else in my computer's hardware (board, graphics cards, memory, even switched from amd to intel cpu) and software (reinstalled vista from scratch a couple of times, in some cases not installing almost any 3rd party software until AFTER I started getting these failures again) and none of these had any significant impact on this issue

    I recently switched from a dell E228WFP where I encountered this problem at least once every 48 hours (frequently 1-2 times a day) to an acer H233H and didn't see this problem for about 3 weeks (wow...) until it struck there too.
    I didn't notice any difference between the frequency of failures using generic pnp monitor drivers and manufacturer's drivers.
    My monitor is always connected via DVI

    Different monitors having an impact may be useful to Microsoft, not because the specific monitors are better/worse but because different monitors have different timings and this might be an issue with the timing and control of the DVI signals.

    (and BTW - my symptoms are identical to all the ones described above - switching to 800x600 mostly on fast user switching, higher probability when multiple accounts are logged on, the infamous "black" logon screen that somewhat reappears as you move the mouse, the ability to switch back to high res some times, and remains stuck until reboot in others, I do not use multiple displays, I do not overclock, and there's nothing particularly interesting running on my computer - see for yourself the hijackthis running process list I posted months ago...)

    Monday, August 03, 2009 3:36 AM
  • I'm getting exactly the same problems mentioned here with dropping to 800x600 during/after fast user switching, getting the black login screen, etc.  Got my hopes up when I started reading these old threads 'cause I thought surely there'll be some good news at the end.  Can't believe this has been going on so long without a resolution.

    For what it's worth, I'm running Vista Ultimate SP2 and I have a single monitor, a Samsung SyncMaster T220 connected via DVI to my computer's onboard display adapter which Device Manager says is an Intel(R) G45/G43 Express Chipset.

    Have noticed something curious in Display Settings.  Even though I have only one monitor attached, two show up.  Monitor 1 is my T220 running at 1680x1050.  Monitor 2 is a 'Default Monitor' running at 800x600.  Is this normal?
    Monday, August 03, 2009 9:04 AM
  • I didn't request the patch as part of this issue as the description didn't seem to indicate is was addressing any of the issues we're seeing. I used our regular channel for getting patches, and MS came back and said the patch had been pulled.

    I'm still doing some more work with MS on the display heaps, so will let you know if we see any progress.
    Monday, August 03, 2009 4:14 PM
  • Guys I have experienced the same problem on one Vista machine which has 5 users (2 admin and 3 standard) but it was not occuring on my other Vista machine which had 4 users (1 admin and 3 standard).  I switched the 2nd administrator account to a standard user on the machine with the problem and the problem seems to have stopped.  I have only just done this, but the problem on my machine was very consistant, every time I had the 2nd admin account logged on, the resolution reverted to 800 x 600.  Maybe it is something or just another red herring.  Does everyone with the problem have more than one Administrator account ? I am running Vista business on the problem machine (X61 Lenovo laptop, single monitor (Chimei 22"), Chip set is Mobile Intel(R) 965 Chipset Family.
    Thursday, August 06, 2009 1:41 PM
  • I can't really add anything to this other than to say that I have the same problem here. Vista Ultimate sp1, switching between users, Symantec AV.

    This time I was able to fix it by waiting a while then switching to 16 bit color, but I don't know if that's going to be repeatable. I usually just bite the bullet and reboot, but I'll start trying out some of these ideas and poking around a bit more when it happens again. It is very frustrating...
    Tuesday, August 11, 2009 8:38 PM
  • This is a terrible affliction.  I'm seeing the same issues as many here.  I have three 24" 1920x1200 monitors.  I don't use user-switching, but I do get my resolutions screwed up, mostly when I try to load up a game.  When the mode switches for the game on my main screen, one or both of the other monitors will drop to 800x600.  Getting it back to 1920x1200 usually doesn't work, but sometimes does.  More likely to work if I wait a long time before trying.  I can usually get 16-bit color to work at that resolution, but I'm not a huge fan of dithering, and as soon as I try using something that switches modes again it tends to all fall apart anyway.

    I use VNC server for remote desktop, so that might contribute.  Avast is my antivirus.

    Microsoft, get off your lazy butts and fix this.
    Tuesday, August 11, 2009 8:58 PM
  • I just went to the KB article and downloaded the patch.
    Did not see the problem after installing that KB.
    Just checked today and it was still available.
    It did not seem to list this issue but did seem to address it.
    You may recall there was an earlier win32k.sys patch for desktop stability on terminal services, and so worked from the idea that win32k.sys was the cause.
    This is a newer win32k.sys so I went for it.

    Anyway I've went to win7 so hoping it does not have this bug.

    Wednesday, August 12, 2009 11:51 AM
  • I downloaded the patch from Microsoft at:
    There is a link at the top of the KB article.
    Most hotfixes have this link and you can serve yourself.
    Just checked today and it was still available.
    Wednesday, August 12, 2009 11:53 AM
  • Yes, the KB 972182 hotfix (a 2nd version of it, judging by the "V2" in the filename) has been available for download for a few days now.
    I installed it on 8/6/2009


    It does NOT solve the problem. I have since had several repeats of the same issue.

    Wednesday, August 12, 2009 2:20 PM
  • The hotfix is useless for this, as mentioned.  Well Microsoft?
    Monday, August 17, 2009 1:27 AM
  • Here's an idea --

    We all see this issue when multiple users are logged in and switching between accounts.
    On my computer, there is one account that has administrative rights, and the others are "limited users". Wild guess - maybe the limited users are prevented from modifying some setting or accessing some service and then logging in as them leaves some piece of software (driver? win32k.sys?) in an invalid state?

    I just made my other users "admins" too (at least temporarily) to see if this changes anything. Does anyone experience this issue when only admin users are logged on to the computer?

    Saturday, August 22, 2009 7:29 AM
  • I have just two accounts both admins and experience the same problem. Had tried changing one of them to non-admin but still no change.

    Saturday, August 22, 2009 3:09 PM
  • Since Microsoft clearly has no interest in fixing this issue in Vista, does anyone know if it exists in Windows 7?

    If it does not, I'd urge people who have this issue to lie about their student status if possible and take advantage of ieee or acs discounts at the following link.  We've been waiting long enough for a fix that there is no moral issue regarding paying less for windows 7 if the issue does not exist in that OS.

    Sunday, August 23, 2009 4:12 AM
  • danimalx

    I am sure you have good intentions, but I am not sure this suggestion is going to be helpful.

    first, as indicated by several posters in the past, this problem exists also on windows 7.
    second, advocating on MICROSOFT's technet forum to illegaly obtain microsoft licenses is probably not the best way to get them to help any of us. (needless to say, with today's technology, a 6 year old can obtain an illegal copy of windows with very little effort, let's assume that most posters on technet would be able to do so as well if they chose to)

    Don't get me wrong, I have been experiencing this problem for over 18 months, I am disgusted and disappointed with Microsoft's lack of care or ability to resolve this issue. This is not a moral issue, it is a technical issue that needs to be resolved (and, at least seems that Microsoft is the only one that has a chance of resolving it, since none of us were able to find a single common piece of hardware, 3rd party driver or other 3rd party software that is common to the people experiencing this issue).

    There are other operating systems out there (Open Source) where if such a bug existed and you had the know-how you could fix it yourself. Since you and I both *chose* to use Microsoft windows, all we can hope for is that at some point the right Microsoft person will notice this thread and do something about it.
    Sunday, August 23, 2009 2:31 PM
  • Interesting...

    I just tried something while my computer was stuck at 800x600 - I used the nvidia control panel to try and create a "custom resolution" option, and gave it the same parameters as my screen's native resolution and frequency (1680x1050 60Hz) then clicked "test settings". It immediately returned an alert box saying that an error occurs and my monitor does not support the resolution (obviously wrong -- it's the screen's native settings!)

    Is that helpful in any way??
    Sunday, August 23, 2009 5:13 PM
  • I've also been experiencing the same problems, with no luck solving it (despite following the suggestions in this thread and those on the NVIDIA boards :

    • switching to 800x600 when fast user switching between 1 admin and 1 user account
    • ability to switch to one less than best resolution, but not best (native) resolution
    • black logon screen that somewhat reappears as you move the mouse

    My system:
    • two displays
    • Primary: Samsung SyncMaster 226BW via VGA via IOGEAR KVM switch (listed as such in Device Manager)
    • Secondary: Planar PL1920M via DVI (listed as Generic PnP in Device Manager)
    • NVIDIA GeForce 7600 GT
    • Realtek High Definition Audio
    • Happauge WinTV HVR-1800
    • Avast! Anti-Virus
    • Windows Vista Ultimate SP-1
    • Asus P5N-E SLI MB
    • Intel E6750
    • 4 GB Crucial Ballistix RAM
    • HAVE Disabled TMM
    • HAVE NOT installed HF#972182
    Interestingly enough, today I could only switch to a resolution two notches less than the native resolution.. I waited a little while and then could switch to the ideal resolution... definitely seems like a resource/clean-up issue.

    Thursday, August 27, 2009 1:24 AM
  • No real luck with the MS ticket...so don't hold your breath....
    would like two more data points from anyone willing to contribute....
    Is anyone experienceing the issue running x64?
    Is everyone experiencing issue running 32bit OS with more than 3gb of ram?
    Thursday, August 27, 2009 2:38 PM
  • No real luck with the MS ticket...so don't hold your breath....
    would like two more data points from anyone willing to contribute....
    Is anyone experienceing the issue running x64?
    Is everyone experiencing issue running 32bit OS with more than 3gb of ram?

    Vista x86
    Memory 4gb
    Issue: yes, since Vista SP1

    As Windows 7 RC is free to install, has anyone had any luck on returning their Vista and getting a refund on the basis that it doesn't work as it is supposed to? The exact wording and grounds on managing to do that varies from country (of purchase) to country of course.
    Friday, August 28, 2009 5:39 AM
  • Is everyone experiencing issue running 32bit OS with more than 3gb of ram?

    Yes, I am.
    Monday, August 31, 2009 6:46 PM
  • I'm running 32bit Vista with 4GB RAM now, had it with 2GB of RAM installed and I've had this issue with Windows XP (32bit as well) when I only had 640MB installed. Scroll up for the rest of the computer details.
    Monday, August 31, 2009 8:42 PM
  • Is anyone experienceing the issue running x64?

    Yes, indeed.
    Running Vista64 SP2 with 4Gb of RAM. Club3D ATI 4850-card. Works ok with ATI Catalyst 9.5, but any upgrade of ATI drivers (9.6, 9.7, 9.8) causes the resolution change when logging off. Had this problem also with some earlier driver versions (before 9.5) but cannot remember which worked and which not.
    Asus mobo and display connected via dvi. Phenom 9550 as proc
    Wednesday, September 02, 2009 7:29 AM
  • Workaround?

    I'm not sure, but I may have found a workaround for when a reboot is needed.

    My system got into the state where I could only select a resolution 2 less than the best (selecting the best, or one less, would take it to 800x600).

    I switched my display settings to 16-bit color and the best resolution... and it stuck... so far so good.
    I then switched to 32-bit color (keeping the best resolution), and it worked! 

    I also quit Google Desktop ... don't know if that made a difference or not.

    If When it happens again I'll give this workaround another test.  I would be interested to know if this works for anyone else.

    Thursday, September 03, 2009 7:47 PM
  • hei guys.....this one is not that great stuff...
    this happens
                      when you update a driver or overwrite a onboard driver with external (nvdia)drivers

    this is not good....

    better uninstall the driver first and then install the new driver(updated one)

    if you have this problem now

    right click Mycomputer icon
    choose manage
    find the graphics driver and uninstall it
    after restarting install the new driver

    dats it

    it works fine for me....now
    Friday, September 04, 2009 9:33 AM
  • hei guys.....this one is not that great stuff...
    this happens
                      when you update a driver or overwrite a onboard driver with external (nvdia)drivers

    this is not good....

    better uninstall the driver first and then install the new driver(updated one)

    I have had this problem only for the past week since I installed a 9400GT and latest drivers from Nvidia. I have tryed drivers from both Microsoft and Nvidia nothing has worked, I am only running one monitor on DVI connector.
    Friday, September 04, 2009 4:23 PM
  • For the record I don't use multiple users.  I run three 1920x1200 monitors.  32-bit Vista, 2GB of RAM.  Nvidia graphics cards 9800gt and 8600gt.  I use VNC as a remote desktop, which seems to install a "Mirror Driver" under displays which might have something to do,  I killed VNC server and uninstalled the extra driver and it hasn't happened in a while, but I'm not exactly going out of my way to test it at the moment as it's extremely annoying having to reboot and restart all of my development tools.

    Usually the resolutions would get all screwed up if I loaded up a full screen game which changed resolution on my main monitor.  The others would go 800x600 and refuse their native resolution.  Upon exiting the game the main screen would also end up in 800x600.  It's seemingly random as I'm sure every one of my monitors has hit 800x600 at one time or another on the mode switch and every one has also survived with 1920x1200 intact before.  If I for instance have two screens with good resolution, and one at 800x600 then try to change the 800x600 to 1920x1200 I would usually lose one or both of the previously unaffected monitors to 800x600.  It's all pretty retarded.

    Microsoft, this shouldn't take years to fix because it's really not that hard to reproduce.
    Sunday, September 06, 2009 1:37 AM
  • I reported the bug on some microsoft's web page a few months ago, and got a call from support person a few days later. I explained the bug, and he took notes (I assume), and told me that he will report it further. Haven't heard anything since.

    As it's clear by now that Microsoft doesn't read their forums, maybe others should do the same, ie. report the bug, maybe that would help.
    Sunday, September 06, 2009 12:23 PM
  • I have changed back to analog on both the video card and monitor and it has stopped having problems. I am sure it was a problem with Vista and digital drivers and or input for digitel monitors.
    Tuesday, September 08, 2009 9:07 PM
  • hei guys.....this one is not that great stuff...
    this happens
                      when you update a driver or overwrite a onboard driver with external (nvdia)drivers

    this is not good....

    better uninstall the driver first and then install the new driver(updated one)

    if you have this problem now

    right click Mycomputer icon
    choose manage
    find the graphics driver and uninstall it
    after restarting install the new driver

    dats it

    it works fine for me....now

    For the record, although I have always uninstalled then installed video drivers i thought it was worth doing a complete clean uninstall of all past versions using Driver Cleaner.

    For a week I almost thought it might have worked, but then .... it happened again.
    Monday, September 14, 2009 1:57 PM
  • So, it seems that one of the only commonalities I could see so far is that we all use digital video and DVI connections.

    This got me thinking... there are several different DVI cables - let's try to figure out if this is the source of our problems. If (like me) you don't know what the different DVI connectors are and what they look like, the following link may be useful:  http://www.directron.com/dviguide.html#cabling

    On my part, I found out that while both my graphic card and my monitor provided dual-link DVI-D connections, I am using a SINGLE link DVI-D cable....
    Since I operate in resolutions/frequencies where single link "should" be ok this is theoretically fine, but if you read about DVI and EDID, you'll see that it makes perfect sense for a problem passing EDID information over the DVI link to cause the computer to fail recognizing certain monitor resolution/refresh rates.

    Needless to say, I'll buy a dual link DVI-D cable and try it shortly

    But since this issue can sometimes take weeks to reproduce, a show of hands would be a good start -- anyone else having this problem and is using single link DVI-D? using DVI-I? has a less-than-perfect match between cable, monitor and graphics inputs/outputs?

    Is anyone having this problem even though they are using dual-link DVI-D cables?
    Monday, September 14, 2009 5:16 PM
  • Thanks, learnt something about DVI cables today.  Unfortunately mine is a dual-link DVI-D.  Good theory though.  We must be getting close.

    Monday, September 14, 2009 6:32 PM
  • Hello everyone. I've been followin this thread for a while now, havin the same issue as most of you (When switching users, the screen resolution changes to 800x600). Not sure if this can be considered somewhat of a fix, but it's a temporary solution I use that seems to work each time. When the screen resolution changes to 800x600, I go into the Display Settings and change it to 1680x1050. When I click apply, it doesn't work, and in fact reverts back to 800x600. When I choose 16 bit 1680x1050, this works each time. (But who wants to experience lack of color?) At any rate, when I encounter this issue now, I immediately log off the user account that I switched from (via Task Manager). Afterwards, going into Display Settings and choosing 1680x1050 32bit works fine. Hope this helps. Also, i'm using an HP monitor + pc, 1680x1050 obviously, vista 32bit premium home edition.
    Tuesday, September 15, 2009 12:24 AM
  • Hi!

    My earlier post:
    Running Vista64 SP2 with 4Gb of RAM. Club3D ATI 4850-card. Works ok with ATI Catalyst 9.5, but any upgrade of ATI drivers (9.6, 9.7, 9.8) causes the resolution change when logging off. Had this problem also with some earlier driver versions (before 9.5) but cannot remember which worked and which not.
    Asus mobo and display connected via dvi. Phenom 9550 as proc

    Updating to latest Ati drivers (9.9) seems to work ok. No res changes when logging off.
    Thursday, September 24, 2009 10:47 AM
  • Hi

    Posting this to find out is there a short-cut key available for fast-user switching. Combination of "'Windows key' + L " locks only a user. Is anything available to shift through users or atleast take me directly to Login as screen.

    Friday, September 25, 2009 2:11 AM
  • I came across this forum by googling the problem.  I have the same problem, BUT I am running XP Pro SP3.  So it seems to have nothing to do with the video card, or the particular OS.  What I do remember is that this probelm only
    happened after we changed our system to mult-user.  Also, some of the users use photographs for their Desktop background.  From all I've read on this list, it seems most likely that the problem is related to memory.  At some point,
    the system just doesn't have enough available memory (probably video memory) to maintain the high resolution and drops down to the lowest resolution.  Once you start logging out users, thus closing their applications, enough memory is usually freed up to let you change back to the higher resolution.   Usually, this happens spontaneously after logging out a user.
    Wednesday, October 07, 2009 9:46 PM
  • Would be nice if microsoft at least gave confirmation that this bug will be ignored and won't be fixed. It's just so irritating to always come back here and see if someone would've finally been bothered to delegate it to relevant department(s), but get disappointed and pissed off every time.
    • Proposed as answer by ft10306 Thursday, October 15, 2009 3:06 AM
    • Unproposed as answer by amdidi Saturday, October 24, 2009 3:15 PM
    Friday, October 09, 2009 8:10 PM
  • Don't know if this helps, but I had this same screen resolution problem intermittently for about 6 months.  I switched to 16-bit color about 2 months ago and have not had it occur at all since then.    Give it a try.
    Thursday, October 15, 2009 3:09 AM
  • Not really a solution, but I too noticed that under 16 bit the problem does not occur, however colors look bad and you loose all the vista effects.

    We really need a proper fix.
    Thursday, October 15, 2009 4:00 AM
  • If you have the NVIDIA Control Panel installed, check the default values.  Default settings may overwriting desired values and be taking affect after you log off or reboot. I kept changing the desired values over and over, however applying new defaults eventually fixed my issue.

    This might be a special case, but I was experiencing the problem for several months where the resolution would switch to a lower one after logging off or rebooting.  I've read that most people with this issue use multiple displays, but I use two independent systems and single displays with Synergy+ software enabling me to use a single mouse and keyboard.

    In my case, it was a configuration problem in the NVIDIA Control Panel where the default settings were incorrect.  Resetting the defaults did the trick for me but I took other actions before that so I will include them in case the cumulative actions provided some resolution.  Maybe someone with a similar case can try changing the defaults alone to see if it that works.

    I will update this thread if the issue returns but here are the steps I took before the resolution issue stopped occurring.

    System:           Two independent displays each with different OS & a shared keyboard and mouse via Synergy+ software (behaves like a dual monitor system but really isn’t).  The system with the display issue has Vista Ultimate (32-bit) SP1 and an NVIDIA GeForce 8800 GTS connected to a DELL E242WFP monitor via one DVI port.  The second DVI port has nothing connected.

    Steps taken:                

    1.      Uninstalled NVIDIA drivers.  Rebooted.  Reinstalled drivers.  (No resolve)

    2.      Used NVIDIA Control Panel to reset resolution. (No resolve)

    3.      Saved / Reloaded NVIDIA display profile using its control panel (No resolve)

    4.      System restores to as far back as possible (Resolved until Windows Update)

    5.      Re-installed monitor drivers (No resolve)

    6.      Repeated 1-3 after Windows Update. (No resolve)

    7.      Disabled and stopped TMM (No resolve)

    8.      Here’s what finally RESOLVED it for me:

    Resolve:    Using the NVIDIA Control Panel - Display Node, I clicked “Restore Defaults” to see what the default were.  The values I saw were not what I’ve been setting so I changed them to 1. Configured independently…(Dualview) and 2. Accepted the default display selection as Dell E248WFP + HDTV.

    Here were the options:

    1.      Choose the nView display mode to use.

    -          Only use one display (Single) [MY ORIGINAL CHOICE]

    -          The same on both displays (Clone)  [DEFAULT]

    -          Configured independently from each other (Dualview) [NEW_DEFAULT]


    2.      Select the displays you would like to use.

    -          Dell E248WFP [MY ORIGINAL CHOICE]

    -          HDTV + Dell E248WFP

    -           Dell E248WFP + HDTV [DEFAULT]

    After applying the new defaults I logged off and my resolution remained stable.   It also remained stable after several reboots and more updates applied.

    Were the steps taken cumulatively affective or not?  Perhaps just examining and applying new defaults provided the real fix but I didn’t want to leave anything out.



    Thursday, October 22, 2009 10:25 PM
  • Does Windows 7 solve this issue? For me, the only solution so far is to go for 16-bit color, which really isnt a proper fix.
    Saturday, October 24, 2009 3:19 PM
  • Well QUOTED, this has been plaguing me for ages, similar config NVIDIA being the relevant point here. My defaults (nvidia.nvp) were way different to the resolution I run at but were what the system falls back to when I experience the problem. Jumped straight to the point and changed the defaults, will let you know how it goes.

    Realise that NVIDIA users aren't the only people suffering but maybe something initiates a restore defaults ?? something for others to try ??
    Wednesday, October 28, 2009 9:04 PM
  • Despite sounding very plausible sad to report that resetting the defaults wasn;t the answer :-(

    Back to the drawing board
    Saturday, November 07, 2009 12:45 PM
  • Same problem here, they prob. won't fix it now with windows 7 out. This happened when SP1 was installed. you think a big company like this could fix all this ____.
    Windows losses again.
    Tuesday, November 17, 2009 10:58 PM
  • FWIW -
    I had this problem for about 2 years and wrote a number of posts in this thread in the past.
    It survived OS reinstallation, change of practically all of my hardware piece by piece (mobo, cpu, monitor, graphics card, memory, power supply...) I used to be affected by this annoying problem at least once every 24-48 hours.

    About 1.5 months ago I wiped out my 32 bit vista ultimate installation and installed Windows7 ultimate 64 bit from scratch and never saw this problem again. GOOD RIDDANCE. Vista was a pathetic piece of ____ that felt like a flashback to the old [horrible] NT4/Windows95 days. I was seriously considering switching over to Apple/Mac OSX if this problem persisted.
    Thursday, December 31, 2009 7:04 AM
  • I am new to this thread, but I have also been experiencing the same problem described by others for more than one year. Having read through the entire thread, one common theme appears to be presence of 4 GB of RAM, which is true of my system as well.

    Has anyone tested whether reducing the amount of RAM from 4 GB down to 3 GB or 2 GB to see whether this stops the issue from occuring?

    If this issue related to RAM > 3 GB, this would help to explain why the problem went away for of34 when Vista 32 bit was replaced by a clean install of Vista 64 bit on common hardware.

    My system configuration is:

    Mobo:  MSI K9A2 Platinum

    CPU:      AMD Athlon 64 AM2 6400+

    Video:   Gigabyte 2600XT 256MB PCIE

    RAM:     4 GB Kingston HyperX

    Drives:  2 x Seagate Barracuda 7200.10 500 GB SATA II

                    1 x Seagate Barracuda 7200.11 750 GB SATA II

    O/S:       Windows Vista Ultimate SP2

    My monitor is connected by VGA Analog.


    Wednesday, January 06, 2010 12:44 PM
  • I had this problem on Vista32 both with 4GB ram and with 2GB in all of the following configurations:
    4x1GB Crucial Ballistix
    2x1GB Crucial Ballistix
    2x2GB OCZ (don't remember the model)

    On each of them I tried it both with the BIOS determining the RAM timing by itself (SPD) and by setting it manually (including underclocking 4-4-4-12 RAM to 5-5-5-15)

    In each case, the RAM would pass a whole night of memtest with no errors.

    Believe me, I tried it ALL and spent so much time on this issue that the price of Win7 is peanuts. Nothing worked for me except a full re-installation of win7-64 (there's no upgrade path from Vista32 to Win7-64 anyway)
    I did NOT try win7 32 bit so I have no idea if that one works.

    In any case, Win7-64bit installed on a machine afflicted with this horribly annoying bug got rid of it for me COMPLETELY.

    I still think that Microsoft's lack of interest in resolving this bug in Vista is horrible and shows a very stinky attitude to its customers. We are not talking about an obsolete almost-end-of-life product either! there are still plenty of computers sold with Vista today.
    Am I happy that I paid that stinky company again for Win7? ____ no! but not having to get pissed at the computer at least once a day when it gets stuck in low resolution and being forced to reboot to resolve it is well worth it.
    Maybe one day Karma will catch up with Microsoft... who knows.

    Thursday, January 07, 2010 5:54 AM
  • Found this thread on the same issue - go to Pats Guy post 16 - if a few of us try this out maybe this will be the answer.


    "I had the same problems for several months after upgrading my video card to the GeForce 8400 GS. I noticed that when fast switching which ever profile I logged into second the NVidia control panel and drivers failed to load. I tried everything that people in this post have done including disabling and removing Trend Micro software.

    So finally what I did as sort of a last ditch effort was to install the drivers that I downloaded from the NVIDIA website onto both profiles - I know it sounds like a stupid approach- but it has worked flawlessly for the last 2 weeks. I haven't had a single problem fast switching between accounts.

    I did create a third profile and didn't install the drivers onto that profile and the first time I tried fast switching to it the resolution changed again, reinstalled the drivers on that profile and it went back to normal.... If you have tried other approaches unsuccessfully give this a try."

    I assume you have to make everyone an administrator to do this - correct me if I'm wrong

    Also found in this thread at


    go to   G Sayeri post

    "I have a guess that it is directly related to direct X10 ( not sure if you can install DX9 for vista ? ) or try giving all users administrator privledges , and see if the user switching problem still occurs.  Give all users admin privledges , and reinstall latest software and drivers for vid cards. give em a try .... and post reply."

    Think I'll try this though with 3 to change to admin will take some time.

    Thursday, January 07, 2010 4:26 PM
  • I changed all accounts to admins, removed UAC, reinstalled display driver for each user, and after first user switch it happened again. gg vista and big fukc you to microsoft.
    Monday, January 18, 2010 3:09 PM
  • Thanks for putting in the effort.  Looks like will have to try something else.  
    Monday, January 18, 2010 4:38 PM
  • I switched the screen saver from Aurora to blank and also switched the desktop wallpaper from a photo to plain black on all user accounts about 1-1/2 weeks ago. The screen resolution switching problem has not recurred during this period. Perhaps it is too soon to say whether this resolved the issue, but the issue would typically have occured during that period in the past.

    Tuesday, January 19, 2010 4:43 AM
  • I tried the above (screen saver and wall paper changes with another person who doesn't sign in with a password but this didn't work for me - resolution went large.

    (XP Nvidia GeForce 7500LE)

    Tried looking for the TMM (see tip higher in thread) but this doesn't exist on XP, only Vista and maybe later OS.

    Tuesday, January 19, 2010 2:47 PM
  • Found this which may be of interest/use


    Kerouac says

    I am a computer engineer. The problem described in the OPs post is not a common one but usually indicates:

    a) limited user account not being able to save settings to the registry

    cool.gif a roaming profile ** this could be the issue as when the machine logs on it will download the users profile for the session and remote sessions tend to be in 800 x 600 mode

    c) the operating system has not been correctly configured: unless there is a group policy in force, no home pc should be set up with limited user accounts, they don't work properly and even Microsoft have admitted they don't work (they say this will be fixed in Windows Vista which will be more akin to Unix in that it will run users unprivileged unless they "elevate" to super user (administrator level)

    d) from what has been described, I would log in as an admin on the computer , create a new user with admin privilege and migrate the user data to the new profile."

    Try also this page   http://www.dougknox.com/xp/utils/xp_userdisplay.htm

    and this page    http://pagesperso-orange.fr/sto41/en/My%20Tools/XPKeepPerUserDisplaySettings.htm

    Info on these last 2 pages is quite old

    I have switched off fast user switching as owner of a home computer used by three people and it aint that bad re time and aggro saved.

    May be less useful to switch it off for those in an office.

    Wednesday, January 20, 2010 11:30 PM
  • I tried Microsoft support too. After a few replies back and forth without a solution, they stopped replying. In few weeks sent me an email as if they were not receiving any of my emails. I re-sent my emails again but no response from them. I have suffered enough and I've switched to MAC. I am never going on Windows ever. I hope Windows 7 solves the Vista c_r_a_p.
    Friday, January 22, 2010 6:01 PM
  • *bump*

    I am a Windows 7 user with the same/similar problem.  Whenever I "fast-switch" users, my screen goes black as it seems to change resolutions a first time.  I am then presented with the user selection screen, which is back in my native resolution (1680x1050).  Upon clicking on the second user, the screen goes black again in another resolution change.  After about 10 seconds, the screen goes back to 1680x1050 and the second user's account loads.

    I have a fresh install of Windows 7 32-bit.  Video card is nVidia, and monitor is a Dell with HDI connector.  When I go to safe mode, the problem persists. 

    By the way - when your computer has only two users, like mine does, why does the "Switch User" command take you to an intermediate screen in the first place?  Neither of us (my wife and I) have passwords.  Couldn't Windows just go straight to the other account?

    Sunday, February 07, 2010 5:37 AM
  • Hi all,

    I have a friends laptop(acer extensa 5220)  which has three user accounts all with admin priviliges. When they log on to any of the three accounts straight after boot up the resolution and all other functionality seems ok. When they try to switch user then the resolution and colour depth is set to the bare minimum and cannot be altered in the usual way.

    When an attempt is made to switch to another user again, it sticks at the blue screen with the switching to user text. I have had to reinstall xp on this machine a number of times in the past. Using the same xp and reformatting every time, my friend was able to use multiple accounts in the past, but not now.

    The only change over time I can think of is that the last time I repaired a problem with their machine it was a hardware issue. One of their two ram modules had failed. I discovered this using Hiren's Boot Cd. On removing the bad ram, the laptop worked well again. Since then they have been using the laptop with 512mb of ram.

    I have only just found out that they had been suffering this reduce resolution on switching problem for a little time without telling me. I am wondering whether it is the reduced ram, since their is no dedicated graphics card on this laptop and so the ram will be responsible for supporting graphics.

    Thursday, February 11, 2010 11:33 AM
  • Dunno for sure yet, but so far it seems that if I disable dwm (run command prompt, and type "net stop uxsms") for one user, the resolution settings for that user will remain at native when switching users. Even if this would be a work-around, it would still suck because without dwm screen updates are very slow and laggy.

    Sorry, didn't help, only postponed the symptoms a bit.
    Sunday, March 07, 2010 2:26 PM
  • As per my previous posts, I used to get this problem a lot.  However a couple of months ago I upgraded to Windows 7 64-bit and haven't had a recurrence since.  Getting other problems instead with Media Center which appears buggy, but at least fast user switching is working again.
    Saturday, March 13, 2010 2:52 AM
  • I used to experience this problem (screen resolution changes upon fast user switching) frequently (e.g. daily); however, the problem simply stopped occuring about a month ago. I didn't change any hardware and I did not upgrade the Operating System during the period when the problem went away. I did, however, update a number of drivers, including the ATI Catalyst Driver and the driver for the SB600 Northbridge on my motherboard. Even though I can't say what solved the problem in my case, I am posting this to document that I was able to resolve this issue without upgrading/reinstalling my O/S. Based on my experience, it appears that this issues is a driver issue; however, I can't say which driver with any certainty. Nonetheless, good ridance to this annoying issue!

    Motherboard:   MSI K9A2 Platinum

    CPU:                 AMD Athlon 64 AM2 6400+

    Video:              Gigabyte 2600XT 256MB PCIE

    RAM:                4 GB Kingston HyperX PC2-6400 DDR2 (4 x 1 GB)

    Hard Drives:     2 x Seagate Barracuda 7200.10 500 GB SATA II

                             1 x Seagate Barracuda 7200.11 750 GB SATA II

    Optical Drives: Asus DRW-1814BLT 1X DVDRW SATA Lightscribe

                             LG HL-DT-ST DVD-RAM GSA-H22L

    O/S:                  Windows Vista Ultimate SP2

    Power Supply:   Seasonic S12 Energy Plus 550W

    Monitor:            Sony SDM-HS73 LCD (analogue input) connected by DB9 from the anlogue pins on the DVI output of the GPU


    Friday, April 02, 2010 6:42 PM
  • How depressing to see this thread run and run.

    Here's my sob story: Dual Screen Viewsonic Monitors, Dell XPS 420, nViidia 8800 GT - vista home premium, 3GB RAM ...

    From new and following various OS reinstalls, machine would start with blank screens - went on for ages, Dell replaced motherboard and video card, still same problems. Replaced DVI cables and monitors and so on. A further video card swap and all updated nVidia Drivers that finally problem went away. 

    Problem that remains is either totally blank screen on coming out of sleep, or bits of background missing, plus the "gets stuck in 800 x 600 mode when changing user".

    Like most others have lost countless hours to this and came back to it today because I thought that after 2 years there might be a fix. Other than switching the machine off and on again, of course. Sigh.

    fwiw it seemed OK when I was running in 1 screen mode for a while - though I see others have problems in 1 screen mode.

    my guess is that there are various intermittent timing problems (screens not being recognised), config caching problems,  plus various resource swapping problems. but in the end, who cares what the problem is, we all want a fix.



    Tuesday, May 04, 2010 4:01 PM
  • Did anyone ever get an answer to this?

    Large unpainted areas on log on screen, eventual drop of resolution to 800x600 and then a reboot.

    Seems to be fully fixed in Win7, so one might expect a hot fix for Vista, but I've not been able to find it.



    Friday, June 11, 2010 9:08 PM
  • Iteska: No answer in this thread at least.

    Also, some here have mentioned that they still see this error with Windows7.

    It is an unbelievably annoying problem. Stuff like this, that goes undiagnosed and unfixed for years makes me want to switch to a Mac. I've already done it at work, probably the next computer at home will be one too.

    My details at least:

    • Dell Studio 540
    • Intel G45 integrated graphics kept up to date with latest drivers
    • Vista 32bit SP2
    • Single Dell 2007WFP Monitor connected via VGA
    • 4 GB of RAM
    • Remote desktop in to the machine occasionally (although I believe the error occurs even during sessions when I have not)
    • Screen goes blank during UAC prompts, by moving the mouse around, you can usually find the [Cancel] or [Continue] buttons because they will repaint to display their 'hover' states.
    • Screen goes blank when the computer locks. As with above, you can eventually cause the [Switch User] button to repaint by moving the mouse around
    • Switch User screen (user selection) sometimes switches the resolution to 800x600/32bit
    • Switching to another user causes that session to switch to 800x600/32bit
      • Switching to any other resolution less than the correct resolution works, but creates a nasty scaling effect on LCDs
      • Switching to the correct resolution but switching to 16bit works
      • Switching to the correct resolution and 32bit causes a switch back to 800x600/32bit without any notice or dialog.
      • Sometimes after some time operating at one of the above "works" options, you can switch back to the correct resolution at 32bits, however the problem will most likely present itself again the next time a user is switched or account is locked.
    • Rebooting fixes the issue and the problem doesn't occur for some time (usually a day or two for me)

    Sunday, June 13, 2010 4:55 PM
  • T.Welch NTauthority-local,

    What is with the 9 proposed answers in the last 10 minutes?????  None of the posts in question solve the problem.  What's the matter with you?

    Tuesday, August 17, 2010 9:29 PM
  • large, unpainted areas of screen mean that you're refresh rate is wrong for your monitor... Go to personalize display, select advanced option, then click on the monitor tab to see what it says... Usually the default monitor, or the generic (plugandplay) or (non-plug and play) would be the culprits here. This is because when SETUP runs, it will always install the most BASIC, VANILLA-FLAVORED  VGA DRIVER  it has, which is useable on nearly every adapter in the world... NOTE that this is a relatively bug-free driver, and that it won't enable all the functions of every adapter... It will tend to run at 800x600 on every possible adapter out there... This is done so setup will run, instead of prompting you for a better driver disk you might not have. It is your responsibility as a computer owner/user to check the computer's device manager after setup to see that all of the drivers are correct and configured properly... If there are no yellow exclamation points shown, then everything is okay... but not necessarily the correct driver for the system to have full usage of its native functionalities. If you have internet access, please visit the manufacturers website, usually the support/downloads areas to get the latest, best drivers for your system... GOOD LUCK!!!

    No offense, but this doesn't really have anything to do with this thread.  I'm pretty sure everyone here with this problem has a driver installed for their video card.  It's a much more complicated issue involving the screen resolution changing to 800x600 when switching between users, afterwhich you cannot switch back to the native resolution.  Please go back and read the posts, and if you could unpropose all of the answers that would be great!

    Or maybe can a moderator unpropose the answers?

    Tuesday, August 17, 2010 10:00 PM
  • How frustrating that MS is not actively participating in this discussion.  Perhaps they were hoping the problem would go away with Windows 7, but it looks like it still persists!


    FYI, I am having the issue with a GeForce 8800, sometimes I switch users and it works great.  Other times, the resolution gets stuck and the only way to get back to my native resolution at 32bit is to reboot.  Very frustrating in the middle of the work day!

    Wednesday, August 25, 2010 5:28 AM
  • unless you, as the system administrator, expressly deny them the right to change the display resolution in the security template applied to the computer, the user retains the right to adjust the display settings as need be for functionality. This is the windows default, and is the correct choice considering the vast majority of users prefer to choose their own customizations. To make the changes permanent, the user must have elevated, admin level priviledges regarding their own account, which could be exercised if they took ownership of the desktop folder under their user account name in the c:\users directory.Any changes made implicitly by the owner of an object will remain in place unless undone or changed by the administrator, who could only do this by taking ownership themselves.
    "While there is NO SUCH THING as a WRONG QUESTION, the EASIEST THING TO GET in the world is a WRONG ANSWER!" 15 years of hands-on-how-to; I "DO" WINDOWS !!!
    Thursday, November 04, 2010 7:19 AM
  •      Okay, I see that your problem is that you are most likely just a user account on the machines. You need to make sure that any changes you attempt are done using administrator-level priveleges, and that you are the owner of your own account under the c:\users directory! And why would you be using fast switching of accounts in a business environment anyways ? grant yourself the permissions you need and use the one account if you want everything to stay put ! and, by the way, I'm sure you got the right drivers from nvidia... but did you get the right ones from the makers of your processor's website for the motherboard's chipset which supports your graphics card ? no? then get them!

         "http://downloadcenter.intel.com ".

         "http://support.amd.com ".      They are free, but you need admin rights to install them.

    Then try MICROSOFT'S new, fully automated support center, which can help resolve most system misconfigurations and symptoms with only a few mouse clicks...and it is free to try and use, also!

          "http://support.microsoft.com/fixit/default.aspx ".

    "While there is NO SUCH THING as a WRONG QUESTION, the EASIEST THING TO GET in the world is a WRONG ANSWER!" 15 years of hands-on-how-to; I "DO" WINDOWS !!!
    Thursday, November 04, 2010 7:51 AM