none
Copy and paste stops working in Windows 8 RRS feed

  • Question

  • I upgraded my laptop to Windows 8 a few months ago. Everything worked fine for a while then about 6-8 weeks ago I noticed that my ^C and ^V shortcuts only worked intermittently. There were some suggestions in a a microsoft community forum (http://answers.microsoft.com/en-us/windows/forum/windows_8-files/copy-and-paste-feature-not-working-in-windows-8/22fe8b55-e1ab-48f1-a413-722f9ca108c1) but nothing fixes it. Even the right click-> copy, right click -> paste is undependable now. I use it to copy for my blogs and also into my spreadsheets from a web shared spreadsheet. It makes little difference where I try to paste I get the same result. If I select text on the web, right click -> copy then switch windows when I right click to paste it's greyed out. Sometimes re-selecting the text works other times it does not.

    The first forum suggestions was : sfc /scannow  I did that an nothing happened

    In anther forum it suggested seeing was running if rdpclip.exe. It wasn't so I started it and included it in startup. That worked for a few days them stopped. Sometimes a reboot clears it up for a while - even days - other times it's a few hours or not at all. This is beyond a joke.

    I've used different browsers and it makes no difference. My machine is absolutely clean, I run multiple protection programs and scan it regularly with the latest scanners (Malware Bytes, ADWCleaner, JRT, and others) and have been in this business since Windows first launched. I've looked under the hood and seen nothing. But this can't go on, it interferes with my real work as well as my pleasure. My Windows 7 machine works fine but I need my laptop.  The problem shows a lot in Bing searches but no solution and I need one.  


    Merlin

    Monday, August 5, 2013 7:24 PM

Answers

  • There were some suggestions in a a microsoft community forum (http://answers.microsoft.com/en-us/windows/forum/windows_8-files/copy-and-paste-feature-not-working-in-windows-8/22fe8b55-e1ab-48f1-a413-722f9ca108c1) but nothing fixes it.

    My suggestions there were diagnostics.  Diagnostics don't fix things.  They return information to help guide inferences which may ultimately result in a clearer symptom description.  Only then would it be possible to start an analysis which identified a problem and then perhaps a fix (or more likely, a workaround) could be devised.

     

    FYI



    Robert Aldwinckle
    ---

    Wednesday, August 7, 2013 3:01 PM

All replies

  • Try clearing out all your browser information, including all cookies.  See: Clearing Cache and Cookies

    Carey Frisch

    Monday, August 5, 2013 7:57 PM
  • Hi,

    Does it work normally when you copy files from one drive to another, or only this problem just happens in Internet Explorer 10?

    This probably caused by a program or service, you can try to make a clean boot for test. Please refer to the link below for more details about clean boot.

    http://support.microsoft.com/kb/929135

    Wednesday, August 7, 2013 12:49 PM
    Moderator
  • I run a cleaner regularly, It makes no difference

    Merlin

    Wednesday, August 7, 2013 2:34 PM
  • There were some suggestions in a a microsoft community forum (http://answers.microsoft.com/en-us/windows/forum/windows_8-files/copy-and-paste-feature-not-working-in-windows-8/22fe8b55-e1ab-48f1-a413-722f9ca108c1) but nothing fixes it.

    My suggestions there were diagnostics.  Diagnostics don't fix things.  They return information to help guide inferences which may ultimately result in a clearer symptom description.  Only then would it be possible to start an analysis which identified a problem and then perhaps a fix (or more likely, a workaround) could be devised.

     

    FYI



    Robert Aldwinckle
    ---

    Wednesday, August 7, 2013 3:01 PM
  • I run a cleaner regularly, It makes no difference

    Does it work normally when you copy files from one drive to another, or only this problem just happens in Internet Explorer 10?
    Thursday, August 8, 2013 2:19 AM
    Moderator
  • It doesn't affect file copying just text and from any browser into Live Writer, sometimes into excel and Outlook.  It hasn't happened since the big update last week maybe something changed

    Merlin

    • Proposed as answer by Ken.Haynes Tuesday, November 12, 2013 2:57 AM
    • Unproposed as answer by Ken.Haynes Tuesday, November 12, 2013 2:57 AM
    Monday, August 19, 2013 3:31 AM
  • Hi All,

    I hope this helps some of you.

    After a lot of research, I noticed that my paste issue only occurred when I had my browser running. It transpired, that is was when any browser (Firefox, Safari, IE, etc) was running.

    Long story short, it was my Webroot security software blocking some of my programs which were attempting to read the Clipboard.

    It makes sense, I have a browser open so I wouldn't want an untrusted application gaining access to my clipboard as it may contain a password. I just hadn't realized that it was doing this. When I disabled the Protect Clipboard Data option, everything worked again.

    Webroot prompted me to disallow / allow a particular program to access the clipboard, with an option to remember my choice. So, I gave certain programs permission and then switched the protection option back on, as I think that it is a great feature.

    I would guess that other security suites use this methodology so if you are experiencing paste issues, you may find it beneficial to check your security suites settings.

    Regards,
    Ken.
    • Proposed as answer by David Bergan Friday, March 14, 2014 9:35 PM
    Tuesday, November 12, 2013 3:16 AM
  • If that was the issue it would be the same in windows 7 vista etc. This is a Windows 8 specific issue. On another note your security software should not do that.  In fact I've never seen that behavior in any of the various suites my clients an I run.  I'd try a different  security if that happened to one of my clients

    Merlin

    Tuesday, November 12, 2013 2:13 PM
  • Ken!  Thanks so much!  My issue was identical to yours, and your recommendation was right on the money!  I spent hours and hours trying to find a solution on line and on the phone with tech support to no avail!  Much appreciated!
    Monday, November 18, 2013 4:51 PM
  • How did you do this?? I have webroot and can not find that option. I am trying to copy URL's for video's and paste them into my downloader. But copy and paste or one of them is not working.
    Thursday, January 30, 2014 9:33 AM
  • WEBROOT was the root of the problem for me.

    Right-click tray icon --> View Status --> [Gear icon] by Identity Protection --> Application Protection

    The application I wanted to paste into was listed as Deny.  I switched it to Allow and it works fine now.

    [Kinda mad that Webroot just takes over, classifies a normal app as a problem (Microsoft Visual Studio in my case), and doesn't tell you that it's messing with copy/paste. But at least I know how to deal with it now.  Also had this problem with MySQL Workbench.]

    Friday, March 14, 2014 9:34 PM
  • Robert Aldwinckle,

    I just turned off computer and restarted it after a 10 second wait. Every thing is normal again.  This works a lot of the time.

    Taft

    Tuesday, June 3, 2014 3:16 AM
  • Yes. Thanks for your suggestion.

    I ran into the same problem, and it was Webroot.

    Webroot messed up my normal application and denied it. These antivirus and antimalware programs frequently are the culprit behind these things.

    In Webroot, it also misclassified a normal application I had.

    I also moved it to allow and now works.

    For some reason, Webroot has these glitches and I have to remember to turn off Webroot to diagnose problems with my windows 8 system. Often, it is Weboot conflicts.

    Thanks.

    Monday, September 22, 2014 2:55 PM
  • I faced the same problem on my dad's system with Windows 8, till I turned off the "IM Anti-virus" option on Kaspersky. 

    Cheers!

    Tuesday, November 11, 2014 9:19 PM
  • Same thing here.  I had a normal application that Webroot marked as Deny.  As soon as I changed it to all, copy and paste worked. Thanks!

    Ralph

    Tuesday, December 9, 2014 11:21 PM