none
After CB 1906 Upgrade and Hotfix Rollup KB4517869 -MPCONTROL stating "port 80 with status code 500" falsely? RRS feed

  • Question

  • Getting the error and then OK 200 status back and forth on Secondary Sites that were Upgraded:

    Call to HttpSendRequestSync succeeded for port 80 with status code 200, text: OK
    Inbox source is local on SERVERNAME.COM
    Sent summary record of SMS Management Point on ["Display=\\SERVERNAME.COM\"]MSWNET:["SMS_SITE=BDH"]\\SERVERNAME.COM\ to \\SERVERNAME.COM\SMS_XYZ\inboxes\sitestat.box\wkz7qbkp.SUM, Availability 0, 524284924 KB total disk space , 522084604 KB free disk space, installation state 0. 
    Http test request succeeded. 
    STATMSG: ID=5460 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_MP_CONTROL_MANAGER" SYS=SERVERNAME.COMSITE=XYZ PID=2468 TID=7660 GMTDATE=Sun Oct 13 05:45:27.782 2019 ISTR0="" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0 
    Successfully performed Management Point availability check against local computer. 
    SSL is not enabled. 
    Using thread token for request 
    Call to HttpSendRequestSync failed for port 80 with status code 500, text: Internal Server Error 
    Http test request failed, status code is 500, 'Internal Server Error'. 
    Successfully performed User Service availability check against local computer for /CMUserService_WindowsAuth/applicationviewservice.asmx. 

    • A Test of MPCERT and MPLIST succeeds…
    • IIS Logs confirm that IIS is functioning properly as well…

    So what would cause MPCONTROL.LOG to shows these?


    David Baur

    Sunday, October 13, 2019 6:05 AM

Answers

  • Solved:

    Error in IIS Log was:

    GET /CMUserService_WindowsAuth/applicationviewservice.asmx - 80 DOMAIN\SERVERNAME$ fe80::5847:ddd6:774c:760d% -  500 19 183 5244 984

    Error in MPControl.log was:

    Call to HttpSendRequestSync failed for port 80 with status code 500, text: Internal Server Error    Http test request failed, status code is 500, 'Internal Server Error'.

    The issue was two fold in my case:

    • There were two entries that were in both the CCM\CMUserService\web.config file and the same in the ApplicationHost.config file.

    The duplicate Entries were in the ApplicationHost.config file

    The Duplicate Entries were:

                    <add name="X-XSS-Protection" value="1;mode=block" />           

     <add name="X-Content-Type-Options" value="nosniff" />             

    • The Second issue was that COMPUTER\ IIS_IUSRS did not have Read Permissions to either file.

    To Correct:

    1. Go to C:\Windows\System32\inetsrv\config\applicationHost.config and Make Backup copy of the ApplicationHost.config to .configold

    2.Edit the ApplicationHost.config

    3. Search in the window for the name “X-XSS-Protection" value="1;mode=block

    4. You should see this:

    <<<<<SNIP>>>>

    <httpProtocol>

                <customHeaders>

                    <clear />

                    <add name="X-Powered-By" value="ASP.NET" />

                    <add name="X-XSS-Protection" value="1;mode=block" />           <<<Delete this

                    <add name="X-Frame-Options" value="SAMEORIGIN" />

                    <add name="X-Content-Type-Options" value="nosniff" />             <<<Delete this

                    <add name="Strict-Transport-Security" value="max-age=31536000; includeSubDomains; preload" />

                    <add name="Content-Security-Policy" value="default-src self" />

    <<<<<SNIP>>>>>

    5. Once Deleted, save the file, Restart IIS and then SCCM Site Component Manager.

    6. Make sure (Path to your ) CCM\CMUserService\Web.config has the permission COMPUTER\ IIS_IUSRS with Read Permissions.

    7. Make  sure C:\Windows\System32\inetsrv\config\applicationHost.config has the permission COMPUTER\ IIS_IUSRS with Read Permissions.  (I have systems and Primary Sites that work without this, but in my case this worked)

     Note: You must add these to the Root Directory where Permissions are being inherited from.

    8. Monitor your MPCONTROL log  and IIS Logs and you should see it now work.


    David Baur

    • Marked as answer by David Baur Jr Tuesday, October 15, 2019 5:40 AM
    Tuesday, October 15, 2019 5:40 AM

All replies

  • Hello David Baur,
     
    Thanks for posting in TechNet.
     
    From the perspective of IIS, the failed test is testing User Service availability by Getting /CMUserService_WindowsAuth/applicationviewservice.asmx. Could you see the same 500 error in the corresponding IIS log? A successful check should like this in the IIS log.
     

     
    From the perspective of SCCM, have you restart the server after upgrading? Have you tried to reinstall the MP on the secondary site server? Is the CM client installed and functional?
     
    Hope my answer could help you and look forward to your feedback.
     
    Best Regards,
    Ray

    Please remembers to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 14, 2019 7:21 AM
  • How often do you get this? Dont believe i've seen that after the upgrade.

    Website: www.walshamsolutions.com Technical Blog: https://www.walshamsolutions.com/technical-blog Personal Blog: https://www.walshamsolutions.com/personal-blog Twitter: Dwalshampro

    Monday, October 14, 2019 8:48 AM
  • Was AV disabled during upgrade? What if re-install the MP role?

    MCSE Mobility 2018. Expert on SCCM, Windows 10, ALOVPN, MBAM.

    Monday, October 14, 2019 12:44 PM
  • Hi Ray,

    • From the perspective of SCCM, have you restart the server after upgrading?  Yes
    • Have you tried to reinstall the MP on the secondary site server? Yes
    • Is the CM client installed and functional? Yes
    • Corresponding IIS Logs show Clean, all give 200..  

    David Baur

    Monday, October 14, 2019 11:32 PM
  • It is still occurring, one right after another, 200, then 500, 200 then 500.

    HTTP Test are good, IIS Logs look good. very odd

    Upgrade Done 2 days ago.


    David Baur

    Monday, October 14, 2019 11:35 PM
  • Tried reinstall of MP, No effect.

    David Baur

    Monday, October 14, 2019 11:36 PM
  • In IIS I do see an error for that:

    2019-10-15 02:29:08 fe80::5847:ddd6:774c:760d%4 GET /CMUserService_WindowsAuth/applicationviewservice.asmx - 80 DOMAINAME\Servername$ fe80::5847:ddd6:774c:760d%4 SMS_MP_CONTROL_MANAGER - 500 19 183 5244 0


    David Baur

    Tuesday, October 15, 2019 3:36 AM
  • Solved:

    Error in IIS Log was:

    GET /CMUserService_WindowsAuth/applicationviewservice.asmx - 80 DOMAIN\SERVERNAME$ fe80::5847:ddd6:774c:760d% -  500 19 183 5244 984

    Error in MPControl.log was:

    Call to HttpSendRequestSync failed for port 80 with status code 500, text: Internal Server Error    Http test request failed, status code is 500, 'Internal Server Error'.

    The issue was two fold in my case:

    • There were two entries that were in both the CCM\CMUserService\web.config file and the same in the ApplicationHost.config file.

    The duplicate Entries were in the ApplicationHost.config file

    The Duplicate Entries were:

                    <add name="X-XSS-Protection" value="1;mode=block" />           

     <add name="X-Content-Type-Options" value="nosniff" />             

    • The Second issue was that COMPUTER\ IIS_IUSRS did not have Read Permissions to either file.

    To Correct:

    1. Go to C:\Windows\System32\inetsrv\config\applicationHost.config and Make Backup copy of the ApplicationHost.config to .configold

    2.Edit the ApplicationHost.config

    3. Search in the window for the name “X-XSS-Protection" value="1;mode=block

    4. You should see this:

    <<<<<SNIP>>>>

    <httpProtocol>

                <customHeaders>

                    <clear />

                    <add name="X-Powered-By" value="ASP.NET" />

                    <add name="X-XSS-Protection" value="1;mode=block" />           <<<Delete this

                    <add name="X-Frame-Options" value="SAMEORIGIN" />

                    <add name="X-Content-Type-Options" value="nosniff" />             <<<Delete this

                    <add name="Strict-Transport-Security" value="max-age=31536000; includeSubDomains; preload" />

                    <add name="Content-Security-Policy" value="default-src self" />

    <<<<<SNIP>>>>>

    5. Once Deleted, save the file, Restart IIS and then SCCM Site Component Manager.

    6. Make sure (Path to your ) CCM\CMUserService\Web.config has the permission COMPUTER\ IIS_IUSRS with Read Permissions.

    7. Make  sure C:\Windows\System32\inetsrv\config\applicationHost.config has the permission COMPUTER\ IIS_IUSRS with Read Permissions.  (I have systems and Primary Sites that work without this, but in my case this worked)

     Note: You must add these to the Root Directory where Permissions are being inherited from.

    8. Monitor your MPCONTROL log  and IIS Logs and you should see it now work.


    David Baur

    • Marked as answer by David Baur Jr Tuesday, October 15, 2019 5:40 AM
    Tuesday, October 15, 2019 5:40 AM
  • Hello David Baur,
     
    Glad to hear that your issue is solved and thank you for sharing the solution.
     
    Best Regards,
    Ray

    Please remembers to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 15, 2019 7:41 AM