none
After using Remote Desktop to connect to a remote PC, the remote PC's monitor does not go back into standby mode

    Question

  • Description:
    I am running Windows XP SP3 on my home computer.

    My screen saver is set to start after 5 minutes and the monitor is set to go into standby after 30 minutes.

    When I use remote desktop to connect to my home computer, the monitor comes out of standby mode and shows the standard windows "computer is locked" login prompt:

    "This computer is in use and has been locked.
    Only xxx\yyy or an administrator can unlock this computer.
    Username
    Password"


    Problem:
    The screen saver never starts and the monitor never goes into standby mode again, even after i disconnect from my home computer. =(

    I know this is a problem on my home computer because my office computer doesn't have the same problem. After i connect to my office computer using Remote Desktop, the screen saver starts as usual and the monitor goes into standby mode after the specified time.

    One difference is that my office computer is using Novell Client for windows and shows the "Novell Client Login" prompt instead of the login prompt i mentioned above.


    Attempted Fixes:
    So i have been cracking my head and still haven't found any solution. I've made sure that the screen saver starts in 5 minutes and the monitor is set to standby in 30 minutes. But the screen saver never starts and the monitor never goes into standby mode.

    I've even tried copying the registry settings for my user profile into the default profile, but still no luck =(

    "HKEY_USERS\.DEFAULT\Control Panel\Desktop\"
    "HKEY_USERS\.DEFAULT\Control Panel\PowerCfg\"

    I know i could turn off the monitor in advance but that isn't really the solution im looking for.

    Thanks in advance for any help provided!

    Noel Ho
    Wednesday, January 07, 2009 5:24 AM

All replies

  • Can you check the settings for the 'remote' session (not the 'host', system where the screen is coming out of screen saver/standby)

    It sounds as if the remote session is set to connect directly to the console session on the 'host'. It has been my experience that the monitor will come out of screen saver/standby, because it is tied to activity on the console session. This is selectable if you are launching from an MMC snap-in... simply uncheck the box 'Connect to Console'.

    Depending upon 'where' you are launching your remote session (same LAN, behind a firewall or router, etc...) you may wish to explore different ways to connect to the 'host'.

    From the Start | Run box, launch mstsc... enter the name of the 'host' system... you should get connected to a remote session instead of the console session...

    An additional advertised method, which I haven't yet tried is to enable IIS on the 'host' system, then do the following : (pasted from a variety of 'Help dialogs...

    To install Remote Desktop Web Connection

    1. Open Add or Remove Programs in Control Panel.
    2. Click Add/Remove Windows Components.
    3. Select Internet Information Services, and then click Details.
    4. In the Subcomponents of Internet Information Services list, select World Wide Web Service, and then click Details.
    5. In the Subcomponents for World Wide Web Service list, select the Remote Desktop Web Connection check box, click OK, and then click OK again.
    6. In the Windows Components Wizard, click Next.

    Notes

    • To open Internet Services Manager, click Start, point to Programs, point to Administrative Tools, and then click Internet Services Manager.
    • Internet Information Services is not installed on Windows XP Professional by default.
    • You must be logged on as an administrator or a member of the Administrators group to complete this procedure. If your computer is connected to a network, network policy settings might prevent you from completing this procedure.
    • To open a Control Panel item, click Start, point to Settings, click Control Panel, and then double-click the appropriate icon.

    end paste.)

     

    Then, from the 'remote' computer, (another cut/paste...

    Here's how to connect to a remote computer using a web connection:

    1. Open Internet Explorer or another web browser, and type the URL using the remote computer's name or IP address, followed by /tsweb/. For example:
      • If the computer name is MyComputer, you would type http://mycomputer/tsweb/.
      • If the IP address is 192.168.1.120, you would type http://192.168.1.120/tsweb/.
    2. On the Remote Desktop Web Connection logon screen, type the server name (the remote computer name), and then click Connect.
    3. Type your user name and password, and then click OK.

    End paste.)

     

    I hope this helps, at least a bit :)

    Friday, January 30, 2009 5:54 PM
  • whoa ... i didnt get an alert to your reply! Came across my post by chance when i was going through some old links in my favourite.

     

    I have since moved on to Win7 and have no idea if your solution would have solved my problem, but thanks for replying anyway! =)

    Sunday, May 15, 2011 12:08 PM