dllhost.exe *32 problem


  • I have been having a hard time getting some folders to open, for example if I click on the desktop and selecr personalize, it just keeps hanging and the page doesn't come up, the cursor just keeps showing busy, and if I end process of the dllhost.exe *32 it will stop but the folder still won't come up.  Also if I click on sounds, the box to change whether you want sounds or not won't come up unless I end process of this dllhost.exe *32, once ended the sounds box comes up.  What could be the problem?  I just got this laptop and was trying to install Corel Paintshop pro 2X and it wouldn't complete the install, every thing just kept hanging and freezing, so I assume this dllhost thing has something to do with that because after I uninstall what was partially installed of the corel that's when I started having problems.  Also having problems in the control panel, I can open control panel but when I go to click on the left hand side menu all I get the the pointing finger and it freezes.

    I need help, thanks
    Thursday, December 03, 2009 11:38 PM


All replies

  • Hi Debgram,


    I would like to suggest you create a new user account and test the issue in Clean Boot to check the issue.


    If it does not work, I also would like to suggest you perform a System File Checker.


    Good luck!

    Arthur Li - MSFT
    Wednesday, December 09, 2009 4:29 AM
  • Hi Debgram,


    I would like to suggest you create a new user account and test the issue in Clean Boot to check the issue.


    If it does not work, I also would like to suggest you perform a System File Checker.


    Good luck!

    Arthur Li - MSFT

    I already did the SFC, twice.  But I did figure it out, I went to Viper's Site to see what services were auto and manual, I made some adjustments and everythign works now.
    Wednesday, December 09, 2009 5:48 AM
  • Hi Even i am facing the same issue..i tried following the things sugggested in the above comments..nothing worked out..can some one please let me know how to STOP this dllhost.exe that is killing my Computer!!!!

    Please help MICROSOFT!

    Wednesday, March 24, 2010 3:23 PM
  • Use Process Explorer to determine what the instance of DLLHOST.EXE in question is running.
    Wednesday, March 24, 2010 5:47 PM
  • Hi how to use the Process Explorer to handle this situations?? please explain..i want to get rid off this issue.....Please help
    Saturday, March 27, 2010 7:52 AM
  • In Process Explorer, find the instance of dllhost.exe that you're concerned about, and hover the pointer over the process name for that instance.  What does the tooltip tell you?
    Saturday, March 27, 2010 10:03 PM
  • I had the same excact problem!!

    • Go to run and type in services.msc
    • Then go to COM+ System Application, not event system.
    • Disable that service

    and the problem will go away

    Sunday, December 26, 2010 11:16 AM
  • turning off Data Execution Prevention on dllhost (the COM surrogate) can fix this problem for some people. This solution is detailed below.

    Right click on Computer, and choose Properties

    Click on Advanced System Settings, and then under Advanced, click Settings

    Select the “Data Execution Protection” tab, and then click “Turn on DEP for all programs and services except those I select�?

    Click on the Add button, and then browse to C:\Windows\System32\dllhost.exe as shown

    Click Open, and then OK.

    Here’s what you should see…

    Now you can browse video folders without problems!

    Sunday, December 26, 2010 11:30 AM
  • You should not do both methods. It is better to detect the cause of the crash. Download this reg file from my SkyDrive:

    and make a double click on the file to import it.

    When the DLLHost.exe (COM surrogate) crashes, Windows Error Reporting Service [1] creates a dmp file under C:\Localdumps. Please upload the file to your public Skydrive [2] folder and post the link here. I take a look at the dump with the Debugger, maybe I can see which Video Codec is the cause.



    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter
    Sunday, December 26, 2010 1:27 PM
    Friday, September 27, 2013 12:33 AM
  • Solution "com.surrogate a cessé de fonctionner" pour Windows 7 64 bits 

    Enfin, délivré de ce cauchemar qui me poursuivait depuis plus d'un an. Si comme moi vous êtes confronté à ce message " Com surrogate a cessé de fonctionner...etc." ou pire encore le message n'apparaît pas, mais alors les imagettes des icônes disparaissent, les recherches dans l'explorateur de fichiers deviennent impossibles, un clic droit sur un fichier est inopérant, un programme ne se lance pas, alors j'ai peut-être trouvé une solution. 
    Jusque-là et parfois plusieurs dizaines de fois par jour il me fallait aller dans le Gestionnaire des tâches et dans Processus, Description,"tuer" le fichier "dllhost.exe*32" pour pouvoir reprendre une activité normale. 
    Pendant un an j'ai essayé toutes les manips proposées dans les forums, sans succès. Il existait bien apparemment une solution mais qui concernait W7 32 bits. Rien pour la version 64 bits
    J'ai trouvé ceci : 
    Il faut supprimer le fichier dllhost.exe, pas celui qui se trouve dans windows/system32 mais celui qui se trouve dans Windows/SywWoW64. Là bien sûr impossible de supprimer ou modifier ce fichier protégé par le système. d'où la démarche suivante : 
    - Clic droit sur "dllhost.exe" (dans Windows/SywWoW64) 
    - Onglet "sécurité" 
    - "Modifier" 
    - Sélectionner "Administrateur" 
    - Dans la colonne Autoriser, cocher "Contrôle total" 
    - Si vous avez la ligne "Trusted Installer", cocher "Contrôle total"dans la colonne Refuser 
    - Sortez en cliquant sur OK.../OK 
    Voilà, maintenant le fichier dllhost.exe peut-être supprimé ou modifié. Il est préférable de le renommer en dllhost.old ou mieux encore en ZZZdllhost.exe (il se retrouvera ainsi juste en fin de répertoire) et en cas de problème il suffira simplement de le renommer à nouveau. 
    Depuis maintenant 3 semaines je n'ai plus ce problème de "com.surrogate" et je n'ai pas constaté de dysfonctionnement par ailleurs. 
    Je ne sais toujours pas pourquoi ça marche (conflit entre dllhost.exe*32 et dllhost.exe*64 ?) mais ça marche !
    Wednesday, January 27, 2016 7:57 PM