none
Microsoft high definition audio controller conflict.

    Question

  • Q: How do you permanently uninstall the Microsoft high definition audio controller?

     

    I've built my media centre and all is well......bar the sound. I had the sound working just fine through the motherboard audio, but due to wanting better sound from Blu Rays, I went out and brought a Asus Xonar HDAV1.3 Slim sound card.

    A lovely sounding card when it works! I have disabled the on-board sound in the BIOS and I haven't installed the motherboards Realtek audio. When I install the Xonar, all works well, music sounds great and it's firing on all cylinders. Then I restart the PC and all goes to pot.

    If I try to play a song through Windows Media Player/ Centre, I get nothing. If I go to the control panel mid song and load up the sound tab, there is the Xonar (default) with the sound scale to the right of it flashing away. If I load up the Asus Xonar bundled control panel, it shows the same sound graph banging away. All this, but no sound through my speakers. The sound card has 2 HDMI sockets on it. An input from the graphics card and then an output which should carry the picture and audio. I'm getting the picture just fine.

     

    I think I've tracked down the source of the problem. Even though the 'Microsoft high definition audio controller' isn't enabled or set to default in the sound tab, it appears to be causing me issues. If I go into the device manager, System Devices,  and uninstall the 'high definition audio controller', it removes the extra sound device and it's all happy.

    A quick reboot of the PC and my sound works again, then after a fashion, it'll be found and reinstall itself. Still not selected as default, it causes my lack of audio.

    I was hoping there was a way that I could keep it uninstalled and to stop it coming back? I've tried uninstalling/ disabling in safe mode, but it still comes back. Any help would be greats as a Media Centre PC with no sound isn't all that great!

     

    David

    Sunday, February 27, 2011 4:53 PM

Answers

  • Hi,

     

    Would you please let me know if you disabled the high definition audio controller in Device Manager? If not, try to disable it and restart the computer to check the result.

     

    Best Regards,

    Niki

     


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Vivian Xing Monday, March 07, 2011 9:41 AM
    Wednesday, March 02, 2011 10:25 AM
    Moderator

All replies

  • My MB has HD audio and it works fine.

    If you want to use the card, disable the onboard audio in the BIOS

    Then your problems should be easier to fix from there on

     


    My MVP is for Windows XP, Vista and Windows 7 IT, and I am getting increasingly good with Visual Studio.

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Sunday, February 27, 2011 6:32 PM
  • I've disabled the onboard in the BIOS. Well, I'm 99% certain I have. I'll go have another look.

     

    Had a look, it's turned off in the BIOS like I thought and mentioned in my first post.

    Sunday, February 27, 2011 10:36 PM
  • Hi,

     

    Would you please let me know if you disabled the high definition audio controller in Device Manager? If not, try to disable it and restart the computer to check the result.

     

    Best Regards,

    Niki

     


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Vivian Xing Monday, March 07, 2011 9:41 AM
    Wednesday, March 02, 2011 10:25 AM
    Moderator
  • Hi.

     

    Very sorry for the reply. I must have missed the email telling me that I had a reply. I've also had to create a new forum name, I'm not sure why. Anyway, I'm Gingerbeadme.

     

    Niki. I have previously done as you propose as mentioned in my first post. I have disabled it/ uninstalled it and done this is safe mode as well as the normal operating mode.

     

    Vegan Fantastic. I also mentioned in my first post that I have disabled the on-board sound in the BIOS already to no improvement.

     

    The Microsoft High Definition audio device keeps on showing it's head if uninstalled. If disabled, it stays disabled. I then have fine audio for a short while until the problem rears it's head again. A quick uninstall of the (disabled) High Def Audio and I'm running fine again with audio.

     

    I don't know if it's defiantly the problem or it just happens to work. I have had a second thought that maybe it's a dodgy motherboard causing issues. The onboard audio is off via the BIOS but yet maybe it's somehow still on maybe and causing a conflict?

     

    Everyone's first answer is to turn off the onboard audio you see.

     

    David

    Saturday, April 02, 2011 2:15 PM
  • I have a couple of old PCI sound cards that I do longer use. They still work.

    I actually tested them recently as I wanted to see if Windows 7 SP1 had drivers that worked.

    I have the Microsoft LX-3000 USB headset and its a separate sound system. Windows 7 can use all of them at once.

    Because of that, the HD audio service may run even if nothing is running out of expectation. Outside an office, everyone uses the audio.

     


    My MVP is for the Windows Desktop Experience, i.e. Windows XP, Vista and Windows 7 IT

    Remote Assistance is available for a fee.

    I am best with C++ and I am learning C# using Visual Studio 2010

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Saturday, April 02, 2011 2:30 PM
  • Having the same problem as you I was very relieved to find this registry edit fix that permanently disables the HD audio controller :

     

    "I have tried to uninstall them in device manager....disable them in device manager yet when I re-boot...TADAAAA there they are again!!
    Surely there must be a way to get rid of them?
    You can disable them by editing two registry keys.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\servic es\HDAudBus\Start=4
    This value disables the High Definition Audio Controller in the device manager > system devices, it needs to be disabled.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\servic es\HdAudAddService\Start=4
    This value disables the High Definition Audio Device/ATI HDMI Audio Device. You don't have to uninstall the devices first and this will also free up an IRQ. After a reboot the devices will show a yellow exclamation point but you can ignore that."

     

    To edit these two values click the start button then type regedit.

    Double click HKEY_LOCAL_MACHINE, then SYSTEM, then CurrentControlSet, then services.

    Click HdAudAddService, then right click Start under the Name column on the right - click Modify, change the value from 3 to 4 and OK.

    Click HDAudBus, then right click Start under the Name column on the right - click Modify, change the value from 3 to 4 and OK.

    Reboot :)

    • Proposed as answer by icrutchv4 Wednesday, February 22, 2012 11:22 AM
    Sunday, August 28, 2011 1:59 AM
  • Steveno - your solution completely disabled all audio :< 

    The hunt continues....

    Sunday, October 21, 2012 6:58 PM
  • might be best to knuckle under and use the onboard audio and remove the audio card


    Windows MVP, XP, Vista, 7 and 8. More people have climbed Everest than having 3 MVP's on the wall.

    Hardcore Games, Legendary is the only Way to Play

    Developer | Windows IT | Chess | Economics | Vegan Advocate | PC Reviews

    Sunday, October 21, 2012 7:18 PM