locked
Enable Administrator Account in W7? RRS feed

  • Question

  • ** cross posting from Vista forum**

    I am trying to keep the local administrator account unlocked in Windows 7 by using the following xml file with this command: 

    sysprep.exe /generalize /unattend:unattend.xml

    Sysprep runs fine and in the end restarts the computer. When I try to login as administrator it tells me the account is disabled. I am NOT usaing any password for imaging purposes (blank password). Can anyone help me figure out what I am doing wrong here? 


    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <AutoLogon>
                    <Username>Administrator</Username>
      <Enabled>true</Enabled>
                </AutoLogon>
                <CopyProfile>true</CopyProfile>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="catalog:**path**windows7enterprise/sources/install_windows 7 enterprise.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>

     

    Thanks!


    Mayur
    Monday, April 12, 2010 7:12 PM

Answers

  • "Enable the account and specify the local administrator password" option

    OR

    command line: net user administrator /active:yes

    do not work.

    The only way I got it to work is to use the unattend file in the task sequence and set following options:

     <AutoLogon>
                    <Username>Administrator</Username>
      <Enabled>true</Enabled>
                </AutoLogon>


    Mayur
    • Marked as answer by Garth JonesMVP Saturday, February 6, 2016 3:06 PM
    Wednesday, April 14, 2010 9:36 PM

All replies

  • Just enable the administrator account in the ConfigMgr task sequence...
    Tuesday, April 13, 2010 10:12 AM
  • Doesnt work either for some reason. I have checked "Enable the account and specify the local administrator password" option.

    Is this what you meant or enable ith with command line: net user administrator /active:yes?


    Mayur
    Wednesday, April 14, 2010 3:24 PM
  • "Enable the account and specify the local administrator password" option

    OR

    command line: net user administrator /active:yes

    do not work.

    The only way I got it to work is to use the unattend file in the task sequence and set following options:

     <AutoLogon>
                    <Username>Administrator</Username>
      <Enabled>true</Enabled>
                </AutoLogon>


    Mayur
    • Marked as answer by Garth JonesMVP Saturday, February 6, 2016 3:06 PM
    Wednesday, April 14, 2010 9:36 PM