none
Missing Network Drives

    Question

  • Edit: Pics Below!

    Every now and then I will "lose" all of my network drives. Ending explorer.exe and reloading it always fixes the problem. Does it forget about my drives or something?!

    I have seen this once before in my life with XP, but since moving to 7, it has been a semi-regular occurrence (once a week or so).

    The install was clean, and it appears to be happening on multiple machines here in the office.

    Login Script Code:
    start /wait net use k: \\[server]\[share] /persistent:no
    start /wait net use p: \\[server]\[share] /persistent:no
    start /wait net use r: \\[server]\[share] /persistent:no
    start /wait net use s: \\[server]\[share] /persistent:no
    start /wait net use t: \\[server]\[share] /persistent:no
    start /wait net use y: \\[server]\[share] /persistent:no

    Like I said, after a while, it seems like Windows will just forget about them and some of them will not show up under "Computer". Any thoughts?
    • Edited by Jeradw Thursday, April 22, 2010 7:21 PM
    Monday, July 20, 2009 3:27 PM

Answers

  • We ended up calling Microsoft - turns out to be a problem with Symantec Endpoint Protection. Our current version is 11.0.6005.562. We are now working with Symantec to resolve this issue. We have transferred a bunch of procmon and windebug logs to them, so we'll see what happens.

    • Marked as answer by Jeradw Friday, September 10, 2010 3:04 PM
    Tuesday, June 08, 2010 8:06 PM

All replies

  • I am having the same issue in my environment, and it's going to be a really big issue for us if we try to deploy Windows 7 next year - Please help!

    Monday, July 20, 2009 3:41 PM
  • bump....
    Wednesday, July 29, 2009 1:13 PM
  • bump.......
    Tuesday, August 04, 2009 3:42 PM
  • bump.......anyone out there experiencing this?
    Friday, August 14, 2009 2:17 PM
  • Have you tried turing off the power off function of your NIC
    Device manager, NIC, properties, power management. From what I have heard, it can loose connected drives upon power down and up of the NIC.
    Friday, August 14, 2009 2:30 PM
  • It was checked to turn off the device to save power...I can try it for a while and see what happens.
    Monday, August 17, 2009 8:59 PM
  • I'm having this issue as well.  Every once in a while I'll lose some or all of my mapped drives in Windows Explorer.  Now, I just did some testing, and the drives are listed in "net use", and I can access the drive through a command prompt. 

    Today I lost my T:\ drive.  If I open up a command window, then run "T:" it will change to the T drive.  If I run "Dir" it will list all the files and folders in the root of the T drive.

    So, this is obviously an issue with explorer.  And I obviously can't role this out to my users with this problem.

    Also, My issue only happens right away when I log in.  If I kill explorer.exe, and restart it I won't lose my drives again unless I reboot.  My "turn off to save power" box was checked as well, so I unchecked it.

    Any other ideas? 

    Monday, August 17, 2009 9:50 PM
  • Dan, Thanks for the response.  I've tried that setting since Monday and I'm still having the same issue. :(
    Thursday, August 20, 2009 2:14 PM
  • I have found another little piece of information that will hopefully help Microsoft get to the bottom of this. It looks like I am having this problem right now on my computer.


    4 scenarios:

    1. I open up Computer via the Start Orb...I get the following network drives (H, S, T, V, Y)
    2. I open up Explorer via the Taskbar (Right click on the Libraries Icon and go to Windows Explorer)...I get the following network drives (
    G, H, I, P, R, S, T, V, Y, Z)
    3. Opening a command prompt and typing "net use" I see (G, H, I, K, P, Z have a status of OK) (R, S, T, V, Y have a blank status)
    4. Opening a command prompt and typing G: or H: or I: etc...allows me set and navigate through the network drives

    So...it just seems like the drives are missing from Explorer, but only certain views of explorer.

    also, this computer was just built yesterday from the Windows 7 install disc.

    Any thoughts?
    Wednesday, December 16, 2009 3:10 PM
  • bump
    • Proposed as answer by Alex Rivas1 Tuesday, October 27, 2015 10:00 PM
    Friday, December 18, 2009 4:47 PM
  • I had this start happening to me today. We use a logon script that maps a couple network shares to drive letters (net use...) and all was working fine until today. On my laptop, I cannot access any of my shares using the drive letter, they do not show up in explorer and when I go to s:\ it says "The system cannot find the drive specified". Yet, in a command prompt, net use lists all my shares with a status of OK and I can CD to them and open files from there all day long. I have tried restartting the computer.. restarting just explorer.. nothing works to return the funtionality of explorer to how it's supposed to work.

    I don't know if this has anything to do with it but I have not registered my Win7 so I did a slmgr -rearm using the directions here: http://www.avinashtech.com/microsoft/how-to-rearm-activate-windows-7-for-120-days/. This was performed today (since it started telling me my Windows was not genuine) and I do not know if the explorer problem was occuring before I did this. The laptop is also on a domain so maybe that plays into it too (in combination with slmgr).
    Monday, December 28, 2009 5:16 PM
  • Here's a visual representation of whats happening:

    So this is what I see when I click on Computer from the Start Orb


    This is what happens when I click on the Start Orb and typen in S:\ + Enter


    And this is what is shown from the command prompt...obviously seeing all the network drives.
    Friday, January 08, 2010 5:17 PM
  • I've seen the same behavior on my new windows 7 c since last week.
    Network mounts to my terrastation first appeared as not connected, and I could not click to open them, getting 'the system cannot find the drive specified' message.
    I tried to manually disconnect them, and after reboot, the mounts are gone, but the drive letters have also vanished.

    Any idea how I can recover these lost drive letters (I'm running out).

    tx,

    jm.
    Monday, January 11, 2010 2:44 AM
  • Small progress, I accidentally found my mapped drive letter in the Device Manager, under 'Portable Devices'.
    Doesn't explain why they disappeared in the first place, but at least, I can reuse them now.
    Monday, January 11, 2010 2:55 AM
  • I think windows mapped one of your portable devices (USB stick or otherwise) to one of your network drives. That happens to me every now and then, but its not quite the same problem. Glad you found them though.
    Wednesday, January 13, 2010 2:16 PM
  • I've been running windows7 for a while and never had this issue. This used to be a problem in older versions of windows as the login scripts may not always run before explorer starts. With windows7 being "better" and "faster" than vista or xp it is quite possible that this will occur more often than before.

    Anyway I checked my GPO settings and have the Always wait for the network at computer startup and logon setting enabled.

    Try doing the following and see how you get on:

    1. Open the appropriate Group Policy object for the computer or computers on which you want to implement the change.
    2. In the left pane, click to expand the following items:
      • Computer Configuration
      • Administrative Templates
      • System
      • Logon
    3. Double-click the Always wait for the network at computer startup and logon setting.
    4. Click Enable, and then click OK.

    (http://support.microsoft.com/kb/304970)

    Wednesday, January 13, 2010 5:45 PM
  • Hmmmm...mine was set to Not Configured. I went ahead and enabled it. I will give it a shot for a while and see what happens.

    Thanks!
    Wednesday, January 13, 2010 6:13 PM
  • Nope. I noticed that some of my drives today were missing (after I changed the GPO setting a couple days ago).   :(
    Friday, January 15, 2010 2:28 PM
  • bump......surely someone else out there has to be experiencing this?  :)
    Tuesday, February 09, 2010 2:37 PM
  • Just out of curiosity, what OS is on the server your mapping to?  And are you on a domain?

    I'm having issues with mapping drives, though not the same issues.
    Tuesday, February 09, 2010 3:05 PM
  • I use a net use batch script to map drives across two vpn tunnels and the local lan(s) (I have three IP ranges here, I am behind triple NAT).

    I do not "login" (as in get pushed any policy settings) to any AD, I do map a drive to a share on  2008  and 2003 AD boxes.

    I do not lose connection and the boxes show in the network map as well as explorer.

    I map drives from 50 some odd win 7 pro boxes to local NAS boxes using batch files no one has mentioned it to me anything about losing the mapping.

    Only a few of the Crystal Reports users get much of anything pushed to them policy wise and as far as I know they are not seeing this.
    So it could be some account setting, AD is not my area.


    I will note a few things here.
    When first rolling out 7 I had some flaky network issues on a few networks, drive mapping taking FOREVER or failing the first time things like this.

    I found out I had some older gear which was not up to the win 7 standards and some of the CAT 5 had issues.

    I had a 10 / 100 linksys / cisco which worked fine with 2000 / XP on the network but the adding one win7 box had the switch going crazy, I unbound IP6 and it got better but
    still had random drops.

    I needed to replace the old switch with a new gigabit anyway, once I did that things went back to normal.

    On two networks it was the cheapo netgear home routers in use, we would get fail DHCP responses, IP conflicts, dropped connections (which would show as drop mapped drives)

    replaced with new cisco gear and all is good.

    so if it was me I would start with the hardware end first.
     

    Tuesday, February 09, 2010 3:15 PM
  • We are mapping to a Server 2008 R2 server, though the problem still was present when the same server was Server 2003.

    Yes, we are on a Windows domain.

    Monday, February 15, 2010 5:16 PM
  • It looks as though the drives that continue to go missing are DFS points. I am going to do some searching to see if Win7 has a problem with DFS. All the pictures above are accurate, and they are all DFS points as well.

    More testing...

    1. I can get to the share by using UNC (\\server\share) or (\\serversip\share), but I still cant get to the share by using the drive letter that is supposidly found by running "net use". So, it seems like its mapped, but not really (see the above pictures). If I do a Start|Run and enter in one of the "missing" drives it will say that it cant find the specified drive.

    2. Tried to unjoin and rejoin the domain, but the problem remains.

    3. Drives stay mapped for an unset amount of time and then just disappear.

    Monday, April 12, 2010 6:24 PM
  • We ended up calling Microsoft - turns out to be a problem with Symantec Endpoint Protection. Our current version is 11.0.6005.562. We are now working with Symantec to resolve this issue. We have transferred a bunch of procmon and windebug logs to them, so we'll see what happens.

    • Marked as answer by Jeradw Friday, September 10, 2010 3:04 PM
    Tuesday, June 08, 2010 8:06 PM
  • We are having a similar problem but on Windows XP. We are connecting to DFS as well. Please let us know what Symantec finds.
    Wednesday, June 09, 2010 12:20 PM
  • They told us to remove the Network Threat Protection module and we havent experienced this problem since. Obviously, this is only a work around, but maybe it will be patched in later versions.

    Tuesday, June 22, 2010 3:02 PM
  • Jeradw,

    Is this work around still in place for you? has it been working? Are there any other fixes that you know of?

    Thanks.

    Friday, October 29, 2010 1:54 PM
  • No - we have since upgraded to a newer version of SEP and have not experienced the problem since. 11.0.5002.333 is the version we are running right now on our Windows 7 PCs.
    Monday, November 01, 2010 12:49 PM
  • I had this problem with Windows 7 clients running in a 2008 R2 domain.  We use logon scripts to map network drives.  Often only certain drives would appear under My Computer or Explorer.  All of the drives would exist at the Command Prompt.  If I stopped and restarted Explorer, all of the drives would appear under Explorer, etc.  The fix was to delay the logon script just a little bit.  In my case I added a ping command statement at the top of each logon script.  The ping command pings my default router and delays the rest of the logon script by about 4 seconds.  There is something goofy about the timing of logon scripts and when the Explorer shell starts.  The 4 second delay in the logon script seems to help.  Try it!
    Wednesday, January 30, 2013 3:59 PM
  • Yeah, six years after all of you wrote about this, I just lost my G: Drive and had it replace itself with H: drive. Bitch of it is, that all of my previously destroyed computer's good data was on that G: drive zip-drive. Now, I plug in the same zip drive and since it's not call the 'H:' drive, it doesn't connect to anything, and I'm told that Windows "cannot locate" the G: drive that I had my zip connected to, two days ago!

    Where, oh God, where did my G: drive go???

    Thursday, April 16, 2015 1:08 AM
  • One of my client having similar issue. Sometimes mapped drives won't show up in explorer but it shows up after restarting explorer.exe

    Client is running Symantec 12.1.5337.5000.

    Anyone knows the fix for this

    Monday, April 04, 2016 10:54 PM