none
WEP - Hex key Wifi connection - not connecting!

    Question

  • I'm attempting to join a wifi network with a 10 digit hexadecimal security key - the network is hidden.  I know the SSID and the hex key for WEP.

    System - Windows 7 - 64 bit, RC

    Interface name: Wireless Network Connection

        Driver                    : Broadcom 802.11g Network Adapter
        Vendor                    : Broadcom
        Provider                  : Microsoft
        Date                      : 10/1/2008
        Version                   : 4.176.75.23
        INF file                  : C:\Windows\INF\oem3.inf
        Files                     : 2 total
                                    C:\Windows\system32\DRIVERS\BCMWL6
                                    C:\Windows\system32\drivers\vwifib
        Type                      : Native Wi-Fi Driver
        Radio types supported     : 802.11g 802.11b
        FIPS 140-2 mode supported : No
        Hosted network supported  : Yes
        Authentication and cipher supported in infrastructure mode:
                                    Open            None
                                    Open            WEP
                                    Shared          None
                                    Shared          WEP
                                    WPA2-Enterprise TKIP
                                    WPA2-Personal   TKIP
                                    WPA2-Enterprise CCMP
                                    WPA2-Personal   CCMP
                                    WPA-Enterprise  TKIP
                                    WPA-Personal    TKIP
                                    WPA-Enterprise  CCMP
                                    WPA-Personal    CCMP
        Authentication and cipher supported in ad-hoc mode:
                                    WPA2-Personal   CCMP
                                    Open            None
                                    Open            WEP

    C:\Users\username\>IPCONFIG /ALL

    Windows IP Configuration

       Host Name . . . . . . . . . . . . :username-laptop
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    Wireless LAN adapter Wireless Network Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Broadcom 802.11g Network Adapt
       Physical Address. . . . . . . . . : 00-23-4E-C0-3B-F8
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::ed8e:a7e3:a17f:78cf%12(P
       IPv4 Address. . . . . . . . . . . : 192.168.1.4(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Saturday, September 12, 2009 6
       Lease Expires . . . . . . . . . . : Sunday, September 13, 2009 6:4
       Default Gateway . . . . . . . . . : 192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DHCPv6 IAID . . . . . . . . . . . : 218112846
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-3D-55-CB-00-23-

       DNS Servers . . . . . . . . . . . : 192.168.1.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Broadcom NetLink (TM) Fast Eth
       Physical Address. . . . . . . . . : 00-23-5A-17-01-6E
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{83CD515E-B29B-4031-8A8A-8A43994E440F}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interf
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e50:14a2:301d:b4b
    erred)
       Link-local IPv6 Address . . . . . : fe80::14a2:301d:b4bc:615e%13(P
       Default Gateway . . . . . . . . . : ::
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter isatap.{D727AB59-6B67-4C9F-9278-D5012EC6547F}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    In tne past, Windows had the ability to enter into WEP either a pass phrase or a hexidecimal key.

    In Windows 7RC, there seems to be no indication of what should be entered into the WEP key - it just says "network security key".

    If I enter my 10 digit hexidecimal key - I cannot connect.  I have selected "open" as I have no encoding on my wireless LAN.

    Fortunately I live near a coffee house and since I drink coffee there, I don't feel too badly about connecting to the Internet to ask this question.

    I've searched and searched - I've read about how Windows 7 seems to make it difficult to connect to WEP wireless LAN's - but it should not do this - often when traveling to schools and other places, I need to use their open wifi - some of the systems are Unix, some Windows Server - with Vista and XP I never had a problem, and I could be sure that my "WEP" entry was used as a pass phrase or hex key.

    This definately should be improved - I really hope it is by the time of the release of Windows 7.

    I checked Windows Update and I see that there is another Broadcom wifi update.

    Since I cannot save this posting, I am going to submit it, and IF things change with the update, I will come back here and say so!



    Saturday, September 12, 2009 11:27 PM

Answers

  • Show my existing wireless key:
    Go to Control Panel > All Control Panel Items > Network and Sharing Center > click the name (in Blue) alongside Connections: > Wireless Properties > Security Tab and put a tick in Show characters.



    Deleting the existing network then setting it up again may be the best:

    1. Delete network
    Go to Control Panel > All Control Panel Items > Network and Sharing Center > Manage Wireless Networks (in the left pane) and right-click the one you want to Remove.

    2. Add a new network
    Go to Control Panel > All Control Panel Items > Network and Sharing Center > Set up a new connection or network > Manually Connect to a Wireless Network > Next. Type in the Network Name (SSID), select Security Type and type in the key. You may also want to tick ‘Start this connection automatically’ and ‘Connect even if the network is not……‘ > Next. Subsequent connections will be automatic.

     

    • Marked as answer by Novak Wu Wednesday, September 16, 2009 7:10 AM
    Sunday, September 13, 2009 5:49 PM

All replies

  • Show my existing wireless key:
    Go to Control Panel > All Control Panel Items > Network and Sharing Center > click the name (in Blue) alongside Connections: > Wireless Properties > Security Tab and put a tick in Show characters.



    Deleting the existing network then setting it up again may be the best:

    1. Delete network
    Go to Control Panel > All Control Panel Items > Network and Sharing Center > Manage Wireless Networks (in the left pane) and right-click the one you want to Remove.

    2. Add a new network
    Go to Control Panel > All Control Panel Items > Network and Sharing Center > Set up a new connection or network > Manually Connect to a Wireless Network > Next. Type in the Network Name (SSID), select Security Type and type in the key. You may also want to tick ‘Start this connection automatically’ and ‘Connect even if the network is not……‘ > Next. Subsequent connections will be automatic.

     

    • Marked as answer by Novak Wu Wednesday, September 16, 2009 7:10 AM
    Sunday, September 13, 2009 5:49 PM
  • I don't know, what W7 with WEP does. But, using of WEP is completely useless. WEP networks can be hacked in minutes (google for Aircrack) . Hidden SSID also won't help. The best way to a secure wifi network is using WPA2 with AES encryption. SSID should be vissable.



    Sunday, September 13, 2009 7:30 PM
  • I don't know, what W7 with WEP does. But, using of WEP is completely useless. WEP networks can be hacked in minutes (google for Aircrack) . Hidden SSID also won't help. The best way to a secure wifi network is using WPA2 with AES encryption. SSID should be vissable.





    If you had read the post properly you would have seen that DJRingJr wants WEP!

    He uses different networks including open networks so, in reality, he probably doesn’t hold classified government or commercial secrets on the computer.

    Also, bear in mind that older laptops and adapters can only use WEP, i.e. its successors didn’t exist at the time.

    Monday, September 14, 2009 7:32 AM
  • BurrWalnut,

    Your reply was perfect.  Thanks for showing me where the settings were!

    DJRingJr


    Tuesday, September 15, 2009 1:32 PM