0x00000100 when adding a networked Xerox


  • I have a machine (windows7 32bit) that cannot connect to a Xerox printer that is shared out from our Server 2008 64bit print server. I have tried changing the driver on the print server, tried installing the printer drivers to the client machines locally, and then connecting directly to the printer via a newly created TCP/IP port so it doesn't have to download the driver from the server, deleting anything xerox related, then reinstalling the drivers both locally and from the server, and nothing prevails yet. It is only happening to this Xerox printer. No matter how i attempt to add it, i receive 0x00000100 with no other explanation.

    I have tried the registry edits that Microsoft has published in a KB, but the registry was fine.

    Any ideas or directions?
    Wednesday, August 24, 2011 10:08 PM

All replies




    I would like to confirm if you have installed the correct driver for Windows 7? Sometimes, the incompatible driver could cause the connection issue.


    We can also use process monitor to capture the process log to see if there is any error during establish the connection.


    Troubleshooting with Process Monitor


    Alex Zhao

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, August 26, 2011 9:29 AM
  • Yes, i am using the correct driver, downloaded directly from Xerox website. The same driver is working on many many other windows 7 machines without issue, all have download from our print server. The same driver had been previously working fine until one day it said it needed to update or download the driver, so it updated and threw that error. Then i uninstalled the driver and printer form the machine, and attempted to re-add the printer several different ways and received the 0x00000100 every time, no matter how i add it. I believe the driver had become corrupted while it was installed on the client, calling it to download and install new or update, but something somewhere is just stuck and not allowing a full removal or reinstall.


    I will try the Process Monitor, see what it says and then ill post the results here.





    Systems / Network Admin

    Monday, August 29, 2011 7:53 PM
  • I created two capture files to reference. In both capture instances i started the capture, attempted to add the printer, received the error 0x00000100, canceled out of the add printer wizard  and then stopped the capture.

    I looked through both of them, and couldn't really find anything that told me what the problem is. Found a lot fo instances of NAME NOT FOUND when looking for the printer name in the registry, but that is to be expected.


    In both of these logs, the print server name is MTAPRINT02 and the printer having the trouble is RA_Xerox. \\mtaprint02\ra_xerox.

    Do you have a place for me to upload these capture file logs for you to look through and see if you can see anything?




    Systems / Network Admin

    Monday, August 29, 2011 9:45 PM
  • Hi,


    Did you try the method mentioned in following article?


    Error message when you try to install a network printer on a Windows Vista-based computer: "Windows cannot connect to the printer Operation could not be completed (error 0x0000000d)"


    You need modify the printer server registry entry.


    Meanwhile, you could upload to SkyDrive.


    Alex Zhao

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, August 30, 2011 2:33 AM
  • I just tried that, and it did not make a difference. However, that process is for a different error (0x00000d) than i am receiving (0x00000100).

    I was finally able to get the printer added by downloading a completely separate driver, adding it as a local tcp/ip port and then choosing that secondary driver. But that is not a desired method of adding a printer because if we make changes to the network or printers, that changes don't replicate down to the clients from the server. So it appears to me that for some reason the original driver that was installed became corrupted, thus calling for it to be downloaded and its now getting stuck somewhere because its already installed but not really. Make sense? Also keep in mind that all other clients connecting to this printer, through the print server, Windows 7, XP 32bit and 64bit have no trouble at all and are printing all day long everyday. So the trouble has to be local to this one client machine.


    I have uploaded the log files from ProcessMonitor.!102



    System / Network Admin
    Wednesday, August 31, 2011 4:42 PM
  • Anything yet? At least any ideas of a direction to head in? I have exhausted all of my ideas. Any help would be awesome and greatly appreciated.





    System / Network Admin
    Tuesday, September 06, 2011 8:39 PM
  • Erik907-

    I'm having EXACTLY the same issue.  Did you ever resolve this issue?




    Thursday, March 15, 2012 6:30 PM
  • Erik... I am guessing you are on a domain compuer. Can you log on a different user and try adding it (non admin and admin)? Can you try logging onto the compuer locally and try and add it? I was having a similar issue with Xerox printers before and on of our level two techs installed a solution that completely screwed up the print spooler. I tried EVERYTHING, including isolating already installed printers via the print management admin console. So I figured I would try it as a different user and magically the printer added without an issue. I went back on the offending user's login and tried adding the printer and it worked fine.

    Are their vista drivers that can be tried to be deployed as replacements also?

    If that does not work, are you getting any errors in the event log, especially under the app and services log | microsoft | windows |print service. Let me know.

    Friday, March 16, 2012 2:36 AM
  • I have finally got this to consistently work. And to answer your questions... Yes we are in a domain environment, and the domain user was local admin on the local machine. My belief is that somehow the driver on the local machine became corrupt some how, because i could still print, add printers, manage printers, remove, add new drivers, change drivers...etc on the print server without any errors. It only appeared a few times on a few local machines after a random period of time.

    The method i used (May not work for you but it did for me, but worth a shot):

    1. On the client machine - Set any printer that was using that driver to use a different one, or just delete the printer ocmpletely.
    2. After no printer is currently using the driver, delete the driver from the machine - XP way -> file, print server, drivers tab, select driver and click delete or remove. Remove driver package if possible. Win 7 way -> Highlight any printer, then click the button on the top that appears Print server properties, Drivers tab, highlight driver and click remove.
    3. If you cannot delete the drivers and you knwo there are no printers using it anymore, you will need to stop and restart the print spooler. Then you should be able to delete the drivers without error.
    4. Then i added the printer again via shared printer from the print server and causing the printer to reinstall fresh like it was never installed before.

    I have got that method to consistently work now and have not yet had the problem return.

    System / Network Admin

    Monday, March 19, 2012 7:30 PM