none
gpedit.msc fails: could not open the Group Policy Object on this computer, details: unspecified error

    Question

  • gpedit.msc fails: could not open the Group Policy Object on this computer, details: unspecified error

    After start of gpedit.msc there's message: (i have polish version of OS, so translation may be incorrect)

    • Group Policy Error: Unable to open the Group Policy Object on this computer. You may not have sufficient rights. Details: Unspecified error.

    After this Local Group Policy Editor appear, but there's no possibility to do anything, and there's no any elements of tree.

    OS: Win 7 Prof 6.1.7601 SP1, There's no changes in GPO. Computer is not part of domain.

    I used SFC to check system, according to http://support.microsoft.com/kb/929833, with no effect. Of course, current user is in administrators group, and LUA (UAC) is off.


    -------------------------------------------

    In Event Viewer i found two errors:

     

    Windows Firewall did not apply the following rule:

     

    Information on rules:

    ID: CoreNet-IPHTTPS-In

    Name: Basic network operations - Protocol IPHTTPS (inbound TCP)

     

    Information about the error:

    Cause: The local port is empty.

     

    Windows Firewall did not apply the following rule:

     

    Information on rules:

    ID: CoreNet-Teredo-In

    Name: Basic network operations - Teredo (UDP inbound traffic)

     

    Information about the error:

    Cause: The local port is empty.

     

    But I don't know how to fix them. It appear, when I'm starting gpedit.msc

     

     

    • Edited by ernehem Saturday, November 5, 2011 9:08 AM
    Saturday, November 5, 2011 8:38 AM

Answers

  • Why did you mark this as the answer when you've not provided an answer or indeed offered any helpful advice whatsoever?

    This is a serious issue around the technet forums where moderators simply bump up their own meaningless point scores by "answering" issues with absolutely nothing at all. Sort it out, Microsoft.

    I still have this issue. It's unresolved, and the answer here doesn't help, unsurprisingly.

    Edit - the solution is to delete the contents of the folder "c:\windows\system32\grouppolicy". You can then open the Group Policy Editor successfully.


    Thursday, October 25, 2012 10:30 PM

All replies

  • hai,

    http://support.microsoft.com/kb/839499   check this


    Regards fazil [Please remember to click this as marked as helpful if u find it useful.. This can be beneficial to other community members reading the thread.]
    Saturday, November 5, 2011 8:47 AM
  • This not work for me.
    Saturday, November 5, 2011 8:54 AM
  • Hi,

     

    Does this issue occur to all users?

     

    Have you tried to create a new user to test?

     

    Alex


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, November 9, 2011 9:38 AM
    Moderator
  • Why did you mark this as the answer when you've not provided an answer or indeed offered any helpful advice whatsoever?

    This is a serious issue around the technet forums where moderators simply bump up their own meaningless point scores by "answering" issues with absolutely nothing at all. Sort it out, Microsoft.

    I still have this issue. It's unresolved, and the answer here doesn't help, unsurprisingly.

    Edit - the solution is to delete the contents of the folder "c:\windows\system32\grouppolicy". You can then open the Group Policy Editor successfully.


    Thursday, October 25, 2012 10:30 PM
  • Its a good point from RPXN....

    The fix mentioned (delete the contents of the folder "c:\windows\system32\grouppolicy".) worked for me so thanks


    Carl Barrett | Twitter: @Mosquat

    Tuesday, June 4, 2013 9:52 AM
  • Thanks rpxn, deleting the folder did the trick...

    Just a side note, my computer was not joined to a domain, but had the windows features for administrating active directory.  I removed those features and deleted the folder.  And it worked.  

    Friday, August 30, 2013 12:50 AM
  • Awesome. It IS working for me. Once it is fixed, I am able to fix the other error "Shut Down Button Is Missing From Windows 7 Logon Screen". 

    [

    Edit - the solution is to delete the contents of the folder "c:\windows\system32\grouppolicy". You can then open the Group Policy Editor successfully.

    ]

    Thanks a million RPXN.

    2015-12-07

    Monday, December 7, 2015 2:59 PM
  • The point goes to RPXN, deleting the the content of the "GroupPolicy" folder resolved this isse.
    Thursday, January 21, 2016 1:56 PM
  • I had this issue on Server 2016 Standard. This server runs Hyper-V for some of our VM's (in a domain).

    It is not joined to any domains.

    Recently, I wanted to disable WindowsUpdates as I prefer to do updates manually and without any surprise restarts. Opening up gpedit.msc gave me that specific error, and a Google directed me to this thread.

    To confirm - deleting the contents of the folder "c:\windows\system32\grouppolicy" resolved this issue for me as well - on Server2016.

    Thanks for this, it is really appreciated.



    Thursday, December 14, 2017 11:22 AM
  • Thank you, It has worked for me.......
    Monday, January 22, 2018 9:02 AM
  • Same Problem on Win 10 and Solution Worked for me too (deleting the contents of the folder "c:\windows\system32\grouppolicy")

    Thanks a lot!

    Wednesday, February 28, 2018 1:31 PM
  • So we are having this same issue on win7 and win10 machines and we DO NOT have the c:\windows\system32\grouppolicy folder.  We do have c:\windows\system32\grouppolicyUsers has anyone come across this?  The folder appears empty.  What's odd is on a system that IS working I have the GroupPolicyUsers folder as well.

    ANY help would be greatly appreciated!

    Wednesday, April 18, 2018 7:48 PM
  • Roger Truss:

    You have to enable hidden files in "View" in order to see the "GroupPolicy" folder.

    • Edited by Batman1458 Monday, April 30, 2018 7:27 PM
    Monday, April 30, 2018 7:26 PM