none
Error Code 80070017 on SP1 Vista install

    Question

  • I have just installed a brand new copy of Vista Ultimate and then tried to do all the updates ...this went well. However on SP1 Vista I get Error Code 80070017 consistently. One thing that may be relevant is that there are two boot up options on the very first screen that comes up after bios creen and it list two vista options. I always click the first one. The hard drive was brand new.
    Tuesday, January 01, 2008 2:21 PM

All replies

  •  

    0x80070017 -2147024873 ERROR_CRC Data error (cyclic redundancy check).

     

     

     

     

    The short answer is the download was corrupted. Did you use windows update or the standalone package?

     

    If you haven't used the standalone package for SP1 use that.

     

     

    Also, You may need to go to C:\Windows\SoftwareDistribution\Download and delete all the contents to fix the problem.

    Tuesday, January 01, 2008 4:02 PM
  • I was using automatic update version. I tried stand alone and this worked.
    Thursday, January 03, 2008 10:50 PM
  • i understand that this error code is only popping up when the installation of service pack 1 for vista is installed.  how do i go about fixing this error as my laptop is beand new and has only been used since february of THIS year and i do need this laptop foy both personal and business use
    Saturday, May 31, 2008 6:31 AM
  • thnx alot it works
    Thursday, January 08, 2009 12:39 PM
  • I am having the same problem, but i went to C:\Windows\SoftwareDistribution\Download and I don't see how to delete all of its content? Any instructions?


    Friday, July 22, 2011 12:04 AM
  • I started out with the standalone SP1, received the 80070017, ran chkdsk c: /f re-attempted install, go the same results, ran "fix-it" from another response and tried again. Still not getting the "SP1" label on the system which appears to be required either for IE9 or for Office 2010 installs, as well as "upgrading" to Windows 7. This is a new install of Vista Business on an antique Pentium 4 with 80 GB HD. I am clearing window\softwaredistribution\download folder and will attempt standalone once again.  8/28/2013
    Wednesday, August 28, 2013 9:57 PM