none
TWINUI App reset to default, browser set to default RRS feed

  • Question

  • I work in PC refurbishing.  Part of what I do is prepare Windows 10 images for deployment to refurbished computers.

    Recently, I went to update all my images to latest updates and recapture them.

    Unfortunately, something has gone sideways in one of the cumulative updates or something.  I have not experienced this issue with Windows 10 1903 before.  It's a recent change.  Within the past 2 months (I generated images back in June successfully.)

    Now what I'm seeing, is when the image is deployed to a target computer (the image has been 'sealed' back to OOBE via Sysprep), upon completing setup questions and seeing the desktop, I am greeted by about 20 notification that various Edge browser associations and App associations were reset to TWINUI.

    I'm really unsure what's going on here.  It's a fresh install basically.  I cannot figure out what is causing this to happen.  Can anyone help?  I can provide further details if it helps.  Everything I can find on the internet related to TWINUI and App defaults getting reset suggest the registry is corrupted and I should use System Restore, or reinstall Windows.  Obviously this not a viable solution, as this IS a fresh install.

    Any help or insights would be fantastic.

    Friday, September 6, 2019 10:17 PM

All replies

  • Hi,

    You can test the Powershell Command

    Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

    in your problematic PC. If the command works fine, I suggested you to recapture your image.

    Hope this helps.

    Best Regards.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 10, 2019 2:16 AM
  • Hi,
     
    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.
     
    Best Regards,



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 12, 2019 10:18 AM
  • Hi, 

    Was your issue resolved? 

    If you need any help, please let us know. 

    Best regards. 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, September 30, 2019 8:19 AM
    • Edited by MilanD3 Friday, October 11, 2019 6:01 PM fixed URL
    Friday, October 11, 2019 6:00 PM
  • So here we are again, with 1909 causing these issues again.

    My previous solution is no longer working.  My previous solution was to install from the 1903 ISO image to a VM not connected to the internet.  Then go into Windows Updates and pause updates.  Doing this prevented any further updates from being installed onto the clean 1903 image.  This stopped the app association default resetting flurry of notifications, while still allowing me to reconnect to the internet to install a few custom apps (those apps being: Adobe Reader, VLC media player and LibreOffice)

    Well, it's back again.  I tried the previous solution to no avail.  I tried allowing updates and resealing/recapturing, no joy, about 14 notifications appear.

    I checked out that other thread by Milan, but nothing in there seems to help, I frankly don't even understand some of the stuff he's talking about, I could not even find a DEFAULTUSER.  I did find .DEFAULT, but none of the registry keys he recommends removing before sysprep even exist in that subfolder of the registry.

    Any insights or things I could try would be fantastic.  I'm going bald here trying to figure this out.

    Everything else about my process remains the same:  Install from ISO to a virtual machine, engage audit mode (Ctrl-shift-F3 from first setup question), make a few adjustments to the desktop, install 3 custom apps, then sysprep to reseal the image.  I am using the CopyProfile feature to propagate desktop customizations (wall paper, icons on desktop, etc)  Create a recovery partition, copy ISO image to that recovery partition, then use DISM to capture from the sealed customized image and place the new install.wim into the recovery partition.  Lastly I run a little script that adds a second boot option to boot from the recovery partition.

    If I can provide any other information that would be useful, just ask.


    • Edited by Chetar Ruby Saturday, November 16, 2019 8:48 PM added audit mode step
    Saturday, November 16, 2019 8:46 PM