After latest update, explorer.exe acts funny RRS feed

  • Question

  • Hello all. 

    I recently got the latest update for windows 10 and since then, something happens (while i am using the laptop) and i cannot use the mouse if i don't use the right click first. Everytime i want to click something on the taskbar and back i have to right click first. I tried ending the explorer .exe from the task manager and start a new task but after a while, it happens again.

    Is there anone else with the same problem?

    Thank you

    Saturday, April 22, 2017 7:32 PM

All replies

  • Have you tried a different mouse? Perhaps an issue with the mouse.
    Saturday, April 22, 2017 10:32 PM
  • Hi OrePap,

    Please refer to this article:
    How to fix mouse issue after installing the Windows 10 Creators Update
    Sunday, April 23, 2017 11:27 PM
  • Hi, 

    Have you tried to run the Hardware and devices troubleshooter to check this issue first?? Also, to check this unusual mouse issue, please test if it can work after uninstall the driver and restart the PC, the driver will be reinstalled properly. 

    In addition, Let's test if this issue also happened in Clean boot mode and Safe mode. and let me know your test results. 

    How to perform a clean boot in Windows

    Boot your PC into Safe mode:

    If this issue just happen on Explorer, we also consider it could be some 3rd party extensions on Windows explorer:

    We can also use shellexView to disable non-Microsoft related extensions of Windows Explorer:


    1. Download ShellExView v1.41 from the following link 

    Please Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.

    2.  Extract "" file and open shexview.exe. It will scan the registry for all the shell extensions.

    3. Select all the non-Microsoft extensions in pink by press "Ctrl" in the keyboard.

    4. Click the "Disable Selected Items" on the toolbar and click Yes.

    5. Restart your computer and check if the issue is resolved.

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Monday, April 24, 2017 8:19 AM
  • Thank you very much for all the answers.

    Seems that the problem is not present now but i did not do anything specific to be honest.

    I had a minor issue with the touch-pad as well as it didn't work after sleep mode and i had to go to settings to fix it every time.

    Monday, April 24, 2017 11:01 AM