none
Microsoft Windows Search Indexer

    Question

  • Whenever I start my computer an error message pops up saying that Microsoft Windows Search Indexer stopped working and was closed.  This occurs everytime I start my computer.  Please offer any solutions to fix this error.

    Thanks,

    Richard
    Thursday, December 20, 2007 4:24 AM

Answers

  •  

     

    Hi Richard,

     

    Thank you for the post.

     

    Let’s try the following suggestions to troubleshoot the issue:

     

    Suggestion 1 Rebuild the Index

    ===========

    1.   Open the Control Panel.

    2.   In the Instant Search box, type Index.

    3.   Click on Indexing Options.

    4.   Click on Run as Administrator and allow the privileges.

    5.   Click on Advanced, then Rebuild.

     

    Suggestion 2 Disable the Windows Search service

    ===========

    1.   Click Start, type services.msc and press Enter.

    2.   Double click on Windows Search.

    3.   Set the Startup Type to Disabled and click OK.

    4.   Restart Windows.

     

    If the issue does not occur, you can re-enable the Windows Search service.

     

    Suggestion 3 Clean Boot

    ===========

    1. Click the Start Button, type MSCONFIG in the Search Bar and Press Enter to start the System Configuration Utility.

     

    Note: Please click the Continue if the "User Account Control" window pops up.

     

    2. Click the Services tab, check the "Hide All Microsoft Services" box and click Disable All (if it is not gray).

    3. Click the Startup tab, click Disable All and click OK.

    4. Restart the computer and test the issue.

     

    Note: Clean Boot is just a troubleshooting step. If some programs have been disabled, we can enable them later on. If you see the System Configuration Utility, check the box of "Don't show this message" and then click OK.

     

    Hope it helps.

     

    Best regards,

    Tim Quan

    Microsoft Online Community Support

     

    Friday, December 21, 2007 7:20 AM
    Moderator

All replies

  •  

     

    Hi Richard,

     

    Thank you for the post.

     

    Let’s try the following suggestions to troubleshoot the issue:

     

    Suggestion 1 Rebuild the Index

    ===========

    1.   Open the Control Panel.

    2.   In the Instant Search box, type Index.

    3.   Click on Indexing Options.

    4.   Click on Run as Administrator and allow the privileges.

    5.   Click on Advanced, then Rebuild.

     

    Suggestion 2 Disable the Windows Search service

    ===========

    1.   Click Start, type services.msc and press Enter.

    2.   Double click on Windows Search.

    3.   Set the Startup Type to Disabled and click OK.

    4.   Restart Windows.

     

    If the issue does not occur, you can re-enable the Windows Search service.

     

    Suggestion 3 Clean Boot

    ===========

    1. Click the Start Button, type MSCONFIG in the Search Bar and Press Enter to start the System Configuration Utility.

     

    Note: Please click the Continue if the "User Account Control" window pops up.

     

    2. Click the Services tab, check the "Hide All Microsoft Services" box and click Disable All (if it is not gray).

    3. Click the Startup tab, click Disable All and click OK.

    4. Restart the computer and test the issue.

     

    Note: Clean Boot is just a troubleshooting step. If some programs have been disabled, we can enable them later on. If you see the System Configuration Utility, check the box of "Don't show this message" and then click OK.

     

    Hope it helps.

     

    Best regards,

    Tim Quan

    Microsoft Online Community Support

     

    Friday, December 21, 2007 7:20 AM
    Moderator
  • Tim,

    I tried suggestion 1 and on the indexing options window the "Advanced" button was greyed out.  So I could not complete the rebuild.

    I went through suggestion 2 and I did not get the error when I restarted; however, once I tried to turn on Windows Search the error popped up.  I tried this twice and got the same result.

    I attempted suggestion 3 and the error message still came up even with everything disabled.

    Also, I have noticed that I continually get the error message when deleting files.

    Please let me know if you have any other options that I can try.

    Thanks,

    Richard
    Saturday, December 29, 2007 4:16 AM
  •  

    Hi Richard,

     

    Thank you for the reply.

     

    As the issue does not occur after we turn off the Windows Search service, we can infer the cause of the issue is the Windows Search service.

     

    The Windows Search service helps us fasten the search on the system. However, it sometimes can affect the system performance. If you do not often search files or folders on the computer, we can safely turn off it.

     

    If you prefer to continue to resolve the issue with the Windows Search service enabled, we may need to spend more time on it as it can be caused by many factors. However, I will try my best to work with you.

     

    Please let me know your decision.

     

    I look forward to hearing from you.

     

    Best regards,

    Tim Quan

    Microsoft Online Community Support

     

    Monday, December 31, 2007 9:15 AM
    Moderator
  • Tim,

    I would prefer to determine the cause of the problem and keep search indexing running.  I do search with regularity.

    Please let me know what to try to determine the cause.

    Thanks,

    Richard
    Monday, December 31, 2007 7:15 PM
  •  

    Hi Richard,

     

    Thank you for the reply.

     

    Now I will continue to work with you to troubleshoot this issue.

     

    First I would like to confirm if the issue occurs in Safe Mode.

     

    If so, the issue can be caused by corrupt Windows Search components. Please let me know your email account and I will send you the Windows Search files to repair the Windows Search component.

     

    If the issue does not occur in Safe Mode, the issue can be caused by third-party programs or corrupt user account. Please try Clean Boot again to test the result. In addition, we can create a new account to test the issue.

     

    Create a New Account

    ==========

    1. Click Start Menu, and then click Control Panel.

    2. Click switch to a Classic View in left panel.

    3. Double-click User Accounts.

    4. Click Manage Use Accounts.

    5. Click Create a new account, and type the name.

    6. Choose account type as Administrator.

    7. Click Create Account.

    8. Log off and log on with the new account.

     

    What’s the result in the new account?

     

    I look forward to hearing from you.

     

    Best regards,

    Tim Quan

    Microsoft Online Community Support

     

    Thursday, January 03, 2008 9:38 AM
    Moderator
  • Tim,

     

    I am having the same problem and did as you outlined on this posr and imediatly the same error came up. it is affecting my Outlook 2007 by slowing it way down, I would also like to fix this.

     

    Thanks,

    Dave M

    Monday, February 25, 2008 4:43 AM
  • I had a simlar problem. My Indexing Service just refused to start; with error : Windows could not start the Windows Search on Local Computer.  My Indexing Options box was also all grayed out. I researched a bit and put the findings on my site : Troubleshooting Windows Vista Search & Indexing Errors

     

    I followed my own advice and was successful in starting the Indexing Service; but it lasted only for a couple of days. Inspite of several re-try's I have been unable to re-start my Indexing Service. I am back where I was.

     

     

    Monday, February 25, 2008 5:46 PM
  • Hi tim...

    I know how to disable Windows Search Service... but how can I purge or delete the file placed on ---C:\Documents and Settings\All Users\Application Data\Microsoft\Search\Data\Applications\Windows--- called windows.edb  it has a size of 500 Mb ... by the way... how can i purge files placed on C:\WINDOWS\system32\dllcache directory.. or C:\WINDOWS\Installer directory??....

    Yes i have a ... 'little' problem of free space..

    Thanks in advance...
    Wednesday, April 29, 2009 2:47 PM
  • Hi Tim,

    Just to let you know, I did Step 2 first and disabled the Windows Search Service.  Then I went in and tried to do "rebuild" under Step 1 but it would only let me "restore defaults" so I did that.  Once I restarted my computer I went back under Step 2 and enabled the Windows Search Service, then went into Step 1 and I could "rebuild" the index and the files all showed back up.  My computer is working fine now.  I stubbled upon this by accident only because Step 1 didn't work first so I tried Step 2, then thought, let me try Step 1 again and something changed so I re-enable the windows search service and restarted the computer after each step and the computer worked.

    Wednesday, January 12, 2011 9:18 AM
  • Found this advice via Google. Brilliant, worked a treat after I rebuilt the indexes.

    Cheers

     

    Saturday, February 05, 2011 6:30 PM