none
Windows 7 lost admin privileges

    Question

  • Dear all,

    I have installed Win 7 64 bit and Sophos security endpoint 9. At some point that silly software has changed the permission of my account from "Administrator" to "Sophos Administrator" so that now my account has no Admin permissions at all. Unfortunately, it is the only account on the PC and all the attempts suggested in this and in other forums did not succeed.

    Now I cannot perform any operations that require admin privileges even if I boot in safe or recovery mode.

     

    Any help appreciated, thank you very much.

    Ciao

    Simone

    Friday, October 15, 2010 12:16 PM

Answers

  • I solved in it this way:

    1. Boot from the Windows 7 installation DVD

    2. Choose repair system

    3. Choose restore system to a previous point

    Fortunately the restore point reverted the modifcations made by the silly software Sophos. Definitely a badly designed software

    that modifies your account premissions.

    Now I learnt the lesson and activated the hidden Admin account with the NET USER command, just in case...

    So the lesson learnt is:

    1. Be sure to activate at least another account with admin privileges (besides yours)

    2. The system restore utility also restores your account settings (something I was not sure of) 

    Thanks anyway

    Simone

    • Marked as answer by sgiannerini Saturday, October 16, 2010 4:54 AM
    • Unmarked as answer by sgiannerini Saturday, October 16, 2010 4:58 AM
    • Marked as answer by sgiannerini Monday, October 18, 2010 8:42 AM
    Friday, October 15, 2010 4:54 PM

All replies

  • Thank you, I followed both ways but they failed

    1. In safe mode (as well as in normal mode) I am unable to uninstall Sophos

    2. I have booted from the DVD and restored, then replaced the utilman.exe with cmd.exe and rebooted. When I start the console (both with utilman and with cmd) I am not able to create/activate the Admin account with the command

    NET USER Adminstrator /ACTIVE:YES

    System error 5: access denied

    By the way: If I restore the system to a previous point will it restore the account settings as well? In such case I might try.

    Any help would be much appreciated

    Regards

    Simone

    • Marked as answer by sgiannerini Friday, October 15, 2010 4:54 PM
    • Unmarked as answer by sgiannerini Saturday, October 16, 2010 4:54 AM
    Friday, October 15, 2010 3:16 PM
  • I solved in it this way:

    1. Boot from the Windows 7 installation DVD

    2. Choose repair system

    3. Choose restore system to a previous point

    Fortunately the restore point reverted the modifcations made by the silly software Sophos. Definitely a badly designed software

    that modifies your account premissions.

    Now I learnt the lesson and activated the hidden Admin account with the NET USER command, just in case...

    So the lesson learnt is:

    1. Be sure to activate at least another account with admin privileges (besides yours)

    2. The system restore utility also restores your account settings (something I was not sure of) 

    Thanks anyway

    Simone

    • Marked as answer by sgiannerini Saturday, October 16, 2010 4:54 AM
    • Unmarked as answer by sgiannerini Saturday, October 16, 2010 4:58 AM
    • Marked as answer by sgiannerini Monday, October 18, 2010 8:42 AM
    Friday, October 15, 2010 4:54 PM