none
Windows media player 12 won't load

    Question

  • Everytime I try to open Media player 12 I keep getting the error message "The file wmploc.dll has a version number of 12.0.7601.18150 where 12.0.7601.17514 was expected." I've tried using the "turn Window functions on or off" function but that didn't work. So I tried the Mr Fixit, that didn't work so I also tried going through the command prompt funtion using the "sfc/scannow" command and that didn't work! And now I can't turn turn Media player player back on in the "turn Window functions on or off" function! So what would be the next thing to do? Does anyone have any ideas?

    I'm running Windows 7

    Thanks ahead.


    • Edited by longi17 Wednesday, March 25, 2015 10:01 PM
    Wednesday, March 25, 2015 9:59 PM

Answers

All replies

  • Hi,

    What "Fix it" tool did you use? What symptom or error message when you attempt to turn it on again from "Turn Windows features on or off" pane?

    Run this command to check the feature's current status:

    Dism /online /get-features

    You would get the list of available features and whether they are currently enabled or disabled as below:

    And if it's disabled, run this command to enable it:

    Dism /online /disable-feature /FeatureName:"WindowsMediaPlayer"

    If it's already enabled, attempt to start it normally to see what happened.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, March 26, 2015 7:22 AM
    Moderator
  • Thanks for the reply. When turning in the "Turn Windows features on or off" the error message is, " An error has occurred. Not all of the features were successfully changed."

    I tried the command prompt and I got,

    "Error: 87

    The online get-features option is unknown.

    For more information, refer to help by running DISM.EXE /?.

    The DISM log can be found at C:\Windows\Logs\DISM\dism.log

    I ran the Mr Fix It with no success.

    https://support.microsoft.com/en-gb/mats/windows_media_player_diagnostic?wa=wsignin1.0


    The first time I ran it it told me that it had fixed a number of faults but now that I can't turn Media player back on it tells me that it's not installed.
    • Edited by longi17 Friday, March 27, 2015 5:57 AM
    Friday, March 27, 2015 5:49 AM
  • Anyone?

    Saturday, March 28, 2015 1:31 PM
  • Hi,

    The error "Error: 87 The online get-features option is unknown" should be because you miss the spaces before the "/get-features". Please copy the paste (don't type by yourself) the correct syntax:

    Dism /online /get-features


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, March 30, 2015 8:47 AM
    Moderator
  • Thanks for the reply and the tips! I ran it and this time the error code I got was "ERROR 14098 the component store has been corrupted. And media player/centre shows disabled.
    Thursday, April 2, 2015 7:15 PM
  • Please open the Start Menu, go to All Programs - Accessories , right-click Command Prompt, and select Run as administrator . In Command Prompt, type the following:

    sfc /scannow

    and press Enter. Let it run until it completes. Does it find any problems, and if so, is it able to fix them? Do you still get the same error afterwards?

    Tim De Baets
    http://www.bm-productions.tk

    Thursday, April 9, 2015 7:31 PM
  • Sorry for the late replay it's been very busy at work!

    It got 15% of the way in and said "Windows resource protection found corrupt files but was unable to fix some of them"

    "Details are incuded in the CBS.log windir\Logs\CBS\CBS.Log. For example C:Windows\Logs\CBS\CBS.Log"

    Sunday, April 19, 2015 7:35 PM
  • I suggest that you run the scan once again, but this time with your Windows 7 installation DVD inserted. The scan should then be able to fix the corrupted files by copying the original version of these files from the DVD.

    Alternatively, you could also fix the corrupted files manually by following the instructions at https://support.microsoft.com/en-us/kb/929833 . Does that help?


    Tim De Baets
    http://www.bm-productions.tk

    Sunday, April 26, 2015 2:26 PM
  • Tried running the scan again with the DVD inserted but it did the same. It got to 15% and gave the same error message. The DVD didn't even spin!

    I've taken a look at trying to repair it manually but that looks a bit more of a headache than I'd like at this stage.  Is there another easier way? The manual instructions aren't that clear.

     
    • Edited by longi17 Tuesday, May 5, 2015 5:42 PM
    Tuesday, May 5, 2015 5:27 PM
  • Saturday, May 9, 2015 3:15 PM
  • I was unable to do  a repair as I was unable to download  Windows 7 SP1 as I don't have it on my disk. I've now lost all my sound now and I can't seem to get it back so it looks I'm going to  have to do  a re install which is fucking shite to be honest! Thanks for all of your help though. This if very frustrating to say the least.
    Wednesday, September 2, 2015 9:53 PM