KB3176938 (14393.103) is breaking something in network security RRS feed

  • Question

  • I've installed KB3176938 which was released today to Insider Release Preview and Insider Slow rings.

    Immediately after, I started having problems with remote desktop connections. Anything I had previously saved credentials for, even on the local network, now says "Your system administrator does not allow the use of saved credentials to log on to the remote computer [computername] because its identity is not fully verified. Please enter new credentials."

    I started looking around group policy and discovered that attempting to access/edit anything says "Network access is denied."

    I uninstalled the update and I'm now back to 14393.82 - these problems are still there!

    I'm posting this here for the benefit of others who haven't installed this update yet, something to consider before they do. Also I have reported it in Feedback hub.

    Thursday, August 25, 2016 11:04 PM

All replies

  • Hi ,

    Thanks for your sharing, it is very beneficial for other community members who haven't installed this update yet. Glad to hear that you have feedback it, KB3176938 is released recently, we are still collecting issues about it. If we are reported same issue from others, will post back and let you know.

    Based on the current, there is little we can try to fix this issue at least.
    For Remote Desktop Client doesn’t use stored credentials issue. please refer to this link for detailed steps to fix it.
    Remote Desktop Client doesn’t use stored credentials
    And for the "Access Denied" issue, the process monitor tool should be useful to troubleshoot it.
    Process Monitor v3.2
    Solving Access Denied Errors Using Process Monitor

    NOTE: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites.

    Best regards

    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 26, 2016 7:48 AM
  • Rick_Li,

    Thanks for your response.

    I noticed reading the list of Fixes & Improvements for build 14393.103, the last item mentions "Addressed additional issues with compatibility, Remote Desktop, ..., networking policies, ..."

    I wonder if it's possible to get some more detail about the specific things that were changed and how it might break things in my particular domain environment.

    To add to the list of symptoms I see on machines where this patch has been installed and then removed, trying to navigate to \\mydomain.local\SYSVOL produces a "Network access is denied" error.

    Friday, August 26, 2016 1:33 PM
  • Just to let everyone know, the only workaround I've found so far is:

    - Mount the ISO for Anniversary Update (14393.0)
    - Run setup and do an "upgrade" by choosing to keep everything.

    This of course replaces the entire operating system including whatever was broken in the registry or policies by installing KB3176938 and left broken when uninstalling it. It also has the effect of making me wait 2 hours, reinstall RSAT and a few other things, update to 14393.82 again, and unstall "Get Office" and other bundled apps.

    Friday, August 26, 2016 5:37 PM
  • Just to let everyone know, the only workaround I've found so far is:

    - Mount the ISO for Anniversary Update (14393.0)
    - Run setup and do an "upgrade" by choosing to keep everything.

    After running the "upgrade" again, are you still in the Release Preview Ring?  If so, and you decide to try .103 again I'd be curious to see if a Network reset would also resolve the problem.  Had you tried that before re-running the "upgrade?"  (Settings / Network / Status / Network reset).

    Friday, August 26, 2016 6:26 PM
  • Thanks for the suggestion, I tried the network reset on a machine I hadn't got to yet (I installed this update on several). It does not seem to have helped in any way. I think I will leave that machine as-is for testing any other ideas that come along.

    None are in the Release Preview ring, I downloaded the KB3176938 cab file and installed it manually. (I have another thread or six open somewhere describing my issues with Windows Update and WSUS since 1607, so getting a cumulative update via WU is not something I can actually do).

    • Edited by PepperdotNet Friday, August 26, 2016 7:29 PM
    • Proposed as answer by polux33 Friday, August 26, 2016 9:32 PM
    • Unproposed as answer by polux33 Friday, August 26, 2016 9:32 PM
    • Proposed as answer by Rafał M Monday, August 29, 2016 6:17 AM
    • Unproposed as answer by Rafał M Monday, August 29, 2016 6:42 AM
    Friday, August 26, 2016 7:27 PM
  • Was just curious, this Isn't a Normal users issue. How could They be expected to fix this in ordinary circumstances, your help file doesn't address this and IM a Tech so I Can find this but a Normal user wouldn't ever. This is More common and you ought to set up a 'Fix it' script for this. You've issued flawed code. Now I am unable to restore because all restore points were destroyed. Yea! You! You've caused Another developer to quit this silly OS, and go back to what an OS that's stable No need for reply you've been More than helpful. I have a machine I have to restart but without windows 10 this time or Id be back in the same shit again.
    Thursday, September 1, 2016 1:21 AM
  • WTF!  Problems reported, and MS' reponse is: "Here are some debugging tools, go find our problem for us!" 

    Windows has long been a crap can of untested knee-jerk reaactive "fixes" that ripple throughout the entire system and MS' repeated response: if it really screws up a lot of other people, we might fix it.  After one of you debugs it for us...

    Thursday, September 1, 2016 4:53 PM
  • The same problem after install this update in win 10 pro working in domain. I have this problem in normal (not insider) version of Windows.

    Dariusz Laszczak

    Thursday, September 1, 2016 7:04 PM
  • You installed "this update"? Check Settings, system, about. Are you at 14393.103 or 14393.105?

    The replacement update 14393.105 that was released to the public does not appear to have this issue. However, if the insider update 14393.103 was ever installed, you'd have to do the ISO upgrade workaround I posted above.

    I have installed the current version of the update on several machines and none of them are exhibiting the problem.

    Thursday, September 1, 2016 7:08 PM
  • We fixed it today using mstsc.exe and mstscax.dll from an older iso and replacing it. They are located in C:\Windows\System32. The .wim file is accessable via 7zip, or copy them from a computer without the update.

    Also sytemrestore did the trick on another system, but this will probably be temporary as Windows tries to install the update again.

    Put them in dropbox:


    • Edited by ymein Monday, September 26, 2016 12:56 PM
    Monday, September 26, 2016 12:46 PM
  • but this will probably be temporary as Windows tries to install the update again.

    More likely permanent. The bug was fixed in 14393.105 and hasn't been seen since in later updates. This update is now superseded so it should never be offered or installed.
    Monday, September 26, 2016 6:27 PM