none
Remote Desktop doesn't work with local printer

    Question

  • I am having trouble using a locally networked printer when I use Remote Desktop to connect to a Vista machine.  Under the local resources tab for RD, I have checked printers.  The only thing I can figure is that my printer is networked locally, not connected directly to my machine.  Every time I try to print during my remote desktop session, I can't access my locally networked printer.

    I installed the printer drivers on the remote computer and when I try to locate the printer, I get the following error: "Windows cannot connect to the printer.  Server print spooler service is not running..." but the spooler service IS runing.

    I also found a post elsewhere that discussed setting 'share permissions' and 'network permissons' to resovle the spooler error.  Still no go.

    I tried to plug in my printer to a local USB port this morning.  Still would not work.  I keep getting the same spooling error.  The drivers are not corrupt, as others have indicated may be the cause.  They work fine on my system locally with 7.

    Any advice would be greatly appreciated.  I've spent a few hours on this one and am at a loss at this point.

    Please help.  I really need to print locally.
    Wednesday, October 21, 2009 2:54 PM

Answers

  • My problem was that the Vista remote system never saw local port that my printer was using for some reason and it never accepted the path noted above (\\servername\printer)...always came back with an error that it was an invalid path.  This was with it both networked and plugged in via USB port.

    I finally figued it out after four days and many hours on the phone with Microsoft.  Microsoft support claimed that it was related to my router settings, but I didn't believe it since the remote computer saw my iPhone just fine when it was connected locally.  After simply playing around, here's what I found...it was actually quite basic!

    On the remote system, when you try to add a 'local' printer, there's a drop down menu with a list of local ports that your remote system sees.  Some of those will be on the remote system, but others will be on your local system.  Make a note of the ones that are seen on your local system.  In my case, LPT1 was not visible, but COM3 was.

    Next, on your local system, in the settings for your functioning printer (Printer Properties, Ports Tab), there's a tick box that says "Enable Printer Pooling."  Once you check that box, you can select multiple ports on your local machine.  Here, you need to tick the box that your remote system is seeing (in my case, it's COM3), but make sure that your exisitng port remains checked as well (in my case, an IP port for my wireless router).  Basically what you're doing is on your local system, you are pooling your exising printer setup with a port that can be seen by your remote system. 

    Then, on the remote system, install the printer drivers but don't select a port.  Then go into Printers and add a printer.  Select 'local' setup for that and when asked for the port, use the port you checked in the previous step on your local system (in my case, I selected COM3 on my local system).  Select your printer from the list.  It will ask if you want to use the exisiting drivers...say yes.  Then print a test page to be sure that it works.  Worked fine for me.

    I simply can't believe how obvsious that solution was!  If the remote system can't see the port you currently use, pool your printer setup with a port that it can see!
    • Marked as answer by divrdrew Monday, October 26, 2009 3:28 PM
    Monday, October 26, 2009 3:26 PM

All replies

  • Hi Divrdrew,

     Try the following first as a Administrator and then Standard user.

     

    Go to Control Panel. Choose printer. Then choose Add Printer.

     

    Choose Add a local printer. Click on Create a new port. The default in the drop down box is Local Port. Do not change that. Click Next.

     

    A dialogue box will appear asking for you to enter a port name. Type in <<\\servername\printer>> where "servername" is the name of the server where the printer exists and "printer" is the name of the printer that we're trying to install.

     

    Click ok and then hit next.

     

    Hope it helps.

     

     

    Thursday, October 22, 2009 3:53 AM
  • Thanks for the advice.  Unfortunately, I am getting a path not found error.
    Thursday, October 22, 2009 3:50 PM
  • Hi Divrdrew,

    Can you visit the printer by enter \\servername\printer in Windows Explorer?

    Thanks.
    Monday, October 26, 2009 2:33 AM
  • My problem was that the Vista remote system never saw local port that my printer was using for some reason and it never accepted the path noted above (\\servername\printer)...always came back with an error that it was an invalid path.  This was with it both networked and plugged in via USB port.

    I finally figued it out after four days and many hours on the phone with Microsoft.  Microsoft support claimed that it was related to my router settings, but I didn't believe it since the remote computer saw my iPhone just fine when it was connected locally.  After simply playing around, here's what I found...it was actually quite basic!

    On the remote system, when you try to add a 'local' printer, there's a drop down menu with a list of local ports that your remote system sees.  Some of those will be on the remote system, but others will be on your local system.  Make a note of the ones that are seen on your local system.  In my case, LPT1 was not visible, but COM3 was.

    Next, on your local system, in the settings for your functioning printer (Printer Properties, Ports Tab), there's a tick box that says "Enable Printer Pooling."  Once you check that box, you can select multiple ports on your local machine.  Here, you need to tick the box that your remote system is seeing (in my case, it's COM3), but make sure that your exisitng port remains checked as well (in my case, an IP port for my wireless router).  Basically what you're doing is on your local system, you are pooling your exising printer setup with a port that can be seen by your remote system. 

    Then, on the remote system, install the printer drivers but don't select a port.  Then go into Printers and add a printer.  Select 'local' setup for that and when asked for the port, use the port you checked in the previous step on your local system (in my case, I selected COM3 on my local system).  Select your printer from the list.  It will ask if you want to use the exisiting drivers...say yes.  Then print a test page to be sure that it works.  Worked fine for me.

    I simply can't believe how obvsious that solution was!  If the remote system can't see the port you currently use, pool your printer setup with a port that it can see!
    • Marked as answer by divrdrew Monday, October 26, 2009 3:28 PM
    Monday, October 26, 2009 3:26 PM
  • Printing to a local Windows 7 or Windows XP  printer while initiating a Remote Desktop  logging into a remote host Host

    1. Unfortunately Remote Desktop by default will only display printers configured on serial and parallel ports, below is a work around I have personally found works.
    2. When you setup the Remote Desktop configuration be sure you click the Tab labeled Local Resources and at the bottom of the screen, see Local Devices and resources make sure that Printers and Clipboard are selected.
    3. Make the Local Printer you wish to print to on the machine initiating the Remote Desktop the default printer and be sure you can print to it (I have found this even works with shared networked printers)
    4. Install proper printer driver at the  Host End  (The site you're logging onto)  that matches the printer on the remote end (The end you’re initiating the Remote Desktop from). When you 1st install this printer on the Host End just select LPT1 as the port for now.
    5. On the Host end go to Devices and Printer and select the printer you  plan to print to, Click on printer properties, Select ports look for port labeled TS001, this should be the default printer on your local Remote Computer, Check this port and run a print test. (Unfortunately these TS??? Ports aren’t described by the operating system, the 3 systems I have checked this out on the port was labeled TS001 which was my default printer on the end initiating the remote desktop, but it certainly could be different on your system so it might take some trial and error to select the proper port.)
    • Proposed as answer by SteveDahl Saturday, March 17, 2012 5:27 PM
    Saturday, March 17, 2012 5:26 PM

  • Printing to a local Windows 7 or Windows XP  printer while initiating a Remote Desktop  logging into a remote host Host

    1. Unfortunately Remote Desktop by default will only display printers configured on serial and parallel ports, below is a work around I have personally found works.
    2. When you setup the Remote Desktop configuration be sure you click the Tab labeled Local Resources and at the bottom of the screen, see Local Devices and resources make sure that Printers and Clipboard are selected.
    3. Make the Local Printer you wish to print to on the machine initiating the Remote Desktop the default printer and be sure you can print to it (I have found this even works with shared networked printers)
    4. Install proper printer driver at the  Host End  (The site you're logging onto)  that matches the printer on the remote end (The end you’re initiating the Remote Desktop from). When you 1st install this printer on the Host End just select LPT1 as the port for now.
    5. On the Host end go to Devices and Printer and select the printer you  plan to print to, Click on printer properties, Select ports look for port labeled TS001, this should be the default printer on your local Remote Computer, Check this port and run a print test. (Unfortunately these TS??? Ports aren’t described by the operating system, the 3 systems I have checked this out on the port was labeled TS001 which was my default printer on the end initiating the remote desktop, but it certainly could be different on your system so it might take some trial and error to select the proper port.)
    • Proposed as answer by SteveDahl Saturday, March 17, 2012 5:30 PM
    Saturday, March 17, 2012 5:29 PM
  • HI Steve, installing the driver at host's end worked well...i was fumbling with this issue for 2 days - remoting from Win7 to XP..........trying few methods until came across yours.......thank god, it worked......  now i can sleep well!!!
    Wednesday, January 22, 2014 5:33 AM