locked
Scheduled Task will run on Windows 7, but will not run on Server 2008 R2 RRS feed

  • Question

  • So I have a scheduled task that uses nircmd to take a screenshot and then email it to a few company emails each night.  With our old Exchange 2003 server, everything works prefectly on the 2008 R2 server (using SMTP).  But since we upgraded to Exchange 2010 it no longer seems to work (at least it never sends the email anymore).

    What confuses me more is that this exact task (I exported it) runs perfectly fine on a Windows 7 Pro computer, even using the new Exchange 2010 SMTP address.

    Both machines are logged in as the same user.  I can even login as the domain administrator on each machine and still have the same issue.  Only the Windows 7 Pro machine will successful run the task.  To restate it, the Server 2008 R2 server will run the task successfully if I use the old Exchange 2003 SMTP address.

    Thanks for any advice!

    Thursday, December 11, 2014 4:22 PM

Answers

  • Might check the logs.

    Event Viewer\Applications\Microsoft\Windows\TaskScheduler\Operational

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    • Proposed as answer by Justin Gu Saturday, December 20, 2014 3:34 PM
    • Marked as answer by Justin Gu Wednesday, December 24, 2014 5:03 PM
    Friday, December 12, 2014 3:06 AM

All replies

  • Might check the logs.

    Event Viewer\Applications\Microsoft\Windows\TaskScheduler\Operational

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    • Proposed as answer by Justin Gu Saturday, December 20, 2014 3:34 PM
    • Marked as answer by Justin Gu Wednesday, December 24, 2014 5:03 PM
    Friday, December 12, 2014 3:06 AM
  • Hi joshz451z,

    Would you please let us know current situation of this issue? Did you refer to Dave's suggestion and check that relevant logs? If any update, please feel free to let us know.

    Best regards,

    Justin Gu


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Saturday, December 20, 2014 3:34 PM