General problem with USB class-compliant MIDI devices


  • I have a general problem with MIDI-controllers based on the standard USB class-compliant driver.
    The devices get recognized correctly and are shown as available MIDI devices. However, actually selecting them in a program does not work.
    I tried it with MidiOX (Error message: "There is not enough memory available for this task. Quit one or more applications..."), a .NET programming library (same error) and NI Kontakt (no error, but driver does not work). There definitely is enough memory available (about 1 GB).
    I think this is a general error with all class-compliant MIDI devices (I tried an Alesis Q25 and a Livid OhmRGB - same behaviour for both).
    My windows is completely up-to-date and the MIDI devices are not used by any other application.
    Any ideas?
    Friday, October 12, 2012 8:21 AM

All replies

  • Hi,

    Firstly, would you please let us know the model of the device.

    Also, please check whether the device is compatible with Windows 7 or not via Windows 7 Compatibility Center.

    Hope this helps.

    Jeremy Wu

    TechNet Community Support

    Monday, October 15, 2012 6:43 AM
  • I have the assumption that this is a general problem with devices that use the USB class-compliant MIDI driver.

    I tried a "Livid OhmRGB" as well as an "Alesis Q25" - both do not bring their own driver but instead use the general class-compliant driver. Thus, they do not appear in the compatibility center. However, both are compatible with Windows 7 according to the manufacturer. I also asked in the Livid forum and people have the OhmRGB running without any problems under Win 7. Both devices work under other computers (WinXP, Mac).

    Monday, October 15, 2012 9:51 AM
  • Hi,

    Thanks for the reply.

    Based on the current situation, it seems that Windows 7 can recognize OhmRGB properly. However, according to the troubleshooting section of OhmRGB, please use MIDIOX and see how it works.

    Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.

    If issue persists, please check if there is any related trace in Event Viewer and provide us screenshots about the issue.

    Hope this helps.

    Jeremy Wu

    TechNet Community Support

    Tuesday, October 16, 2012 9:40 AM
  • Hi,

    I think this is a general problem with all Midi controllers that use the standard Windows class-compliant driver.

    I tried:

    • Livid OhmRGB
    • Alesis Q25
    • icon iControl

    All are based on the standard Windows driver - none of them works. The iControl did work on the very same computer some time ago, but does not anymore. I could not find anything in the Event Viewer. Is there a way to re-install the class-compliant Midi driver?

    The error is always the same and already appears when I select the driver:

    My system is up-to-date:

    Tuesday, October 16, 2012 10:37 AM
  • I know this is an old thread, but I also have this problem.  Rebooting my system (with Win 8.1) sometimes abates the error message "There is not enough memory available for this task.".   But rebooting the system doesn't always make that go away.

    My system has 64 GB of DDR3...and the memory tests run perfectly.  So it's not a real memory problem.

    Wednesday, August 13, 2014 11:21 AM
  • I'm having the same problem when trying to connect a Roland digital piano to Cakewalk Sonar in Windows 8.1 via USB.

    I get this error message "there is not enough memory available".
    I'm getting the same error message in Midi-Ox.

    Has anyone found a solution? 

    I'm using:

    Windows 8.1, Intel Skylake processor, 32 GB RAM memory, Roland F-140R digital piano (Similar to FP-30, which gets the same error message, or F-130), Cakewalk Sonar Platinum DAW. 


    If I close my Chrome browser, and then start Sonar or Midi-ox, I don't get the error message. After Sonar recognizes the Roland, I can open Chrome again, and still use Sonar and the Roland. 

    I wonder if each tab in Chrome is claiming a MIDI port, leaving none for Sonar. That might explain why opening Sonar before Chrome solves the problem: It allows Sonar to claim whatever midi ports it needs, before Chrome hogs them. Just a wild guess.

    UPDATE 2:

    Unfortunately, this error occurs when I try to run Midi-Ox and Reaper together, or Midi-Ox and Sonar together. So I cannot use Midi-Ox to troubleshoot Midi messages coming to and from those programs. 

    Saturday, October 01, 2016 3:38 AM