Windows 7 printing


  • I have a newish Hewlwtt PAckard PC which WAS running Vista Home premium 64 bit until the 22nd Oct.
    This compute is connected wirelessly. It is using MS Security essentials
    Windows 7 advisor stated all was compatible except the software for my HP C6180  All in one printer. This printer is installed on the Ethernet
    I do an upgrade to W7 64 bit.  Upgrade goes fine. All applications and datafiles are fine.

    I download and install the HP software for W7. This installs correctly and can print test pages and scan images ( Haven't tried fax and don't care)

    Problem      Nothing else will print. Word 2002,  W7 Notepad  for example.   The documents show up in the spooler display and then disappear. However the HP testpage shows up identically and prints.  I have tried with  Firewall on and off, MSE on and off    no difference.

    My next try will be to completely uninstall the HP software and have Windows install the printer and see what transpires.

    My question therefore is:   Is there a know problem with network printing after an upgrade?
    Tuesday, October 27, 2009 3:29 PM


All replies

  • Have you tried using the HP Printing Diagnostic Utility?
    Carey Frisch
    • Marked as answer by Linda Yan Monday, November 02, 2009 2:23 AM
    Tuesday, October 27, 2009 3:48 PM
  • That utility only supports USB connected printers.    The printer does work and the HP software for W7  installs it and it is visible in the printer and devices folder on W7. The HP solutions software will print a test page to it via the Windows spooler.

    The problem is that nothing else will print.  You can see the documents go to the spooler and the spooler says "printing"  to the same "port" as the HP software and then nothing.

    Thats why I am asking here not on an HP forum.

    Tim L
    Tuesday, October 27, 2009 4:25 PM
  • Well, at least try the HP Printer Networking Forum
    Carey Frisch
    • Marked as answer by Linda Yan Monday, November 02, 2009 2:23 AM
    Tuesday, October 27, 2009 5:57 PM
  • Indeed I have asked in the All-in-one Install and set up forum on HP.

    I am now trying:

    Completely uninstall the HP software.
    Have Windows 7 discover the printer  and install it.

    Try printing, if it works then try scanning. If that works then I'll stop there and ask a different set of questions on the Hp forum.

    If that does not work I'll be back here!

    Tim L
    Tuesday, October 27, 2009 6:16 PM
  • That did not work.  

    I wonder if the Vista to W7 upgrade left something around that is interfering like an old version of some of the printer software.
    Tuesday, October 27, 2009 6:47 PM
  • So. I even connected the PC by wired E'net incase the wiresless adapter was causing the problem
    I installed a legacy HP deskjet on USb and that all worked.
    The C6180 scan works but the printing does not. EXCEPT from HP's own "solutions " and then that is only the test page.

    I will try the C6180 on USB but That can only be just for a trial, not for actaul use.

    I am inclined to think that problem is HP that it is not connecting to the spooler properly.
    Tuesday, October 27, 2009 8:25 PM
  • Hi timlocke,


    Please try removing the printer by going to Start -> Devices and Printers. After that, please re-add the printer from there and see if the issue can be resolved.


    However, if the issue persists, please adjust the printer to print directly and check the result.


    1. Please click "Start", type "printers" (without quotation marks) and click the item displayed in the search results.

    2. Right click on the current printer and click "Properties".

    3. Enable an option named "Print directly to the printer". Usually, this option can be found on the "Advanced" page. However, this may be different according to the printer.


    Please open Notepad or Word and check if the printer works properly now.


    Hope this helps.





    Wednesday, October 28, 2009 8:23 AM
  • Thank you Linda.

    I tried your suggestion.    I get the following errors

    From Notepad   a dialog    Module not installed
    From Word 2002     A dialog  " Windows cannot print   etc etc."

    Note that at this instant the HP Solutions centre still can print and prints its test page correctly.

    I have been wondering that beacuse I had the Vista 64 HP software kit installed before upgrading to W7 whether something or some setting got left behind and is not being corrected  by the new HP install.

    I then connected the printer via USB... that was interesting... suddenly the HP software started up to configure the fax capabilities of the printer.

    After that printing still would not work either via the spooler nor directly  ALTHOUGH the HP fax setup software did manage to print a page  and thats what I really do not understand, how the HP software can print via the W7 spooler but nothing else can

    Thursday, October 29, 2009 1:09 PM
  • Hi timlocke,


    Please clear previous printer driver and reinstall printer by referring to this thread. After that, please reinstall the printer driver and software from HERE.

    Please Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.




    Friday, October 30, 2009 3:21 AM
  • Linda, I followed the instructions  from Dale and no difference.
    There was an extra key in Hkey-Local.....Print/Monitors  of PCL hpz31w71   which the HP software reinstall replaced.  There was a directory  named 3  in ...drivers\w32x86 which was not put back after I renamed it.

    HP are having a forum on W7 next week which I'll ask this question to them. 

    I do not understand why documenst appear in the spooler and appear to go to status "printing" and then just disappear, apart from the one document form the HP test page itself.  Obviously that is where the problem lies.


    Tim L
    Friday, October 30, 2009 3:30 PM
  • Tim,

    I have exactly the same problem as you almost to the letter.  I went one step further and thought I would try something and it worked.  After loading the HP driver and full feature download for Windows 7, setting up for a USB connection, I am getting all the same failures you have experienced wiht the C6180 driver.  Going out on a limb sort of, I tried using the C6300 series driver to see if I could fake out the system.  All seems to work as it should now.  I tried the C6200 series driver and it would not work.  So, this tells me that the HP C6100 series driver has a problem for sure, at least with the Windows 7 64 bit software update.

    I also have a laptop, that I upgraded to Windows 7 32 bit.  I set it up with the same HP driver and full feature software from HP for the C6100 series printer, using wireless connection and it worked just fine. 

    I will be looking forward to see if you get an answer at the forum.

    Good luck,

    Wednesday, November 04, 2009 5:54 PM
  • I have exactly the same problem with HP PhotoSmart C7280. Installed new drivers for Win 7, installed the computer (new system; first-time install), test page prints, scanning works but when I try to print a doc or jpg or anything, nothing happens.

    This printer is on a wireless network and I can print to it from my Win7 machine via network, using the same printer, routed via XP laptop.

    Did y'all get any help with fixing this? Where should I search further?

    Thank you.

    John F.
    Sunday, January 10, 2010 5:47 AM
  • has anyone tried who is on MSE (microsoft security essentials- who have version 2 tried to go into 

    Settings/Real Time Protection and UNCHECK Enable Network Inspection System, clicked SAVE and closes the program. I had a similar problem that I could not see devices and printers when i opened MSE and  I rebooted the machine and now I was able to open Devices and Printers and everything is back to being there and everything is now printing



    Wednesday, February 16, 2011 12:47 AM