locked
HP hs2350 WWAN modem loses connection ability after Windows 10 may 2020 / b2004 update. RRS feed

  • Question

  • Hello!

    After update to may 2020 compilation I can't use my HSPA+ modem.

    When trying to connect to cellular network, I'm getting error:

    Can't connect to this network.
    Cellular data isn't working properly. Try again later.

    Before may 2020 update, cellular was working perfectly. When booting to Ubuntu on the same machine, cellular connection works. I tested second modem (I had a spare), and it displays the same behavior.

    Hardware:

    computer: HP Probook 6470b
    modem: Ericsson / HP hs2350 HSPA+ WWAN mini-PCIe modem (this modem is whitelisted in BIOS, cannot upgrade)
    firmware: R3C11 (this is upgraded firmware - this modem out of the box doesn't work with Windows 8.1/10)

    APN & other connection settings were verified, SIM card is seen, I can search for networks and see signal strength, yet not connect.

    At least one user has identical issue (Polish forum, post is in Polish language):
    https://www.elektroda.pl/rtvforum/topic3709362.html

    He had the same findings, verified going back to 19H2 Win10 build fixed connection loss.

    This is probably the closest I can do to filing bug report - what should be my next steps?

    Thursday, July 23, 2020 2:57 PM

All replies

  • Your current practice is correct, your HP hs2350 WWAN modem should have compatibility issue with the latest 2004 version, then lead to current connection error, roll back to previous version is a good method.

    You could wait for update from both of Microsoft and HP.

    The Microsoft community has a similar case and you could use the method in reply to check result.

    https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/device-hp-hs2350-hspa-mobile-broadband-module-wwan/19352901-b4de-446a-afb0-d57660ddbff0

    Regards


    "Windows 10 Hardware & Performance" forum will be migrating to a new home on Microsoft Q&A!

    We invite you to post new questions in the "Windows 10 Hardware & Performance"  forum's new home on Microsoft Q&A!

    For more information, please refer to the sticky post.

    This "Windows 10 Hardware & Performance" Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.

    Friday, July 24, 2020 2:10 AM
  • Thank you for confirmation.

    The thread you mentioned refers to firmware issue, which I have already resolved - the device requires a firmware update to work with Windows 8.1 and Windows 10 at all, otherwise driver installation will fail.

    There is significant amount of threads on HP forums, but nothing about Win10/2004 issue.

    No rollback for me, full reinstallation :(

    Friday, July 24, 2020 7:26 AM
  • Well, hope you can find something in HP forum, wait some days and delay 2004 version's upgrade.

    Please mark the reply as an answer if you find it is helpful.

    Tuesday, July 28, 2020 9:35 AM
  • I have the same problem, HP 2570 / hs2350

    When I go to "device/manager - network adapters - HP hs2350 - properties - event" I read the following (extracts from a number of messages)

    Device USB\Vid_03f0&Pid_3d1d&Cdc_0d&Mi_06\7&35ad1ea9&0&0006 requires further installation.

    Device USB\Vid_03f0&Pid_3d1d&Cdc_0d&Mi_06\7&35ad1ea9&0&0006 was migrated.
    Last Device Instance Id: USB\Vid_03f0&Pid_3d1d&Cdc_0d&Mi_06\7&35ad1ea9&0&0006
    Class Guid: {4d36e972-e325-11ce-bfc1-08002be10318}
    Location Path: 
    Migration Rank: 0x0
    Present: true

    Device USB\Vid_03f0&Pid_3d1d&Cdc_0d&Mi_06\7&35ad1ea9&0&0006 was configured.
    Driver Name: netwmbclass.inf
    Class Guid: {4d36e972-e325-11ce-bfc1-08002be10318}
    Driver Date: 12/06/2019
    Driver Version: 10.0.19041.1
    Driver Provider: Microsoft
    Driver Section: wmbclass.ndi
    Driver Rank: 0xFF2000
    Matching Device Id: USB\MS_COMP_MBIM
    Outranked Drivers: netwmbclass.inf:USB\Class_02&SubClass_0E&prot_00:00FF2001
    Device Updated: false
    Parent Device: USB\VID_03F0&PID_3D1D\4DC85C8C6E45A6M0

    Device USB\Vid_03f0&Pid_3d1d&Cdc_0d&Mi_06\7&35ad1ea9&0&0006 was started.
    Driver Name: netwmbclass.inf
    Class Guid: {4d36e972-e325-11ce-bfc1-08002be10318}
    Service: cxwmbclass
    Lower Filters: 
    Upper Filters: 

    Note the statements "requires further installation", "migrated" and "Device Updated: false". I hope this information will help the Microsoft people to solve this issue.
    Friday, July 31, 2020 7:40 AM