locked
No Option To Change Unidentified Network RRS feed

  • Question

  • I have an issue when I connect my Win7 build 7100 laptop to my home network (all static IP addresses) it's not possible to change the listing of "unidentified network" to a home or work network in Network Sharing Centre because the blue hyperlink by the unidentified network is greyed out..

    I have come across a number of posts indicating simalar issues (often resolved by re installing NIC drivers - which appears to work by allowing the "type of network" dialogue to start (sorry for non tech language)

    I can work around the issue by disabling and re enabling my firewalls or changing static IP ranges.

    Can someone tell me whether or not it is intentional to not be able change an "unidentified network" to a home/work ie private one
    Friday, June 26, 2009 2:02 AM

Answers

  • I think the problem is that Windows 7 is unable to identify your network because there is no default DNS suffix defined for the network. When you install Windows 7 on an "identifiable" network, you can click on "Public network" in the Network and Sharing Center to change the network from Public to Home or Work. If you don't have that option, it is because Windows 7 was unable to identify the network and therefore cannot assign a firewall profile to the network.

    Can you try setting the DNS suffix in the Advanced IPv4 settings of the network adapter?


    Ray
    • Marked as answer by Adam M MCP Saturday, June 27, 2009 2:53 PM
    Friday, June 26, 2009 7:18 AM

All replies

  • I think the problem is that Windows 7 is unable to identify your network because there is no default DNS suffix defined for the network. When you install Windows 7 on an "identifiable" network, you can click on "Public network" in the Network and Sharing Center to change the network from Public to Home or Work. If you don't have that option, it is because Windows 7 was unable to identify the network and therefore cannot assign a firewall profile to the network.

    Can you try setting the DNS suffix in the Advanced IPv4 settings of the network adapter?


    Ray
    • Marked as answer by Adam M MCP Saturday, June 27, 2009 2:53 PM
    Friday, June 26, 2009 7:18 AM
  • When you set up your Win 7 laptop's static IP address, do you also specify a default gateway? Is that default gateway reachable (does 'ping <gateway_ip>' work?)?
    Friday, June 26, 2009 5:35 PM
  • Or you can try this :

    Go here : http://msdn2.microsoft.com/en-us/library/bb201634.aspx  and try the script
    or manually open Regedit
    find    hklm:\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}
    look for your nic adapter and create a dword named "*NdisDeviceType"  ...modify the value from 0 to 1 . And disable/enable network adapters .
    ==============
    you also might try this :

    open registry editor,
    1. If you are prompted for an administrator password or for confirmation, type your password, or click Continue .
    2. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}
      In this registry path, click the (GUID) subkey that corresponds to the network adapter that is connected to the network.
    3. On the Edit menu, point to New , and then click DWORD (32-bit) Value .
    4. In the New Value #1 box, type DhcpConnEnableBcastFlagToggle , and then press ENTER.
    5. Right-click DhcpConnEnableBcastFlagToggle , and then click Modify .
    6. In the Value data box, type 1 , and then click OK .
    7. Close Registry Editor
    =================
    look for bonjour service ...by typing "services.msc"  ...START -> "search box" and Enter
    This service it's installed by Apple if you have iTunes or adobe aplications.
    ===========
    watch out with antivirus who install their own firewall...i was having problems with avira and kaspersky...and norton
    =====
    In my case the "*NdisDeviceType" trick saved me :) .

    Good luck!
    • Proposed as answer by Tr0y_69 Tuesday, January 31, 2012 8:58 AM
    Saturday, June 27, 2009 9:07 AM
  • Hi,

    We have been having the same problem hete.

    Will try you advice and let you know how it goes.

    Thanks

    Flagor

    Wednesday, October 27, 2010 8:27 AM
  • romania_25 You are a star! hehe solved a lot of problems for me thank you :-)
    Tuesday, January 31, 2012 8:59 AM
  • I think the problem is that Windows 7 is unable to identify your network because there is no default DNS suffix defined for the network. When you install Windows 7 on an "identifiable" network, you can click on "Public network" in the Network and Sharing Center to change the network from Public to Home or Work. If you don't have that option, it is because Windows 7 was unable to identify the network and therefore cannot assign a firewall profile to the network.

    Can you try setting the DNS suffix in the Advanced IPv4 settings of the network adapter?


    Ray

    Not all small networks have a DNS to set. A hub or router used for local LAN or even gaming does still have the problem when setting the DNS suffix. Didn't work for me.
    Tuesday, January 31, 2012 9:02 AM
  • Hi i know the easiest way to make it your home network.

    first go to start menu

    second type "services.msc

    third find "secure socket tunelling protocol" then double click on it

    fourth if its not started start it, there will be a start button on the screen

    5th then find "SSDP discovery" double click on it then start it

    6th go to network and sharing center, from there you can change it to your home network

    it should work if you do the steps correctly

    Saturday, May 19, 2012 6:01 PM
  • Hi i know the easiest way to make it your home network.

    first go to start menu

    second type "services.msc

    third find "secure socket tunelling protocol" then double click on it

    fourth if its not started start it, there will be a start button on the screen

    5th then find "SSDP discovery" double click on it then start it

    6th go to network and sharing center, from there you can change it to your home network

    it should work if you do the steps correctly

    This method does not work at my Win7
    Sunday, November 4, 2012 12:20 PM
  • Thank you, it worked well!
    Saturday, August 17, 2013 3:14 PM
  • SSDP Discovery won't start
    Thursday, April 17, 2014 2:00 PM