none
Duplex Printing in windows 7 proffesional

    Question

  • Hi.

    At my company, we have started to install windows 7 to some of our users. Before she had windows XP on her machine and duplex printing was perfect. It all happend manually and the printer turned the paper it self.

    Now when she is going to print with her new Windows 7 Proffesional OS, this function do not work. It is the same printer, with the same driver.

    I was having a look at the print options with duplex, and on windows 7 it says "manually". She said that that havent been there before.
    I tried to update the print driver with no diffrence.

    Has anyone else seen or heard about this problem that might give me a hand? 
    Tuesday, October 27, 2009 2:11 PM

Answers

  • Yes I would agree,  Knowing the model and manufacturer is vital, you stated your using the same printer and same "driver" did you install the driver using compatibility mode? Or is it a "7" driver? This is probably the issue.
    Network Systems Engineer * Zvetco Biometrics * Windows Server 2008 R2 * Core2 6600 @ 2.40GHz * 16 GIGS RAM * NVIDIA 9400GT *
    Tuesday, October 27, 2009 3:23 PM
  • Hi ITapprentice,

     

    I would agree with them.

     

    You should search, download and install the printer driver for Windows 7 from the printer manufacturer’s website.

     

    If no printer driver for Windows 7 is available, try to install it in compatibility mode. But it may not support the advanced feature of your printer in Windows 7.

     

    Install driver under compatibility mode & Administrator level

    =================

    1.Right click on the exe file for driver and click Properties.

    2.Click on the Compatibility tab.

    3.Select “Run this program in compatibility mode for.”

    4.Choose Windows Vista (Service Pack 2) from the drop down list.

    5.Select “Run this program as an administrator” option under the Privilege Level topic.

    6.Click Apply, click OK.

    7. Please double click on the exe file again.

     

    In addition, the Windows 7 built-in driver only supports the basic printer feature.

     

    Good luck!


    Arthur Li - MSFT
    Wednesday, October 28, 2009 3:39 AM
    Moderator

All replies

  • What model printer and manufacturer?


    Tuesday, October 27, 2009 3:08 PM
  • Yes I would agree,  Knowing the model and manufacturer is vital, you stated your using the same printer and same "driver" did you install the driver using compatibility mode? Or is it a "7" driver? This is probably the issue.
    Network Systems Engineer * Zvetco Biometrics * Windows Server 2008 R2 * Core2 6600 @ 2.40GHz * 16 GIGS RAM * NVIDIA 9400GT *
    Tuesday, October 27, 2009 3:23 PM
  • Hi ITapprentice,

     

    I would agree with them.

     

    You should search, download and install the printer driver for Windows 7 from the printer manufacturer’s website.

     

    If no printer driver for Windows 7 is available, try to install it in compatibility mode. But it may not support the advanced feature of your printer in Windows 7.

     

    Install driver under compatibility mode & Administrator level

    =================

    1.Right click on the exe file for driver and click Properties.

    2.Click on the Compatibility tab.

    3.Select “Run this program in compatibility mode for.”

    4.Choose Windows Vista (Service Pack 2) from the drop down list.

    5.Select “Run this program as an administrator” option under the Privilege Level topic.

    6.Click Apply, click OK.

    7. Please double click on the exe file again.

     

    In addition, the Windows 7 built-in driver only supports the basic printer feature.

     

    Good luck!


    Arthur Li - MSFT
    Wednesday, October 28, 2009 3:39 AM
    Moderator
  • Before you go through trying new drivers, this may be a simple fix.  I struggled with the same thing for about a week.  In older versions of windows, there was an option to say that a duplex unit was installed under printer properties.  To my dismay, I right clicked on my printer, found properties, but was not able to find the correct option.

    As it turns out, windows seven now has split properties into multiple items in the context menu.  There are "Printing Preferences", "Printing Properties", and "Properties".  I know it makes no logical sense to have two properties options in the context menu, but that is what they have done.  So go to start>>devices and printers, right click on the printer, click "Printer Properties" (NOT JUST "PROPERTIES"!), and move to the device settings tab.  There, you should find an option to turn duplex printing on.  :)

    Hope that helps!
    -Kyle
    Wednesday, October 28, 2009 3:44 PM
  • Thank you Kyle.  I just put Windows 7 Pro on my laptop and had the same problem with duplex printing on my HP Officejet 7410.  Your tip saved me a lot of time and hunting.
    Lew
    Thursday, October 29, 2009 1:43 AM
  • Thank you so much Kylie for your guidance, it saved my another day:) ..

    jyotasana
    Tuesday, February 02, 2010 4:14 PM
  • Thank you Kyle for taking the time to post your answer.  It saved me considerable time and much headache and probably a tree or two...
    Friday, February 12, 2010 11:34 PM
  • Kyle,

    A million thanks for this post.  HP's site was of no value, and your post saved me a ton of time.  Your directions work perfectly for CP2025dn under Windows7 Home Premium.

    Again, thanks so much.

    David H.

    Wednesday, July 14, 2010 10:14 PM
  • I already wondered where that option was. Thanks for posting.
    Friday, November 12, 2010 12:37 PM
  • KFox112

    Thank you.  First intelligent response I have seen in a long time.

    Saturday, January 01, 2011 6:51 PM
  • thank you for the tip, worked just fine for an HP P4515n and Windows 7 user :)
    Wednesday, January 12, 2011 11:30 PM
  • Thanks, this is the correct solution!
    Saturday, May 21, 2011 11:40 PM
  • Kyle,

    You are a genius.  Thanks, this worked after several months of me struggling to get duplex printing.

     

    Thanks,

    shankar

    Friday, January 20, 2012 3:00 PM