locked
OSX Remote Desktop Client cannot connect to Win 8.1 or Server 2012 R2 Preview

    Question

  • Hi,

    In installed Win 8.1 Preview on one of my machines.   I typically connect via Remote Desktop to the machine.  However, after upgrading from 8.0 to 8.1 preview, I can no longer RD to the machine.  If I look at the RD settings, everything is grayed out except the 'Select Users' and the 'Allow connections only from NLA enabled....'  

    The allow remote assistance configuration appears normal and is usable.  

    I don't have a Remote Desktop Hosts Server service running, or even listed, but I'm not sure there should be one in Windows 8.  

    Is anyone else seeing this behavior or able to RDP to a Windows 8.1 machine?






    • Edited by talon2112 Wednesday, July 10, 2013 1:33 PM
    Friday, June 28, 2013 3:06 PM

All replies

  • I am able to remote desktop from my Surface RT and only sometimes from my desktop. But I seem to have a different issue than you, I get a wierd low virtual memory error everytime i try to remote now. I was able to get the Windows 8.1 app to work one time but that is it.
    Friday, June 28, 2013 3:21 PM
  • An update to this:  I am able to RDP from another windows machine (2008 Server) but not using the Mac Microsoft Remote Desktop client.

    Still a mystery why the settings would be greyed out the way they are though...  There aren't any group policies enforced by our domain that should affect that and it was working fine before the upgrade.

    • Proposed as answer by defocusal Saturday, September 14, 2013 2:05 AM
    Friday, June 28, 2013 3:26 PM
  • Hi,

    I don’t have issue with windows client remote to windows 8.1 preview,  can you unselect “Allow connections only from NLA enabled” option then have a try?


    Alex Zhao
    TechNet Community Support

    Tuesday, July 2, 2013 5:36 AM
    Moderator
  • Thanks for the response.  It was not checked to begin with.  I've tried in both modes. 

    This appears to be an issue specifically with the RDP client on Mac, as the windows RDP client works.   Something changed though, as this was working fine right up to the upgrade to 8.1.   In fact, I started the upgrade from the Mac RDP client.

    Tuesday, July 2, 2013 4:46 PM
  • More digging.

    I've looked into the event logs for the RDP server and I see:

    1. the connection request come in
    2. the server creates the new RDP connection
    3. A new perf counter session is created
    4. The server terminates the main RDP connection with the client.
    5. The disconnect reason code logged is '0'

    0 seems like an odd disconnect reason code.  Does anyone know where's there is a list of these codes?

    Tuesday, July 2, 2013 6:20 PM
  • Hi,

    Can you post the full event message in forum? Maybe that would lead us to a right direction.


    Alex Zhao
    TechNet Community Support

    Thursday, July 4, 2013 12:41 AM
    Moderator
  • I set allow remote connections on, all users and am connected with no issue.

    suggest you turn off remote desktop, reboot, and try turning it back on

    Thursday, July 4, 2013 5:31 PM
  • I have come across the same issue, I am able to remote in from other windows machines (7, 8, 8.1) but not from my mac. The machine i'm trying to remote into was running windows 8 and I did the upgrade to 8.1, and all of the other settings i set were transferred over without a problem. 

    It is for this reason that i'm starting to think the problem is with the remote desktop connection for mac app. My guess is that we will have to wait for Microsoft  to put out an update to the mac app before we will be able to connect.

    Friday, July 5, 2013 4:18 AM
  • Yep. I am seeing the same issue with the RDP client on Mac OS X Mountain Lion. When I try to connect to a Windows 8 computer it works fine. When I try to connect to the 8.1 computer it does not work. Settings are the same. I can connect to the 8.1 computer from a Windows 8 computer without a problem so it does indeed look like an issue with the Mac client.
    Friday, July 5, 2013 12:25 PM
  • Agreed.  

    Thanks for verifying.  Unfortunately connect isn't taking bug information on Win 8.1 Preview yet, so i can't even report it. Hopefully someone from MS sees this. 

    Friday, July 5, 2013 4:04 PM
  • I am having the same issue.  I am able to connect from other devices to Windows 8.1 without an issue including my RT device.  I am able to use the RDC client for Mac to connect to other Windows devices, just not the 8.1 device.  I am running OSX 10.8.4 using RDC 2.1.1
    Sunday, July 7, 2013 2:19 AM
  • Also having a problem with RDP and 8.1. Although for me I can't even log in.  I've created several local accounts, but no matter which I try to log in with, I get a message saying "The credentials that were used to *** did not work..."

    I guess I'll have to roll back to 8 and wait for final.

    Monday, July 8, 2013 3:33 AM
  • Hi,

    I would report this feedback to our product team, thanks for your post.


    Alex Zhao
    TechNet Community Support

    Monday, July 8, 2013 10:06 AM
    Moderator
  • I am having the same problem.  Before installing 8.1 preview I could remote in with Mac or Windows client.  After installing 8.1 preview I could only remote in with the windows client.
    • Proposed as answer by defocusal Saturday, September 14, 2013 2:06 AM
    Monday, July 8, 2013 10:00 PM
  • Facing the same issue after upgrading to windows 8.1, i can successfully login into the device using another  PC with windows 7 but not from mac (mountain lion). RDP version 2.1.1  on mac.

    • Edited by Praveen Prasad Monday, July 15, 2013 4:19 PM added image
    • Proposed as answer by defocusal Saturday, September 14, 2013 2:06 AM
    Monday, July 15, 2013 4:17 PM
  • Hi

    i´m facing the same issue.

    But by using Cord http://cord.sourceforge.net/ it works fine.

    So for temporary solutions you could use cord.

    Cord is also a better tool if you need to connect to several MS machine/servers!

    Sunday, July 21, 2013 10:08 PM
  • I'm having the same issue, probably not a Mac OS issue but a RDP for Mac issue.  Lets hope Microsoft releases and update for this soon.
    Tuesday, September 3, 2013 8:18 PM
  • Same issue here, RDP for the Mac has hit a wall.  MSFT UPDATE PLS .. and include support for RemoteFX 

    Instead of CORD, check out the 2X Mac Client, it's very nice and full featured.  Connects great to my 2012 R2 

    • Edited by PRESSTHEANYKEY Tuesday, September 10, 2013 4:16 PM
    • Proposed as answer by defocusal Saturday, September 14, 2013 2:05 AM
    Tuesday, September 10, 2013 4:12 PM
  • Same Issue, osx mountain lion, remote desktop connection for mac, worked on windows 8, upgraded to 8.1 and won't let me in. 'Remote Desktop Connection cannot verify the identity of the computer that you want to connect to.'

    I'm in a workgroup not a domain, both machines in the same workgroup, can access all windows shares but not rdp, anyone tried any other rdp apps for osx? 

    Also gone through all the security settings on the windows box, turned everything to the lowest setting or off, confused! It's not like it's a whole new os, just a little upgrade, suprised they would have even touched the rdp code or whatever they do.

    • Proposed as answer by defocusal Saturday, September 14, 2013 1:44 AM
    • Unproposed as answer by defocusal Saturday, September 14, 2013 1:44 AM
    Saturday, September 14, 2013 12:59 AM
  • Just found another post, It worked and I'm in , http://social.technet.microsoft.com/Forums/windows/en-US/0b865c92-5e0b-4518-9092-790aed895f5b/remote-desktop-connection-for-mac-os-x-cannot-connect-to-windows-81 second post down, first answer ! Great stuff!
    • Proposed as answer by defocusal Saturday, September 14, 2013 1:45 AM
    Saturday, September 14, 2013 1:45 AM