locked
Remote Desktop connection to Windows 10 PC not working anymore RRS feed

  • Question

  • I'm using Microsoft Remote Desktop for macOS (latest version) to control three different Windows PCs in my local WLAN network.

    This has worked OK for many months but suddenly I cannot connect anymore to one of these PCs with Windows 10 Pro. Microsoft Remote Desktop tries to connect but then stops with the error message "Unable to connect to remote PC. Please verify Remote Desktop is enabled, the remote PC is turned on and available on the network, and then try again".

    Remote Desktop is enabled (System Properties -> Remote -> Allow remote connections to this computer) and the remote PC is turned on and on the same network. What was turned off - without me having done this - was Network Discovery, and I turned that on again. However, I cannot connect to this computer - possibly having to do with the fact that I recently changed the external wifi adapter on that PC. Several restarts did not help.

    I'm quite sure that this is not a Mac problem as I'm still able to connect from it to another Windows 10 PC on my network. 

    Is anybody here able to help me to get this to work again?


    • Edited by resucami Thursday, July 6, 2017 1:26 PM
    Thursday, July 6, 2017 1:26 PM

Answers

  • Well turn off the firewall on the Windows machine and the Mac to test. I have been on posts like this when that was tried late but it was the issue so please try that to rule that in or out.

    So can you try to connect by IP? You said ping but thinking maybe that was the wrong IP?

    What are the others PC's you can remote too from the Mac? Windows 10 exact same version any of them?

    • Marked as answer by resucami Saturday, July 8, 2017 12:51 AM
    Friday, July 7, 2017 7:42 PM

All replies

  • On the affect PC, from a command prompt does;

    netstat -a | findstr -i "Listen"

    Show anything listening on the 3389 port? (so ends in :3389)

    What client is affect trying to connect? Your post seems to point to it being only a Mac that cannot connect?

    Can the affect client machine that is trying to connect ping the remote PC ok? Does the name resolve the correct address?

    Thursday, July 6, 2017 8:41 PM
  • netstat shows listening on port 3389 (and on many other ports):

     TCP    0.0.0.0:3389           Dell-Desktop:0         LISTENING

    I am always only using Microsoft Remote Desktop on my Mac (which is my main computer) to connect to 3 different PC's in my local network. I always could and still can connect this way to a different PC, but I cannot anymore connect to this one (but could do so in the past).

    I can successfully ping the PC from the Mac and the Mac from the PC.

    Friday, July 7, 2017 1:06 AM
  • Well turn off the firewall on the Windows machine and the Mac to test. I have been on posts like this when that was tried late but it was the issue so please try that to rule that in or out.

    So can you try to connect by IP? You said ping but thinking maybe that was the wrong IP?

    What are the others PC's you can remote too from the Mac? Windows 10 exact same version any of them?

    • Marked as answer by resucami Saturday, July 8, 2017 12:51 AM
    Friday, July 7, 2017 7:42 PM
  • I can't believe that it was something so stupid - the Remote Desktop rules in the firewall settings on the PC were disabled. I wonder how that happened (definitely not done by me).

    Thanks, Mr. Happy, I'm glad I know the reason and could fix it.

    Saturday, July 8, 2017 12:51 AM
  • Thanks 

    it resolved my problem. It was my anti virus firewall which was preventing this connection. Just turned it off & boom..

    Sunday, January 28, 2018 4:59 PM
  • Thanks this helped me out. my remote desktop rule was also disabled.. Odd, some change in win10 I didn't perform? Some update changed this? Seems not the only one rule that changed..
    Thursday, February 22, 2018 9:45 PM
  • How can you do this. How can you screw up RDP? You wonder why Microsoft, dont wonder. This is the bed you have laid. Unreal.
    Tuesday, June 19, 2018 12:23 PM