none
Windows 7 reseting color profile on screen flash etc.

    Question

  • Hi, I'm running Windows 7 release version (though this also happened in the RC version) and have a custom ICC/ICM profile that I'm loading for the display. The profile was generated using a Spyder 2 and seems to have no issues in itself, however things like screen blanks and UAC warnings seem to reset the display (LUT) to defaults (ie: I lose my color management). The odd thing is it initially starts with the correct profile on reboot, but a few seconds later resets to the default unmanaged state.

    At first I was using the ColorVisionStartup to load the ICC/ICM profile, however since Windows 7 now supports color management out of the box, I made it do the load (or tried to at first - it appears I had to create a second profile using the Windows 7 tools before it would let me use mine, which was kind of curious, but whatever). I've since disabled the ColorVisionStartup.

    Anyway, regardless of how I load the profile, it still resets on screen blanks, UACs, reboots (after a few seconds of being correct), etc. Apparently this was a Vista issue as well (since corrected) and others have also now seen the Windows 7 problem (see bottom comments):

    http://neosmart.net/blog/2007/windows-vistas-gamma-table-bug/

    I'm using a Toshiba Netbook NB205. The graphics driver is an Intel 945 Express and it's using the latest Intel Windows 7 "beta" driver 8.15.10.1825. I don't have a terribly good reason to be sure one way or another, but I suspect it may be an interaction between the "Intel Graphics Media Accelerator Driver for Mobile" tool (which you can't uninstall without taking the driver with it) and the Windows 7 color management.

    I don't however think it's entirely particular to the Intel driver because it sounds like others using different drivers are having issues as well, though perhaps it's related.

    Couple of odd things:

    1. On reboot it starts with the right profile (at least id did in RC) and then switches back to default quickly.
    2. I can't even get the profile to load without creating another profile and switching between the two (that is, make switch the default to the wrong one, then switch the default to the right one). Telling it to manually reload the profile doesn't help.
    The system is full updated and otherwise works without issue. It's just a PIA to lose my color everytime.

    Thanks in advance.
    Sunday, October 25, 2009 5:58 AM

Answers

All replies

  • I should also note that if I create the profile with the Windows 7 tools, making them ridiculous to be obvious, it still resets on UACs, screen blanks, boots, etc. So it's clearly not the profile itself.

    Note I'm making all these changes via the system defaults color management.
    Sunday, October 25, 2009 6:04 AM
  • Hi,

     

    I just tested on my test machine and found the profile can be changed and saved by the system properly.

     

    From the Intel site, I found the latest version of the graphics card is 8.15.10.1930, since yours is 8.15.10.1825, please upgrade it and see how it works:

     

    Mobile Intel® 945GM Express Chipset Family

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    For more information about Color Management, please also refer to:

     

    Windows Color System

     

    Color management settings: frequently asked questions

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Monday, October 26, 2009 8:03 AM
    Moderator
  • I just want to add that I am having the same issue as Matt, with the exception being that I am using a Huey Pro for calibration, rather than te Spyder 2.  Searches reveal that we are by no means alone on this issue.

    I have the latest Intel 965 chipset drivers running on Windows 7 Home Premium on a Lenovo IdeaPad Y510.

    Like Matt, I have tested with many variations of settings, including trying to set the Huey-created profile as the system default, but no satisfactory results. This sounds like a similar problem that Vista had, which was apparently corrected by an obscure security fix (http://support.microsoft.com/kb/951537/en-us).

    I hope this gets resolved ASAP, as it is truly annoying to have to re-apply the correct profile many times during a session.
    Wednesday, December 23, 2009 9:23 AM
  • I have a Dell Studio 1747 laptop running Windows 7 Professional x64, and I have the same issue Matt and PhotoExp mentioned. I looked for the latest video driver (my system has an ATI Mobility Radeon HD 4650), and it happens that my current drivers are the most recent ones.

    The issue happens even when I lock the computer. When I unlock it, my already-set-as-default color profile is ignored and the screen is reset to the original color profile. I have to go to the color management window and set my calibrated color profile as default (even though the window says it is the default) for my custom settings to be applied.

    This is very annoying; it happens no matter what, I can have a second monitor connected to the computer and it happens, I can have no monitors connected to the computer and it happens.

    Please get this issue resolved!

     

    Friday, April 16, 2010 4:05 PM
  • Put me down as same problem. Was supposed to be fixed but isn't. Any help greatly appreciated as there seems to be an endless number of tricks required to get it back to using my calibrated profile.
    Saturday, April 17, 2010 11:06 AM
  • Is this ever going to be fixed??

     

    Thursday, June 17, 2010 4:41 PM
  • it seems like it's never going to be fixed.  It's really PITA.  In my case, I always have to do a fake calibration using windows 7 tool then press cancel at the end of the process, and only then it will revert back to my Spyder2 icc profile. 

     

    Sigh.

     

    ps:  the Vista fix only work during bootup but not after I put the PC to sleep/standby mode.

    Sunday, August 08, 2010 1:51 PM
  • I am also having this issue.

    What I'd add is that I have two Dell 17" monitors running off a single laptop in a docking station, and have calibrated and created profiles for each monitor. These are loaded as system profiles on Windows 7. The profiles are correctly loaded up at bootup (I'm using dispcalGUI and Argyll for colour calibration), but if I lock and unlock the desktop, the profile on the primary display (left) reverts to default.

    The above fix of going through a windows calibration and then cancelling at the end reverts the primary display back to the profile it should be.

    Because only the primary display reverts to a default profile after unlocking, and not my other display, I'm pinning this on a bug in Windows itself, rather than any sort of display driver.

    No wonder people opt for other platforms for serious multi-monitor design, graphics and video work.

    Monday, August 09, 2010 11:52 AM
  • Microsoft keep wondering why people want to stay with XP.  This is why.

    Nicholas, it seems the fix only works on your PC but it doesn't work with any of ours, and any of mine too (2 laptops with Win7 Pro, 1 Desktop with Win7 Pro, 2 Desktops with Vista).

    Do you guys even care?  Why are you guys forcing us using the crud-tastic ISF stop-gap solution there?  I know the owner of ISF and even he said that it doesn't work properly (guess what laptop he's using?  NOT Windows OS).  That's tragic when the developer of your calibration software is not even willing to use your OS.

    Monday, August 09, 2010 10:10 PM
  • The answer does not seem to be independently verified.

    Still having the same problems as described.

    Thursday, August 12, 2010 9:30 AM
  • I think I fixed the issue on my system (Win7 Pro). Here's what you need to do (given that Microsoft is not concerned about improving the company-customer relationship):

    1. Open Task Scheduler.
    2. Go to Task Scheduler Library, Microsoft, Windows, WindowsColorSystem.
    3. Double click the only task listed there: Calibration Loader.
    4. Click the Triggers tab, and then the New... button.
    5. Change the "Begin the task" option to "On workstation unlock", and then click OK twice.

    I tested this by setting my computer to sleep mode and bringing it back up (the profile was always reset on this scenario), and it worked. Please remember to have set your profile as default.

    So yes, pretty stupid; Microsoft hasn't thought of fixing this task so that the profile is loaded when you unlock your system.

    Hope it works for you.

    • Proposed as answer by Rozi Saturday, April 02, 2011 1:40 PM
    Wednesday, August 25, 2010 5:11 PM
  • Hi,

    I've been having this exact issue with one of my Windows 7 computers with an Intel Graphics Display Adapter as well.  I found that if you do not allow the "igfxpers.exe" process to run, the LUT's are no longer reset after locking a desktop.

    They still seem to be reset after a UAC prompt appears on the secure desktop.  Therefore my solution to that would be to set the UAC setting to the second-to-last slider option: "Notify me only when programs try to make changes to my computer (do not dim my desktop)".

    Hope it helps you and others as well!

     

    • Proposed as answer by Rozi Saturday, April 02, 2011 1:42 PM
    Wednesday, September 29, 2010 11:46 PM
  • I also found something else that's interesting.  Contrary to what I've heard and seen in the past, it seems Windows 7 can load LUT's from ICC profiles. 

    I found that when in the "Color Management" dialog, and go to the "Advanced" tab, and choose the "Change system defaults..." option, you can set the default profile for the system for the monitor device, and then in the "Advanced" tab there, you can now check the box for "Use Windows display calibration". 

    ** Note that I did NOT use the "Calibrate Display" feature built into Windows at all, only set the ICC profile produced by my monitor calibration tool.  Once you check this box, it immediately sets the LUT's.  This seems to persist even if you lock the screen and come back in again. 

    However, UAC prompts still breaks this method as well (if it is set to dim the desktop, of course).  If you have the UAC slider set to something higher than second-to-last option, then you probably can't even try this method.  I would reset this first before testing.

     

    Thursday, September 30, 2010 12:19 AM
  • Thank you very much - my screen kept blinking as the video driver crashed. This solved it completely.

    FuzzyRev
    Friday, December 03, 2010 12:55 AM
  • Thanks a lot ! igfxpers.exe was the problem in my case.
    Thursday, June 07, 2012 4:28 AM