Vista SP1 installation generates error: 0x8007000B

    General discussion

  • A friend ran System Restore on her system running Vista Home Premium (32 bit) and lost all her updates. Whatever I try, I keep seeing error code 0x8007000B and would really appreciate some guidance please :'(


    I have tried:

    1. renaming the Software Distribution folder (didn't help);

    2. I used a tried and tested download of SP1 and downloading a new copy from Microsoft (didn't help).

    3. SFC/Scannow found some errors but I didn't understand the log (said like "Failed to initialize SQM wrapper")

    4. I scanned with MBAM but it only found some harmless rubbish

    5. I followed Microsoft's advice to run: "fsutil resource setautoreset true c:\" in Command line as Administrator (didn't help)

     Can anyone please shed any light on what I should be doing? I really dont' want to kill hours by reainstall ing everything onto her laptop.




    EDIT October 29th 2011 - SOLVED:

    In the absence of any resonses, I kept trying things and eventually used the Toshiba Recovery DVD to access the Repair functions. I didn't have the Recovery media initially. The Repair feature did the trick. Afterwards, I was able to install SP1, then SP2 then 50+ other updates via Windows Update.

    • Edited by Jann0th Saturday, October 29, 2011 5:43 PM
    • Changed type Sabrina Shen Thursday, November 03, 2011 7:48 AM
    Thursday, October 27, 2011 3:50 PM

All replies

  • Hi,


    Thank you for your sharing.


    If you have any questions or concerns, please feel free to reply this post directly so we will be notified to follow it up.


    BTW, we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.





    This posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, November 03, 2011 7:48 AM