none
Windows 2008 SP2 stops with request for SP1 RRS feed

  • Question

  • We are testing Windows 2008 SP2 on several servers and have run into a problem.  On the third server, Windows 2008 64-Bit SP1, it stops and says that it requires SP1 before SP2 can be loaded.  Checking the comptuer properties, it shows that it is on SP1.  Should we just reload SP1?  The server is current on updates except IE8.  This server is running Hyper-V with several guests, will reloading SP1 effect them at all?  Thanks

    Mike
    Wednesday, May 27, 2009 1:20 PM

All replies

  • There is no such thing as SP1 for Windows 2008 Server.  Windows 2008 Server was first released in parallel with Vista SP1, with all its bits at SP1 level.
    Robin Walker
    Wednesday, May 27, 2009 4:19 PM
  • In the mean time, tried running "SFC /scannow" and didn't find any integrity viloations.

    Tried the Reset Windows Update Components and that didn't fix anything either.  http://support.microsoft.com/kb/971058

    Tried installing SP2 under a different account, no change.

    Now what?

    Wednesday, May 27, 2009 7:26 PM
  • Same issue here, x64 with Hyper-V. Installation stops asking for SP1.

    Wednesday, May 27, 2009 9:16 PM
  • Here's a little more info from the event log.

    These three events are logged when trying to perform SP2 update:

    1.  Service pack 2 installation started.

    2.  The Windows Modules Installer service entered the running state.

    3.  Service Pack installation failed with error code 0x800f0a05.



    This server is an IBM x3650 and I can't remember if we installed Windows 2008 using IBM ServerGuide of if it was a straight install from a Windows DVD.

    Mike
    Wednesday, May 27, 2009 9:46 PM
  • I had some problems adding and removing roles.

    So i ran the System update readiness tool kb947821

    I can now add and remove roles. And it also solved my problems with SP2.
    Thursday, May 28, 2009 1:12 AM
  • Hi Mike,

    Did you try running System update readiness tool. If No, please try downloading it from http://www.microsoft.com/downloads/details.aspx?familyid=B950E3B1-3267-41C2-8F10-1FE9A4BFA44D&displaylang=en and see if that resolves the issue.
    If you already run it, then did that resolve the issue/

    Thanks,
    Sachin
    Thursday, May 28, 2009 6:46 AM
  • Thaks for linking to the correct version, the only one I could find yesterday was for Windows 2008 R2.

    Here are the results in the CheckSUR log file:


    =================================

    Checking System Update Readiness.

    Binary Version 6.0.6001.22375

    Package Version 5.0

    2009-05-28 08:13

    Checking Deployment Packages

    Checking Package Manifests and catalogs.

    Checking package watchlist.

    Checking component watchlist.

    Checking packages.

    (f) CBS MUM Missing 0x00000002 servicing\packages\Package_for_KB961260_server_0~31bf3856ad364e35~amd64~~6.0.1.3.mum

    (f) CBS MUM Missing 0x00000002 servicing\packages\Package_for_KB961260_server~31bf3856ad364e35~amd64~~6.0.1.3.mum

    (f) CBS MUM Missing 0x00000002 servicing\packages\Package_for_KB961260~31bf3856ad364e35~amd64~~6.0.1.3.mum

    Checking component store

    Summary:

    Seconds executed: 140

    Found 3 errors

    CBS MUM Missing Total Count: 3




    is this the link to the correct update:  http://support.microsoft.com/kb/961260?  Is that what I should load?

    Mike

    Thursday, May 28, 2009 1:31 PM
  • tried to download that package and the older version of that package, both said that they didn't apply and wouldn't install.

    Found this:   http://social.technet.microsoft.com/Forums/en-US/winservermanager/thread/8f85073b-af2a-472f-95c8-c8dce3e60c71

    and copied those files, along with the ".cat" files over from another server (two others that I've upgraded to SP2 didn't have them oddly, but one did) and that worked.  The system update log file showed 0 problems and the SP2 update is running now.

    Mike
    Thursday, May 28, 2009 2:53 PM
  • I have the same problem and system update readiness log only shows:

    (f)    CBS Watchlist Component Missing    0x80070002    amd64_microsoft-windows-naturallanguage6_31bf3856ad364e35_0.0.0.0_none_1dd3656b2b438299    Package_2_for_KB955020~31bf3856ad364e35~amd64~~6.0.1.0    Package registry presence failed, possibly an orphaned package on package watchlist


    I still cannot install the service pack via windows update or the downloaded kb948465 file.  I get the same error as above stating that service pack 1 must be installed (running server 2008 enterprise).  Any advice please?
    Monday, June 1, 2009 11:31 PM
  • There are others reporting this problem.  See:  Windows 2008 SP2 RC: SP1 Required!?!.
    Monday, June 1, 2009 11:53 PM
  • Guys. I was able to resolve my problem, which was identical. Please reference this thread. It might be helpful.

    http://social.technet.microsoft.com/Forums/en-US/winservermanager/thread/b4526323-210d-4ada-be12-dace2d9693ef

    Cheers,


    Thursday, July 16, 2009 2:40 AM
  • Mike:

    Go to the link I provided, download the missing packages (Tim still has them posted) and it will fix your problem.

    Link, again:http://social.technet.microsoft.com/Forums/en-US/winservermanager/thread/b4526323-210d-4ada-be12-dace2d9693e

    Cheers.

    Gene

    Friday, July 17, 2009 3:39 AM