none
Code 800B0100; Update for Windows 7 for x64-based Systems (KB976098)

    Question

  • Hello.
    WU said that there's new update available for my Windows 7 RTM x64. KB976098
    I don't actually remember if it asked me if I want to install it, or it started installing it on his own, but I got a Power outage during installation of the Update, and now it won't install.
    I get Code 800B0100 each time I try to install it from WU. I tried downloading the update as a separate file and launching it - I get a message that it was not installed. \

    I installed Windows6.1-KB976098-x64.msu, but it did not help.
    I see an icon near Shut Down button, saying that it will install updates and then Shut my PC Down, but I tried it few times already and it still shows there, and WU says that there's still an update available.

    Here's log from Windows/Logs/CBS - http://lplive.net/personal/sergslim/Windows/CBS.rar
    One file was 10 MB, so I put all 3 of them into archive.
    Friday, November 27, 2009 9:44 PM

All replies

  • Quite often Windows Updates make Restore Points.  You might consider trying the System Restore functionality (Control panel - Recovery applet) and restoring the system to the point saved just prior to the application of the update.

    Hope this helps.

    -Noel
    • Proposed as answer by bash1 Saturday, October 15, 2011 4:59 PM
    Saturday, November 28, 2009 3:20 AM
  • System Restore says that No Restore Points have been created on my computer's system drive.
    Saturday, November 28, 2009 10:50 AM
  • Try this
    Click Start, select Run, now type in:
    regsvr32 wintrust.dll
    Press Okay

    Try Windows Update again, if that doesn't work then -


    Click Start, select Run, now type in:
    CMD
    (Note this opens the command prompt windows)

    Now type in the following (noting to press Enter after each line)

    net stop cryptsvc
    ren %systemroot%\system32\catroot2 oldcatroot2
    net start cryptsvc

    Reboot if necessary and try Windows Update again
    MCSE, MCSA, MCDST
    Saturday, November 28, 2009 7:23 PM
  • If I do what you said I get errors, so I ran CMD from Search As Admin.
    Regsvr32 worked, but Wu still shows the same error.
    cryptsvc also did not help :(
    Saturday, November 28, 2009 7:54 PM
  • Monday, November 30, 2009 3:42 AM
  • Hi Sergslim,

    Here is a Microsoft KB for this error.

    Error message when you try to use the Windows Update or Microsoft Update Web sites to install updates: "0x800B0100"

    Hope it helps.
    As I wrote in my first post, I already installed that fix, that is said to help in that link you gave, and even uploaded logs from it.
    Tuesday, December 01, 2009 8:55 AM
  • Hi Sergslim,

    Sorry for missing information.

    I checked the CBS and CheckSUR logs and find the following message:

    (f) CBS MUM Corrupt 0x800F0900 servicing\packages\Package_37_for_KB976098~31bf3856ad364e35~amd64~~6.1.1.1.mum  Line 1:
    (f) CBS Catalog Corrupt 0x800B0100 servicing\packages\Package_37_for_KB976098~31bf3856ad364e35~amd64~~6.1.1.1.cat
     

    In additon, I would like to let you know:

    0x800B0100 - TRUST_E_NOSIGNATURE
    A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider

    According to current stage, could you please confirm following points?

    1. What anti-virus/firewall applications or security suites are installed on the computer? 
    2. Please make sure computer's time, date, and time-zone settings are all correct.

    If possible, could you please download the update to local computer and manually install it without enabling any security software?

    Hope it helps.

    Thanks.
    Wednesday, December 02, 2009 2:12 AM
  • Hey.

    1. I'm using Microsoft Security Essentials .
    2. Checked everything - it's all correct. UTC +2, 11 am, 02.12.2009.

    I tried downloading and installing that Update, but it says that it's not applicable to my computer.
    I figured out it's for x86 , and downloaded x64 version. But I already tried downloading and installing it separately.

    It starts installing and says - The following Updates were not installed:

    Update for Windows (KB976098)

    I turned off Real-Time Protection in Microsoft Security Essentials before trying to install it this time.
    Wednesday, December 02, 2009 9:05 AM
  • Hi Sergslim,

    Thank you for your update information. I am glad to hear the antivirus is not culprit.

    As this is a TRUST_E_NOSIGNATURE and we can find following message from CBS log:

    2009-11-27 22:00:28, Info                  CBS    WinVerifyTrust failed [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
    2009-11-27 22:00:28, Error                 CBS    Failed to verify if mum file
    \\?\C:\Windows\Servicing\Packages\Package_for_KB976098_RTM~31bf3856ad364e35~amd64~~6.1.1.1.mum is vouched for by catalog \\?\C:\Windows\Servicing\Packages\Package_for_KB976098_RTM~31bf3856ad364e35~amd64~~6.1.1.1.cat. [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]

    I suggest you take following steps to troubleshoot this issue:

    1. Click "Start" button, type "sigverif" (without quotation marks) in the Start Search Bar and press Enter.
    2. Click the "Start" button to make a check.

    For more information abour sigverif, please click HERE

    If possible, you can try to rename these files and try to install the update again.

    Hope it helps.

    Thanks.

    Thursday, December 03, 2009 7:51 AM
  • :( This did not help either.

    sigverif said "Your files have been scanned and verified as digitally signed".
    I even deleted those 2 files (I had to change ownership and give Full Permission).
    After that I tried installing the update again, and it Failed :(
    Thursday, December 03, 2009 10:10 AM
  • I have exactly this same problem, and none of the proposed fixes have had any effect. I'm using Windows 7 Home Premium, 32 bit, and I've been trying to solve this issue for two weeks now. It's gotten to the point where I have to do a startup repair *every time* I turn on my computer because updates are failing on shutdown.

    I get error codes 800B0100, 80073712, and 8024200D, "Windows encountered an Unknown Error"

    I now have 9 important updates waiting to install and can't install any of them either automatically or manually

    Thursday, June 03, 2010 8:14 PM
  • If you receive the Windows Update error 800b0100, it means that a file needed by Windows Update is not registered with Windows correctly. The System Update Readiness Tool can correct some conditions that cause this error. To use the tool, follow these steps:

    1. Go to the System Update Readiness Tool webpage. In the Information for advanced users section, find the version of Windows and system type of your computer, and then click the link to download the System Update Readiness Tool. If you don't know which version of Windows you have, see View your computer information.

    2. Run Windows Update again.

      Note

      Typically, the scan takes 15 minutes or less, but it can take longer on some computers. The Windows Update progress bar is not updated during the scan, and progress seems to stop at 60% complete for some time. This behavior is expected. The scan is still running and you should not cancel the update.

    If the problem persists after you take these steps, go to the Microsoft Update Solution Center website to find more information about the error code or to request support by e‑mail.

    Thursday, July 15, 2010 9:49 PM
  • I am having the exact same problem, I spent 2 hours in the phone with MS PC Safty with no lock either.
    Dalorzo
    Wednesday, August 17, 2011 3:41 AM