none
Slow Clock or Lagged Time on Win7 x64

    Question

  • I thought I would ask a quick question here to see if anyone else had encountered it. My hand-built system has a "slow clock" when running in a specific hardware configuration with Win7 x64 RC, but strangely only with x64.  Here's how it breaks down:

    Clock Works/Keeps Time When...
    1. CPU throttling (Cool n' Quiet in AMD-land) is disabled
    2. Away mode (AMD Live! in AMD-land) is disabled

    Clock Loses Time When...
    1. CPU throttling is enabled
    2. Away mode is enabled

    The bummer is disabling the CPU throttling produces a lot more heat and uses much more power. Also strange is the fact that these same settings don't impact the time keeping abilities of Win7 if running x86 versions.  This is very odd and I've not found any other reports of this behavior. Does anyone have any ideas?

    I am ready to supply any information needed to help troubleshoot the problem.  Here is a sampling of the system configuration:
    AMD Phenom II 940 X4, 4GB DDR2 RAM, 500GB Seagate 7200.9 SATA HDD, NVIDIA nForce 780a chipset, Microsoft Natural Keyboard 4000, Logitech G5 mouse, NVIDIA GeForce 8800GTX GPU, NVIDIA GigE networking, Windows 7 x64 Ultimate clean installation.
    Friday, August 07, 2009 12:37 AM

Answers

  • Realise this threads nearly a month old but I have the same problem when using Vista 64 with a Asus M3N72D and a Phenom II X4 955. The system loses time, but when I dual boot into XP 32 bit, the system doesn't lose time.Very strange and really annoying when you realise you're too late to Bid for that elusive item on Ebay! ;) Looks like this is a 64Bit issue and it's not just Win 7.
    Wednesday, October 07, 2009 8:26 PM
  • I also had the same problem, Motherboard is M3N72D with Phenom II X4 955 CPU and 4 GB RAM. Windows 7 64-bit.

    BIOS was keeping time without any issues. I then decided to change the time source from the default which was time.windows.com to time-a.nist.gov and clicked on update now button next to it. Since then the problem has disappeared.

    Worth trying and seeing if this fixes your problems.
    Wednesday, October 07, 2009 9:28 PM

All replies

  • I thought I would ask a quick question here to see if anyone else had encountered it. My hand-built system has a "slow clock" when running in a specific hardware configuration with Win7 x64 RC, but strangely only with x64.  Here's how it breaks down:

    Clock Works/Keeps Time When...
    1. CPU throttling (Cool n' Quiet in AMD-land) is disabled
    2. Away mode (AMD Live! in AMD-land) is disabled

    Clock Loses Time When...
    1. CPU throttling is enabled
    2. Away mode is enabled

    The bummer is disabling the CPU throttling produces a lot more heat and uses much more power. Also strange is the fact that these same settings don't impact the time keeping abilities of Win7 if running x86 versions.  This is very odd and I've not found any other reports of this behavior. Does anyone have any ideas?

    I am ready to supply any information needed to help troubleshoot the problem.  Here is a sampling of the system configuration:
    AMD Phenom II 940 X4, 4GB DDR2 RAM, 500GB Seagate 7200.9 SATA HDD, NVIDIA nForce 780a chipset, Microsoft Natural Keyboard 4000, Logitech G5 mouse, NVIDIA GeForce 8800GTX GPU, NVIDIA GigE networking, Windows 7 x64 Ultimate clean installation.

    Are you using the latest bios for the motherbooard?
    Friday, August 07, 2009 1:56 AM
  • Not the absolute latest, but one back from the latest that specifically added Phenom II support.  Previous encounters with ASUS BIOS updates have taught be to be very suspicious of the latest releases.
    Monday, August 10, 2009 11:50 PM
  • Hi,
    I've been having the same problems. It has occurred with 2 different mainboards and 2 cpu's. Worked fine in vista.  I had the latest bios installed on both boards.

    I am currently running an asus crosshair II formula (780a chipset), amd 965 x4, 4gb ram, C1e and cool and quiet turned on,
    tri sli with hybrid power enabled, win 7 64 bit.  The bios seems to keep time properly, but the windows time is slow.  Can synchronize to correct it, but lags just a
    short time later.   Had no problems under vista with a similar set up (tri sli, m3nht motherboard, amd 940x4, etc.).  I have an lcd post screen which came with the crosshair
    and is set to display time.  It currently reads 8:35, while my windows display reads 8:29.   I suppose I could disable cool n quiet, c1e, etc, but I was under the impression
    that all of this tech is supposed to work.   Any help would be appreciated.  Any  questions feel free to contact.

    Monday, September 07, 2009 1:46 PM
  • I have the same issue...

    I have an Asus M3N72D motherboard which is flashed to the latest BIOS version.  I previously had an Athlon processor in the system, but replaced it 2 weeks ago with a Phenom II X4 955 processor.  Prior to the upgrade no problem, but since then the clock has been consistently losing time when booted in Win 7 64 bit.  I can reset the time by synching with an internet time clock, but the system immediately starts to lose time again. 

    This happened with Win 7 64 bit RC.  I wiped the partition, and installed the 90 day evaluation of Win 7 64 bt RTM - the problem is still there so it looks like unless a patch is released any PHenom II installs after the 22nd October are going to experience the same problem from the start.

    As above, any help would be appreciated.
    Wednesday, September 09, 2009 8:04 AM
  • Realise this threads nearly a month old but I have the same problem when using Vista 64 with a Asus M3N72D and a Phenom II X4 955. The system loses time, but when I dual boot into XP 32 bit, the system doesn't lose time.Very strange and really annoying when you realise you're too late to Bid for that elusive item on Ebay! ;) Looks like this is a 64Bit issue and it's not just Win 7.
    Wednesday, October 07, 2009 8:26 PM
  • I also had the same problem, Motherboard is M3N72D with Phenom II X4 955 CPU and 4 GB RAM. Windows 7 64-bit.

    BIOS was keeping time without any issues. I then decided to change the time source from the default which was time.windows.com to time-a.nist.gov and clicked on update now button next to it. Since then the problem has disappeared.

    Worth trying and seeing if this fixes your problems.
    Wednesday, October 07, 2009 9:28 PM
  • Unfortunately the suggestion from Binesh does not fix the problem.  Even though I have just synchronised with the time server suggested, my system continues to lose time.  This is as you would expect - the time synchronisation only "fixes" the system clock at that time, but does not address the underlying issues!

    Yogimax
    Thursday, October 08, 2009 11:27 PM
  • Also like Davi0 above, I dual boot into XP Home 32bit.  The clock does not slow down at all in that 32bit environment, but it happens without fail when in Windows 7 64bit.

    This appears to be definitely a Windows 7 issue with the AMD Phenom II processor!

    Yogimax
    • Proposed as answer by ESotSM Tuesday, October 13, 2009 3:32 AM
    Saturday, October 10, 2009 9:41 AM
  • I got the same issue on ASUS's  M3A32-MVP DeLuxe/WiFi-AP with AMD Phenom II 940 X4, changing "SpecialPollInterval" value for NTPClient could be a temporary fix.

    And another question: Do we all use ASUS motherboards?
    Tuesday, October 13, 2009 3:39 AM
  • It would appear that we are all using ASUS motherboards.  In my case, I am not using ASUS drivers, only the BIOS.  I am using either the default drivers supplied by Win 7 or else the reference chipset drivers from Nvidia - the problem occurs with both situations.

    Yogimax
    Tuesday, October 13, 2009 5:27 AM
  • me too, using default Win7 driver + AMD graphic driver.
    actually till now there's no Win7 driver from ASUS for that motherboard...

    well, I'm going to downgrade the BIOS version, let's see what happens then
    Tuesday, October 13, 2009 6:02 AM
  • Same issue here... Amd P2 940 and Asus Formula II mobo... running win7 x64 defenetly seams to be an issue with Asus and win7 X64 :/
    Thursday, October 22, 2009 10:09 PM
  • me too, using default Win7 driver + AMD graphic driver.
    actually till now there's no Win7 driver from ASUS for that motherboard...

    well, I'm going to downgrade the BIOS version, let's see what happens then
    I tried downgrading the BIOS version, same issue...
    Friday, October 23, 2009 8:46 AM
  • asus m3a79-t  + phenom II 940.  Same problem.  it only happens when C&Q is on and cpu is idle
    Friday, October 23, 2009 9:40 AM
  • I have the same system as you (asus m3a79-t deluxe + phenom II 940) with Vista x64 and also the same problem, but for me the origin of the problem is the C1E feature, not C&Q. I can enable or disable C&Q and have the processor idle or not, but my system clock will not slow at all, until I enable C1E. In that case, the system clock start to slow down a lot.

    I've seen that the 0905 BIOS revision of our motherboard is supposed to solve this problem (x64 enviroment + C1E enabled) but this problem seems to appear again with specific configuration. I'm running the 1203 BIOS revision, I'm going to try the new one (1303) and see what happens...

    PD: Excuse my English :P
    Sunday, November 08, 2009 11:32 AM
  • I have the same system as you (asus m3a79-t deluxe + phenom II 940) with Vista x64 and also the same problem, but for me the origin of the problem is the C1E feature, not C&Q. I can enable or disable C&Q and have the processor idle or not, but my system clock will not slow at all, until I enable C1E. In that case, the system clock start to slow down a lot.

    I've seen that the 0905 BIOS revision of our motherboard is supposed to solve this problem (x64 enviroment + C1E enabled) but this problem seems to appear again with specific configuration. I'm running the 1203 BIOS revision, I'm going to try the new one (1303) and see what happens...

    PD: Excuse my English :P
    might be caused by C1E?
    I'll have a try and put the answer
    • Proposed as answer by ESotSM Tuesday, November 10, 2009 7:04 AM
    Monday, November 09, 2009 1:50 AM
  • I flashed the newest BIOS for my motherboard (Asus M3N72D, BIOS version 1301) which was just released  a few days ago.  This seems to have fixed the problem for me.  However, I notice that in the BIOS settings, C1E is disabled by default.  I have not tried reenabling C1E to see what happens yet so my CPU will run at full speed irrespective of load.
    Yogimax
    Monday, November 09, 2009 8:21 AM
  • I flashed the newest BIOS for my motherboard (Asus M3N72D, BIOS version 1301) which was just released  a few days ago.  This seems to have fixed the problem for me.  However, I notice that in the BIOS settings, C1E is disabled by default.  I have not tried reenabling C1E to see what happens yet so my CPU will run at full speed irrespective of load.
    Yogimax
    Monday, November 09, 2009 8:21 AM
  • ESotSM, yes, it seems to be caused by C1E option, but only in a x64 enviroment. With my previous x86 OS it doesn't happen.

    Well, I've tried the lastest BIOS rev. 1303 for the ASUS M3A79T-Deluxe, but with no result... If I enable the C1E feature, my processor is about 6-8 Celsius degrees lower in idle, but the clock start to slow again.... I have an offset of 15 minutes in less than 12 hours......

    I hope ASUS release a new BIOS that solves this annoying problem...
    Monday, November 09, 2009 12:20 PM
  • Likewise - with C1E disabled I didn't have any system clock slowdown.  As soon as I enabled it along with the AMD Cool'n'Quiet option, the clock lost about 3 minutes in half an hour!
    Yogimax
    • Proposed as answer by jamesb21 Tuesday, January 26, 2010 6:53 PM
    Tuesday, November 10, 2009 12:50 AM
  • Just to add my experience, I have an older Asus M2N3232-SLI Deluxe (an AM2 board) with latest beta BIOS 2207 running Vista Business 32 Bit. I just installed a Phenom 2 X2 545 (AM3, which otherwise works fine by the way, although the BIOS does not recognize it exactly) and got the problem, clock basically running at half speed. Disabling just C1E worked for me too. Cool n Quiet is activated, apparently no problem.

    Bit it must be something in Windows too "supporting" the problem. Even with C1E active in BIOS, the problem is not there when I start Windows in secure mode. As part of my testing I ran a virus test from a CD using a live linux and over hours of testing and using other apps the clock stayed good to the second as well.
    • Proposed as answer by jamesb21 Tuesday, January 26, 2010 6:53 PM
    Friday, January 22, 2010 5:43 PM
  • I thought I would ask a quick question here to see if anyone else had encountered it. My hand-built system has a "slow clock" when running in a specific hardware configuration with Win7 x64 RC, but strangely only with x64.  Here's how it breaks down:

    Clock Works/Keeps Time When...
    1. CPU throttling (Cool n' Quiet in AMD-land) is disabled
    2. Away mode (AMD Live! in AMD-land) is disabled

    Clock Loses Time When...
    1. CPU throttling is enabled
    2. Away mode is enabled

    The bummer is disabling the CPU throttling produces a lot more heat and uses much more power. Also strange is the fact that these same settings don't impact the time keeping abilities of Win7 if running x86 versions.  This is very odd and I've not found any other reports of this behavior. Does anyone have any ideas?

    I am ready to supply any information needed to help troubleshoot the problem.  Here is a sampling of the system configuration:
    AMD Phenom II 940 X4, 4GB DDR2 RAM, 500GB Seagate 7200.9 SATA HDD, NVIDIA nForce 780a chipset, Microsoft Natural Keyboard 4000, Logitech G5 mouse, NVIDIA GeForce 8800GTX GPU, NVIDIA GigE networking, Windows 7 x64 Ultimate clean installation.

    Turn on the cool and quiet and the Away mode, you are wasting you money. If the clock is slow, you can update it with internet time. By default it should be updated weekly.

    I assume you have an adequate power supply for all of the gear.

    Check your clock with the internet time and see how much it drifts.


    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe

    Server: ASRock P4-2GHz, 1.5 GB RAM, Linux Server, need IDE/SATA disks for my chess site

    Workstation: Asus M2NBP-VM CSM, Athlon64 X2 4200+ 65W CPU, 2GB RAM, x600, 320GB + 160G backup, Windows 7 Ultimate x64.
    Friday, January 22, 2010 9:46 PM
  • ESotSM, yes, it seems to be caused by C1E option, but only in a x64 enviroment. With my previous x86 OS it doesn't happen.

    Well, I've tried the lastest BIOS rev. 1303 for the ASUS M3A79T-Deluxe, but with no result... If I enable the C1E feature, my processor is about 6-8 Celsius degrees lower in idle, but the clock start to slow again.... I have an offset of 15 minutes in less than 12 hours......

    I hope ASUS release a new BIOS that solves this annoying problem...

    It's caused by C1E, even upgraded to the newest 1903 bios...

    So anybody meet this issue please disabled C1E in bios. C&Q is not affected, let it be "on".
    • Proposed as answer by ESotSM Monday, January 25, 2010 6:14 AM
    Monday, January 25, 2010 2:55 AM
  • C1E is not working for a lot of machines, so I suggest disabling it. My machine becomes very lethargic if I enable it.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM AMD X2 4200+, 2GB DDR2-800, x600, more details on my site
    Monday, January 25, 2010 4:55 AM
  • i've had this issue with vista 64 and now on 7 64. on vista i turned off sync and added another clock(form hawaii) this fixed the issue, with 7 no luck. i'll try the cle
    Sunday, June 06, 2010 10:42 AM
  • it works!! it has also stopped my games from crashing all the time. i used to get about 5 mins out of anno 1404 now i have just completed a level, fallout about ten mins now not a problem in 90 mins.  i was considering a new motherboard(current: m3n-hd/hdmi) or graphics card(current: gtx 295) but no need now. thanks soooo much, you just saved a few hundred pound.
    Sunday, June 06, 2010 2:14 PM
  • Another way to fix it seems to be to adjust the Windows power profile. I don't know what the point of it is but in the profile you can set a maximum and minimum CPU loading. If you set the minimum above about 50% (might need to experiment), the slow clock thing goes away. I could switch C1E back on again with this adjustment. Whether this gains anything on power saving I don't know. C1E is for power saving, but maybe setting the minimum above 50% cancels that out.

    I get the problem in Vista 32 since I fitted a AM3 Phenom to a AM2 Asus board, even with the new BIOS to support the Phenom.

     

     

    Sunday, June 20, 2010 9:53 AM
  • Recently I upgraded my motherboard and C1E works fine now. So its definitely a BIOS defect if the C1E causes issues.

     


    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe Need a some parts finish the new server, see the site for remaining items needed
    Wednesday, June 23, 2010 9:28 PM
  • I'm not so certain. The problem does not occur under Linux with identical BIOS settings, so there must be some interaction with Windows  causing the problem. But I suppose not everybody has the problem anyway, otherwise the outcry would be massive. It must be some particular combinations.
    Saturday, June 26, 2010 12:20 PM
  • I'm not so certain. The problem does not occur under Linux with identical BIOS settings, so there must be some interaction with Windows  causing the problem. But I suppose not everybody has the problem anyway, otherwise the outcry would be massive. It must be some particular combinations.
    Yes, I can confirm this issue does not exist on CentOS5 and FC12.
    Monday, June 28, 2010 5:36 AM
  • The same problem present when using Asus M2N32-SLI Deluxe  (beta Bios rev 5002 ) with Amd Phenom II X4 945

    As there's no older bios that can support this cpu there are not a lot of options with this particular setup

    I'll try disabling C1E, thanks for all the info guys!

    Tuesday, August 03, 2010 7:38 AM
  • Same issue - older D31 Intel Mobo, Intel Q6600 CPU. Just put a Nvidia GTS450 in, replacing my old 9800. Vista 32-bit SP2. Now my system clock is very slow. I've had the machine for a year and a half - it wasn't an issue before I put the new video card in.
    Monday, March 28, 2011 11:22 AM