none
Lock icon appears beside file names

    Question

  • I just recently bought a new computer running Windows 7 and have a Iomega external hard drive attached.  Any files that I write to this external drives appear with a lock beside the file icon.  I have talked with Iomega and they can not explain why this happens.  Is there anyone on this forum who can explain to me why this happens and what does it mean.  I can edit/display the files without any problem.  Is this a feature of 7 that I don't understand or is there something wrong with the security setup on the Iomega drive??

    Thanks for any answers to my question.
    Saturday, December 05, 2009 1:55 AM

All replies

  • I just recently bought a new computer running Windows 7 and have a Iomega external hard drive attached.  Any files that I write to this external drives appear with a lock beside the file icon.  I have talked with Iomega and they can not explain why this happens.  Is there anyone on this forum who can explain to me why this happens and what does it mean.  I can edit/display the files without any problem.  Is this a feature of 7 that I don't understand or is there something wrong with the security setup on the Iomega drive??

    Thanks for any answers to my question.

    This is not  a feature o windows 7.
    If you have bitlocker enable in the disk you see a lock in the Drive....

    Tel me EVERY things tha you'v installed.

    Ricardo Polo "HodracirK"
    Saturday, December 05, 2009 3:06 AM
  • I agree with Richard. It seems the lock is enabled by some additional application. If you right click the lock, is there any pop-up menu?

    Does this lock symbol only show with files in this Iomega drive? All all files including those on the local hard disk.

    Also, if you connect the Iomega drive to another computer, does the problem exist?
    Microsoft Online Community Support
    Friday, December 25, 2009 12:17 PM
    Moderator
  • Lock Icon on Files in Windows 7

    When you talk about the Lock Icon on files, you are probably referring to something like this:

    Lock Icon Example

    This is something that I had trouble finding information on as well, but finally found a reasonable answer. I currently use Windows 7 Professional and the Lock Icon appears on some files when I move them around from Desktop to folders on my C Drive (such as C:\Media). Essentially what I found is that the files are not shared outside of the Administrator access (you) so if anyone else logs into the computer and tries to access those files (with the lock icon) they will be prompted by UAC for credentials to continue. This is a general security measure and I'm not entirely sure if it is due to BitLocker or if it is built into Windows 7 (though I am leaning toward the latter).

    What does this mean for you? Well if you are an administrator on your computer (as the main account often is) then nothing is different for you. You can access those files and move them around however you want. For anyone else who attempts to use your computer without being under your login credentials, they will be prompted to input your credentials before they have access to those files.

    How to Remove The Lock Icon


    Let's say that this lock icon is just annoying, or you really have no reason to lock down files and restrict access. In this case, you can Right-Click the files in question and choose Share With .

    Share With Menu

    Choosing Nobody from this menu means that only the administrator (you) may read or write these files, essentially locking them for anyone else. There is also the ability to share with Homegroup in either Read Only (view but not edit) or Homegroup (Read/Write) access. The latter is essentially giving full permissions to anyone that uses your computer to read or write that file without credentials. Keep in mind that the additional items on my Right-click menu may not show up for you (AVG, TeraCopy, etc) because these are 3rd party installed programs I use. If you are seeing Lock Icons on items though, then you should see the Share With on your Right-Click Menu

    As you can see, choosing Nobody will put a lock on that file and choosing either Homegroup option will remove the lock. If you wish to do this for more than just a single file, you can select many files and set Sharing on them, or you can also choose entire folders (in my case C:\Media) whereby anything you put in there will not be locked down. If a file you put in a shared folder is still showing a lock icon, simply right click it and choose the Share With menu to correct that.

    Keep in mind, if you choose to make files shared with homegroup, they will be accessible to anyone who logs into the computer and anyone who logs into via computer to computer network sharing. In this manner, permissions on files and folders can be set, and now you know what the Lock Icon is all about in Windows 7 :)

    Hope this helps out!
    • Proposed as answer by ls01c Friday, February 05, 2010 2:34 AM
    Saturday, January 02, 2010 12:35 AM
  • Is this option on specific to W7 Ultimate PC's or is it applicable on Enterprise as well?
    Thursday, March 11, 2010 8:59 AM
  • Well done, you have proven that it is possible to go into these forums and get a real answer that actually works.  Special kudos for not asking memory, processor speed, drive firmware ver. etc. etc. 
    Sunday, April 11, 2010 7:26 PM
  • Well done, you have proven that it is possible to go into these forums and get a real answer that actually works.  Special kudos for not asking memory, processor speed, drive firmware ver. etc. etc. 

    Kudo's Darian Knight!  I agree with Joe Crowe wholeheartedly.  Great work!!!!
    Friday, May 07, 2010 7:31 AM
  • Hello there, I was having the same problem. I am a 17 year old Obsessive Compulsive and Attention Deficit male and lock symbols on my copied files really bug me. Software: Windows 7 Ultimate x86 (32 bit) Teracopy What i noticed was that if I simply cut-paste or drag-drop files around within my hard drive it gives me the lock symbol but copy and pasting does not. :? What I do: I simply cut and paste to my desired location. Then I select the file with lock icon. Copy. Paste. Delete lock icon (Source File). From my understandings it is something to do with permissions and may be specific to my copying program. Please message me if you have an easier solution Many Thanks RainbowKisser
    Monday, May 09, 2011 6:38 AM
  • Great answer, very complete. I think it is a Windows 7 feature as I haven't downloaded bitlocker.
    Sunday, May 22, 2011 12:13 AM
  • THANKS VERY MUCH. I HAD SIMILAR PROBLEM, and your solution worked perfectly to even to share files in the Network.  
    Sunday, July 03, 2011 4:47 AM
  • Have the same problem with a new PC running Win 7 Home.  I can't even read the locked file (Documents and Settings)  Gave this a try, but no go.  Just get an error message that this file is not available to share.  Also tried changing permissions in Properties/Security.  No go.  Tried Copy and Paste to a new folder.  Nada.  Wonder if using PCMover to move from XP on old PC to the new PC could have anthing to do with the problem.
    Sunday, July 31, 2011 5:43 PM
  • You the man.
    Sunday, September 04, 2011 1:31 PM
  • Well, I figured out the real reason why that lock icon appears when copying and moving files to another destination. This happens because of an obvious flaw in the TeraCopy software, so anyone who has TeraCopy installed, will see this particular problem until it's brought to their attention and fixed. As of the latest update (Oct. 2011), this problem still exists. Best way to get rid of the issue, is to uninstall TeraCopy, restart Windows, and you're good to go.
    Friday, October 28, 2011 9:16 PM
  • This locked file situation in Win7 happens with many applications that run fine in Win98SE and WinXP.  My old "best webcam ever made" Vista Vicam (also was 3Com Homeconnect, now Digi Watchport) has a viewer that will save snapshots to a JPEG file.  Into the default Images folder under the Vicam installation folder, the shots have a locked property.  After a few hours search, I found this form and thread, and got the folder "Shared".  No change in the lock.  Then I found the property under Security that could get them Allow(ed) to everyone.  The lock disappeared from the large icons.  But strangely, the files could not be found, no matter what I did to see them.  I could still see the old pix I took when I took a new pix and did a Save As to the same default folder.  But I could do nothing with them.  Even copying them to another folder or drive did not happen (Windows could not find the file).  The only way I could get pix to use was to avoid the default Save As and send new pix to another location.  There they were unlocked and accessible.

    Gregg


    • Edited by starryskyne Thursday, December 22, 2011 10:19 PM
    Thursday, December 22, 2011 10:18 PM
  • Mr. Knight... I kinda sorta maybe figured all this out on my own over the past few months and, if pinned downed, could kinda sorta maybe explain it to someone else. But, brother, YOU DID AN EXCELLENT JOB in explaining. If I didn't spend all my money on crystal meth, I'd hire you to follow me around and explain things to me all day long. I am just honestly impressed at how simple, yet detailed; at how easy to follow, yet unabridged your answer was.  Well done, Thank you,sir.
    Thursday, June 14, 2012 10:08 AM