Cannot kill process


  • I have a process (NFS Shift) which has become unresponsive and just refuses to die. I cannot kill it through task manager, taskkill or pskill (from sysinternals). The process just sits there consuming memory but no CPU cycles.

    This has happened previously with Pidgin as well. The only option is to reboot the computer which seems a little extreme.

    OS is Win 7 x64

    Please help! :-(
    Wednesday, December 30, 2009 8:08 PM

All replies

  • How about if you try it from the command line

    taskkill /f /im process-name.exe

    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Wednesday, December 30, 2009 8:52 PM
  • If you have Sysinternals Process Explorer, you can select the process, right click, search online.  That should get you more info on what the process is doing, what app owns the process, and perhaps away to shut it down and/or stop it from running in the first place.

    You can't fix stupid.
    Wednesday, December 30, 2009 8:55 PM
  • @W2K8DT

    Tried that, no luck. It happened with both pidgin and the game I was playing.


    I tried that option with taskkill, but no luck.

    This is the second instance of this behaviour I've seen. Without the reboot, there's no way to kill the process. I tried running the commands in an admin/privileged window and even logged off. My user id was the owner of the process, but even logging off didn't help.
    Thursday, December 31, 2009 1:59 AM
  • The programs should work properly in general situations. I suspect that there are software compatibility issues. You may temporary disable the anti-virus and check the result.

    If the issue persists, please disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

    1. Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.
    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).
    3. Click the "Startup" tab, click "Disable All" and click "OK".

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

    Please test this issue in the Clean Boot environment, if the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

    This issue can also be cause by the video driver. You may download the latest driver from the computer or the device manufacturer and install it.

    Arthur Xie - MSFT
    Thursday, December 31, 2009 7:47 AM
  • @Arthur

    I tried all of what you said. Ultimately I went for the reformat-reinstall routine. The problem hasn't recurred yet. I should also add that this exact behaviour was reproducible with another program - Pidgin. In fact, it was so bad that the pidgin process would not quit no matter what I tried. Uninstallation wasn't possible either as the uninstaller would claim that Pidgin is running and refuse to proceed further.
    Tuesday, January 26, 2010 2:35 AM