none
how do I get a lock icon on my folder to come off?

    Question

  • Ok, here's the situation. I shared my entire F:\ drive so that I could get music and video and etc etc etc to my new laptop, but now when ever I put in new folders onto that hard drive the turn out like this: Image Hosted by ImageShack.us

    I have everyone set to full access as well as have everything checked in the check boxes except for "special permissions" which is greyed out. My question is how can I get this stupid lock icon off of it. I constantly add new folders of both tv shows / movies onto this drive and I'd prefer not to have to have these folders appear like this everytime.

    Does anyone have a solution??

    Thank you!
    ~Mike
    Friday, May 08, 2009 10:32 PM

Answers

  • It involves changing the ownership of the root directory.

    I wouldn't advise to attempt to change ownership.  I did so I could gain access to the SendTo folder and it messed up something to do with the WMI.  My Event Viewer can no longer start.   I am erasing my drive right now and will install Win 7 x64 all over again.

    • Marked as answer by shukero Thursday, May 28, 2009 2:03 PM
    Saturday, May 09, 2009 2:52 AM

All replies

  • It involves changing the ownership of the root directory.

    I wouldn't advise to attempt to change ownership.  I did so I could gain access to the SendTo folder and it messed up something to do with the WMI.  My Event Viewer can no longer start.   I am erasing my drive right now and will install Win 7 x64 all over again.

    • Marked as answer by shukero Thursday, May 28, 2009 2:03 PM
    Saturday, May 09, 2009 2:52 AM
  • Its because "authenticated users" isnt added to the security permissions.
    • Proposed as answer by Protuhj Sunday, August 15, 2010 2:46 PM
    Monday, July 27, 2009 6:28 AM
  • I had the same problem with this. Even though I messed with all the settings, I could still not make this lock go away. So, I just created a "New Folder" and drug everything in there and deleted the old Folder. Then I just renamed the "New Folder" like the one that was deleted. That took care of that problem.
    • Proposed as answer by hphenriques Sunday, August 05, 2012 5:10 PM
    Wednesday, October 21, 2009 4:18 AM
  • I successfully removed the lock Icon on a test folder by opening security tab and giving the group "Users" full permision.
    • Proposed as answer by ONE ZERO Sunday, January 02, 2011 11:53 AM
    Wednesday, October 21, 2009 4:14 PM
  • Not sure if this is the same thing, but I have found the lock icon on files located on my own computer when I was trying to access them from within an application. In other words, my application allows me to create a file, and when I go to a certain sub-window within that application and wish to open a screen, it shows me several choices including defaults it came with, and mine that i just created. Mine has a lock on it. No problem............except..................when I try to find the file from outside the application, which i could always do in XP and Vista, I can't. Uggh.

    Any ideas?
    Monday, October 26, 2009 5:17 PM
  • I had this problem with one of my directories (Users\[username]\Downloads) and it happened after I tried to play around with the HomeGroup options.  All the files in the directory had a lock on the icon, however I could access the files fine.  I looked at the security permissions and saw a "HomeUsers" group that I didn't recognize, so I deleted it, and the locks disappeared.  So I'm assuming this has to do with the permissions of your home group users group somehow.
    Monday, November 02, 2009 2:35 PM
  • I had this problem with a folder that was created during Windows Update, on a separate HDD from my OS drive. I'm assuming it's a Windows Update-created folder because it has one of those auto-generated names : cd3b13b8392abf7b30fb6c2fced9. Inside are two folders, amd64 and i386, which Windows won't even let me open. Whatever tab I click on, I get "You do not have permission to view or edit this object's permission settings".
    When I tried to delete it, I get "Folder Access denied. You need permission to perform this action. You require permission from S-1-5-21-1844237615-202542965-839522115-1004 to make changes to this folder." I had no idea what that meant, or how to find out. Finally I found a tab that would allow me to switch the permissions from the mysterious "S-1-5-21-1844237615-202542965-839522115-1004" to me. That did it. But it was complicated!
    Monday, November 02, 2009 6:13 PM
  • Everyone's close. It means that the Users group doesn't have access to the folder. Adding even Read authority to the Users group will remove the lock.
    • Proposed as answer by TanMan1217 Tuesday, December 15, 2009 6:41 PM
    Tuesday, December 15, 2009 6:41 PM
  • Its because "authenticated users" isnt added to the security permissions.

    Simple as that! Big UP for this answer!!!

    Monday, June 07, 2010 3:09 PM
  • There are multiple reasons for this - including the other causes & cures mentioned earlier, another one is that if there was a particular user account on computer #1 that had specific permissions on the "locked" folders, but that account does not exist on computer #2.

    So when you attach the drive to PC #2, it'll show the lock icon and an "unknown account" entry in the folder's permissions (folder properties -> security tab). Removing the "unknown account" from the permissions will also remove the lock icon.

     

    Wednesday, July 14, 2010 2:15 AM
  • Hello!  I have a related question.  I have somehow created double folders with "exactly" the same name within the same root.  This happened when attemping to merge folders from a .old folder from when I have Vista to Windows 7.  Also, be aware that under Vista my personal folders were in English and in Windows 7 my folders (sys) is in French, so when I "merged" the folders, no matter whether I put "My Documents" or "Mes documents", the folders merged and I created a single user folder for various common folders such as the example I gave.

    However, when I go into my user folder, I can't merge "Mes images" (My Photos) or "Mes vidéos" (My Videos) folders in the user folder with the lock, like I did the other folders.  So, what this does is when I click my Library folder or my user name from the Start menu and then select "Images", I only see the images in the user folder without a lock (did I say that when I look in the user folder I have two folders with the same user name, one with and the other without a lock.

     

    Issue:  How to I get these remaining folders to merge?

    Friday, August 06, 2010 2:56 PM
  • A correction, my two user folders do not have exactly the same name. (In case this has anything to do with finding the solution.)
    Friday, August 06, 2010 3:18 PM
  • A solution that I found that has worked so far:

     

    1) Right-click the folder or drive that has a lock icon and select "Properties".

    2) Click on the "Security" tab, then select "Edit..." to change permissions. Click "Add.."

    3) In the text field for "Object Name", enter in "Users" (without quotations). Hit "OK".

    4) "Apply", "OK", and voila, the padlock next to the icons should be gone.

    • Proposed as answer by PDrummond Friday, April 27, 2012 4:32 PM
    Monday, September 13, 2010 6:39 AM
  • Worked like a charm for me!!

    The lock is GONE!

    Thursday, September 16, 2010 4:50 PM
  • Go into sharing and give everyone full access, this should take the lock off
    Friday, October 15, 2010 2:54 PM
  • RIGHT CLICK ON THE FOLDER/ GO DOWN TO SHARE WITH / THEN CHOOSE HOMEGROUP READ /THE END :d

    Monday, October 18, 2010 9:51 PM
  • Hey! Can some one help me? I have the same problem but I can't even view the file. I can only see it through a programs open window. And then, with administrator privileges, i've tried all of your advice but it can't find the folder! Its invisible and locked! And I can't copy or move anything because pasting says it can't find them. Please help!
    • Proposed as answer by Mitchell82 Friday, December 31, 2010 1:57 AM
    Friday, November 12, 2010 8:42 PM
  • This worked perfectly! Give it a try...
    Friday, December 17, 2010 3:55 PM
  • I successfully removed the lock Icon on a test folder by opening security tab and giving the group "Users" full permision.
    Yes dude you are right i had the same problem and got solved out by giving the group Users "full permission" thanks dude
    Sunday, January 02, 2011 11:47 AM
  • Are you saying that if I remove the lock the folders with the same name (my user folder and the other two folders I mentioned - "Mes images" and "Mes vidéos" will merge like the other folders did, even when I had the two user folders (one with a lock and one without - which happened because I transferred over my .old user folder from when I had Vista and now upgraded to Win 7)?
    JEL
    Monday, January 24, 2011 5:16 PM
  • JEL, yes, removing the lock from the old folders will enable you to move the folders as you want. Just don't mess with the new Windows 7 folders, or you'll give yourself more problems.

    And in the future, open a new question instead of adding your question to a different thread. You'll get a better response that way.

    Monday, January 24, 2011 5:29 PM
  • Its because "authenticated users" isnt added to the security permissions.

    OMG THIS WORKED GREAT FOR ME !
    Saturday, February 05, 2011 1:14 AM
  • Give "Users" "Read & Execute" permission. Full Control can be dangerous.
    Wednesday, April 06, 2011 6:15 PM
  • Yes! This worked!
    • Proposed as answer by DamianRocks Thursday, June 09, 2011 2:46 PM
    • Unproposed as answer by DamianRocks Thursday, June 09, 2011 2:46 PM
    Tuesday, May 10, 2011 2:50 PM
  • The "lock" means to other users, so the answer is simple. Right-Click the "locked" file. Scroll to "Share With."  Click either Homegroup READ or Homegroup READ/WRITE.  File is now unlocked.
    • Proposed as answer by DamianRocks Thursday, June 09, 2011 2:49 PM
    Thursday, June 09, 2011 2:49 PM
  • Well I have successfully removed the lock icons from the files when I view them in Explorer, but they are still on the files when I view them in WordPerfect 10 on PC1.  When I try to view them from PC2, the aren't even viewable.  This all started after I reinstalled everything on PC1 after a hard drive crash.  I wonder if Carbonite added the locks.  The pre-crash files don't have locks on them.  Any new file created on PC1  has the lock, and any modified and saved file has the lock.  Help.
    Thursday, October 27, 2011 8:36 PM
  • Thx Thee MC. It works.
    Thursday, November 03, 2011 6:01 PM
  • I had the same issue, after trying a number of things, this was my solution:

    make sure your recycle bin is empty, drag all the the icons with locks into the the recycle bin, then just restore them.

    Sunday, November 13, 2011 10:19 PM
  • That worked great for me on XP

     

    Thanks heaps mate,i appreciate your help,you saved me time ,and frustration.your a good man

    Monday, December 12, 2011 2:18 AM
  • Its because "authenticated users" isnt added to the security permissions.

    its absolutely correct

     

    Saturday, January 07, 2012 5:53 PM
  • Thanks, it worked.
    Friday, June 08, 2012 6:51 PM
  • Thanks alot, worked for me

    Saturday, July 28, 2012 5:39 PM
  • This stumped me for a few minutes. What I did was to right click the folder with the "lock" icon. The context menu popped up. I went to "share with" and selected one of the two other options (Homegroup read or Homegroup read/write.) WHen I selected "read" the lock went away.

    You have to make sure you join a homegroup, though. Here is how: http://windows.microsoft.com/en-us/windows7/Join-a-homegroup

    Friday, August 10, 2012 3:52 PM
  • OK, I'm reading over all the "fixes" below, and am wondering...

    why now???

    I've never had this issue until today. I am constantly using my gmail account to send pictures from my pictures folder to my wife. Never had an issue before. Today, I went to attach a picture I had just saved to my folder, but gmail couldn't find the folder! When I opened windows explorer is when I saw the lock on the icon.

    I have installed nothing new on this computer for months. The only activity I can think of other than normal email send/receive and creating/saving Word/Excel docs is that I have auto-updates turned on for both Office and Windows 7.

    Could this have been caused by a recent update?

    Thanks.

    Monday, April 08, 2013 12:52 PM
  • I know this is an old thread but thank you bunches! "Its because "authenticated users" isnt added to the security permissions." worked for me!
    • Edited by sirtekalot Saturday, June 01, 2013 4:19 PM
    Saturday, June 01, 2013 4:18 PM
  • right click on the folder.

    click on share with

    select homegroup read/write.

    Done or if its still there

    click on folder

    go to properties

    unclick read attricbutes

    done.  if starts to read files that fine its just unlocking to the comp.

    Worked for me and now I can access during my email unlike before and other applications

    Monday, June 10, 2013 12:37 AM
  • geometrikal's fix worked for me!
    Wednesday, August 07, 2013 2:11 AM
  • A solution that I found that has worked so far:

     

    1) Right-click the folder or drive that has a lock icon and select "Properties".

    2) Click on the "Security" tab, then select "Edit..." to change permissions. Click "Add.."

    3) In the text field for "Object Name", enter in "Users" (without quotations). Hit "OK".

    4) "Apply", "OK", and voila, the padlock next to the icons should be gone.

    I came up with the same solution and it worked great.
    Saturday, January 25, 2014 11:46 PM