locked
Windows 8 slow doing RDP RRS feed

  • Question

  • I have a client who likes to be on the bleeding edge. He is deploying Windows 8 Enterprise throughout his company, replacing Windows 7. This is a Windows domain with the DCs running Server 2008 R2.

    He's complaining that now when he logs in to any server via RDP, that it is very slow (his words "it takes forever"). He says he is getting messages something like "loading group policy". As for the messages, I suspect they were getting displayed all along but that his logging in with a Windows 7 system was sufficiently fast that he just didn't notice them. However I have no idea why logging in via RDP would be so much slower with Windows 8.

    Any suggestions of what to look for or where to start?


    Jonathan

    Friday, September 28, 2012 9:11 PM

Answers

  • Hi,

    That seem the issue occurs when you change the GPO. As I’m not expert with GPO conflict,  I suggest to contact GPO forum for further help:

    http://social.technet.microsoft.com/Forums/en-US/winserverGP/threads

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. 

    Thank you for your understanding.

    Regards,

    Leo   Huang


    Leo Huang

    TechNet Community Support

    • Marked as answer by Leo Huang Monday, October 8, 2012 2:19 AM
    Wednesday, October 3, 2012 7:48 AM

All replies

  • Hi,

    According to your description, I suggest to perform these tests:

    1 Temporary disable firewall and antivirus program on Windows 8

    2 Disable auto-tuning:

    Open elevated command prompt with administrator’s privileges.

    Type the following command and press Enter:

    netsh interface tcp set global autotuning=disabled

    Hope that helps.

    Regards,

    Leo   Huang


    Leo Huang

    TechNet Community Support

    • Proposed as answer by ismiazam Tuesday, January 8, 2013 12:42 PM
    Monday, October 1, 2012 6:01 AM
  • Hi Jonathan, to speed up your RDP you want to try Ericom Blaze RDP compression and acceleration software. It will addresses the challenge of slow remote desktop connections, PDF performance on terminal services (RDS) and more. With Ericom Blaze, you can deliver a superior local PC-like experience and speed up remote desktop connections while reducing RDP bandwidth consumption - across WANs and congested LANs. check out www.ericomblaze.com

    Trolling for customers is not appreciated.


    Jonathan

    Monday, October 1, 2012 6:53 PM
  • Hi,

    According to your description, I suggest to perform these tests:

    1 Temporary disable firewall and antivirus program on Windows 8

    2 Disable auto-tuning:

    Open elevated command prompt with administrator’s privileges.

    Type the following command and press Enter:

    netsh interface tcp set global autotuning=disabled

    Hope that helps.

    Regards,

    Leo   Huang


    Leo Huang

    TechNet Community Support

    Unfortunately it didn't help. Logging in to the TS was just as slow as before. Darn. Any other ideas Leo?


    Jonathan


    • Edited by WinSvrAdmin Monday, October 1, 2012 8:11 PM
    Monday, October 1, 2012 8:11 PM
  • Hi,
     
    Please click “Options” in RDP client and switch to the “Experience” tab and adjust the Performances settings to see how it works.
     
    If the issue persists, please try to disable SNP on your Windows 8 by setting Registry as following:
    Note: Please backup the registry before change it.
     
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
    EnableTCPChimney=dword:00000000
    EnableTCPA=dword:00000000
    EnableRSS=dword:00000000
     
    If the keys are not there, please create them first.
     
    Hope this helps.

     


    Leo Huang

    TechNet Community Support

    Tuesday, October 2, 2012 3:41 AM
  • I just found out some more information from the client. I had recently installed Server 2012 in Hyper-V as a print server. Installed all active printers on it and shared them and deployed them via the Print Manager. I removed all print queues on the old server from being listed in AD and unshared them. I changed the existing GPO for printer mapping so clients were pointing to the queues on the new server instead of the old.

    The new info I just found out from the client is that RDP login was working fine prior to that. But after the change of the GPO from the old to the new print server is when RDP login slowed way down with apparently the application of the altered GPO taking most of the time.

    Now that I finally have this information, it appears that the altered GPO is what is responsible for the slow login. Since this is my first experience with Windows 8 clients, I don't know what could be the problem. The slow login is only from Windows 8 clients, not Windows 7 clients.


    Jonathan

    Tuesday, October 2, 2012 7:27 PM
  • Hi,

    That seem the issue occurs when you change the GPO. As I’m not expert with GPO conflict,  I suggest to contact GPO forum for further help:

    http://social.technet.microsoft.com/Forums/en-US/winserverGP/threads

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. 

    Thank you for your understanding.

    Regards,

    Leo   Huang


    Leo Huang

    TechNet Community Support

    • Marked as answer by Leo Huang Monday, October 8, 2012 2:19 AM
    Wednesday, October 3, 2012 7:48 AM
  • Type the following command and press Enter:

    netsh interface tcp set global autotuning=disabled


    This perfectly fixed my RDP problem from windows 8. thanks.
    Tuesday, January 8, 2013 12:45 PM
  • Hi, I have been facing similar issues in my environment where RDP to Win2k8R2 servers was working fine, however RDP to Windows Server 2012 servers was very slow and sluggish. After some research came across some group policy settings which resolved the issue for me.

    1. Go to Computer Configuration > Policies > Admin Template > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connections

    2. Select Network Detection on the server

    3. Enable and Select the Network Detection level to "Use both Connect Time detect and continous network detect"

    4. Slect RDP transport protocol and Enable

    5.  Select Transport type = Use only TCP

    Please do let me know if this resolves your issue

    • Proposed as answer by aydeejones Wednesday, May 7, 2014 7:24 AM
    Wednesday, July 17, 2013 7:38 AM
  • I'm actually here because I was looking for questions about slow RDP connections TO a Win 8 workstation.  I access Win 7 and Win 8 workstations simultaneously over RDP, after establishing a Citrix desktop connection to get in the door.  The Win 8 workstation is laggy when dragging the mouse cursor and I have performance taken down to the bare bones, "56k modem" setting.  

    The netsh command instantly improved mouse movements over text areas, like in SQL Server Management Studio.  As soon as I move the cursor over graphical elements, it becomes laggy again.  Meh.  All effects and transitions and such are disabled, time to experiment more, but it's interesting how that did help somewhat.

    Tuesday, October 15, 2013 9:05 AM
  • I had problems in my local network connecting from one Windows 8.1 machine to another. What happened was that every few minutes the screen was like freezing, could not click anything for a few seconds. I believe that my router does not understand the auto-tuning options. Thanks for the tip!
    Saturday, December 21, 2013 9:20 AM
  • I'm feeling like a goofball for my comment below, which came after this one that contains a solid solution for Windows 2012 and "by extension" Windows 8.  It's still not quite as fast as my Win 7 box through RDP (which is a much older, lower spec box) but I'll take it!

    Wednesday, May 7, 2014 7:23 AM