none
Full screen RDP shows local taskbar in foreground RRS feed

  • Question

  • After installing the Windows 10 Anniversary Update 1607 I am having a new issue with the Remote Desktop client (Win32 version).

    I have two monitors.  When I have the Remote Desktop client use both monitors for my full screen RDP session, on my primary monitor I can not access the task bar for the remote computer. My local computer's taskbar is in the foreground and the remote taskbar is displayed in the background (visible via transparency in the taskbar for the local machine).

    However on my secondary monitor, the taskbar of the remote computer is displayed in the foreground (as it has traditionally worked).


    Monday, August 8, 2016 1:11 PM

Answers

All replies

  • A reboot has fixed this issue for me.
    Monday, August 8, 2016 1:18 PM
  • Good to hear that it is fixed now, thanks for sharing your experience.

    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, August 10, 2016 1:31 AM
    Moderator
  • Actually, I spoke too soon.  Its still happening intermittenly. If I minimize and restore my RDP session a couple of times at some point I will be unable to access the taskbar on the remote host (but only in on the Primary monitor).

    The issue only started happening after installing the Anniversary Update.

    Wednesday, August 10, 2016 1:58 AM
  • It happens to me. There are a lot of support postings in the Feedback Hub about this post uograde issue.


    ~Paul

    Wednesday, August 10, 2016 2:55 AM
  • I also get the occasional blue screen of death and a dpc watchdog violation and forced restart when using RDP. on my host computer. I am not sure if this has anything to do with the RDP issues or my NVIDIA GPU drivers. I wonder if you have any GPU related errors in your event logs or if you have received a sudden bluescreen reboot of the host while in a RDP session.

    Also, regarding Minimizing and and restore the RDP session. As a workaround I moved my Host computers taskbar to the top with autohide ticked on. Doing the same, eventually the Host Taskbar stops hiding and when I go to settings the Auto Hide tick is still marked on and I have to turn it off and back on to get it to hide again. Upon reboot of the host the taskbar settings reverts to the default, always on and on the bottom.

    This almost leads me to believe the taskbar issues when running an RDP session might be related to either the Host's Taskbar or even now, maybe the RDP desktop session isn't loading properly because of the dpc watchdog violation issue with the GPU drivers. 

    Are you using an AMD or Nvidia type motherboard or an Intel. For note sake, my RDP client computer is an Intel and my Host is an AMD / NVIDIA board.


    ~Paul


    • Edited by P37307 Wednesday, August 10, 2016 3:48 AM clarify the dpc watchdog violation is on the host computer and not the RDP client
    Wednesday, August 10, 2016 3:46 AM
  • Over at the Social thread where we were trying to find the issue, here is what we figured out.

    For me and Jae, the issue was resolved by closing hangouts.

    Jae Soon Kim replied on In reply to Paul_W_Chambers's post on August 10, 2016 </button>

    While trying to figure out what on earth is going on since the new anniversary update, i've stumbled across a few pages which seems to have similar issues,

    This particular post in particular got me thinking

    http://answers.microsoft.com/en-us/windows/forum/windows_10-start/auto-hide-task-bar/362df0e4-e65a-43a8-ab83-fefaedffb656

    The answer on the first link by "Shawn 'Cmdr' Keene [MVP]" said 

    "Thanks Tony, that means a program has raised the MustBeSeen system flag.  Typically this is a program that needs your attention, like antivirus or backup program that has some message it's waiting to tell you.  It is almost always a program icon near the clock in the notification area.  Once you clear the MustBeSeen flag by addressing the program, the taskbar will hide again.

    As a best practice suggestion, hit Ctrl+Shift+Escape and disable anything on the Startup tab you don't need autorunning.  That limits how many things load there, and lessens how many programs can raise the MustBeSeen flag. "

    Reading his suggestion, i decided to close every application i had on my taskbar and lo and behold, my taskbar stopped overlaying on top of any full screen applications, RDP included.

    I then decided to close one item at a time until i found the culprit, and for me it was Hangouts that was causing this behaviour.

    There must have been something in the Windows 10 Anniversary Update that's changed the way how the taskbar overlays work and so seems to be causing it.

    It's a pretty bad work around for me (just need to turn off hangouts while i'm RDPing or using any full screen apps) but at least i can access the taskbar now.

    Just thought i would share this with you in case you have any luck with your taskbar too.

    FINAL EDIT: I wanted update. I went into Google Hangouts settings and disabled "always on top" and now I am able to have Hangouts open and use RDP at the same time without a Taskbar issue.


    ~Paul



    Wednesday, August 10, 2016 9:49 AM
  • I wanted update my previous comment. I went into Google Hangouts settings and disabled "always on top" and now I am able to have Hangouts open and use RDP at the same time without a Taskbar issue.

    ~Paul

    Wednesday, August 10, 2016 10:41 AM
  • P37307: That sounds very promising.  I'll try this the next time it happens to me.   Thanks for sharing!
    Wednesday, August 10, 2016 12:33 PM
  • Same problem here - Taskbar not always hiding when I rdp in fullscreen. No programs open - besides mstsc. No unread notifications etc. I hope this will get fixed soon...

    Thursday, August 25, 2016 6:19 AM
  • Also experiencing the issue but not using Google Hangouts. This issue is specific to RDP for me.

    At first I suspected it was the Action Centre, as it had a notification. Acknowledgement of it hasn't fixed it.

    Could Skype also be a culprit? I can't see any other apps running that could cause it.


    Ian


    Sunday, September 4, 2016 4:52 PM
  • Hello Ian, you can see by going into Skype, Menu, Tools then options and then notifications and turn off desktop notifications. Curious if that is the culprit.

    ~Paul

    Sunday, September 4, 2016 6:09 PM
  • MustBeSeen thing made me think. It turns out that Spotify on my local machine kept the taskbar on top of my RDP taskbar despite having the RDP on dual fullscreens.

    Thanks for the tip.

    • Proposed as answer by Costiaan Thursday, January 4, 2018 11:59 AM
    • Unproposed as answer by Costiaan Thursday, January 4, 2018 11:59 AM
    Thursday, February 2, 2017 10:39 AM
  • The small floating window of Skype for Business also keeps the task bar on top of the remote session. Hiding the window resolves the problem immediately.
    Wednesday, February 8, 2017 1:00 PM
  • Thanks man...Closing hangouts fixed the issue for me.

    I think Hangout has the option "Always On top" try disabling that

    Thursday, February 23, 2017 4:51 AM
  • Bringing this up to date - This is happening to me as of this morning on Windows 10 1703.

    I don't use have Hangouts and Skype isn't running.

    Wednesday, September 6, 2017 1:25 PM
  • Worked for me. Thank you!
    Tuesday, September 19, 2017 4:58 AM
  • I have the same issue and it is very frustrating.  I just got a new computer and this used to work on the previous one, which was Windows 7.  I now have Windows 10 (version 1703, OS Build 15063.608).  I have two monitors.  When in Remote Desktop "full screen" on Monitor 1, I used to be able to see the local taskbar on Monitor 1 when clicking anything on Monitor 2, thereby causing Remote Desktop to lose focus.  Yes, I already know that I can show the same taskbar on both monitors, but that isn't the real intent of my question.  

    When working with vendors, I frequently use Webex in the external computer (the one through Remote Desktop) and share that screen with the vendor.  We do not permit outsiders from accessing our internal systems directly.  They must use a Webex connection.  If I 'minimize' the Remote Desktop on my computer, it causes the vendor to lose mouse/keyboard in their Webex session.  But, if I just click my Monitor 2, causing Remote Desktop on Monitor 1 to 'lose focus', all is fine.  

    It isn't the use of Webex that is the problem.  The local taskbar doesn't reappear when the full screen Remote Desktop window loses focus even if Remote Desktop is the only open application on the computer.  Naturally, if the Remote Desktop is NOT full screen, the local taskbar is present.  But, I want to be able to toggle back and forth between a full screen Remote Desktop and my local computer without having to 'minimize' Remote Desktop.  Remember that minimizing Remote Desktop screws with Webex on the external computer.

    Thanks for your help!!  

    Tuesday, October 10, 2017 3:45 PM
  • I was able to solve this by restarting explorer.exe (on the host/local machine).

    You can do this by opening task manager, killing explorer.exe, and then using file -> run new task -> "explorer.exe"

    • Proposed as answer by Sander798820 Tuesday, November 21, 2017 3:55 PM
    Friday, November 3, 2017 10:32 PM
  • Thanks. Killing explorer.exe and starting it again worked for me!
    • Edited by VSP123 Thursday, November 16, 2017 4:39 PM
    • Proposed as answer by Oom Koning Van Tutti Monday, February 12, 2018 8:56 PM
    Thursday, November 16, 2017 4:38 PM
  • Same here also happening on the 1709 update. 

    Killing Explorer.exe fixed it. (I did have to start a new windows explorer window as I did not have one open, and thus the process was not listed)

    a quick Win-E and voila

    Tuesday, November 21, 2017 3:56 PM
  • no this doesn't answer the question have the same problem on windows 10 1709.

    Wednesday, December 13, 2017 6:55 PM
  • Just realized that my problem was all about the pop-up screen of Skype. I guess it behaves like that if some process is actively running and interrupting the local computer constantly (like Skype, Hangouts, etc.). Because of the same reason, when you try to reboot your computer, the problem with the rdp looks like fixed until the interruption starts on the local computer again. It is obviously a bug. For me, best way to deal with it was closing all apps that I suspicious about it may cause an interruption, and start them up one by one, until I detect the problem. When you detect the problem, just try to find another way to use that application without causing any constant interruption.

    Hope this helps.

    Cheers,

    Wednesday, December 27, 2017 11:23 AM
  • The quick-fix for this is to open up Task Manager (ctrl+alt+del) and kill explorer.exe

    Then click on File > Run New Task in task manager and type in "explorer" and hit OK

    This seems to reset the "always on top" strata of the task bar and fixes it without needing to log out or reboot

    Wednesday, January 10, 2018 9:22 PM
  • For me I found having sticky notes open in the background kept the taskbar visible. Closing it fixed it so it sees these are more than one thing that can keep it up.

    geckonet

    • Proposed as answer by GlenTech83 Wednesday, August 8, 2018 2:06 PM
    Thursday, March 1, 2018 10:32 AM
  • That worked for me, thanks!
    Tuesday, April 3, 2018 7:19 PM
  • This fixed it for me;

    Bring up the task manager on the local computer, right-click "Windows Explorer" and select "Restart".

    I re-opened the RDP session and now the Fullscreen worked fine again.

    http://how-i-fixed-it.blogspot.com.mt/2017/01/windows-remote-desktop-local-taskbar.html 

    • Edited by grayman619 Friday, April 13, 2018 6:56 PM
    Friday, April 13, 2018 6:49 PM
  • OMG.. so simple! I always assumed x'ing out of that window would end the call! But it doesn't, and it allows my RDP to go full-screen. Genius! Thank you!
    Tuesday, April 17, 2018 2:18 PM
  • If it helps anyone, I get this using the microsoft teams app, close it to systray RDP fits properly.
    Thursday, May 24, 2018 4:26 PM
  • This solution worked for me too.. Thanks !!
    Wednesday, June 6, 2018 4:32 AM
  • Works for me. Thanks!
    Tuesday, July 10, 2018 5:01 PM
  • Thanks you Its resolved my issue :)



    • Edited by Dadasaheb Wednesday, July 18, 2018 11:11 AM
    Wednesday, July 18, 2018 11:10 AM
  • This is the only solution that has ever worked for me. However, it soon recurs. 
    Tuesday, July 24, 2018 8:01 AM
  • I was able to solve this by restarting explorer.exe (on the host/local machine).

    You can do this by opening task manager, killing explorer.exe, and then using file -> run new task -> "explorer.exe"

    As of August 7th, 2018 (2 years after the original issue was posted) I was able to fix the problem with this method. 
    Tuesday, August 7, 2018 8:19 AM
  • I think this was the case for me. Windows Security had a yellow flag wanting to run a periodic scan.
    Saturday, August 18, 2018 12:49 AM
  • THIS!!! THANK YOU!!!  
    Wednesday, August 22, 2018 5:28 PM
  • This worked for me as well. Thanks!
    Wednesday, August 22, 2018 6:06 PM
  • I know it's an old thread, but just experienced the same thing. 
    My PC is ON or in hibernation and programs are never closed, until a reboot is required.

    In my case good ol' Internet Explorer 11 caused the problem. Closing it gave me the RDP in full screen without local taskbar on top.

    Thursday, September 13, 2018 7:22 AM
  • I've also recently had a similar issue. I managed to trace it to my laptops function key App. This shows notifications when the function keys are pressed(mute, disable wifi....etc)

    It has a floating shortcut on the desktop that was keeping the Desktops taskbar "focused".

    Exiting the app resolved the taskbar staying on top of the full screen VM Taskbar.

    Hope this helps others.

    Tuesday, October 2, 2018 9:54 AM
  • It's not a new issue and if I remember correctly I've had this in previous versions of Windows too. Restarting the machine or just explorer.exe helps most of the time. For a while it helped to close a random program by right clicking it on the local task bar. Could be as simple as closing Notepad. But that doesn't work anymore..

    I don't want to find out a new way to fix this every time. A full screen Remote Desktop session should be on top when requested. It's as simple as that.

    Wednesday, October 24, 2018 9:46 AM
  • Thanks that helped. It was Windows Command Prompt (in Administer mode). Closing that down, did the trick! 

    Much thanks this prevented reboot and not going to the cause! 

    Saturday, October 27, 2018 11:35 PM
  • You asked question west and everyone answer you east.
    it is very simple,

    Right click on task bar and uncheck "lock the taskbar" it will solve your problem

    Sunday, November 4, 2018 8:44 AM
  • Thanks, this worked for me as well :)
    Tuesday, November 27, 2018 9:32 AM
  • Same problem. Not a single one of the suggestions thus far fixes it. Buggy Windows 10. Simple as that.
    Saturday, January 19, 2019 11:26 PM
  • I get this a lot and the only thing that ever fixes it is restarting Explorer. All well and good, but why should I have to??

    After reading through this thread and others, I thought maybe it was something to do with a MBS flag from Defender, which constantly has an orange exclamation mark overlaid on its systray icon saying 'Actions recommended', but checking it out reveals green ticks all round and 6 x 'No actions needed'.

    Monday, February 25, 2019 11:54 AM
  • Hi,

    I used to have the same problem, but i found a solution to this, thought of sharing this with others.

    Open Remote desktop window, you can see local taskbar, just rightclick on it and click on taskbar settings and your local taskbar will dissapear and you can see your remote desktop taskbar again.

    Regards....Laxman.


    Friday, March 15, 2019 6:14 AM
  • Hi,

    I used to have the same problem, but i found a solution to this, thought of sharing this with others.

    Open Remote desktop window, you can see local taskbar, just rightclick on it and click on taskbar settings and your local taskbar will dissapear and you can see your remote desktop taskbar again.

    Please try this and comment.

    Regards....Laxman.

    Friday, March 15, 2019 6:18 AM
  • When I experienced this problem, it had to do with the RDP session not being in true full screen mode.

    Put the RDP session into Windowed Mode by clicking on the corresponding icon. When it's in windowed mode, right click the window in the blank portion and click on Full Screen. This should force it to draw over the local task bar.

    Wednesday, September 18, 2019 10:02 PM
  • Thank you for this.  Worked like a charm!!
    Friday, October 18, 2019 5:50 PM
  • Did a little troubleshooting, started closing some apps and somehow it got fixed after closing WhatsApp desktop App. It could be just anything though...
    Friday, October 25, 2019 11:35 AM