none
Windows 10 Remote Desktop - slow / delay / lag when laptop screen is off

    Question

  • Hi,

    I have a windows 10 pro laptop with remote desktop setup (allow remote connections to this computer). I remote into the laptop from a PC.

    I just noticed that when the laptop display is turned off (set to turn off after 10mins), there is delay in keystrokes and mouse movements when the laptop is accessed remotely.

    When I wake up the laptop screen by pressing a key on the keyboard or moving the mouse, the delay is gone when accessing the laptop remotely until the laptop screen goes off again in 10mins.

    I have the latest windows 10 version (1607, Build 14393.693).

    How do we fix this issue? The current workaround is to set the 'turn off the display' to 'never'.

    Thanks

    Wednesday, February 15, 2017 6:26 AM

All replies

  • Hi,

    Based on my lab machine test, the result is the same regardless whether the display is turned off.

    My lab environment is two Windows 10 computers. They are all build 14393. 

    How much time did the delay spend? 

    If it's too less time, just ignore it.

    In addition, check the event viewer to see if any clue.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, February 16, 2017 8:01 AM
    Moderator
  • "Based on my lab machine test, the result is the same regardless whether the display is turned off."

    You will need an actual laptop for this testing.

    You will need the following for the testing parameters:

    -remote into the laptop, make sure you have the RDP Experience 'show window contents while dragging' enabled. This makes it easier to see the lag/delay.

    -close the lid on the laptop (laptop display is off), set the display to go to sleep after 1 min.

    -in the remote session, open notepad on the laptop, drag the window around, you can see that it doesn't lag. After 1 min, the display goes to sleep even though it is already off, drag notepad around and you can see it constantly stuttering/lagging. The lagging is gone once I wake up the laptop screen by pressing a key on the keyboard or touching the touch pad but it will come back once it goes to sleep again.

    How do we fix this? This is only happening with windows 10.

    Thanks
    • Edited by kungpow112 Thursday, February 16, 2017 5:14 PM
    Thursday, February 16, 2017 5:10 PM
  • Looks like others are having the same issue:

    Remote desktop develops mouse/keyboard lag after some duration

    • Edited by kungpow112 Friday, February 17, 2017 5:24 PM
    Friday, February 17, 2017 5:22 PM
  • Hi,

    Sorry, I cannot reproduce your issue on my environment. The RDP host is an actual laptop, client is my lab machine.

    Here I suggest you change the screen resolution to see if any different.

    Meanwhile, try to update all your Windows 10 to the latest build, 14393.729.

    Windows 10 and Windows Server 2016 update history

    https://support.microsoft.com/en-us/help/4000825/windows-10-and-windows-server-2016-update-history


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, February 22, 2017 8:46 AM
    Moderator
  • I can confirm this issue, I am experiencing the same issue.  Lenovo T460P laptop with build 14393.693
    Wednesday, February 22, 2017 2:39 PM
  • Sorry, I cannot reproduce your issue on my environment. The RDP host is an actual laptop, client is my lab machine.

    I just tested this with two more laptops and same results.

    The test is very easy to reproduce.

    It is best to test from a clean install so you know there can't be anything else that could be causing this problem:

    1. Format the laptop and install windows 10 pro via MediaCreationTool.exe with USB stick

    2. After OS install, install latest windows updates

    3. Enable RDP on the windows 10 pro laptop

    4. Configure the laptop to have the screen turn off after 1min.

    5. Use another computer and remote into the laptop, wait 1min for the screen to go off and you will notice the delay/pause every 2 seconds when you drag windows around. In addition to the delay/pause, you will also notice the 'System' process spikes the cpu up every 12 seconds to around 10% if you have a touch screen laptop with the lid closed and it goes away immediately when you open the lid.

    Lenovo B50-80 non-touchscreen:

    -1607, Build 14393.693

    -delay/pause every 2 seconds with RDP enabled

    -'System' process doesn't spike up the CPU with the lid closed


    HP Envy touch screen:

    -1607, Build 14393.576

    -delay/pause every 2 seconds with RDP enabled

    -'System' process spikes up the CPU with the lid closed (only difference is touch screen). CPU jumps from 0-10% every few seconds.

    -'System' process slowly spikes up with CPU with the lid open. CPU goes from 0-10% slowly and goes back to zero and repeats.

    This is clearly a problem with windows 10.

    We need a solution asap.

    Thanks

    • Edited by kungpow112 Thursday, February 23, 2017 8:47 AM
    Thursday, February 23, 2017 8:23 AM
  • Hi,

    I do really cannot reproduce this issue on my lab machines. Have you encounter this issue on the same laptop when you install another version of Windows ever?

    It might be your laptop hardware configuration cause.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, February 24, 2017 9:20 AM
    Moderator
  • I can also confirm this issue.

    I remote desktop into a Surface Pro 4, Windows 10 Version 1607 (OS Build 14393.969), all updates installed.

    As soon as the screen of the Surface Pro 4 turns off the keyboard and mouse input in the remote desktop session on the Surface Pro 4 are lagging behind.

    If you make the screen of the Surface Pro 4 turn on again (press a key on the surface type cover for example), the remote desktop session running on it responds to user input fast again.

    Workaround is to keep the screen of the Surface Pro 4 turned on. Either by disabling screen sleep, or setting it to a value of 1 hour and touch a key on the Surface Type cover once an hour.

    Please fix this.

    Wednesday, April 5, 2017 9:00 AM
  • The following thread describes the same problem as this thread. And it can also be fixed by preventing screen sleep on the Surface Pro.

    https://social.technet.microsoft.com/Forums/windows/en-US/bb480b17-0b28-41c0-a5a5-5b2015eef353/context-menus-not-painting-during-w10-to-w10-remote-desktop-session?forum=win10itpronetworking

    Wednesday, April 5, 2017 9:04 AM
  • I found the cause of this problem. If you look at the Event Log you can see that Windows enters "Connected Standby" (Kernel - Power, Information, The system is entering connected standby, Reason: Idle timeout).

    Via remote desktop I can do whatever typing, working, compiling - the surface pro 4 never gets out of "Connected Standby" and the UI is lagging. As soon as I make the screen wake up by pressing any key on the type cover connected to the surface pro 4, so that the login screen appears, the system gets out of "Connected Standby".

    Now why the system doesn't get out of "Connected Standby" if I am actively working with it via remote desktop is beyond me, but you can easily avoid it by turning off "Connected Standby" (registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\CsEnabled to 0).

    I had hoped that the "Creators Update" would have fixed this, but nope, same problem. Same solution - disable "Connected Standby".

    You have to use "Hibernate" instead of "Sleep" then and waking up from "Hibernate" can take a few seconds but for me that is ok.

    • Proposed as answer by naor1029 Tuesday, October 17, 2017 6:06 AM
    Monday, May 15, 2017 1:28 PM
  • Same problem here, since 1607 version I experience slow response on keyboard and mouse by RD connection. I have a Surface Pro 1 tablet.

    It freezes and some seconds later it moves/write down keys pressed during freeze.

    Monday, June 5, 2017 6:47 PM
  • I have similar issues on my surface pro 3 connected with surface dock, and remote access by RDP outside from another windows 10, when screen off, the response from keyboard mouse response will significantly slow and lag.

    when the screen is on again, the issues will gone immediately. set screen sleep is another options to fix this.

    i have tried the set Connected Standby but seem unable to get this fix.

    my current windows 10 version. is 1703 build 15063.413

    this issues greatly influence my working behaviors, please fix this ASAP.

    Thanks,

    Wednesday, June 21, 2017 1:53 PM
  • I found the cause of this problem. If you look at the Event Log you can see that Windows enters "Connected Standby" (Kernel - Power, Information, The system is entering connected standby, Reason: Idle timeout).

    Via remote desktop I can do whatever typing, working, compiling - the surface pro 4 never gets out of "Connected Standby" and the UI is lagging. As soon as I make the screen wake up by pressing any key on the type cover connected to the surface pro 4, so that the login screen appears, the system gets out of "Connected Standby".

    Now why the system doesn't get out of "Connected Standby" if I am actively working with it via remote desktop is beyond me, but you can easily avoid it by turning off "Connected Standby" (registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\CsEnabled to 0).

    I had hoped that the "Creators Update" would have fixed this, but nope, same problem. Same solution - disable "Connected Standby".

    You have to use "Hibernate" instead of "Sleep" then and waking up from "Hibernate" can take a few seconds but for me that is ok.

    Jan dM, seems to be working. THANK YOU!

    • Edited by naor1029 Tuesday, October 17, 2017 6:08 AM
    Tuesday, October 17, 2017 6:08 AM
  • This is still a problem with 1709 running on Intel NUC 6i5SYH computer. Unfortunately, setting HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\CsEnabled to 0 does not help in my case (I do not think the computer even supports modern standby). Keeping the display on in power settings or moving mouse from time to time does - although I have the computer connected to a TV that is not even on.

    I did not not notice the lag/stutter by moving windows, but it is very noticeable when starting a command prompt and quickly typing "mnmnmnmnmnmnmnmn..." (or any other two letters). Surprisingly, when simply holding one key, the problem does not seem to appear.

    If you do not want to keep display on all the time, it might be possible to use Task Scheduler to turn display on and keep it on while connected and enabling normal power settings when remote session is disconnected. But it would be nice to see Microsoft fixing the issue.
    • Edited by Jan Klos Wednesday, February 7, 2018 9:37 AM
    Wednesday, February 7, 2018 9:36 AM
  • I had to do this, PLUS I had to RDP using "mstsc /admin". Then my remote laptop finally started to be fully responsive thoughout long sessions.
    Thursday, May 17, 2018 10:45 PM
  • I'm facing the same Issue - im currently at W10 1803 (Build 17134.228)

    Setting the registry key (CSEnable to 0) does not helped in my case.

    If my laptop screen turns off, i encounter lags when scrolling and do other UI related "fast" things. Its really annoying - and changeing the powersaving setting to keep the screen turned on isnt really a solution, especially for a Laptop with an unpluged powersupply.


    • Edited by Cadburry Wednesday, September 12, 2018 1:01 PM
    Wednesday, September 12, 2018 1:01 PM
  • This happens to me as well, target machine I'm connecting to is a Dell 7490 running 1803

    I tried two different source machines I'm connecting from, one is Windows 8.1, the other is Windows 10.  The behavior occurs on both.  It doesn't matter what options I select in the Remote Desktop "Experience" connectivity section.

    Friday, September 14, 2018 1:10 PM
  • Same problem here ... Lenovo T51 .... screen on - all OK ... screen goes off and i have intermittent lags.

    Suggested registry setting change seems to work, will update this to confirm.
    Monday, September 24, 2018 9:10 AM
  • Has anyone figure this out,  I am also having the delay and Setting the registry key (CSEnable to 0) does not help.  This is very annoying, I am surprise Microsoft has not provided a fix yet.  

    Saturday, November 17, 2018 10:57 PM
  • This is still a problem in 1809! Disabling connected standby does NOT help. :(
    Thursday, December 6, 2018 10:38 PM
  • Yeah, its been a problem for a while.  I tried this registry option and it doesn't work.  But here is what I observed.   Overall, there is a keyboard drag when over RDP.   I use the Dos Box for development, I'm old school and my power programmer editor is Qedit/TSE by SemWare, the best for Dos/Windows since the 80s. 

    Semware  had several versions.  The first 32 bit one was DOS based, console.  The updated 32 bit was still console but it used Windows GDI.  In other words, it created a new emulated console window.  It did not inherit the parent console like when you type "q file" to open the editor.   The Window-based emulated console GDI version, qw.exe, does not exhibit the keyboard delay while the pure console q.exe has a significant delay.   Windows 10 is still slower than the other OSes under RDP, like in this web-based editor creating this message, there is definitely a delay but not as bad when I am under the dos window using q.exe.   With QW.exe, it is not bad.

    So what that means it could be a time slicing issue, concurrency, multitasking issue with the conhost process that manages the pure console windows.  I have't tried it, but perhaps the priority on this process can be increased.

    I've given up trying to use Windows 10 as a development box.  Too much spying, monitoring, too much TCP/IP overhead on the system when its sending data to Microsoft, its no wonder the overall performance is bad and the experience for developers is miserable.    All I use this Laptop for is testing my applications and customers say its works fine as a server system.   But for developers, for power programmers needing fast keyboard typing capability, it is really bad. 


    Hector Santos, CTO Santronics Software, Inc. http://www.santronics.com


    • Edited by hector santos Tuesday, December 18, 2018 4:30 AM typos
    Tuesday, December 18, 2018 4:26 AM
  • I used SysInternal's process explorer to increase the priority of a q.exe console editor session above normal and it was definitely better, obviously.  While its not really a good idea to be increasing process thread priority, it goes to show it is most definitely an overhead, time slicing performance issue.

    Hector Santos, CTO Santronics Software, Inc. http://www.santronics.com

    Tuesday, December 18, 2018 4:49 AM
  • Worked straight after I've changed it to 0. Thanks!
    Friday, February 1, 2019 12:06 PM
  • I turned off HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\CsEnabled (to 0) but still facing the issue on Windows 10 1809.
    Saturday, March 23, 2019 8:59 AM
  • Well. It's 2019 and the problem still not fixed. I'm experiencing it on HP ProBook laptop. Had to set "Turn off monitor" to "Never", but it's not good for screen and power consumption.
    Friday, May 17, 2019 11:46 AM
  • This has been a problem since the Anniversary Update in summer 2016. ALMOST 3 YEARS! I have been searching ever since then but none of the solutions put forth work, other than keeping the monitor on.
    Wednesday, June 12, 2019 1:32 PM