none
CCMEval Doesn't Remediate Disabled Microsoft Policy Platform Local Authority (lpasvc) Service? RRS feed

  • Question

  • I was troubleshooting a client issue recently where applications wouldn't evaluate/enforce (though classic packages worked fine.) The main error I saw was in CIDownloader.log:

    Compiler lPhaseError: 3, ObjectNum: 1, hRes: 80041013 FirstLine: 2 LastLine: 39

    And then a few others mentioning "lantern" which is associated with the Microsoft Policy Platform. It turns out that the Microsoft Policy Platform Local Authority (lpasvc) service was disabled so none of the CI data was being processed. Re-enabling it quickly solved the issue.

    However, I thought that was something CCMEval was supposed to remediate...

    I took a look in CCMEval.xml, and it appears to me that while the health check is checking for the existence of both the Microsoft Policy Platform Processor (lppsvc) and Local Authority (lpasvc) services, it only remediates issues with lppsvc.

    Can anyone else reproduce/verify?

    If this is the case, it seems an odd oversight to me. I tried searching TechNet and Connect to see if there were any other reports but didn't find any (granted, I didn't dig for too long. Maybe someone else will have better luck.)

     I intend to file a bug report on Connect unless one already exists, or if I'm overlooking something here.

    Thursday, September 4, 2014 3:04 PM

Answers

All replies

  • Can anyone else reproduce/verify?


    I am seeing the same.

    Torsten Meringer | http://www.mssccmfaq.de

    • Proposed as answer by Jason SandysMVP Thursday, September 4, 2014 5:43 PM
    • Marked as answer by KevinMJohnston Thursday, September 4, 2014 6:03 PM
    Thursday, September 4, 2014 3:24 PM
    Moderator
  • Thanks Torsten. Here's the bug report I filed on Connect if anyone is interested:

    https://connect.microsoft.com/ConfigurationManagervnext/feedbackdetail/view/963919

    Thursday, September 4, 2014 6:03 PM
  • Long shot on this old of a thread, but did you ever find a resolution to this? I'm seeing similar behaviour in my environment.
    Wednesday, May 24, 2017 2:46 PM
  • The Connect report I opened was closed as Fixed, so CCMEval should be remediating this scenario, but it's possible that the fix wasn't implemented until Current Branch.

    https://ccmcache.wordpress.com/ | @kevmjohnston

    Wednesday, May 24, 2017 5:09 PM
  • I know this is an old thread, but this definitely helped me.

    Just FYI, currently on 1902 SCCM CB.

    I found a client where even reinstalling the client did not resolve the issue with app enforcement not occurring.

    Tried to manually start the Microsoft Policy Platform service and got an error of "file not found".  The folder for MPP was missing altogether on this particular client, so I copied it over from another machine and he presto, issue resolved.

    I believe the services are set to manual by default, maybe the issue is that the CM client cannot start the service for which the file doesn't exist or maybe in the OP's case, corrupt / missing the all the needed files within %programfiles%\Microsoft Policy Platform\.

    Wednesday, December 4, 2019 12:11 PM