Msg.exe Error 5 Getting Session Names



    Ok after 2 days of research and messing with policys i still have yet to resolve this issue. Due to vista not having netsend anymore I tried using the msg.exe command. So far I have got it to work just on my local computer. But sending it to other vista computers It gives me an error:


    Error 5 getting session names

    I am computer Atlantis

    Destination: computer designated as "Challenger"

    Both running Vista Business SP1


    msg /server:atlantis admin "Test Message"

    (local to local pc works)


    msg /server:challenger admin "Test Message"

    ---> Response: "Error 5 Getting Session Names"


    We are in the same work group, we are not part of a domain


    Any help would be appreciated. From reading it seems to be a policy edit that needs to be changed, but I do not know what to change, so any detailed instructions would be greatly appreciated...


    Alternative i tried: Also i downloaded netsend by and I can only send the message to XP computers. I cannot send a message to even myself. 

    Wednesday, June 25, 2008 6:53 PM

All replies

  • Hello,


    Msg.exe can only send message to a terminal server role, based on my test.


    Both Windows Server 2003 and Windows Server 2008 with terminal service correctly configured can receive the message sent by Msg.exe from Windows Vista-based PC.


    Hope it helps!





    • Proposed as answer by Joohee Friday, March 28, 2014 9:50 AM
    Tuesday, July 01, 2008 9:34 AM
  • So if this only works as a terminal service role then what is the alternative to netsend because the program from cezeo as the netsend replacement doesn't seem to work either.

    Wednesday, July 02, 2008 5:50 PM
  • Hello,


    Based on some discussions about this topic, some community members provide the following tool as the replacement of net send that is not included in Windows Vista:



    It’s said to support Windows Vista. Please give it a try. 


    Important Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.





    • Proposed as answer by Pavel Sokolov Tuesday, May 10, 2011 12:25 PM
    Thursday, July 03, 2008 11:12 AM
  • Actually based on my research and use of this tool, this seems to only work for machines doing Vista->XP machines


    Vista Business -> Vista Business doesn't seem to work with this at all thats why i tried using msg.exe to do vista to vista communications


    Also XP -> Vista communcations doesn't seem to work either. Looks like the messenger service is the key for recieving in Vista or some kind of permission setting

    Thursday, July 03, 2008 7:38 PM
  • is this fixed yet?
    i agree with Viper0402 and think it has somthing to do with the workgroup or domain
    my vista business machines are on the same lan and workgroup and can easily share files but i dont have a domain. A domain was not needed for net send though!
    Sunday, July 20, 2008 9:07 PM
  • Just an update on this issue that I forgot to post on this thread.

    The cezero netsend allows you to send netsend messages but it doesn't actually allow receiving because there is no winpopup installed on vista. As an alternative, msg.exe does work only in a domain environment.

    For those of you on a workgroup environment such as me, I have found a solution that actually works....

    Program called WinSent 1.1, install that czero netsend and just run this program, it is a freeware basic messaging window that is the closest thing I can find on the web to resemble netsend. It pops up and can be closed down.

    Issue I ran into working at a library environment, patrons tend to turn the program off, work around I found...

    I'm sorry I can't find the tiny program, but there is a program that can be found on google, its about 50k big, what it does is search for a particular instance of a program of your choice and if its closed it reopens it to your system tray, the little program runs as a hidden process and you can set it to whatever time you want it to check... ex: 1 second, 5 seconds etc....

    Other issue that I have yet to fix nor will I be able to fix, once the pop up message window actualyl opens, it can be dragged out of the viewable range and that is the end of that... Only work around I found is that when you log off using steadystate and log back into the profile it is reset....

    Hope this helps anyone out.

    Tuesday, February 03, 2009 8:38 PM
  • This is a lame method/work around for a product that worked in previous versions.

    Thursday, May 14, 2009 4:47 PM
  • Found a solution in this page: instead/ posted by an user called console.


    To make it short, in order to work (in my experience win7 to win xp) I had to add a key to the registry in the xp machine.


    the following registry key must be activated (as described by Consoles above):

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server

    Name : AllowRemoteRPC

    Type : REG_DWORD

    Value : 1



    After a restart no more "Error 5" with the 'msg /server * asdasd' command. Works like a charm!

    Wednesday, April 21, 2010 6:41 AM
  • I have tested this with Win 7 -> Win 7 machines in a Workgroup environment (no domain).

    Gaby appears to have identified that by default, in XP, Vista, and Win 7, this Terminal Services AllowRemoteRPC registry setting is disabled by being set to 0 (probably to prevent you from getting these spammed to you), and if you update this registry key to 1 on any of those above operating systems, the normal msg.exe command will work just like the net send command did in the golden days ;)

    Thanks, Gaby!

    Tuesday, May 18, 2010 5:08 AM
  • For some reason it doesn't work for me. I changed the value on both computers, then restarted them and it still gives me error 5. I can send a message to the computer I'm on just fine, but I can't send a message to the other one and vice-versa. Both computers are in the same workgroup.

    Any ideas?


    UPDATE: It's back to error 1825 for me. I'm even kind of relieved now, at least I know it's something else and can stop hitting my head against the wall (that hard).

    Could it be an issue with router? I don't know what else could be since it doesn't work on any computer. All computers are in the same workgroup, is there any other requirement?

    Monday, May 24, 2010 5:20 AM
  • I'd like to learn how this works too.
    Wednesday, July 14, 2010 4:20 PM
  • I've got the same problem. Applied the registry key to the target system running Vista Business and I still can't sent a message to that computer.
    Tuesday, November 16, 2010 3:02 AM
  • Worked like a charm for me too.

    Thanks a lot.

    Wednesday, January 05, 2011 8:06 PM
  • Changing the registry , in particular, the REG_DWORD value in terminal server (AllowRemoteRPC) to 1 from 0 is the solution.

    It's also important to follow the syntax exactly for this command. For instance, specify the server, user, and put message in string format (in quotes).

    So, if you wanted to send a message for peter smith to contact the help desk, for instance, user psmith(or whatever the naming scheme is for your domain) who is using petersmith-PC (the name of his machine) the syntax for msg.exe would be:

    C:\ msg /server:petersmith-pc psmith "Please contact the help desk"

    This worked like a champ for me.

    Thanks, gabyregistrado!

    Wednesday, January 26, 2011 8:50 PM
  • In my case, I wanna send a message from Win7 to Win7.

    And Change the registry value "AllowRemoteRPC" to 1 both computer. they are on the same network.


    I specified the server name as an IP address and it doesn't work.

      msg / * "hello"

    but when I change it to computer name, it finally works!!!

      msg /server:computername * "hello"


    I don't know the reason. I hope I must use the IP address.

    do you have any sollution?




    Monday, July 18, 2011 2:17 AM
  • I found what works for MSG.

    1) I changed AllowRemoteRPC to a "1" of the recieving computer in the following key location:

                HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server

    --note: Dont bother trying to change this on your computer unless you want a reply from the recieving PC.

    2) I then used the following syntax to  send the message:

               msg /server:[RECVING_PC] [USR_SESSION_ON_RECVG_PC]  [message with quotes]

    Example: c:\>msg /server:foopc foouser "Hey foo. How ya been?"


    for all user sessions on recieving pc; replace user with *.

    c:\>msg /server:foopc * "Hey everyone!"


    for all pc's on the same broadcast domain with all user sessions use the below example:

    c:\>msg /server:* * "Hey world!"

    Note: AllowRemoteRPC must be turned on for all PCs to recieve (eg: REG_DWORD = 1)



    Friday, September 02, 2011 2:15 PM
  • Never tried using IP, but my initial thought is that IP won't work if you have DHCP as the IP changes, unless you have the IP reserved, or are using static.
    Net Dude
    Friday, September 02, 2011 8:56 PM
  • Hi,

    I found that on Win XP system there is no "AllowRemoteRPC" so i created one as described by  gabyregistrado

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server

    Name : AllowRemoteRPC

    Type : REG_DWORD

    Value : 1

    And need the messenger service to be started on WIN XP system.

    I could able to send messages to Win XP & Win 7 systems but unable to receive messages on Win 7 from Win XP system


    Friday, October 07, 2011 6:34 AM
  • This worked like a charm for me. I have Windows 7 x64 in a domain environment. Thanks Gaby
    Tuesday, March 27, 2012 8:54 PM
  • to send a message to another pc, first you must be using professional version or ultimate version.
    assuming that you do,
    before you do this, back up your system. messing with the registry files is a risky business

    First, in the search box in the start menu, type in regedit. double click hkey_local machine, then system, then CurrentControlSet, then Control, then terminal server, and finally in the window on the right, double click AllowRemoteRPC. Change the value data to 1 and then click ok

     Second, in the start menu search box, type credential manager. In credential Manager click on add a Windows Credential. The top box wants the name of the remote computer. the second box wants the username that you will be messaging. the third box wants the password of the username of the remote computer.

    Third, restart your computer

    Fourth, you should be ready to send a message. Open a command prompt window. type msg /server nameofremotepchere usernamehere messagehere

    good luck

    ps the error 5 is because of the hkey problem, in case you want to know

    • Edited by dugoatboy Tuesday, August 07, 2012 12:11 AM
    Tuesday, August 07, 2012 12:10 AM
  • There is another workaround using PSTools.

    You can use PSExec to run the command on the target PC, so no remote RPC is required.:

    c:\pstools\psexec \\<computername> msg * /v Please reboot your computer to finisre cleanup - IT Services

    Saves having to do any mucking about in the registry.

    Friday, December 28, 2012 10:17 AM
  • Credentials need to be used with msg.exe.

    Search for credential manager in the computer that will receive the message. 

    Add a Windows Credential.

    Enter the name or IP, username, and password of the computer that will send the message.

    Restart the computer.

    Msg.exe will now work for the sending computer to send a message to the receiver, but credentials must be entered in the sender for the receiver if a response is to be sent.

    So, you can get back the convenience of the "net send" command, but the receiver must have your credentials entered in to their PC beforehand.  This will not be easy to set up in a large office, but the service will not be easily high jacked for unwanted messages.

    Credentials can help with print sharing and other new security measures.

    Wednesday, August 07, 2013 11:44 PM
  • On the remote computer you need to edit the Terminal Services Registry Key.


    > System
    > Current Control Set
    > Control
    > Terminal Server

    Change the value of the DWord called 'AllowRemoteRPC' to 1 (Default = 0)

    Restart remote computer and try again.


    • Proposed as answer by ZuriTidus Wednesday, January 14, 2015 8:19 PM
    Tuesday, March 18, 2014 4:27 PM
  • WTF is wrong with you M$?

    I've got 3 identical laptops. All have Win 8.1 Pro installed.

    All on a domain controlled by Win Server 2008 R2.

    Using msg will work for one machine, but not the other 2.

    Can only system admins receive broadcast messages for some reason?

    The AllowRemoteRPC is set to 0 on all 3 machines.

    Do you idiots not think that being able to send broadcast messages might be a useful thing for system admins? Pull your f***ing fingers out.

    Thursday, August 07, 2014 1:49 PM
  • As a bonus, setting AllowRemoteRPC also allows use of "Remote Desktop Services manager" to manage users on those workstations so you can log them off remotely if you need to.
    Thursday, February 12, 2015 8:44 PM