none
PPTP VPN on Windows 7 - error 720

    Question

  • I manage the network for a small non-profit.  The organization officers, and I, are authorized to connect remotely to the office computer using a PPTP VPN.  Until last month I had this all working:  the office computer was WinXP Pro, I had another XP computer and a Vista laptop, others had other computers including some Win7 release candidates.  And everybody could connect.  Trouble was, they were all connecting to the same userid, using a shared password; very bad juju.

    All these systems have now been upgraded to Windows 7, and I can't get the PPTP VPN to work.  I want to set it up so everybody who needs to use the VPN has a user account with a password on the office computer, and all those user accounts are authorized to use the incoming connection, which I set up according to the instructions shown in various forums I've found.  I want everybody to dial into the VPN using their own userids and passwords. 

    The VPN setup is pretty much the same as in XP!  I've done this before and got it working.  But, using my own account on the office computer as a sample, I keep getting "error 720" when I try to connec, "unable to connect."  Can anybody suggest what I may be doing wrong?

    Also, the default on the outbound VPN connection on my Win7 desktop is to connect using SSTP - I can't use that without reconfiguring my router which is only set up to accept PPTP and L2TP.  Where can I find out what ports SSTP uses?  I've chosen the PPTP option but it still doesn't connect.

    (Just to annoy me more, the office computer is on Win7 Release Candidate - don't ask - so I'll have to set it all up again when the upgrade disk comes, probably tomorrow...)
    Monday, December 21, 2009 1:36 AM

Answers

  • Error 720 - No PPP Control Protocols Configured - Case 1

    Symptom: When attempting to establish a VPN connection to Windows RRAS, you may receive the following error message: Error 720: No PPP control protocols configured.

    Cause: This behavior can occur if your computer and the RAS server do not have a protocol in common, or if RAS is not configured correctly.

    Resolution: Assuming the RRAS is using, you need to make the Windows client is running PPTP too. To do this follow these steps:

    a.       Click Start, click Control Panel, and then double-click Network Connections.

    b.       Under Virtual Private Network, right-click the VPN connection, and then click Properties.

    c.       In the VPN Connection Properties dialog box, click the Networking tab, and make sure that you have a protocol that the RAS server is running.

    If you do not have a protocol that the RAS server is running, add the needed protocol:

    a.       Click Install, click Protocol, and then click Add.

    b.       Click the protocol that you need to install, and then click OK.

    c.       Click Close in the VPN Connection Properties dialog box.



    VPN Error 720 - the connection attempt failed because your computer and the remote computer could not agree on PPP control protocol - Case 2

    Uninstall/Reinstall the TCP/IP Protocol

    Symptoms: 1. When attempting to establish a VPN, you may receive the following error message during the "Registering your computer on the network":

    Error 720 - the connection attempt failed because your computer and the remote computer could not agree on PPP control protocol.

    2. If you view the devices in Device Manager, you may notice a yellow exclamation mark (!) over the icon for the WAN Miniport IP (#2) device.

    Resolution: To resolve this issue, uninstall the TCP/IP protocol, remove the second WAN Miniport IP device, and then reinstall the TCP/IP protocol. To do so, follow these steps:

    1.

    Uninstall the TCP/IP protocol. To do so:

    a.

    In Control Panel, double-click Network and Dial-up Connections, right-click Local Area Connection, and then click Properties.

    b.

    Under Components checked are used by this connection, click Internet Protocol (TCP/IP), and then click Uninstall.

    c.

    Follow the on-screen instructions to uninstall TCP/IP.

    d.

    Restart the computer when prompted, but click No if you are prompted to allow Windows to enable a protocol.

     

    2.

    Right-click My Computer, and then click Properties.

    3.

    Click the Hardware tab, and then click Device Manager.

    4.

    On the View menu, click Show hidden devices.

    5.

    Under Network adapters, there should be no WAN Miniport IP devices. If a WAN Miniport IP device is listed, continue to the following step. If no WAN Miniport IP device is listed, go directly to step 16.

    6.

    Click Start, click Run, type regedit in the Open box, and then click OK.

    WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

    7.

    Locate the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}

    8.

    On the Registry menu, click Export Registry File, type backup-key in the File name box, and then click Save.

    Note You can restore the changes that you make to this registry key. To do so, double-click the backup-key.reg file that you saved.

    9.

    Click each of the registry subkeys under this key, and then view the Data column of the DriverDesc value to determine which of the subkeys corresponds to WAN Miniport (IP). For example, the 0005 subkey.

    10.

    Right-click the subkey whose DriverDesc value data is WAN Miniport (IP) (for example, right-click 0005), and then click Delete. Click Yes to confirm that you want to delete the key.

    11.

    Quit Registry Editor.

    12.

    Right-click My Computer, and then click Properties.

    13.

    Click the Hardware tab, and then click Device Manager.

    14.

    On the View menu, click Show hidden devices.

    15.

    Under Network adapters, right-click WAN Miniport (IP) and then click Uninstall. Click OK to confirm that you want to remove this device.

    16.

    Reinstall the TCP/IP protocol. To do so:

    a.

    In Control Panel, double-click Network and Dial-up Connections, right-click Local Area Connection, and then click Properties.

    b.

    Click Install.

    c.

    In the Select Network Component Type dialog box, click Protocol, and then click Add.

    d.

    Under Network Protocol, click Internet Protocol (TCP/IP), and then click OK.

    e.

    When the protocol is installed, click Close.

     

    17.

    Reset the modem by turning the power off and then on, or for an internal modem, restart the computer.

    18.

    Test your Internet connectivity.


    Also read this article to see if that will help also http://thenonapeptide.blogspot.com/2009/09/solving-pptp-vpn-error-720-on-windows-7.html

    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    • Marked as answer by Novak Wu Tuesday, December 22, 2009 6:21 AM
    Monday, December 21, 2009 3:42 AM

All replies

  • Error 720 - No PPP Control Protocols Configured - Case 1

    Symptom: When attempting to establish a VPN connection to Windows RRAS, you may receive the following error message: Error 720: No PPP control protocols configured.

    Cause: This behavior can occur if your computer and the RAS server do not have a protocol in common, or if RAS is not configured correctly.

    Resolution: Assuming the RRAS is using, you need to make the Windows client is running PPTP too. To do this follow these steps:

    a.       Click Start, click Control Panel, and then double-click Network Connections.

    b.       Under Virtual Private Network, right-click the VPN connection, and then click Properties.

    c.       In the VPN Connection Properties dialog box, click the Networking tab, and make sure that you have a protocol that the RAS server is running.

    If you do not have a protocol that the RAS server is running, add the needed protocol:

    a.       Click Install, click Protocol, and then click Add.

    b.       Click the protocol that you need to install, and then click OK.

    c.       Click Close in the VPN Connection Properties dialog box.



    VPN Error 720 - the connection attempt failed because your computer and the remote computer could not agree on PPP control protocol - Case 2

    Uninstall/Reinstall the TCP/IP Protocol

    Symptoms: 1. When attempting to establish a VPN, you may receive the following error message during the "Registering your computer on the network":

    Error 720 - the connection attempt failed because your computer and the remote computer could not agree on PPP control protocol.

    2. If you view the devices in Device Manager, you may notice a yellow exclamation mark (!) over the icon for the WAN Miniport IP (#2) device.

    Resolution: To resolve this issue, uninstall the TCP/IP protocol, remove the second WAN Miniport IP device, and then reinstall the TCP/IP protocol. To do so, follow these steps:

    1.

    Uninstall the TCP/IP protocol. To do so:

    a.

    In Control Panel, double-click Network and Dial-up Connections, right-click Local Area Connection, and then click Properties.

    b.

    Under Components checked are used by this connection, click Internet Protocol (TCP/IP), and then click Uninstall.

    c.

    Follow the on-screen instructions to uninstall TCP/IP.

    d.

    Restart the computer when prompted, but click No if you are prompted to allow Windows to enable a protocol.

     

    2.

    Right-click My Computer, and then click Properties.

    3.

    Click the Hardware tab, and then click Device Manager.

    4.

    On the View menu, click Show hidden devices.

    5.

    Under Network adapters, there should be no WAN Miniport IP devices. If a WAN Miniport IP device is listed, continue to the following step. If no WAN Miniport IP device is listed, go directly to step 16.

    6.

    Click Start, click Run, type regedit in the Open box, and then click OK.

    WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

    7.

    Locate the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}

    8.

    On the Registry menu, click Export Registry File, type backup-key in the File name box, and then click Save.

    Note You can restore the changes that you make to this registry key. To do so, double-click the backup-key.reg file that you saved.

    9.

    Click each of the registry subkeys under this key, and then view the Data column of the DriverDesc value to determine which of the subkeys corresponds to WAN Miniport (IP). For example, the 0005 subkey.

    10.

    Right-click the subkey whose DriverDesc value data is WAN Miniport (IP) (for example, right-click 0005), and then click Delete. Click Yes to confirm that you want to delete the key.

    11.

    Quit Registry Editor.

    12.

    Right-click My Computer, and then click Properties.

    13.

    Click the Hardware tab, and then click Device Manager.

    14.

    On the View menu, click Show hidden devices.

    15.

    Under Network adapters, right-click WAN Miniport (IP) and then click Uninstall. Click OK to confirm that you want to remove this device.

    16.

    Reinstall the TCP/IP protocol. To do so:

    a.

    In Control Panel, double-click Network and Dial-up Connections, right-click Local Area Connection, and then click Properties.

    b.

    Click Install.

    c.

    In the Select Network Component Type dialog box, click Protocol, and then click Add.

    d.

    Under Network Protocol, click Internet Protocol (TCP/IP), and then click OK.

    e.

    When the protocol is installed, click Close.

     

    17.

    Reset the modem by turning the power off and then on, or for an internal modem, restart the computer.

    18.

    Test your Internet connectivity.


    Also read this article to see if that will help also http://thenonapeptide.blogspot.com/2009/09/solving-pptp-vpn-error-720-on-windows-7.html

    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    • Marked as answer by Novak Wu Tuesday, December 22, 2009 6:21 AM
    Monday, December 21, 2009 3:42 AM
  • Thanks so much for the detailed answer, I'll use this in trying to get it to work.  I'm not at all sure my problem isn't the "incoming connection" setup on the target computer, which I didn't set up so I don't know the details.  We expect to be able to rebuild that machine next week, after which I'll set up the incoming connection myself, and also look at the firewall on the target computer (I have no idea what's allowed through that firewall). 

    I'm a little confused, though - you discuss the WAN Miniport (IP) at length, but AFAIK the protocol we're using is actually PPTP - should I not then do the same with the WAN Miniport (PPTP) instead?  PPTP is the only protocol that our router allows.

    If I wanted to use SSTP for the VPN:
    1) Is that possible?
    2) What ports do I have to open on the target router and target computer firewall?

    SSTP seems to be the new default for this sort of connection, it's what Win7 tried to use when I first tried to connect.  I've reconfigured my local VPN connection to use PPTP.

    I looked at the article you recommended, but he's connecting from Win7 to Server 2003, whereas my connection is from Win7 Professional to (at this point) Win7 Release Candidate (probably Professional but I'm not sure, besides it's going away).  Would the issues be the same if the connection has Win7 (and not server) on both ends?
    Thursday, December 24, 2009 10:25 PM
  • One more question:  your instructions suggest that, in Device Manager on my local machine, with Hidden devices displayed, there should be NO "WAN Miniport IP" devices.  I have 8 WAN Miniport devices under Network Adapters, only one of which is WAN Miniport IP.   Is that a problem?  This is sort of a corollary to my other question about WAN Miniport (PPTP). 
    Thursday, December 24, 2009 10:46 PM
  • Thanks for the presented solution but it doesn't work on my system.

    I can't follow the instructions written in step 1. The "Uninstall"-Button is disabled, it can't be uninstalled. The other steps i do then but it comes to no success.

    In the Event-Display there is the Event-ID 20227 and the CoID {4DC801E0-A644-409B-A071-98E444763E4C}; returned reason code 720.

    Thanks for any solutions that help.

    jpkow
    Wednesday, December 30, 2009 12:25 PM
  • You can change the VPN connection method manually in the properties of the connection.

    http://cid-25ab668da65c8fbe.skydrive.live.com/self.aspx/Windows%20images/To.png#resId/25AB668DA65C8FBE!133

    Change it to PPTP from SSTP or Automatic in the pull down.

    Also see this...

    http://blogs.technet.com/rrasblog/archive/2007/04/08/troubleshooting-vista-vpn-problems.aspx

    MS-MVP Windows Desktop Experience, "When all else fails, read the instructions"
    Wednesday, December 30, 2009 12:43 PM
  • Thanks for the answer Al Jarvi but I tried already this setting "PPTP". It doesn't function.

    The second link contains no error 720 :(
    Wednesday, December 30, 2009 12:53 PM
  • You may have an encryption type issue. Make sure they match the server. See Item 2 in that link and the link it points to.
    MS-MVP Windows Desktop Experience, "When all else fails, read the instructions"
    Wednesday, December 30, 2009 6:07 PM
  • I got my VPN working today, I'm happy to say.  I set up the incoming connection fresh on the receiving box, after the system was rebuilt; and initial testing didn't show the Error 720.  I had a remote tester working with me, and between us we managed to get the VPN working by unchecking TCP/IPv6 in the Networking configuration at both ends of the link (since I don't know enough about IPv6 to do the configuration).  With only IPv4 enabled, the VPN seems to be working fine on PPTP and the user can log in using his own userid and password.

    Thanks again for your help and good luck to the others!  On to the next problem...
    Thursday, December 31, 2009 6:52 AM
  • I am having the same problem with a slightly different situation.  I am trying to setup a VPN between my Windows 7 RC machine (host) and a Windows XP 2002 Service Pack 2 machine (server).

    I followed the at the link below and it appears that I have accommodated for every troubleshooting tip I have found.
    http://www.computernetworkinghelp.com/content/view/41/1/1/0/

    As for the first long bit of help, Case 1: both machines are using TCP/IP (IPv4) as a protocol and Case 2: PPTP is setup properly and I only have one properly working WAN Miniport (PPTP) and WAN Miniport (IP).

    I'm very stumped and can't find much help on the internet.

    Any and all advice is appreciated.
    Tuesday, January 12, 2010 9:07 PM
  • I got my VPN working today, I'm happy to say.  I set up the incoming connection fresh on the receiving box, after the system was rebuilt; and initial testing didn't show the Error 720.  I had a remote tester working with me, and between us we managed to get the VPN working by unchecking TCP/IPv6 in the Networking configuration at both ends of the link (since I don't know enough about IPv6 to do the configuration).  With only IPv4 enabled, the VPN seems to be working fine on PPTP and the user can log in using his own userid and password.

    Thanks again for your help and good luck to the others!  On to the next problem...

    I got my connection working too, by just disabling the ipv6 on the client side. Go figure...

     

    Thanks for the help.

    Friday, April 8, 2011 1:51 AM
  • A VPN 720 Error can also occur if your server's VPN configuration doesn't point to a valid DHCP server on its network.  The result is your client can't connect since it doesn't have a valid IP address to use.

    On the VPN Server, go to "Routing and Remote Access" under "Administrative Tools" and go to the "DHCP Relay Agent" configuration.  Check the DHCP server IP addresses that are listed for correctness.

    • Proposed as answer by NonUserHostile Tuesday, April 12, 2011 9:04 PM
    Tuesday, April 12, 2011 9:02 PM
  • Had the same trouble and as one of the other replies noted, it can be fixed by ensuring you aren't having an addressing problem.  I have a Win7 box that runs my Quickbooks software and sits behind a D-Link router.   I want to allow a bookkeeper to open my data file over a VPN from her WinXP machine. I opened port 1723 on the router, created an incoming connection on the Win7 box and the VPN connection on the XP box.  After ensuring that both client and server and router are set to use PPP, I still failed to connect.  I kept getting the 720 error when the client was registerng on the network with the host. I realized that since my router asigns IPs and not my VPN server/Win7 box, there was probably an issue with handing the connecting client a proper IP for my network.  found the solution to be editing the IPv4 properties so that I specified a range of IP addresses that lies within my network's IP address range.  Go to Network Connects :: Incoming Connections :: Properties :: Networking :: IPv4 Properties and select Specify IP address instead of Assign IP addresses Automatically.  Plug in a range that is on your network, OK, OK etc. and the client connects.  I suppose one could also check "Allow calling computer to specify its own IP" and then assign an address within your subnet. 
    Sunday, November 4, 2012 2:45 AM
  • Dear All,

    Have been having same problems connecting to vpn connections and getting error 720.  Had nothing to do with no ip address assigned via the remote server.

    This seemed to start after removing various vpn clients and was having a tidy up! I went through all the options using devcon etc but alas to no avail.

    In the end I took an image of my pc, prefer to use acronis, used to my win 7 ultimate CD to upgrade to Win 7 ultimate :) all applications work and the VPN problem has been resolved. I spent hours on this , and in the end it was quite a quick fix. I would like to know why the miniport driver disappeared and could not be reinstalled.

    hope my solution helps someone else, but remember ...backup before you make changes !!!

    Kind regards

    Rod Linford

    Monday, November 12, 2012 11:41 AM
  • Dont use DHCP - specifi IP range manually on RAS server



    Wednesday, December 26, 2012 11:21 PM
  • Had a error 720 when connecting to a SBS 2011 VPN. Ran fix network wizard, detected a internet port wasn't open in router, fixed it and now all good.

    Hope this helps.

    Friday, May 31, 2013 6:26 AM
  • I didn't see the solution that worked for one of our users receiving error 720 (everyone else was connecting OK) posted anywhere so maybe this will help others.

    In Active Directory, the one particular user having a problem with the VPN had different selections on the "Dial-in" tab from other users. We're not sure how "Allow access" ever got selected, but selecting "Control access through NPS Network Policy" allowed the user to connect. (See screen shot)


    You may want to try this!

    Wednesday, August 6, 2014 4:01 PM