none
RDP connection to Windows XP RRS feed

  • Question

  • Hi there,

    I'm connecting to a Windows XP SP3 via RDP and I'm experiencing slow monitor refresh rates whenever no user input is present.
    I use a program with an animation and whenever I move my mouse or press a key (like 3-5 per second) the animation runs super smooth. No user input however slows down the animation to a point where I am not able to use the program efficiently anymore.

    Is there a way to force the refresh rate to a maximum or to simulate the user input? I don't really want to sit there and spam a key all the time ;)

    Thanks in advance,
    Jan

    Sunday, August 25, 2019 9:55 AM

Answers

  • Hi,

    > Is there a way to force the refresh rate to a maximum or to simulate the user input?
    I have not found relate configuration which met your requirement until now. 

    As Windows XP has been ended of its lifecycle. It is recommended to patch it fully with Windows Update/hotfix, it would be helpful for improving the performance and security. Also, it is recommended to upgrade the system to newer OS version, such as Windows 10 if possible.

    Besides, if you use MSTSC to establish the remote desktop connection, please try below configuration:
    1. On local system, open Run, type MSTSC and end with enter.
    2. Click Show Options, and select to open Display tab, change the Colors configuration as High Color (16bit).
    3. Select to open Experience tab, under Choose your connection speed to optimize performance option, select Modem (56 kbps). And un-select all sub options.
    4. Un-select the option persistent bitmap caching.
    5. Save the change and try to establish remote desktop connection and check the result.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 26, 2019 6:34 AM
    Moderator

All replies

  • Hi,

    > Is there a way to force the refresh rate to a maximum or to simulate the user input?
    I have not found relate configuration which met your requirement until now. 

    As Windows XP has been ended of its lifecycle. It is recommended to patch it fully with Windows Update/hotfix, it would be helpful for improving the performance and security. Also, it is recommended to upgrade the system to newer OS version, such as Windows 10 if possible.

    Besides, if you use MSTSC to establish the remote desktop connection, please try below configuration:
    1. On local system, open Run, type MSTSC and end with enter.
    2. Click Show Options, and select to open Display tab, change the Colors configuration as High Color (16bit).
    3. Select to open Experience tab, under Choose your connection speed to optimize performance option, select Modem (56 kbps). And un-select all sub options.
    4. Un-select the option persistent bitmap caching.
    5. Save the change and try to establish remote desktop connection and check the result.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 26, 2019 6:34 AM
    Moderator
  • Hi,

    How things are going there on this issue?

    Please let me know if you would like further assistance.

    Best Regards,
    Eve Wang 

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, August 27, 2019 9:23 AM
    Moderator
  • Hi,

    Is there any update?

    Please click “Mark as answer” if any of above reply is helpful. It would make this reply to the top and easier to be found for other people who has the similar problem.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, August 29, 2019 6:47 AM
    Moderator