New item on Desktop renames every item


  • Hello,

    This problem is hard to reproduce because it doesn't happen every time, but I have noticed it on multiple windows 7 desktops.

    Occasionally, when I create a new document or folder I am first asked to type a name (like usual), but after typing the name and pressing enter I get an error:

    An unexpected error is keeping you from renaming the folder. If you continue to receive this error, you can use the error code to search for help with this problem.

    Error 0x80004001: Not implemented

    The options to choose are Try Again, Skip, and Cancel.  It appears that I get this error because Windows is trying to rename the Recycle Bin.  If I choose Try Again it will fail, if I choose Skip it will continue to rename EVERY ITEM on my desktop until it encounters another item that can't be renamed, or it renames every item to the name I choose for my new file.

    For example, create new folder named test.  I will get the error, choose skip or cancel, and every item will be named test (1), test (2), etc.  It's as if it applies the name to the contents of the entire desktop instead of just the new file.

    I checked the event viewer and it doesn't mention any error occurring at the time I have noticed it.  I have taken a screenshot, though.

    The crazy part is, it only seems to happen one time per reboot, and most of the time it doesn't happen at all.  I have tried selecting everything and creating a new file (it unselects everything properly).   I have tried pressing ctrl + a during a file's creation (doesn't select everything).  I have tried everything I can think of to intentionally break this simple process, but Windows seems to handle it just fine.  As soon as I am convinced that it was a one time fluke, it happens again.

    UPDATE: Pressing Ctrl + Z will undo the changes, renaming everything back to the correct name EXCEPT the new file I just created will take the default name "New folder" or "New Text Document" instead of the name I gave it.
    • Edited by QuickMana Tuesday, June 26, 2012 4:26 PM Update
    Tuesday, June 26, 2012 4:25 PM

All replies

  • Hi QuickMana,

    Error 0x80004001: Not implemented..

    - Have you made any changes to your computer prior to the issue?
    - Have you logged into your administrator account?
    Follow these steps and check if the issue persists.
    Step 1:
    Test the issue in a clean boot state.

    How to configure Windows 7 to start in a "clean boot" state


    Step 2:

    Run a DirectX Diagnostic on Windows 7
    a. To start the diagnostic, click on Start \ Run and type in “dxdiag” and click OK.
    b. If this is the first time your running this diagnostic windows will ask you for permission to check for WHQL Digital Signatures.  Click Yes to this.
    c. You will then get the DirectX Diagnostic Tool. The default tab will be System, where it lists the general information about your system and most importantly what version of DirectX you currently have installed. 

    d. The DirectX Files tab will show you if any critical files are missing. Check the Notes section for a recommendation on fixing the problem.

    Please refer KB article.

    --> Test the issue with another user account If another user account works fine, please follow the steps in the document: How to fix a corrupted user profile.

    Hope this helps.

    Mohammed Imtiyaz Ali

    Wednesday, June 27, 2012 8:19 AM
  • Hi,

    You may try to use Autoruns tool to disable the third party startup item for a test.

    Kim Zhou

    TechNet Community Support

    Thursday, June 28, 2012 9:55 AM
  • Thank you for your consideration, but I don't believe it is related to a 3rd party program as I have seen this on multiple systems with different configurations.

    In this case, my computer is a member of a Domain but I am a local administrator.  I tried today to reproduce the issue with no success.  It happens randomly enough that it's not a high priority, I was just posting to see if there was a known bug or something like that.

    Thanks again.

    Thursday, June 28, 2012 5:23 PM