none
Virtual Memory issue with Windows 7 build 7100

    Question

  • I installed the evaluation windows 7 build 7100 and every time my computer restarts I get a box saying performance options and it wants me to set my virtual memory settings but they won't hold..it keeps resetting to no paging file..I've tried everything I can think of and had a few people who are a bit more knowledgeable than I am on the computers and they can't figure it out either...I've tried clicking the "automatically manage page filing size for all drives" ..we've tried to set a custom size..and I've tried to set system managed size ..I've clicked set (there is no apply button until you say ok and back out of the virtual memory page) ..then I click apply where it prompts me to restart the computer ..which I do and when it restarts I get the same box come up for the performance options...any ideas on what I should do?? Thanx for any help.
    Monday, August 17, 2009 5:55 AM

Answers

  • This issue is likely that you need to run the command from an elevated CMD prompt.  To start an elevated CMD prompt, click the start orb, type cmd.exe, and then in the list right-click CMD.exe and choose "Run as Administrator".  Respond to the elevation prompt, and then type in the aforementioned command, and press enter.  The command should indicate it completed successfully ([SC] ChangeServiceConfig SUCCESS ).
    • Marked as answer by AngelSoles Saturday, September 05, 2009 5:08 PM
    Thursday, September 03, 2009 1:45 AM
  • Run the following from an elevated CMD prompt (you may again wish to involve one of your children, if that is more comfortable to you):
      sc config afs start= disabled

    (note that the syntax of the command is very particular - there is no space before the =, but there is one after it)

    Then, reboot.  When you log in, retry the VM configuration.

    In the event the system fails to boot, use the Last Known Good Configuration (LKGC) or Startup Repair to recover, and post back.
    • Marked as answer by Linda Yan Thursday, January 07, 2010 6:49 AM
    Tuesday, September 01, 2009 9:09 PM
  • Hi Max,

    That command sets the "start" type of the "AFS" service or driver (in this case, driver) to disabled - that is, it tells Windows not to load the driver.

    AFS is presumably some sort of "audio file system" driver.  I don't pretend to know what it is or what it does, or what an "audio file system" is (other than at least an interesting concept), but the driver apparently interferes with one's ability to set VM settings.  But others that have disabled it to address this type of behavior, have not reported any ill effects as a result of disabling it, and it does permit them to change VM settings...
    Friday, September 11, 2009 1:47 AM

All replies

  • Hi AngelSoles,

    Did you perform a "fresh" install of Windows 7 build 7100, or did you upgrade a previous install of Windows?

    What is the output of running sc qc afs from a CMD prompt?
    Monday, August 17, 2009 9:09 AM
  • Sorry for taking so long to get back to you...I couldn't get on the site (sign in issues) and I didn't know what to do what you asked..had to ask one of my kids..haha..i did fresh install windows 7 and this is the result of the CMD prompt (which I didn't know what to do)..I still have the issue..

    Microsoft Windows [Version 6.1.7100]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.


    [SC] QueryServiceConfig SUCCESS

    SERVICE_NAME: afs
            TYPE               : 1  KERNEL_DRIVER
            START_TYPE         : 0   BOOT_START
            ERROR_CONTROL      : 1   NORMAL
            BINARY_PATH_NAME   :
            LOAD_ORDER_GROUP   : SCSI CDROM Class
            TAG                : 1
            DISPLAY_NAME       : AFS
            DEPENDENCIES       :
            SERVICE_START_NAME :

    Thanx for any help you can give me
    Tuesday, September 01, 2009 8:45 PM
  • Run the following from an elevated CMD prompt (you may again wish to involve one of your children, if that is more comfortable to you):
      sc config afs start= disabled

    (note that the syntax of the command is very particular - there is no space before the =, but there is one after it)

    Then, reboot.  When you log in, retry the VM configuration.

    In the event the system fails to boot, use the Last Known Good Configuration (LKGC) or Startup Repair to recover, and post back.
    • Marked as answer by Linda Yan Thursday, January 07, 2010 6:49 AM
    Tuesday, September 01, 2009 9:09 PM
  • I just tried running the command you gave me and I received noticed that it didn't work. I got the following message:

    [SC] OpenService FAILED 5:

    Access is denied.

    I double checked and I am an Administrator. So I restarted still got the paging error then tried it again with the same results. Is it possible that the service is currently running and I have to stop it before I'm able to disable it from the start up?

    Thanks again for your help.
    Wednesday, September 02, 2009 10:47 PM
  • This issue is likely that you need to run the command from an elevated CMD prompt.  To start an elevated CMD prompt, click the start orb, type cmd.exe, and then in the list right-click CMD.exe and choose "Run as Administrator".  Respond to the elevation prompt, and then type in the aforementioned command, and press enter.  The command should indicate it completed successfully ([SC] ChangeServiceConfig SUCCESS ).
    • Marked as answer by AngelSoles Saturday, September 05, 2009 5:08 PM
    Thursday, September 03, 2009 1:45 AM
  • Wahoo...seems to have worked ...or so my son says ;)...Thank you so much for all your help..have an awesome day :)
    Saturday, September 05, 2009 5:08 PM
  • Thank you so much it worked for me too
    Wednesday, September 09, 2009 12:16 AM
  • Can someone explain wthat the command  "sc config afs start= disabled" it is disabling AFS? What is AFS?

    Thanks

    Max
    Wednesday, September 09, 2009 5:24 AM
  • I should have stated that I am having very slow performance on my XPS 1330 with 3 GB of RAM. This was an upgrade to Vista in 32 bits.

    I have been running Win 7 Rc 7100 for a few months now in another laptop (Dell as well) which is older than the XPS and have been running great and fast, which is the reason I decided to update my Vista XPS.
    The install in the older Dell was a clean one.

    Thanks

    Max
    Wednesday, September 09, 2009 5:28 AM
  • Excellent news! Thanks for reporting back that it fixed the problem! :-)
    Friday, September 11, 2009 1:44 AM
  • Good to hear, juaniquil - thanks for indicating that this also addressed a similar problem you were having...
    Friday, September 11, 2009 1:45 AM
  • Hi Max,

    That command sets the "start" type of the "AFS" service or driver (in this case, driver) to disabled - that is, it tells Windows not to load the driver.

    AFS is presumably some sort of "audio file system" driver.  I don't pretend to know what it is or what it does, or what an "audio file system" is (other than at least an interesting concept), but the driver apparently interferes with one's ability to set VM settings.  But others that have disabled it to address this type of behavior, have not reported any ill effects as a result of disabling it, and it does permit them to change VM settings...
    Friday, September 11, 2009 1:47 AM
  • I have the same problem and have tried running the commands from the cmd.exe as administrator but I get a different error

    [SC] OpenService FAILED 1060:

    The specified service does not exist as an installed service.

    The cmd root is in C:\windows\system32, I have Windows 7 32 bit installed

    I still have the virtual memory resetting problem on every restart.

    Anyone any other ideas to try?

    Thanks


    Tuesday, November 03, 2009 6:31 PM
  • Hi Clive,

    In the registry, does the following key exist?
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AFS]
    Wednesday, November 04, 2009 4:45 AM
  • Hi

    I also have the [SC] OpenService FAILED 1060 when running the command.
    The
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AFS]

    is not in my registry.

    Any idea?

    Wednesday, November 18, 2009 3:37 PM
  • I have Win 7 build 7600 and this command prompt entry solved my paging memory settings problem - plus it solved the problem with "sleeping".

    Many thanks for No.Compromise - my Win 7 install is now clean and everything works!
    Wednesday, November 18, 2009 8:46 PM
  • In that case, sbargay, it would not appear that the AFS.SYS driver is present on your system. Are you experiencing the behavior reported by AngelSoles, the original poster in this thread?  If so, consider checking what third-party drivers are installed or loaded, and systematically eliminating them as a potential candidate for the cause of the behavior.
    Thursday, November 19, 2009 3:44 AM
  • Interesting to note - thanks for the feedback, Ken, and reporting your experience!
    Thursday, November 19, 2009 3:45 AM
  • Hi

    I have discovered that when I installed RollBackRX 9.0 - it somehow corrupted my pagefile.sys - causing the behavior described by AngelSoles Users Medals.

    I uninstalled RollBack and it is working now. RollBackRX support claims they will have a new version ready soon that should be certified for Windows 7.

    BTW - I was using RollBack 9.0 on several Windows 7 machines, and it was working fine, except from this machine.


    Regards
    • Proposed as answer by aquaphx Saturday, June 05, 2010 1:04 PM
    Thursday, November 19, 2009 7:38 AM
  • Thanks for indicating what you found the problem to be, sbargay!
    Thursday, November 19, 2009 10:47 AM
  • Hi, I am having the same issue as Clive Fox and sbargay in that the command gives me "[SC] OpenService FAILED 1060: The specified service does not exist as an installed service."

    I have checked and I do not have the [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AFS] registry key.

    I've removed all recently installed software and updates since I remember having this problem but it is still there, exactly as AngelSoles described it.

    Does anyone have any further suggestion on how I can get this AFS.sys file back as it has clearoly been removed by something?
    Tuesday, January 05, 2010 8:31 AM
  • Hi, I have now fixed this problem.

    I had some scenarios that were unique to my install which may change the solution but I thought I'd share anyway in case anyone else has the same setup.

    My Windows 7 machine was booting from a VHD file and I had tried to install BitLocker also.

    It turns out that things were causing my problem:

    1) The page must exist on a phsyical partition and cannot be inside a VHD, which was the case in my scenario. To resolve this I shrank my physical partition and created a new 10Gb partition to host my page file and then set it to that partition in the 'virtual memeory' dialog

    2) Aprently, Bitlocker is not supported on VHD files, but when I'd enabled bitlocker it sets HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management/PagefileOnOsVolume to 1. This is what basically causes the issue so I set this back to 0 and rebooted. This article talks about this  http://support.microsoft.com/kb/929820

    3) I also ran check disk - I'm not sure if that diretcly helped but it certainly did not hurt.

    Regards - Martin Kearn

    • Proposed as answer by drbachrach Wednesday, May 29, 2013 4:17 PM
    Thursday, January 07, 2010 8:34 AM
  • thanks martin.....i too was loading win7 x64 from a VHD file, that i initally setup virtualized from hyper-v using win server 2008 r2.

    guess you cannot set the pagefile inside the vhd...kind of beats the purpouse of encapsulating the os in the vhd then. esp when you have multiple oses.

     

    Friday, March 19, 2010 6:26 AM
  • I am on the Me Too bandwagon here. Thanks so much my Toshiba laptop is now fixed thanks to this thread, now I just have a couple more problems to sort.  :D
    Sunday, April 25, 2010 8:50 AM
  • Cool - good to hear that you fixed that problem! :-)
    Sunday, April 25, 2010 3:17 PM
  • This issue is likely that you need to run the command from an elevated CMD prompt.  To start an elevated CMD prompt, click the start orb, type cmd.exe, and then in the list right-click CMD.exe and choose "Run as Administrator".  Respond to the elevation prompt, and then type in the aforementioned command, and press enter.  The command should indicate it completed successfully ([SC] ChangeServiceConfig SUCCESS ).


    Hi guys ;I have the same problem for last few months after i upgraded from vista to 7.I have done the CMD.exe and got success but still get the pop up window about the VM ,its getting to my nerves now any help please?

    many thanks

     

    Sunday, May 02, 2010 11:21 PM
  • What is the output of sc qc afs  when run at the command prompt?
    Monday, May 03, 2010 10:51 AM
  • Hi ,the output is ([SC] ChangeServiceConfig SUCCESS ),

    but I still get the same pop up window which is says again about VM

    many thx again

    Monday, May 03, 2010 2:22 PM
  • Note that the command that I requested output for is different than the initial command you ran.

    sc qc afs

    This will provide some details about any service known as afs on the system.  (Rather than changing the configuration.)

    • Proposed as answer by bigvolcan Monday, May 03, 2010 10:07 PM
    Monday, May 03, 2010 3:27 PM
  • Hi ,this is the output:

    Microsoft windows [version 6.1.7600]

    copyright <c> 2009 Microsoft corporation. All right reserved.

    c:\windows\system32>sc qc afs

    [SC] QueryServiceConfig SUCCESS

    SERVICE_NAME: afs

                   TYPE                           : 1   KERNEL_DRIVER

                   START_TYPE                : 4     DISABLED

                   ERROR_CONTROL        : 1     NORMAL

                   BINARY_PATH_NAME    :

                   LOAD_ORDER_GROUP  : SCSI  CDROM CLASS

                   TAG                            : 1

                  DISPLAY_NAME             : AFS

                  DEPENDENCIES            :

                  SERVICE_START_NAME :

    C:\Windows\system32>

     

    thx again

     

     

    Monday, May 03, 2010 10:26 PM
  • OK - what popup window are you referring to?  What does it say (precisely), and when do you experience it?
    • Proposed as answer by bigvolcan Tuesday, May 04, 2010 10:14 PM
    Monday, May 03, 2010 10:37 PM
  • OK - what popup window are you referring to?  What does it say (precisely), and when do you experience it?

    Hi ,each time i start the computer this popup comes up,even when i restart,it does the same:

    system properties

    windows created a temporary paging file on your computer because of

    a problem that occurred with your paging file configuration when you

    started your computer. The total paging file size for all disk drives may

    be somewhat larger than the size you specified.

                                                                                                         OK

     

    this is the first popup i get and when i press OK on that another popup comes which is:

    PERFORMANCE OPTIONS

    advanced

    processor scheduling

    choose how to allocate processor resources.

    adjust for best performance of:

    programs                                            background services

     

    virtual memory

    A paging file is an area on the hard disk that windows uses as

    if it were RAM.

    Total paging file size for all drives:           0MB

                                                                 change

     

                        OK              CANCEL             APPLY

     

    any changes i made on VM size(even when i choose Automatically manage paging file size for all drives),it doesn't matter the next time i started the computer those popup come back again.

    sorry for trouble

    thx

     

     

    Tuesday, May 04, 2010 10:42 PM
  • No trouble. :-)

    Can you boot into safe mode, make the changes to the VM settings, reboot into safe mode, and check if the changes persist, or if they get reset?

    Wednesday, May 05, 2010 10:56 AM
  •  

     JOB DONE!! thanks ever so much  "No Compromise"  after few months headache with popups, its happy time now!

     

    bigvolcan

    Thursday, May 06, 2010 10:50 PM
  • You're welcome.

    So some component is still interfering, but that component isn't loaded in safe mode and you are able to make the changes there.

    The component is likely some third-party driver that loads when the system is booted "normally" and has a timestamp prior to July 2009.  If you're so inclined, you could use Process Explorer to check those items.  Ultimately, discovering what the component is will likely be a matter of trial and error.

    • Proposed as answer by bigvolcan Tuesday, May 11, 2010 10:28 AM
    Friday, May 07, 2010 10:55 AM
  • Running 7 enterprise n x86 and have had this issue from the outset (about 4 months), but "too busy" to deal with it.  I finally had enough of it and found this workaround.  My machine and I are now on better terms...Thanks for the fix!
    Monday, May 10, 2010 2:48 PM
  • Good to hear you were able to get past this! :-)
    Monday, May 10, 2010 3:05 PM
  • You're welcome.

    So some component is still interfering, but that component isn't loaded in safe mode and you are able to make the changes there.

    The component is likely some third-party driver that loads when the system is booted "normally" and has a timestamp prior to July 2009.  If you're so inclined, you could use Process Explorer to check those items.  Ultimately, discovering what the component is will likely be a matter of trial and error.


    Hi, how do I check which component interfering with that? I mean I didn't undrstand the  use of 'PROCESS EXPLORER',sorry i'm not very good with this things.

    thx

    bigvolcan

    Tuesday, May 11, 2010 10:32 AM
  • The idea is to note the third-party drivers on your system when you're booted into safe mode and when you're booted normally.  Then compare the list and note the differences - what modules aren't loaded when you boot into safe mode compared to when you are booted normally.

    To check the third-party drivers that are loaded, boot normally, launch Process Explorer, choose File->Show Details for all Processes, select the SYSTEM process (PID 4), press CTRL+D (this will show the drivers in the lower pane), and then choose File->Save to save the report.  Do the same when booted into safe mode, and compare the reports.

    Tuesday, May 11, 2010 10:43 AM
  • I have the same issue on start up, the performance options window opens up.

    I tried restarting in safe mode making the changes and restarting again, but it continued to happen even in safe mode.

    Any other recommendations?

    Thanks

    Wednesday, May 12, 2010 1:08 AM
  • What is the outcome of running  sc config afs start= disabled

    ?

    Can you check your third-party drivers?

    To check the third-party drivers that are loaded, boot normally, launch Process Explorer, choose File->Show Details for all Processes, select the SYSTEM process (PID 4), press CTRL+D (this will show the drivers in the lower pane), and then choose File->Save to save the report. Do the same when booted into safe mode, and compare the reports.
    Wednesday, May 12, 2010 11:20 AM
  • Hi

    I have discovered that when I installed RollBackRX 9.0 - it somehow corrupted my pagefile.sys - causing the behavior described by AngelSoles Users Medals .
    thanks for the info. i had rollbackrx too, never would figured this is the cause. thanks a lot.
    Saturday, June 05, 2010 1:05 PM
  • AFS is Audio File System driver. It allows windows to read Audio CD's and presents the tracks as individual files. I'm unsure if iif disabled in the services config if Windows will properly read, play and/or present track data on an Audio CD.

    It seems Windows 7 is thinking that an Audio CD is mounted as a fixed disk and since it cannot read the disk or create a pagefile.sys on it that it causes the system to fail with the pagefile completely.

    File path for most drivers of this type is %systemroot%\system32\... I have not tried on an effected system to Expand a fresh copy of the AFS.sys but I wonder if that would be a good fix as well.

    • Edited by Rhys D Tuesday, June 29, 2010 11:58 PM added information
    Tuesday, June 29, 2010 11:56 PM
  • Some additional discussion around the origin, here.

    Not all Win7 installations have an afs.sys driver.

    Wednesday, June 30, 2010 12:44 AM
  • It's been some time since the last response to this vexed question regarding a nuisance Paging File pop Up however, I have tried the recommened command promt and  "sc config afs start= disabled" and I can report it worked for me today 30 April 2011.

    Thank you to all the above - I can now retain my sanity.

    Saturday, April 30, 2011 6:52 AM
  • Hi i have the same problem, i do everything thats stated ,till i get to the black box,what do u type in there?  what is the  aforementioned command,  i have to enter here? thanks trent
    Sunday, May 01, 2011 9:51 PM
  • Thanks, everyone. Disabling AFS worked like a charm! I think in my case, installing Adobe InDesign CS3, Design Standard CS3, Premiere and Photoshop Elements, and Acrobat 9 Pro broke it. Since I installed them each back-to-back without a reboot (I know better, but ignored common sense), so I have no idea which caused the problem.
    Jonathan Hall
    Tuesday, May 17, 2011 5:28 PM
  • I  have a small asus eee netbook which since it did not have a cd drive or a large hard drive I put windows 7 on a usb drive using pwboot project.  Everything works perfectly except the page file reset to 0 on each restart. I used the recommendations above and even in safe mode the issue persisted. Anyone have any other suggestions to correct this issue?
    Wednesday, November 16, 2011 9:46 PM
  • I had to bring the original internal drive back within the device manager and the page was able to to be placed on it while still keeping the usb operating system. 
    Sunday, November 20, 2011 6:31 AM