none
wireless adapter not working after installing hotkeys (ASUSTek, ATK0100)

    Question

  • Hello,

    I have some problems with my wireless adapter (Atheros 5700eg) on my Toshiba Sattelite L40-12K.

    I installed the Hotkey driver and Utility (made for Vista) on my Windows 7 and after that my wireless stopt working. I tried to restore the system to an earlier point but it didn't help. Also I updated the driver for Atheros 7500eg but no result. I uninstalled the ACPI/ATK0100, which left me with an unknown device in the device manager - it seems Windows is not able to install it automatically as it did with clean install of Windows 7. So I installed the Hotkey Utility again. The hotkeys work, but I rather have my wireless adapter back.

    When I go to wireless adapters in the control panel the Atheros 7500eg shows enabled ( i tried disabling and enabling again but no effect), but it finds no wireless networks. When I switch it on the small led does not light up, also now the hotkeys work a small pop up window shows the same picture as when I turn it off (the red cross in the picture of the pop up). In the device manager it says 'working properly' and it has the newest driver where it worked on before.

    Anybody an idea of what might be causing this? And, how to solve it?


    Remarkebly, I had the same problem with this laptop and this wireless adapter when I installed XP SP3 long time ago. After uninstalling SP3 and thus going back to SP2 it worked again. However, now it has everything to do with the Hotkey Driver and Utility. But the downgrading of SP3 made some changes that it worked again so maybe a clue of where the problem exists.


    Tuesday, February 02, 2010 5:18 PM

All replies

  • Your problem can only be solved by acquiring system software and drivers from Toshiba specifically for your laptop.

    I had the exact same problem on my Asus Eee PC 1000HE when I intially installed Win 7 on it.  The problem was corrected only after Asus published updated BIOS, system software, and drivers specifically for Windows 7.

    You need to contact Toshiba to see if they are going to publish updates that will correct your problem.
    Tuesday, February 02, 2010 6:29 PM

  • It did work on my Windows 7 before I installed the Hotkey Driver and Utlity.

    This means I need to get back my configuration before this installation. As written above, system restore, updating drivers and uninstalling devices did not help.

    Before I installed the Hotkey, I had no unknown devices, so I assume the ACPI/ATK0100 was installed before with a driver on the Windows 7 CD. Can I extract this driver from the CD and install it manually?

    This looks the most logical to me...
    Tuesday, February 02, 2010 6:31 PM
  • The system software and drivers are not on the Win 7 DVD.  You must acquire them from Toshiba.  And Asus software will not work on your Toshiba.  As far as I know ACPI/ATK0100 is from Asus and not from Toshiba.

    If the system is messed up you may need to do a clean install and start over.  But, you still need the system software and drivers from Toshiba.

    Go to the Toshiba website and get the Windows 7 downloads for your laptop model and series.
    Tuesday, February 02, 2010 6:54 PM
  • If I need to acquire them from Toshiba how can it be explained that my wireless adapter worked without installing anything from the Toshiba website? ACPI/ATK0100 is indeed from Asus as I mentioned in the title of my first post (ASUStek), nevertheless, it can be downloaded for Vista on the Toshiba support site for Hotkey functionality.

    My hotkeys did not work before I installed the Hotkey Driver and Utility from the Toshiba site, but my wireless adapter (Atheros 5700eg) did work without any installations besides Windows 7.

    I really appreciate your inputs but both of them make not too much sense to me.

    When I use the diagnose tool it mentions trouble but not specifiying anyhting more than that...strange.


    Maybe the Hotkey Driver and Utility installed a new device (ACPI/ATK0100), in other words, it was not there before. This would also explain why it shows an unknown device after uninstalling ACPI/ATK0100, even after rebooting. After reboot it should not be unknown anymore as there never was an unknown device before and I only installed windows 7 regarding drivers. Then I would conclude that after uninstalling ACPI/ATK0100 the device that was created during the installation is not removed, and therefore still hindering the wireless adapter.

    Is there anybody who has more specific knowledge about this? Or who knows where I can find an expert on this matter..


    Tuesday, February 02, 2010 7:17 PM
  • I know from my own expereince with my Eee PC that the ACPI/ATK0100 for Vista will not function correctly as published in Win 7.  Someone on the Eee PC users forum modifed the utility to work in Win 7.

    When Asus published all the supporting software for Win 7 the ACPI/ATK0100 was replaced entirely.  One of the notes from Asus was the ACPI/ATK0100 driver was replaced with a Hotkey Service utility.

    What is so hard about going to the Toshiba website and downloading Windows 7 system drivers and software for your laptop?  You're not going to get your system working correctly until you decide to do it the right way!

    You will find an expert at the Toshiba Support website or in a Toshiba forum for you laptop.
    Tuesday, February 02, 2010 8:03 PM
  • Thanks for your reply Rick.

    There is no Windows 7 driver for the Hotkey Utility.

    I have installed the Windows 7 driver for Atheros wireless LAN but no effect.

    available Widnows 7 drivers are: http://nl.computers.toshiba-europe.com/innovation/download_drivers_bios.jsp?service=NL


    What is the new ASUS Windows 7 version for hotkey functionality? I would like to try that one...
     
    Tuesday, February 02, 2010 8:18 PM
  • It's called Hotkey Service.  But why don't you download the software from the link you have above?  There are three different utilities there.  I don't know which one does what, but there must be something that tells you what they are.
    Tuesday, February 02, 2010 9:35 PM
  • Hi Clausule,

    Rick is right, you can't download and install Asus drivers for your Hotkey Service because it's made for Asus not Toshiba.

    You should download and try the other two utilities for it and after that install latest drivers for your Wlan card.

    Try to use different combination. Always backup your system and restore it to previous state before you try to install different utility.

    I have Asus laptop with Atheros Wlan card, using ACPI/ATK0100(Vista drivers) provided from Asus and the latest Atheros drivers with my Windows 7 Home Premium and everything is working fine because it's ASUS and it's made for it.

    Wrong combination of drivers and utilities can mess your system.

     
    Wednesday, February 03, 2010 11:55 AM
  • I will try tonight to install the utilities provided on Toshiba support site.

    Really awkward that Toshiba provides the ASUSTeK Computer Inc. Hotkey Utility 10.12 for my laptop model on their support site...


    Wednesday, February 03, 2010 12:09 PM