none
Personalize option throws Explorer.exe: Unspecified Error message - KB hotfix does not work

    Question

  • We are currently testing Windows 7 x64 which we would like to deploy in the near future (if all goes well)...

    We have disabled all Control Panel items (by Group Policy) and due to this we get an error from explorer.exe stating unspecified error when we right click on the Desktop & select Personalize.

    There is a KB article describing this issue, including a hotfix for this.  The KB article can be found at: http://support.microsoft.com/kb/982405

    We have downloaded & installed the hotfix but it does not fix this issue, when looking at the KB article, the file information says that shell32.dll should read 6.1.7600.20690 but when checking this on our machine it reads 6.1.7600.20765

    So my question now is, is it possible that the hotfix did not install because we are already using a newer version of shell32.dll?  If so, shouldn't this fix already be included in the new build that we are using?  Any advice on how to get this issue resolved would be very welcome!

     

    Monday, January 31, 2011 12:30 PM

All replies

  • No, the newer shell32.dll (LDR branch 6.1.7600.20XXX) includes the hotfix. If the fix doesn't work, contact the MS support again.

    Btw, have you tried the Sp1 RC? Do you still have the issue there?

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Monday, January 31, 2011 1:52 PM
  • We haven't tried the sp1 RC yet.

    Maybe the included fix is working partially... When we click on Personalize then we first get a popup titled Restrictions with the following message: This operation has been cancelled due to restrictions in effect on this computer.  Please contact your system administrator.

    There is only a OK button, and if we click on it then we get the Explorer.EXE - Unspecified error message.

    So I suspect that with the earlier build we would have only received the unspecified error message, while now, with the latest build, we first get a descriptive message after which we still get the unspecified error message.  So I guess that this unspecified error message should be supressed?

    Anyone else able to confirm this issue?  In the mean time I will download the sp1 RC and see whether that changes this behavior...

    Monday, January 31, 2011 2:26 PM
  • I have just installed sp1 RC and I still get the same issue: first a restrictions message, followed by an unspecified error message.

    In the mean time I have found the sp1 RTM version which I am installing now, hoping that it might fix this issue...

    Tuesday, February 01, 2011 10:25 AM
  • No, the newer shell32.dll (LDR branch 6.1.7600.20XXX) includes the hotfix. If the fix doesn't work, contact the MS support again.

    Btw, have you tried the Sp1 RC? Do you still have the issue there?

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/

    Just tried sp1 RC & sp1 RTM and both also have this issue.  I will check whether we can open a support ticket for this.  Thanks for your assistance.
    Tuesday, February 01, 2011 12:56 PM
  • ok, contact the support again and tel them that the hotfix doesn't work and you still have the issue.

    André


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Tuesday, February 01, 2011 1:46 PM