none
Cannot Access XP PC from Windows 7 PC

    Question

  • Hi, I cannot access my XP workgroup pc from my windows 7 pc. It says I do not have access, and/or permission to access the xp computers files. Can anyone tell me how to allow open sharing between both of the PC'S? Or how to set the permission? I have everything set to share on the network, no passwords needed, and the PC's are on the same workgroup.
    Friday, May 15, 2009 3:04 PM

Answers

All replies

  • I have experienced the same thing, nor can I access my Windows 7 PC, or share my printer, from any of my XP machines.  I can, however gain access to and from my wives laptop running Vista.
    • Edited by Greg63 Friday, May 15, 2009 3:11 PM
    Friday, May 15, 2009 3:09 PM
  • You might try removing the share and adding it back again making sure to open to all users
    Friday, May 15, 2009 4:04 PM
  • Same problem here. Can't access the printer on my XP machine with my Win7 machine. Says I don't have permission even though the printer is set to share.
    Friday, May 15, 2009 5:10 PM
  • You might try removing the share and adding it back again making sure to open to all users

    I'll give it a shot, thanks!
    Friday, May 15, 2009 6:49 PM
  • Still no luck.
    Friday, May 15, 2009 7:09 PM
  • Still no luck.
    Me neither, and I still cannot find anywhere in XP to change permission settings.
    Friday, May 15, 2009 7:57 PM
  • Still no luck.
    Me neither, and I still cannot find anywhere in XP to change permission settings.

    Q. How do I enable Windows 2000-like file sharing and security in Windows XP workgroups?

     

    A. In the FAQ Under Windows XP in a workgroup, why don't I see the Security tab for a file/folder?, we saw that to bring up the Security dialog box for files/folders/shares, you had to hold down the Ctrl key. To eliminate this requirement, perform the following steps:

    1. Start the Microsoft Management Console (MMC) Local Security Policy snap-in (Start, Control Panel, Administrative Tools, Local Security Policy).
    2. Expand the Local Policies branch.
    3. Select Security Options.
    4. Double-click "Network access: Sharing and security model for local accounts.”
    5. Select “Classic-Local users authenticate as themselves”, and click OK.


    6. Close the snap-in.
    7. Reboot the system for the change to take effect.

    Now you have share permissions and file security on NTFS volumes. On FAT volumes, the Security menu will remain unavailable.

    Friday, May 15, 2009 11:17 PM
  • Still no luck.
    Me neither, and I still cannot find anywhere in XP to change permission settings.

    Q. How do I enable Windows 2000-like file sharing and security in Windows XP workgroups?

     

    A. In the FAQ Under Windows XP in a workgroup, why don't I see the Security tab for a file/folder?, we saw that to bring up the Security dialog box for files/folders/shares, you had to hold down the Ctrl key. To eliminate this requirement, perform the following steps:

    1. Start the Microsoft Management Console (MMC) Local Security Policy snap-in (Start, Control Panel, Administrative Tools, Local Security Policy).
    2. Expand the Local Policies branch.
    3. Select Security Options.
    4. Double-click "Network access: Sharing and security model for local accounts.”
    5. Select “Classic-Local users authenticate as themselves”, and click OK.


    6. Close the snap-in.
    7. Reboot the system for the change to take effect.

    Now you have share permissions and file security on NTFS volumes. On FAT volumes, the Security menu will remain unavailable.

    I think thats only for XP Professional users. I have XP home, and cannot access local security whatsoever. I think Im just going to have to live with only being able to access and change files from the XP side of things. Which is ok, since I hardly ever use my XP PC.
    Saturday, May 16, 2009 12:41 AM
  • I had the same type of issue, when I was using the beta everything worked fine, I could see every machine on the network, click the machine name and view the shares, connect to the shares and even connect to the hidden admin shares (C$). Once I formatted and loaded RC1 that all changed I could no longer click on the machine name on the network and see the shares even though they are shares for everyone.

    I tried everything I could find on google but nothing worked, what did work is to change the NTLM Security Option then it worked fine. There is something odd with respect to how the beta worked and RC1 does not.

    Matt
    Saturday, May 16, 2009 2:45 PM
  • How Do I see the Security Tab in XP Home? This tip provided by Gilles Pion Go to: http://www.microsoft.com/ntserver/nts/downloads/recommended/scm/default.asp Instructions: Download the x86 (Intel) version of the Security Configuration Manager and save it to your hard disk. Double click the SCESP4I.EXE file you downloaded and extract the contents to a temporary location on your hard disk. Then open the folder you extracted the files to and locate the Setup.inf (Setup Information) file. Right click Setup.inf and select Install. After the installation is finished, reboot your computer. Disclaimer: I have tested this procedure on my XP Home installation, and it works. I cannot guarantee that it will work on your system. Make sure you create a System Restore point before proceeding. WARNING: Adjusting the permissions on a drive, file or folder can lock even the Administrator account out of that drive/file/folder. Deny Permissions take precedence over Allow Permissions, regardless of your group membership. Administrators are members of the User's group, by default. Uncheck Allow, rather than using Deny.
    Sunday, May 17, 2009 4:40 PM
  • check your firewall setting  too

    Sunday, May 17, 2009 4:56 PM
  • my xp machine sees workgroup on Win7 machine, but does not see the WinXP on the same workgroup.  any thoughts?
    Monday, May 18, 2009 1:19 PM
  • Can you try accessing it through Windows XP mode?
    Thursday, June 18, 2009 7:49 PM
  • There definitely is something screwed up with the RC version of Windows 7.    I've had a network setup for years with shared printers and drives that work on every other computer in the house (3) and was working fine with the beta version of Windows 7.    There is nothing wrong with the permission levels on the share so the suggestions above will not help.   I don't have a solution yet but noticed the following:

    1.) I get a dialog for the shares I'm unable to access asking for authentication.   OK, normally I would log in using either the guest or a valid user account on the machine providing the share.    However, Windows 7 RC is forcing the use of a domain that is the same as the Windows 7 machine.  This certainly would seem like the cause.    Also typical commands such as "net use \\Windows2000ServerShareMachine password /user:usename" fail with a system error 1326.

    2.) Listing the machines in the network, the  Windows2000 machine shows up the network.   However, another XP box on the network does not show in this list.  Funny enough, I can access the shares on that XP machine after typing the net use command above.   I'm not sure what I did but that machine for a while was exhibiting the same behavior as the Windows 2000 server one.

    Conclusions:

    A.) There is definitely a problem with Windows 7 RC with Network shares either intentionally of otherwise.  I suspect the behavior is not intentional.

    B.) It seems to be related to whether or not the Windows 7 machine views the share machine as being in the same network or not.   This one is  a guess.  Basically, a code path used for machines belonging to a domain is in some cases some how getting called for machines that are not in a networked domain but instead belong to the same workgroup. 

    Funny, for an OS that was suppose to make network sharing easy, I've never had problems like this and have spent all day on it. 


    Sunday, July 05, 2009 1:37 AM
  • UPDATE
    =====

    With regards to B, this guess is likely wrong.  I simply don't know what's going on.   I configured two machines exactly the same with the only exception being one was running Windows 2000 Server and the other Windows xp.  The Windows 7 RC machine can see the XP share but not the 2000 share.  Again I need to stress that without any changes it worked fine with Windows 7 BETA.  I'll dditionally add that all machines have the same user accounts/passwords.  They all belong to the workgroup WORKGROUP.   There is no homegroup.   The shares are configured with access permission to Everyone.  

    The fact that every other machine in my network works fine, the only conclusion that can be drawn is sharing is at least partial broken in Windows 7 RC.   I've found many threads to this extent with not a single solution unfortunately.

    The bottom line is this is a showstopper issue for Windows 7 RC.   No matter what other improvements exist I simiply cannot use an operating that won't allow me to use resources on the network that the user is authorized to.  Too bad...
    Sunday, July 12, 2009 4:15 PM
  • I agree with Scott, and been having the same problem. Can't access Windows 2000 machines with RC build 7229.


    Thoughts anyone?
    Wednesday, July 15, 2009 5:33 AM
  • I had the same problem but I solved it and now I can access, view and copy files between either Win 7 or XP computers. One mistake I was making was letting Win 7 name the network group "WORKGROUP" (don't use the default Homegroup network as it only works between Win 7 machines). I changed the network group name to the same name as the XP group, in my case it is "MSHOME". (Control Panel\Right Click Computer\Change Settings.

    Then I went  to Control Panel\Computer\ click the drive I wanted to share and right clicked on the directory I wanted to share. I chose "Share with" and Right Clicked on the top "Nobody" which displayed a Padlock then selected Change Share Settings. Then in the empty Panel I entered the name Everybody and clicked ADD. Then Right Clicked Everybody and selected how I wanted to Share. Click on Share and Win 7 does the rest.

    Glenn
    Wednesday, July 15, 2009 12:38 PM
  • I solved ONE of my network share problems with an obscure fix

    This issue may occur if the IRPStackSize registry entry on the server is set too low. I was unable to connect to XP PC  from any other PC on network. Set ip to 15 and problems went away

    I doubt seriously that this is a widespread solution but I thought I would at least mention it

    BW
    Thursday, July 16, 2009 9:30 PM
  • I've had no luck networking with XP or my OS X Mac, which are networked together fine.  Putting Win 7 into the same workgroup made no difference, nor did disabling the firewall in case that was the problem.  Have been networking Windows since 3.1 days, so I should know what I'm doing...  VERY frustrating, and also frustrating that there is no documentation that I can find from Microsoft to detail what should be done to incoroporate Windows 7 into a heterogenous network.

    Karl

    Wednesday, July 22, 2009 9:20 PM
  • I also have a network of 2 wireless XP pc's connected to a wired Win7RC pc with a usb printer. ON the Win7RC pc if I open my network & sharing centre and choose show full map; I can "see" my XP pc's but not connect to them. If I try to connect I get "remote desktop cannot connect" ensure that remote access is enabled?
    On my XP pc's I can "see" the Win7RC pc and when I add a remote printer it "finds" the printer. When I try to print it allows me to choose the printer then tells me I cannot print?
    I have searched all over this site and can find NO information from MVP's or Microsoft staff that networking XP machines onto a Win7RC machine is possible. So I can only assume that it is not possible. But if that is so why don't they tell us? It is strange that the only comment from a MCP was to ask can you connect via a virtual pc in XP mode. It seems strange that nobody knows if you can?
    With so many XP machines out there surely Microsoft will work this out before the release of the public version of Windows 7?
    Friday, July 24, 2009 9:08 PM
  • Say WHAT???
    networking works fine there is no issue with xp / 7 networking file sharing or printing
    This has been beat to death here, there are plenty of post here dealing with this.
    It is VERY SIMPLE to do, spend a few mins looking here and the answer will jump up and bite you.
    Friday, July 24, 2009 11:05 PM
  • It is difficult and complicated to network or file share XP with Win7, but the best help I have found is,

    http://www.howtogeek.com/howto/windows-7/share-files-and-printers-between-windows-7-and-xp/

    Judging by the number of hits on this thread alone, over 1500, it would seem that plenty of folk are having similar problems.
    Maybe this howto ought to be stickied to the beginning of this networking forum?
    Old Mig15 pilot. Using Windows 7 RC Vista that works.
    • Proposed as answer by wired_retired Monday, November 16, 2009 5:16 PM
    Saturday, July 25, 2009 8:47 AM
  • Davy-D
    folks are having similar problems because they do not read the posting or know how to network computers, win 7 networking is not hard it just happens to NOT BE XP HOME
    which just use simple sharing, any network admin should have no problems with networking win 7 with older versions of windows...now add older linux  (samba) into the mix and things can get a little hairy...older samba does like the login protocol that win 7 uses.

    The walk thru you posted should help anyone with file sharing.
    And yes a sticky would help but only if folks read it before hand, which as we know not many will do so.
    Saturday, July 25, 2009 1:04 PM
  •  any network admin should have no problems with networking win 7 with older versions of windows
    With respect Bubbapcguy, a network admin should not have any problems; but the folks having problems are mostly NOT network admins, they are just Mums & Dads trying to sort out their families home network which now doesn't work.
    Old Mig15 pilot. Using Windows 7 RC Vista that works.
    • Edited by Davy-D Saturday, July 25, 2009 2:27 PM I must remember to spellcheck.
    Saturday, July 25, 2009 2:26 PM
  • I've fixed this by.... from windows 7, win+r > gpedit.msc > Computer Configuration > windows settings > security settings > security options > "Network Security: LAN Manager Security Level" = "Send LM & NTLM responses"

    i didn't need to logoff or reboot for this change to take affect. Also this was connecting to a win2k server. hth
    • Proposed as answer by tyroc Sunday, June 06, 2010 8:53 PM
    Sunday, August 16, 2009 12:39 PM
  • In the Network Center you can change the way Home Group connections are managed. The default is that Windows handles things. Change that to Use user accounts and passwords.....
    Tuesday, August 18, 2009 9:33 PM
  • Thanks Shooda! You get my vote for being the #1 Windows expert on this group!  ;-)   Changing the "LAN Manager authentication level" worked for me also.  NOTE however, the policy name wasn't "LAN Manager security level" and was under Local Computer Policy > Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options > Network security: LAN Manager authentication level ..at least on my Windows 7 machine.

    Bubbapcguy, perhaps you can point me to the place in the "how to network share" guide that discusses modifying the local group policies?  I certainly did miss that when reading through a few dozen posts on this topic.   However, I agree knowing the details of LM, NTLM, and NTLMv2 authentication protocols should be common knowledge (sarcasm for those didn't get that).

    So interesting...   the default setting was NTLMv2 with my Windows 7 RC install.   I wonder what the default was for the Windows 7 beta since network sharing ***did*** work with the beta?!?!   I wouldn't be surprised if this was something particular to only a handful of installs and not wide-spread.   I guess I'll see when I do a fresh install of the release once available.

    Suggestion to Microsoft... how about a more descriptive error message such as "Remote server does not support local supported Authentication protocols.   Check your group policy settings."   Certainly a lot more helpful than "unknown username or bad password".

    Good luck everyone!
    Tuesday, August 25, 2009 3:44 AM
  • Scott You will find a few threads here dealing with the details of LM, NTLM, and NTLMv2 authentication protocols and older linux based (samba) NAS / Print servers.
    modifying the local group policies has only been needed when access to a nas / print server needed.

    Also with the removing of Windows Live Sign-In Assistant to solve some issues.

    And sorry if you took my post the wrong way, I was just saying step back and look at each setup; knowing that it can be done, many times folks get something in their mind and can not see past that.

    I have networked WIN 7 rc over 30 times in mixed networks (2000 / XP / Linux) so in comes easy now, and I forget not everyone spends 14~16 hours a day doing this stuff.




    Tuesday, August 25, 2009 1:06 PM
  • Just like to say, I had this problem with Windows 7 Beta 1, never got round to trying the RC. I fixed it in W7B1 by using \\192.168.0.50 instead of \\hostname

    More recently, I've been running Vista Ultimate and accessing the same XP machine that was giving me issues from W7B1 fine, until today, when all of a sudden after a month of no issues it starts this same issue.

    As per shooda's advice:

    I've fixed this by.... from windows 7, win+r > gpedit.msc > Computer Configuration > windows settings > security settings > security options > "Network Security: LAN Manager Security Level" = "Send LM & NTLM responses"

    This has fixed the problem for me in Windows Vista Ultimate x64, and the problem was the exact same symptom as I felt in W7B1. The \\IPAddress trick did not work for me this time however.
    Thursday, October 01, 2009 12:42 PM
  • I have a Windows XP SP3, Vista x64 and Windows 7 x64 mixed network at home as well. The Windows 7 and Vista machines had no problem networking across the home network behind a standard Linksys router. However, while the Windows 7 system could see all other PCs on the network by name, it is unable to access the XP machines by UNC share name. After reading this thread I tried using the IP rather than the system name and presto - access occurred without issue! Come on guys... Windows 7 is unable to resolve the Share Name to an IP?

    So can someone please explain what is missing or broken that allows Windows 7 to see the Computer Name on the network but not be able to resolve its IP? This is apparently a common issue. I would think if it indicates a simple but serious error if Windows 7 can connect by UNC using the IP but not the share name.

    BTW, the change to Group Policy mentioned above did not help in my situation.


    Sunday, November 08, 2009 6:44 PM
  • I've had similar issues with two windows 7 home premium upgrades not being able to access a windows server 2003 or windows xp home pc over the network.  I can access all our vista pc's just fine.  The error i was getting was 0x8003075 (or something like that) and that i could not find the network path when using the \\servername path.  I tried every registry change I could think of as well as every other answer found on the wild world of web and nothing worked when trying to connect from the \\servername\share path.  Remote desktop worked fine to the server however.  I could access the windows 7 pc from the server, but not vice versa.  Anyways, I gave up and just mapped all my drives using the IP of the server (\\10.0.0.X\share_path) address and it works fine.  This is not a select few having these issues, it is a very common issue from what I can tell.  Just have a google search on the issue and see for yourself...

    I feel sorry for any basic user that doesn't have networking experience trying to troubleshoot this issue.  Total P.I.T.A.
    Saturday, November 14, 2009 5:21 AM
  • Yeah, i think I fall into the boat you just described azarock.  I have a small network, clunker vista machine, XP pro laptop and I just upgraded my workstation to W7.  I can access see my workstation and access it's shared folders fine from both the vista box and xp laptop.  But, I can only see the vista machine from my W7 workstation.  I can't see the XP laptop.  I tried accessing it via the laptop's IP addess, but it gave me the same error.   Luckily, I was able to access my drobo by typing in the volume name.  Pretty disappointing.  I still have a lot to read through in order to get up to speed, but all the same, not great. 

    Any ideas?
    Sunday, November 15, 2009 9:45 PM
  • Glad I'm not the only one.  Having same problem as azarock.  Upgraded Vista Business 32 bit laptop to Win7 Prof 32 bit - it can *see* all my other boxes (mostly Vista Business and one Win7 Prof 64 bit), including Server 2003, XP Prof and RHEL5 but cannot access file sharing on these three - even though I can ping all three by IP and name.  Remote desktop works by name for Server 2003 and XP Prof.  Not worried overly much about Linux/Samba, that's always a challenege to get to play nice with M$ stuff anyway.

    From XP Prof, Server 2003 and RHEL5, I can access the files on the Win7 Prof 32 bit so it works in that direction.

    Have tried many suggestions from many forums but nothing works.  The Win7 Prof 64 bit workstation is fine, though - it can see every box and access file sharing, and vice versa.  Win7 Prof 32 bit laptop is on a wireless connection, wondering if there is something tweaky with that.  Have removed adapter and drivers and reinstalled just in case but no luck.

    I have been working with networking since the *olden days* and so know my way around.  Decided it is something on the laptop since all my other boxes can *play nice* with each other in this sandbox of mixed OS's...  Prior to upgrading the laptop, it happily connected to everything as well, but now is a *disaffected* family member...!!!

    Guess I'll just have to get my lazy tail up and walk over to these machines with flash drive in hand to snag files, or remote desktop into these workstations and then copy files to shared drive on laptop.  Thankfully it is only 3 machines I have issue with and not ALL of them...  Thank God for small favors, I suppose...!!!




    Monday, November 16, 2009 7:48 PM
  • IT DON'T WORK
    Thursday, November 19, 2009 7:10 PM
  • Colleagues,

    problem somehow is connected with SMB and SMB2 and Kerberos.

    NetMon shows problems with Kerberos.

    Facts:

    1. While connecting through IP address from Vista (7) to XP - NTLM used and everything working fine.
    2. While connecting through name from Vista (7) to XP - Kerberos used and it fails. Netmon shows following:

    Smb: KrbError: KRB_ERR_GENERIC (60) R; Session Setup Andx, Krb5Error (0x300) - NT Status: System - Error, Code = (22) STATUS_MORE_PROCESSING_REQUIRED

    and then nothing. Seems to be service waiting for some additional portion of data but server (XP in this case) is not provide it:-(

    3. While connecting through name from Vista (7) to Vista (7) - SMB2 is used and everything working fine (!).

    Do not understand what happened...
    Tuesday, November 24, 2009 1:19 PM
  • I have the same problem The share shows up on my XP Media Center laptop but when I try to access it I get the administrative privileges error. What's even more confusing, the same folder I cannot access now I was able to access a week ago. ALL shared folders are set up the same yet some I can access and some I can't.
    Für Elise - Support the Heart & Breast Cancer Foundations.
    • Proposed as answer by Scarface43P Thursday, December 03, 2009 2:17 AM
    Monday, November 30, 2009 12:06 AM
  • General System Information


    Windows version: Windows XP (5.1.2600) Home
    Registration Key: KG27H-JV9M6-2CXKV-GMP22-HF2BQ
    Windows ID: 55277-OEM-0011903-00101
    System Name:
    Processor Name:
    Memory Installed: 127.42 MB
    Okay. I have a Toshiba Satelite Laptop, and im atempting to network with my old celeron computer.

    The problem is this. To connect to it i have to be apart of two networks

    Network A is wirless, Through a Router and to Bigpond, Network B Is wired, and is a router acting as a hub that connects me to the old Celeron, Running XP Home.

    On the Celeron, i can see files and folders on my laptop, copy and paste them, all that jazz. From the laptop i cant. I can see NETWORK A (wich is actually called SERVER) But it says i donot have the correct permissions. Wich seems to be the problem that everyone is having.

    To get around this, i created a VPN across my router, without connecting to the internet, and Bam, theres the files on the Celeron.

    However, the VPN is mega annoying, it works great, but i have to use a program to set it up, every time i log on. Not major, but a pain in the neck.

    After all that happened, i had annother problem. I cant connect to the internet when i am connected to both networks, i have to remove the wired one. Does wired take precidence over Wireless? and how do i get rid of it?

    And for people out of ideas to network between W7 and XP Home/Prof then use this program: http://www.teamviewer.com/index.aspx

    Create two accounts, one on each. Add Both acounts to both white lists, and add your other pc as a partner.

    Make sure when you set up you install the VPN Component. Then just hit VPN and bobs your uncle.

    Hope that helped

    /Scarface43%

     P.S. Here Are My Laptop Specs

    General System Information Windows version: Windows Seven (6.1.7100)
    Registration Key: Q3VMJ-TMJ3M-99RF9-CVPJ3-Q7VF3
    Windows ID: 00447-321-7001265-70953
    System Name: Satellite A200
    Processor Name: Intel(R) Core(TM)2 Duo CPU T5550 @ 1.83GHz
    Memory Installed: 2,038.40 MB

    And The Desktop Specs
    Windows version: Windows XP (5.1.2600) Home
    Registration Key: KG27H-JV9M6-2CXKV-GMP22-HF2BQ
    Windows ID: 55277-OEM-0011903-00101
    System Name:
    Processor Name:
    Memory Installed: 127.42 MB

    • Proposed as answer by Scarface43P Thursday, December 03, 2009 2:17 AM
    Thursday, December 03, 2009 2:17 AM
  • U Rock Shooda!! after 3 hours I found this Thread worked like a charm !!! Thank A lot!
    Wednesday, January 06, 2010 12:05 AM
  • I tried every single thing I could find on this forum and others. None of the solutions worked. This is what worked for me.

    I had the following error codes:

    0x800704b3
    To fix this one I started the service Webclient. After this I still could not access any computers via \\machinename or \\132.x.x.x but it now took a while for it to fail. Before it simply failed immediately.

    After this I got the error code:
    0x80004005
    To fix this I had to start the service TCP/IP Netbios helper.

    After this I could access the network computers via \\machinename.

    Hope this helps those that could not solve the problem using the other methods.
    • Edited by ninjaphysics Wednesday, February 03, 2010 2:00 AM spelling error
    Wednesday, February 03, 2010 2:00 AM
  • I had this problem with my Home Edition of Windows 7 and XP home.

    Follow this link and perform the registry change on the XP machine. It fixed my problem immediately after a reboot of the XP.

    http://support.microsoft.com/kb/913628

    Pingboy...
    Thursday, February 04, 2010 10:11 PM
  • This solved my issue -- many thanks!

    Tuesday, March 16, 2010 6:46 AM
  • Shooda got it right for us!  THANK YOU SHOODA!

    Background: A small non-profit with an aging Win2000 server suddenly is forced to try to add a new Windows 7 notebook to the network.  Just to make it fun, the notebook was running the 64 bit version of Windows 7.

    Issue: Whenever we tried to map to the network server, Windows 7 refused to connect and kept telling us our password was invalid.  The Win7 diagnostic on the issue said we didn't have permission to access the drive, but of course we did--at least in Windows 2000 we did.

    The wrinkle: The notebook had the Home Premium edition of Windows 7, which does not contain the gpedit (group policy editor) that is needed to fix the problem.

    The solution: Upgrade the Home Premium Edition of Windows 7 64-bit to a higher version, in our case we went with Ulitimate.  Follow shooda's directions, but see Scott Albrecht's August 25 2009 post (below) as well for a variation in the path and names that we also encountered.  One of them will get you to the right spot.  If you don't get the win+r part, then click start, type in gpedit.msc (be sure to include the .msc) and follow the directions from there. We rebooted, although we probably didn't have to.  It makes me look smarter to my coworkers when I say you have to reboot, so I say it a lot.  Then try to map a folder or drive on the network.

    The result: Our spanking new Windows 7 64-bit Ultimate Edition notebook connected right away to our poor old gasping and partially fossilized Windows 2000 servasaurus.  We all did our happy dances and sat down thoroughly embarrassed that we had done our happy dances in public.

    Wednesday, April 07, 2010 7:05 PM
  • I had the exact same issue, but also have home premium edition, but I didn't want to upgrade it. Using process monitor, I tested a machine that has windows 7 professional and found out what registry key was being modified by that gpedit setting. The answer : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\lmcompatibilitylevel. It didn't even exist in the home edition. Creating it (DWORD value) and setting it to 0 caused everything to work smoothly after a reboot!
    Saturday, May 08, 2010 6:12 PM
  • Great tip! I had problems accessing files on a windows 2000 PC from my Windows 7 laptop. I followed this tip and it worked instantly, although shooda missed a step.

    win+r > gpedit.msc > Computer Configuration > windows settings > security settings > Local Policies >security options > "Network Security: LAN Manager Security Level" = "Send LM & NTLM responses"

    thx
    Sunday, June 06, 2010 8:56 PM
  • I had the same problem. I used Network Magic which came with my Linksys router and it did it all automatically by answering a few simple questions. Now I see everything on my Win 7 laptop from my XP desktop computer and vice-versa. Smooth!!! I now have the option to buy Network Magic or not.
    Saturday, June 12, 2010 5:52 PM
  • you are the best (period). :)

     


    asad malik
    Monday, June 14, 2010 9:08 AM
  • I found and ran gpedit.msc on my XP machine, but, my Network Security: LAN Manager Security Level" was already set to "Send LM & NTLM responses". I even went a downloaded Network Magic. Still I have the same permission issue.

    I tried to run gpedit.msc on Win7, but no file was found.

    Any other thoughts?

    Thx guys/gals.

    thxxxx

    Lorena 

    Saturday, June 26, 2010 4:48 PM
  • Someone should sticky this as the solution, while you're at it, pay to have this fix advertised as the #1 hit result on Google.  I've been working against this for about 5hours.  Even started to question if it was time to leave the IT field.

     

    Was leaning toward policy issues, but this saved me days of digging through local policies to figure out which one was hosing me!

     

    Kudo's to Shooda

    Saturday, June 26, 2010 5:13 PM
  • Deam it worked! I spent hours on this!

    Thanks Shooda. Just want to add:

    Default value, as documentation explains in the second tab (when editing the setting), SHOULD BE NT & NTLM, but it was not!

    After setting it to LM & NTLM (it was clear), I was able to access my XP machine again. Why it didn't work? what changed that?

     

    Luck everybody,

    Friday, July 16, 2010 9:55 PM
  • On win7, open regedit (start/run)

    Navigate to  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\

    as if it was a folder list.

    Look for lmcompatibilitylevel on right side, should be 0 or 1. If it don't exist, create it:

    - Right click/new dword
    - Name it acordly (LmCompatibilityLevel)
    - Set value to 0 or 1 (test it)

    Does the same as using gpedit, and should work on home edition.

     

    Optional: Copy/paste this text into notepad and save it ito a "NTLM.REG" file (without the --begin and --end, don't forget to use the quotations on file name!):

    --- begin

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
    "LmCompatibilityLevel"=dword:00000001

    --end

    Shuld show an icon with a with a 3 x 3 light blue cube over a sheet of paper. Open it with a dobule click and it will import the setting for you :)

    Luck!


    Yop
    • Proposed as answer by TLindsay42 Sunday, October 31, 2010 9:10 PM
    Friday, July 16, 2010 10:27 PM
  • disable your firewall on win7
    Monday, July 19, 2010 2:25 PM
  • I'm having the same problem.  2 Windows 7 PCs, one Windows 7 laptop and one Vista Laptop all can "talk" but one XP PC and two XP laptops can't.  All get internet through our same secure WPA network.  I found this video and follwed step-by-step, still no luck for me but thought I'd share in case it helps for others.  An IT guy told me we need to be running Windows 7 Pro instead of Home Premium for this to work, but the video done by Microsoft says all versions of Windows 7.  Go figure?

    http://windows.microsoft.com/en-US/windows7/Networking-home-computers-running-different-versions-of-Windows 

    Would love to hear from someone at Microsoft to clarify if what the IT guy told me was true...wanted to charge me a boatload of money to purchase upgrades for both Windows 7 PC & laptop, plus "get it all running."

    Oh, one more thing.  I am running Norton 360 on several of the units and NIS on others.  The video does suggest firewall settings may need to be adjusted if using other than Windows Firewall, and to get direction on that at Microsoft support, but I can't find anyplace on here what I should be allowing or blocking to let this work.  Anyway, I think that's why the video didn't work for me and I hope it helps others.

    Wednesday, July 21, 2010 9:42 PM
  • Here is some detailed stuff - http://windows.microsoft.com/en-US/windows7/Networking-home-computers-running-different-versions-of-Windows. You will have to check the firewall section in detail if you use anything other than windows firewall.To test this, you can switch to windows firewall and see if everything works fine.
    Potable DVD Player Home network setup
    Friday, July 23, 2010 2:33 PM
  • it's not about firewall settings. I even had disabled the firewall and it still not work.

    but the solution here to change the registry setting does work!!

    thank you, JorgeRojas and all friends here.

     

    Here the solution that work from the posting by JorgeRojas. I only do copy-paste:

    Optional: Copy/paste this text into notepad and save it ito a "NTLM.REG" file (without the --begin and --end, don't forget to use the quotations on file name!)

    --- begin

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
    "LmCompatibilityLevel"=dword:00000001

    --end

    Shuld show an icon with a with a 3 x 3 light blue cube over a sheet of paper. Open it with a dobule click and it will import the setting for you :)

    Luck!

    • Edited by Dani3l Ramawidjaja Saturday, July 24, 2010 5:52 PM fix the post to make it clear to others
    Saturday, July 24, 2010 5:36 PM
  • You need to change the registry setting on the XP or windows 7?
    Saturday, August 07, 2010 2:35 AM
  • Never mind, I got it. 
    Saturday, August 07, 2010 2:37 AM
  • Hi JorgeRojas,

    I have a similar problem.  I have 2 computers one is windows 7 Home premium, one is vista home premium.  Windows 7 can't access vista shared folder.  I turned on networking discovery on both computers, turned on share files and printer.  Since both computers have username and passwords to login to the system, I turned off the Password protection" on both computers.  I'm sure that 2 are in the same "WORKGROUP" and it's home network (I tried work network anyway) neither one is working.  win 7 however can open some public folders that vista shared, but not the shared folder.  It says I have no permission to access \\Name-PC\\folder.  I've gave full control permission.  and I've tried your change registry method. it's not working.  any help?  Thanks.

    Saturday, August 07, 2010 2:51 AM
  • For me, solution found in uninstaling Acronis True Image Home 2010. As site http://winhlp.com/node/40 refers, some software may block networking beetwen Win 7 and XP (in one direction - from 7, xp home is visible, but not accessible). 

    After unsuccessful try to access xp shared folders, error message contains terms like "permissions", "contact administrator" and "Not enough server storage" at the end.

    Mentioned "problematic" software include:

    Norton AntiVirus

    Acronis TrueImage, version 10 or 2009 or higher,

    Seagate DiscWizard (a rebranded version of Acronis TrueImage),

    IBM AntiVirus,

    Microsoft's Bitdefender, and

    Symantec EndPoint Protection (version 11+).

    In my case, disabling Acronis services and restarting didn't work, so networking succeed only after complete uninstall. On mentioned website there are some ideas for bypassing the problem without uninstalling software which I didn't try. 

    Hope this helps. 

     

    • Proposed as answer by dooge54 Tuesday, October 30, 2012 6:32 AM
    Thursday, August 19, 2010 10:40 PM
  • The answer to this is

     

    Make sure you have client for Microsoft Networks Installed

     

    i bought a windows 7 laptop and it did not have this client installed

    To Fix go to: 

    control panel
    network and internet
    network connection

    Select the network adapter you use for the net wireless or LAN

    right click it an select "properties"
    Make sure "CLIENT FOR MICROSOFT NETWORKS" is there in the list under where it says"this connection uses the fillowing items"

    if it is not click install
    select "Client" then press "add"
    select "CLIENT FOR MICROSOFT NETWORKS"

    install and reboot and you're good to go

    hope this helps you as it fixed this 100%

    i actually thought before this that microsoft had gone nuts and not allowed us to network with older computers

    • Proposed as answer by djspice uk Thursday, September 16, 2010 2:15 AM
    Thursday, September 16, 2010 2:15 AM
  • This finally fixed the issue for me.  Thanks JorgeRojas!
    Sunday, October 31, 2010 9:12 PM
  • This solved my problems, thanks you Pingboy.

    For the high tech wizards on the forum, you are not taking into consideration the vast amount of variables with any question and answer. Consider my example which is still very limited.

     

    Error message when you try to access a Windows XP-based network computer: "You might not have permission to use this network resource"

     

    Windows 7 computer can see the XP computer but cannot access any drive, folder or file.

    The XP computer can access the Windows 7 computer where permissions are set for sharing.

     

    Prior to fixing this problem I could map the network drive with \\computername\c\folder.

     

    All PC compatible computers

    All settings in Networking and Sharing Center have been checked and they look good.

    Using "Home" network with common network name on all computers.

    Windows 7 Professional computers

    Windows XP Professional computers

    Sharing is turned on for all computers as required.

    Using DHCP (no manually assigned IP addresses)

     

    Based on the nature of the problem it is most likely an improper setting on the XP computer.  

     

    Microsoft Article ID: 913628

     

    ¨       To resolve this issue, set the value of the restrictanonymous registry entry to 0. To do this, follow these steps:

    1. Click Start , click Run , type regedit , and then click OK .
    2. Locate and then double-click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    1. On the right side, double-click restrictanonymous .
    2. Make sure that the value in the Value data box is set to 0, and then click OK .
    3. Close Registry Editor.
    4. Restart the computer.

     

    Friday, December 17, 2010 4:34 PM
  • Well i faced the same problem. Tried all the stuff like enable file sharing, setting same workgroup, ...etc. Nothing helped but this:
    I noticed that there is a multiple number of network adapters in Device manager. All were hidden so one must click View and enable hidden devices. all of it were named something like ...4to6 adapter. When i removed all these adapters my file/printer sharing and networking with XP clients starts working after reboot. If there is a huge number of these adapters you have to remove it all. It can be done using appropriate (32 or 64 bit version) tool DEVCON.EXE (which is part of Windows Driver Kit - Download details: Windows Driver Kit Version 7.1.0). More can be found here The DevCon command-line utility functions as an alternative to Device Manager.
    This i have found here microsoft 6to4 adapter and solution is here Automating "6to4" Adapter Removal in Windows - RyanVictory.com - thank you Ryan.
    Saturday, January 22, 2011 7:46 PM
  • Hi,

    I had the same problem like  i cant access any folder or shared printer on a xp machine from any other pcs on the network.the problem is on the shared pc ie on xp pc.i just tried ,to set up again a network . http://www.microsoft.com/windowsxp/using/networking/setup/homenet.mspx.  And in the work group when its asked put the exsisting work group name.and enable file and printer sharing.that solved my issues.now i can access files and printers of xp pc from all the network pcs.

    Tuesday, March 22, 2011 10:30 AM
  • Say WHAT???
    networking works fine there is no issue with xp / 7 networking file sharing or printing
    This has been beat to death here, there are plenty of post here dealing with this.
    It is VERY SIMPLE to do, spend a few mins looking here and the answer will jump up and bite you.

    Who are you kidding bubbapcguy? I have had years of experience with networking before Windows 7 came along and messed it up! If you think you know all the answers perhaps you should take a look at the number of posters who, despite their experience, still find this an almost impossible task! And as for the 'VERY SIMPLE TO DO' comment you make, take another look at the number of folk who subscibe to this forum and repeatedly return because those suggestions have failed them. I'm still waiting for one of those suggestions to 'jump up and bite me', but until it does I shall continue, as no doubt many others are, burning the midnight oil!
    Wednesday, August 03, 2011 7:53 AM
  • Hi Friends,

    I was facing similar problem like, I can access my win7 from WinXP, but cannot access WinXP(Shares and RDP) from Win7. I have tried something from what i saw in this thread but didnt get through. So after some of my own trial I found the solution. Thinking like it will be good to share here so that it may be useful to others who face same issues.

    SOLUTION (Should be done on Win XP)

    1. Go to "My Network Places"

    2. Click on "View Network Connections"

    3. Select your LAN NIC, Right click and select properties.

    4. Click on "Advanced" tab

    5. Click on "Settings"

    6.  On Windows Firewall window ,  click on "Exceptions" tab

    7.  Select "File and Printer Sharing" , "Remote Desktop" &  "Remote Assistance".

    8. Click OK to all windows opened.

    Hope this will help.

     

    Regards

    Bobin


    Saturday, August 13, 2011 3:12 PM
  • The question started off "I cannot access my XP workgroup from my windows 7". Pingboy provides an answer that works!!!

    And since then we have had all sorts of "other" problems thrown in here including RC, all confusing us "simple" people who simply want an answer to the question that was asked in the first place.

    The answer provided by Pingboy to change the regedit on the XP machine worked for me whereas all the other stuff did not.

    Lesson learnt.

    And as for Bubbapcguy, if it was THAT easy then how comes what you posted didn't work for any of us either?????



    • Edited by condoghost Friday, September 16, 2011 11:47 PM
    Friday, September 16, 2011 11:46 PM
  • The solution that appears to have worked for me when two new Win 7 machines were added to a network of three XP machines and they saw some of each other in a mixed fashion, but none saw all the others. Workgroup name was set to same as the XP machines. After all machines were connected I went to each one and renamed the workgroup to a totally new name, then rebooted each machine. After doing this both 7 machines and the 3 XP machines do file sharing with no problem.
    Monday, November 14, 2011 3:24 AM
  • In first place, sorry for my English. I know the post is quite old, but the last entry was a few months ago.

    In my case, once Windows 7 was installed I never could access my xp shared drives (c$, d$). I have readed carefully all the answers and finally, for my surprise, the problem has ended.

    I have done 3 things. I have readed 2 of them in this forum.

    I have change the workgroup names to be coincidents.

    I have change  local secutiy policy "Lan Manager: authentication level" by the "LM&NTLM Sends and responds" or something similar. In Xp this was the default value while in Windows 7 the value was in blank, not configured.

    And finally (this is what has worked) I started one service in the XP machine. The service is "Remote access conecction manager" which description is "Create a network conecction".

    Afther 3 steps I could finally access my Xp share drives from Windows 7. I hope this be to help. Bye

    • Proposed as answer by Manulinx Tuesday, April 03, 2012 8:02 PM
    Tuesday, April 03, 2012 8:01 PM
  • Have you tried setting up a Username and Password that is the same on all the computers? This is "too easy" an answer, I know, but it worked for me. I could access and read the Win7 computer from the XP units but not the other way around. The win7 computer could SEE but not open folders on the XP units. By simply adding a user (from control panel) on each computer, that is the same on each drive, with the same password, and same permissions, this did the trick!

    If you have been able to see the folders but not open them (you do not have permission... dialog when you try) this will probably work great for you.

    Once this is done, you may have to adjust permissions on the files or folders, including adding rights for the new user, if some are restricted.

    See http://windows.microsoft.com/en-us/windows7/Networking-home-computers-running-different-versions-of-Windows (Article ID: MSW700032) This has quite a few steps you might try but toward the bottom if you've already done these, or want to try this, is the section: "Consider using password-protected sharing" This explains it.
    • Proposed as answer by fixitman2001 Wednesday, August 15, 2012 4:06 AM
    • Edited by fixitman2001 Wednesday, August 15, 2012 4:18 AM New information
    Wednesday, August 15, 2012 4:06 AM
  • Network magic, basically, sets itself up as a User on each computer, you can do the same thing manually by simply adding a user on each computer with the same Username and Password. You won't have to have that sticky Network Magic folder to deal with then.
    Wednesday, August 15, 2012 4:11 AM
  • For me, solution found in uninstaling Acronis True Image Home 2010.  software may block networking beetwen Win 7 and XP (in one direction - from 7, xp home is visible, but not accessible). 

    After unsuccessful try to access xp shared folders, error message contains terms like "permissions", "contact administrator" and "Not enough server 

    Acronis TrueImage, version 10 or 2009 or higher,

     

    This was exactly the case for me. I couldnt access my XP machine from W7 but accessing the W7 machine from my XP was fine. Networking was working fine for months and I couldnt figure out what changed. Acronis TrueImage 2010 was the culprit. Full uninstall and everything is perfect again. I'm glad you mentioned this and I stumbled across it FILIP. I've been going crazy and spent hours trying to figure this out and was about to give up

    Cheers!

    • Proposed as answer by dooge54 Tuesday, October 30, 2012 6:35 AM
    Tuesday, October 30, 2012 6:35 AM
  • I've fixed this by.... from windows 7, win+r > gpedit.msc > Computer Configuration > windows settings > security settings > security options > "Network Security: LAN Manager Security Level" = "Send LM & NTLM responses"

    i didn't need to logoff or reboot for this change to take affect. Also this was connecting to a win2k server. hth

    just got a new Win7Pro pc, wanted to copy over my data and couldn't get my old XP Pro machine to see shares on the new Win7.

    this fixed it for me immediately, so thanks heaps for the tip!

    I'd been pulling my hair out checking everything else!!

    Wednesday, July 10, 2013 9:20 AM
  • How many wives have you got ? I only have one "wife" and I use my wife's laptop occasionally.

    lol

    Sunday, July 21, 2013 8:25 PM
  • Folks,

    As long as the XP-based PC's share the same group name AND the XP-based PC's workgroup name is 'different' from the workgroup name assigned to the Win 7-based PC's, that's all that is necessary. It took me a full week of trial and error to find this out. It works!

    Before doing anything with workgroup names, be sure you can ping from/to each PC. If not, you have 'bigger' problems than just sharing

    As a work-around, you can also access XP-based PC's from a Win 7 PC by entering the following in the Win 7 search programs and files field:

    \\computername\shared folder name

    note: you only need to create one shared folder on the XP machine to access it (the pc)

    Sunday, July 28, 2013 4:29 PM
  • Shooda, YOU ARE THE BEST !!! Your solution works !!! I have been searching for this solution for TWO DAYS STRAIGHT. I was off duty for two years and never suspected this might happen again. There was a sudden black out a few weeks ago before I returned to my client, and suddenly all the Win 7 cannot access the Win 2003 server. But anyway, THANK YOU !!! May God bless you.
    Thursday, August 01, 2013 9:51 AM