none
[RTM] Aero Peek not available or not working RRS feed

  • Question

  • hello, I have Ultimate Final from my MSDN subscription installed. First I installed it on a notebook (C2D, Nvidia 9600GS) and got to see Aero and it's features. Especially: Aero Peek.

    Now I have it also installed on my Desktop - a much more powerfull PC (3GHz 4 core, Nvidia 8800GT). Aero Performance Index is 6.9. I have choosen an aero theme and Aero is basically working (transparency, snapping etc.). What is not working is Peek :( That means: I hover the mouse over the "Show Desktop" on the taskbar but get no transparent windows. I hover the mouse over a window preview on the taskbar but do not get the "show this window and make all others transparent".

     And what's weird: The setting in the Taskbar properties is checked but grayed out/readonly. Also, in the context menu on the "Show Desktop" Button in the taskbar, the "Preview Desktop" entry is checked but grayed out/readonly.

    In short: Desktop Preview (Peek) is "Enabled" but not working and I cannot change the setting.

    What could be the reason for this?

    Desktop machine is a dual screen setup. I disabled one screen but this made no difference. I switched between various themes but still no difference. I found a hint to a registry key, something in the line of "desktopPreviewDisabled" and it is set to "0" (=enabled as all the checkboxes indicate). I did set it to 1 and back to 0 - no difference.

    Help please
    • Edited by Jens001 Monday, August 17, 2009 6:12 AM "not working" explained
    Monday, August 17, 2009 6:07 AM

Answers

  • Update: Peek does work with a second (the admin) user that has still all default settings.

    With my normal user account I played around a lot to make it fit my needs. Now I really wonder which change caused Peek to not work anymore?



    Long time WinXP user, skipped Vista and starting to like 7
    Hi

    Try the Aero troubleshooter.

    Open Control Panel/Troubleshooting.
    Under Appearance and Personalization, select the Display Aero desktop effects.

    In the Troubleshooter dialog, click the Advanced link and place a check mark in the Apply Repairs Automatically option.

    Click Next to run the troubleshooter.

    Let us know the results.

    Thank You for testing Windows 7

    Ronnie Vernon MVP
    Tuesday, August 18, 2009 8:00 AM
    Moderator

All replies

  • Update: Peek does work with a second (the admin) user that has still all default settings.

    With my normal user account I played around a lot to make it fit my needs. Now I really wonder which change caused Peek to not work anymore?



    Long time WinXP user, skipped Vista and starting to like 7
    Tuesday, August 18, 2009 5:59 AM
  • Update: Peek does work with a second (the admin) user that has still all default settings.

    With my normal user account I played around a lot to make it fit my needs. Now I really wonder which change caused Peek to not work anymore?



    Long time WinXP user, skipped Vista and starting to like 7
    Hi

    Try the Aero troubleshooter.

    Open Control Panel/Troubleshooting.
    Under Appearance and Personalization, select the Display Aero desktop effects.

    In the Troubleshooter dialog, click the Advanced link and place a check mark in the Apply Repairs Automatically option.

    Click Next to run the troubleshooter.

    Let us know the results.

    Thank You for testing Windows 7

    Ronnie Vernon MVP
    Tuesday, August 18, 2009 8:00 AM
    Moderator
  • Hi W7Newbeeee,

    Does Ronnie's suggestion work?

    Please let us know the results.

    Thanks.

    Wednesday, August 19, 2009 5:43 AM
  • Troubleshooter reports "all issues checked" and no issues found.

    I created another standard user account and there Peek does work as well as with the admin account. So, it's something I did change in my user profile. But meanwhile I run through all possibly changed settings that I could think of and changed them back to default - still no Peek :(

    Only "Solution" I can think of is to scrap my profile and create it from scratch, sigh :(



    Jens
    Long time WinXP user, skipped Vista and starting to like 7
    • Proposed as answer by justcheck Wednesday, February 3, 2010 8:05 PM
    Wednesday, August 19, 2009 5:45 AM
  • Hi Jens,

    I suspect this issue is caused by a incorrect Group Policy issue. Could you please check it on your problem account?

    1.      Click "Start", input "CMD" (without quotation marks) to Start Search bar and press "Enter".

    2.      Please run the following commands one by one.

     

    gpresult -v > D:\gpresult.txt

    Then, check the context of gpresult.txt.

    Thank you for your cooperation.

    Wednesday, August 19, 2009 8:17 AM
  • hi,

    haven't checked GPs yet.

    But it seems the issue got solved somehow. I'm not sure what exactly helped: I wanted to deactivate some of the animations in the UI. So I opened the Advanced system settings => performance settings => visual effects. I played with the checkboxes and at some point I noticed that Peek was suddenly working! Put it back to "let windows choose ..." - Peek still working. Back to my custom settings - Peek still working!

    So, the issue is fixed for me. But I feel a bit uncomfortable, not knowing exactly what the issue was ...


    thank you all for listening :)
    Long time WinXP user, skipped Vista and starting to like 7
    Friday, August 21, 2009 6:18 AM
  • I have fixed it! go to advanced system settings -> performance -> settings and put a tick in Save taskbar thumbnail Previews.
    for some reason it works with but not without.
    • Proposed as answer by justcheck Wednesday, February 3, 2010 8:06 PM
    Sunday, August 30, 2009 2:47 PM
  • Aero peek has stopped working on both my desktop and laptop computers. The troubleshooter reports all is fine and both computers easily meet the requirements for all Aero effects. I've tried changing themes, and enabling all the video effects checkboxes, but all I get is the thumbnail view. The "Peek at Desktop" option is available (not grayed out), but toggling the setting has no effect.

    Does anyone have any ideas?
    Wednesday, September 9, 2009 9:58 AM
  • Thanks to Robinson Zhang I've found the problem with Aero Peek to be the with the local Group Policy

    To fix the problem go Start, Run gpedit.msc and navigate to Administrative Settings, Windows Components, Desktop Windows Manager and set the policy for "Do not allow window animations" to be undefined. There are entries for this in Computer Configuration and User Configuration.
    Wednesday, September 9, 2009 10:27 AM

  • I suffered from the grayed out check box also. Unfortunately for me, none of the answers listed above resolved my issue. After a bit more research, I did find the answer.  My problems was caused by a "Windows Experience Index" rating of 1.0. I guess Aero Peek will not function without a score of 2.0 or better. All I had to do is re-run the assessment. I scored a 2.0 and immediately everything worked.

    Open the system properties (Windows Key + Pause/Break key) and your score is on the opening page.
    Sunday, October 4, 2009 4:46 AM
  • Aero + Aero peek may not become active until you run the "System-Performance" test under rightclick-computer-properties.
    If you have a "1.0" there you should start the test manually. Win7 does it on it's own if you are not using the computer for a while, so Aero may "suddenly" become active. in Vista you HAD to start the test manually.

    Set
    • Proposed as answer by Setsunaaa Sunday, October 4, 2009 4:13 PM
    Sunday, October 4, 2009 4:05 PM
  • I traced it down to one of the monitors being configured for High Color (16 bit) instead of True Color (32 bit). When all my monitors were True Color, the Aero Peek worked great.
    • Proposed as answer by EvanBarr Wednesday, September 5, 2012 5:17 PM
    Friday, October 9, 2009 1:45 PM
  • hi

    I had exactly the same problem and managed to fix it now. I had LogMeIn software installed which has its own video adapted driver. When I removed logmein Aero Peek started to work nicely.
    Tuesday, November 10, 2009 7:48 AM
  • I had this problem as well. None of my windows where displaying a thumbnail, just a bar with the title and if i hover my mouse over the show desktop part, nothing would happen. i would have to click it. i was about to restart my computer. so i saved all my work and closed all my windows and it started working.

    I had the following things running in my task bar.
    Firefox
    Emperor (game)
    Outlook
    MSN Messanger and 2 chat windows
    Excell
    Game Maker
    Winamp
    My Computer
    Google Talk
    Adobe Photo Shop
    Calculator
    Notepad

    This is just an assumption, but i think if you hagve too many things open in your task bar, then it temporarly disables this feature. Or so i though

    So before restarting i opened all the same stuff again. and it disabled the feature again. So I closed one at a time untill it was inabled.

    I discovered one thing in the process. The game i was running... Emeror. I was running it in windowd mode. This is what was temporarely disabling it. I think anything that affects anything to do with color depth, resolution, or displays will disable this.

    If you have this problem, i would recommend pressing CTRL+ALT+DEL, then click "Start Task Manager" then click the Processes tab and slowly, one at a time, start ending your processes that are started by the user, not SYSTEM. Hopefully it is as simple as a program running in the background that is affecting it.

    :)
    Thursday, December 3, 2009 5:04 AM
  • Had the exact same problem as the author. setting in taskbar was checked (enabled) but greyed out. Aero peek was not working. Fixed it by following above instructions to run Troubleshooting (in Control Panel) for Appearance ("Display Aero Affects"). The problem was this: Desktop Windows Manager was Disabled , the troubleshooter enabled it automatically for me and all is well. Don't know why it was disabled since it's a fresh installation, but whatever - it works!
    Saturday, December 5, 2009 8:14 AM
  • I had the same issue with Win7 AERO PEEK stopping on me and I cannot pinpoint the exact cause either, (However I did have System assesment going at the time, after it was done and I closed a couple windows AERO-PEEK Started working again...
    Press ENTER to look up in Wiktionary or CTRL+ENTER to look up in Wikipedia
    Tuesday, December 8, 2009 6:39 AM
  • Same issue(s).  Aero Peek broke.  Troubleshooter found a problem with mirror drivers, and Windows Experience Index had not been run.  Ran index (4.0) and in device mgr -> display adapters I found HP RC Mirror Driver.  Disabled it, reboot, Aero Peek works.  Hope this helps.

    HP tx2z-1000 tablet, 8GB, W7Ultimate x64.


    [Edit]Also, thanks to the suggestions above to steer me in the directions that helped the most.[/edit]
    Tuesday, December 8, 2009 12:37 PM
  • I'm having a similar issue.  Aeor peek works fine after a reboot.  It seems to fail after going to sleep or resuming from sleep mode while running on battery.  I've tried the various fixes above with no luck.  Any other ideas?
    Monday, December 14, 2009 4:19 PM
  • I'm having a similar issue.  Aeor peek works fine after a reboot.  It seems to fail after going to sleep or resuming from sleep mode while running on battery.  I've tried the various fixes above with no luck.  Any other ideas?

    I know sometimes that a computer will disable things when running on battery mode. Chances are that it is disabeling unnessisary things and one of which is Aeor Peek. Try not running on battery, and then resume from sleep and see if you still have the problem.

    if you dont have the problem after resuming then you will have to try and look for something along the lines of power management options on your laptop and see if it tells you to disable certain things.

    If you still have the problem then i will have to guess updating your video card drivers and see if that helps because i believe that this feature of Win7 is disabled when something else is affectiong or using your graphics card and im guessing your resume is not resuming your card properly, that is why you restart and it works.

    hope this helps ;)
    Monday, December 14, 2009 4:27 PM
  • I know sometimes that a computer will disable things when running on battery mode. Chances are that it is disabeling unnessisary things and one of which is Aeor Peek. Try not running on battery, and then resume from sleep and see if you still have the problem.

    if you dont have the problem after resuming then you will have to try and look for something along the lines of power management options on your laptop and see if it tells you to disable certain things.

    If you still have the problem then i will have to guess updating your video card drivers and see if that helps because i believe that this feature of Win7 is disabled when something else is affectiong or using your graphics card and im guessing your resume is not resuming your card properly, that is why you restart and it works.

    hope this helps ;)

    Once the aero peek stops working, I need to reboot to get it back.  Resuming from sleep/hibernate while plugged in makes not difference at that point.  So far I have tried recreating my user profile, updated by video driver multiple times, and some of the tips listed above.  Nothing seems to help.  A few others in my company are starting to experience this as well.

    At this point I'm at a total loss.  I have learned to get by using Cntrl-click on my taskbar icons.  It will cycle through the windows for the selected icon.  It's not great, but it prevents unnecesary reboots.
    Monday, December 14, 2009 4:37 PM
  • I know sometimes that a computer will disable things when running on battery mode. Chances are that it is disabeling unnessisary things and one of which is Aeor Peek. Try not running on battery, and then resume from sleep and see if you still have the problem.

    if you dont have the problem after resuming then you will have to try and look for something along the lines of power management options on your laptop and see if it tells you to disable certain things.

    If you still have the problem then i will have to guess updating your video card drivers and see if that helps because i believe that this feature of Win7 is disabled when something else is affectiong or using your graphics card and im guessing your resume is not resuming your card properly, that is why you restart and it works.

    hope this helps ;)

    Once the aero peek stops working, I need to reboot to get it back.  Resuming from sleep/hibernate while plugged in makes not difference at that point.  So far I have tried recreating my user profile, updated by video driver multiple times, and some of the tips listed above.  Nothing seems to help.  A few others in my company are starting to experience this as well.

    At this point I'm at a total loss.  I have learned to get by using Cntrl-click on my taskbar icons.  It will cycle through the windows for the selected icon.  It's not great, but it prevents unnecesary reboots.

    mmm, ok, then i am at a loss as well :O. If i come accross anything i will post it here for you. ;)
    Monday, December 14, 2009 4:41 PM
  • "Use aero peek" was greyed out in my taskbar settings.
    After trying most of the recommendations here this is what worked for me :
    • Disable and re-enable Aero Peek. (Yep thats all)
    1. Quickly go to advanced performance options by typing "adj app" in the start menu search box and selecting "Adjust the appearance and performance of windows"
    2. Uncheck the "Enable Aero Peek" checkbox and Apply.
    3. Check the "Enable Aero Peek" checkbox and Apply.

    Note: I temporarily changed my account from Standard to Administrator before making these changes for the following reason:
    • The normal procedure to get to the Performance Options is to go through Advanced System Settings which requires Administrator privileges. I thought that logging in with an administrator account to change these settings might save the settings in the wrong account.
    However, a standard user can get to the performance options using step 1, so changing to administrator is probably unnecessary.
    Friday, January 15, 2010 6:22 PM
  • What worked for me was simple;
    I type AERO on the START menu search bar 
    and clicked on "Find and Fix Problems with Transperancy and Other Visual Effects" and it fixed it for me.

    • Proposed as answer by welsh jon Wednesday, October 13, 2010 2:38 PM
    Sunday, January 17, 2010 3:44 AM
  • I am having the same problem.  Aero works fine until computer goes to sleep.  After it wakes up Aero does not work anymore.  Someone mentioned something about the Windows Experience Index.  What I have noticed is that after my desktop computer goes to sleep and then I wake it up the Windows Experience Index is all blank like it was never run.  I click the Rate this computer button and tests run and gives me the rating.  Put computer to sleep, wake computer up and the rating says never run again.  Reboot computer and ratings are there put computer to sleep, wake up computer and it says rating was never run.  Because there is no rating Aero will not work.  Seems like a Aero is not the problem but a symptom of Windows Experience Index being wiped out by the computer going to sleep.
    Is anyone else seeing this?
    Tuesday, January 19, 2010 5:38 PM
  • I have the same issue as Havrek has and I never found a solution. I have emailed Microsoft, my computer maker (HP), AMD as well as MSI (my motherboard). They are all confused by this and don't have a clue. I have tried everything mentioned on the web and from those I emailed. I have three HP computers and only one has problems with Aero Peek not  working out of sleep mode. Really strange. If anyone figure this out post here... please.
    Saturday, January 23, 2010 11:08 PM
  • hey when in visual effects you just need to check "save tasbar thumbnail previews" and click apply. Thanx for your info or else i would of still been stuck.
    • Proposed as answer by justcheck Wednesday, February 3, 2010 8:05 PM
    Wednesday, February 3, 2010 8:04 PM
  • 100% worked for my notebook. thanks ronnie!
    Thursday, February 18, 2010 3:52 PM
  • 100% worked for my notebook. thanks ronnie!

    Hi

    Glad this helped.

    Enjoy.

    Thank You for using Windows 7


    Ronnie Vernon MVP
    Thursday, February 18, 2010 8:46 PM
    Moderator
  • I am having the same issues with Aero Theme. I did all the fixes mentioned before I created this account. Here's the list of what I've done :

     

    1. Enabled Windows Desktop Manager

    2. Updated my video card's driver (Radeon 4670) , I even used my mobo's video card (Radeon 3200), didn't work.

    3. Ran the test, got a 6.8 score on Graphics (5.5 overall) using my video card, 3.2 when using the motherboards onboard VC.

    4. Ran the test on Aero, checked the Apply Repairs Automatically. It said that the "Current theme doesn't support Aero" though I made sure   that the setting is still set to Aero theme and "Desktop Windows Manager is disabled" which is not true cause I made sure it's enabled before and after I did the auto fix. (I also stopped Desktop Windows Manager then enabled it again, rebooted the PC, didn't work.)

    5. Checked all the boxes Performance Option => Visual Effects. I noticed that even if I check "Enable desktop composition" and Use Visual Styles on windows and buttons" boxes, then click Apply, it will revert to it's previous setting when I open up Performance Options. That was under Custom though. When I put a dot on Let Windows Choose, "Save taskbar thumbnail previous" has the problem.

    6. Played with the resolution, True Color 32bit is enabled.

    7. Opened Task Manager, I ended some processes one by one (users only not system).

    8. Download the registry fix to Enable Aero. Added UserMachineCheck, Animations and Blur manually, all REG_DWORD type, all three got a value of 0.

    9. Checked All Programs for those applications that comes with Mirror Drivers, nothing found. Checked Device Manager, nothing with Mirror Drivers shows up.

    10. Tried System Restore, the weird thing is that it's saying that I don't have any Restore Points, though I've done a lot of system restore in the past. Created some restore points as well.

    11. Did the gpedit.msc procedure, disabled "do not allow desktop composition" on both User and Computer. Didn't work. Switched it back to Not Configured, didn't worked as well.

    I am trying to think what else I've done within the past 2 days, but all in all my system's Aero theme is still not working, "Use Aero Peek to preview the desktop is still checked, but grayed out, nothing worked for me. Can you please advice if I need to reformat and reinstall my OS? HELP!

    Wednesday, May 26, 2010 8:02 AM
  • anyone who can help me out?
    Friday, May 28, 2010 6:28 AM
  • What worked for me was simple;
    I type AERO on the START menu search bar 
    and clicked on "Find and Fix Problems with Transperancy and Other Visual Effects" and it fixed it for me.


    this worked for me thanks
    Sunday, July 11, 2010 9:06 PM
  • arter i aero troubleshoot the problem is fixed until i restart my computer it is disabled again! It will not stay,what should i do?
    Tuesday, July 13, 2010 5:51 PM
  • I think this is what's happening to my desktop now. When I check Screen Resolution > Advanced settings > Monitor tab, its Monitor Type says "Generic PnP Monitor (DPMS)". Clicking on the Properties brings up the "Generic PnP Monitor (DPMS)" property window w/c says LogMeIn, Inc. as the Manufacturer.

    Will try to uninstall LogMeIn to confirm.

    Tuesday, August 17, 2010 1:17 PM
  • Open  "Services.msc"   Check to Automatic or Active the service "Desktop Window Manager Session Manager"  good luck
    Thursday, August 19, 2010 5:34 PM
  • Hey Ronnie

    Thanks Dear it worked for me..

     

    Thursday, September 2, 2010 2:05 PM

  • Try the Aero troubleshooter.

    Open Control Panel/Troubleshooting.
    Under Appearance and Personalization, select the Display Aero desktop effects.

    In the Troubleshooter dialog, click the Advanced link and place a check mark in the Apply Repairs Automatically option.

    Click Next to run the troubleshooter.

    Let us know the results.

    Thursday, September 2, 2010 2:07 PM
  • This one worked for me way to go and thanks.....

    Tuesday, September 14, 2010 6:24 PM
  • I was having similar behaviour discussed in this thread in that a) when hovering over programs in the Task Bar peek was not displaying the preview window and b) when hovering over the show desktop rectangular button in Task Bar this was not 'peeking' at my desktop.

    The suggestion posted by Calros Antunez solved both the problems.

    Wednesday, October 13, 2010 2:43 PM
  • Dear all,

    I tried most of the above solutions but none worked for my problem.  What worked for me is resetting my graphics driver back to default settings.  I hope this helps at least some of you out there.

    Cheers,

    John.

    Friday, October 22, 2010 4:14 PM
  • I had the same problem. Hit let windows choose whats best for my computer, took off save taskbar thumbnail previews, hit apply. Peek worked. Then hit adjust for best appearance, apply, worked. Thanks for the tips :)
    Thursday, December 2, 2010 9:57 PM
  • Update: Peek does work with a second (the admin) user that has still all default settings.

    With my normal user account I played around a lot to make it fit my needs. Now I really wonder which change caused Peek to not work anymore?



    Long time WinXP user, skipped Vista and starting to like 7
    Hi

    Try the Aero troubleshooter.

    Open Control Panel/Troubleshooting.
    Under Appearance and Personalization, select the Display Aero desktop effects.

    In the Troubleshooter dialog, click the Advanced link and place a check mark in the Apply Repairs Automatically option.

    Click Next to run the troubleshooter.

    Let us know the results.

    Thank You for testing Windows 7

    Ronnie Vernon MVP

    it showing troubleshooting couldnt identify the problem
    Tuesday, December 14, 2010 7:34 AM
  • gud work... resolevd in a click. thnxxxx
    Sunday, January 16, 2011 6:43 AM
  • @Ronnie Vernon

    This worked perfectly for me. ^5

    Kind Regards


    Jason www.maury411.com
    • Edited by JHBowles Wednesday, March 2, 2011 5:57 PM To properly address the correct user
    Wednesday, March 2, 2011 5:56 PM
  • I disabled the Logmein  Mirror Driver in the device manager - display adapters (although never had problems with it before. Suddenly today out of nowhere...
    Sunday, May 22, 2011 9:30 AM
  • Dear all,

    I tried most of the above solutions but none worked for my problem. 

    Confirm.What is new in my problem,that in System properties/advanced/settings/visual effects___ the option  of " enable Aero Peek" is absent.At all.Doesn't appear in the list.Any suggestions?
    Best regards

    Zak


    Resolved!!!!Just installed a theme from this wonderfull site http://www.window7theme.com/ and everything started to work properly


    Wednesday, July 27, 2011 4:02 PM
  • Finally!! Figured it out :D
    1. Go to start
    2. Type 'services.msc'
    3. Scroll down until you find 'Desktop Window Manager Session Manager'
    4. Click  'Restart this service'
    Done :D :D
    Saturday, August 6, 2011 8:02 AM
  • it works! thank you very much! ^^
    Friday, August 19, 2011 11:58 AM
  • I had a major problem with getting aero peek enabled.

    Finally after Troubleshooting-> instead of clicking display aero desktop effects, i clicked on Appearance and Personalization. and the performace settings appeared, all i did was to custom, uncheck aero peek and surprisingly, my aero peek came back to me after days!!!

     

    After so much of searching the net for answers in vain, tried everything and finally i got it to work.

    !! :) 

    Saturday, September 10, 2011 10:17 AM
  • Remove any adapters that do not belong to the computer, display adapters drivers if the hardware is not related to a computer (like logmein device), should be removed from the system
    Then you can see results
    • Proposed as answer by asa121 Monday, September 26, 2011 7:24 PM
    Monday, September 26, 2011 7:24 PM
  • I did the troubleshooter and it worked like a charm. My Windows desktop manager was turned off. Troubleshooter turned it back on and Aero Peek came back up.

     

    Thanks for the help!

    Wednesday, October 5, 2011 10:28 PM
  • This didn't work for me.  Nothing I've tried has worked. 
    Friday, October 7, 2011 6:29 AM
  • OK - I'm not sure why everyone is being SO complicated. Here is THE answer. Click on the start button and search for: "adjust the appearance and performance of Windows". When you click on the link, it should take you to a box which says "performance options" at the top and it should default to the tab titled "visual effects".  On this tab there are many boxes to check/uncheck and one of the boxes is titled "Enable Aero Peek". More than likely, yours will be unchecked. Put a check on "Enable Aero Peek" and click OK. There. Done.
    Tuesday, October 25, 2011 6:32 PM
  • This Worked....

    Thanks

    Monday, October 31, 2011 11:58 AM
  • Hey I searched forum, after forum, after forum and tried about everything to get the aero peek to work again. After trying everything above and everything on the other forums (which none helped) I figured it out on my own and it was EASY. Start - Right Click "Computer" - Properties - Advanced System Settings - Under Performance click settings - Click on Adjust for Best Appearance and Apply.

    If this doesn't work apply for Best Performance first and then Best Appearance. It seems to reset or restart something that is hidden in the check boxes below.

     

    Hope this works for everyone else

    Monday, December 26, 2011 4:16 AM
  • This solved my problem, too.  I was trying all the other suggestions to no avail.  The lack of Aero-peek was not affecting my usability, it was just bugging the heck out of me because I couldn't figure it out.  Thanks for saving me from wasting any more time on this!!!
    Monday, December 26, 2011 8:37 PM
  • No problem. Glad I could help.
    Monday, December 26, 2011 10:34 PM
  • Please Consider: If you are not currently using "Aero Themes" under "Personalization"...In other words, you downloaded some photo to use as your desktop image, then "Enable Aero Peek" does not even appear in the visual effects options. You can try 1000 suggestions and still have aero peek greyed out in the system tray area button.  You must select Aero Themes in order to have the Aero Peek option.

    Good luck!



    • Edited by PapaTerry Tuesday, March 6, 2012 12:28 AM
    Monday, March 5, 2012 10:34 PM
  • I traced it down to one of the monitors being configured for High Color (16 bit) instead of True Color (32 bit). When all my monitors were True Color, the Aero Peek worked great.

    This is the one that fixed it for me.  Thanks.

    www.ProjectInVision.com

    • Proposed as answer by PCfriendly Friday, October 26, 2012 6:33 PM
    • Unproposed as answer by PCfriendly Friday, October 26, 2012 10:30 PM
    Wednesday, September 5, 2012 5:19 PM
  • (Sry I proposed the above reply a solution, oops new to this forum)

    I tried everything on this forum and more!  My problem was, no transparency, no switcher, no preview when hovering over bottom window tabs, no aero option in system performance tab, and the aero troubleshooter didn't resolve my issue.  The service was running, but the troubleshooter would report it was not.

    What solved it for me was I had an extra display driver/adaptor in the device manager.  A 3rd party app to run my tablet as a display installed a display driver that prevented aero from running.  Removed the driver, rebooted, and aero came alive again in full!

    • Proposed as answer by PCfriendly Friday, October 26, 2012 9:42 PM
    Friday, October 26, 2012 6:42 PM
  • Dear all,

    I tried most of the above solutions but none worked for my problem. 

    ...in System properties/advanced/settings/visual effects___ the option  of " enable Aero Peek" is absent. Doesn't appear in the list.Any suggestions?

    Likewise, many of the Visual effects options in my Windows 7 PRO are not there.  The list looks like the Visual effects option list of the Windows 7 Home version. This just suddenly happened last week.  Any ideas how to get the full option list for 7 Pro back? 

    Thanks.

    Thursday, November 29, 2012 9:10 PM
  • Update: Peek does work with a second (the admin) user that has still all default settings.

    With my normal user account I played around a lot to make it fit my needs. Now I really wonder which change caused Peek to not work anymore?

    my aero peek was greyed out, I tweaked with theme fonts and a few theme settings then checked aero peek, It was ticked and UNTICKABLE it works now, lol haha create a new profile gimme a break geta  clue, besides reg fixes abound for these greyed out type of instances its always fixable one way or another, specially with a reg script to change the greyed out to usable tickable option once again, anyway safemode it if you have to and get your windows aero peek back peace out and stop blabbing about creating a new profile for this troublesome greyed out aeropeek good lord you guys some of ya are far too extreme and way off base and troubleshooting resoultions to mundane issues... peace out njoy your  pc time get multimedia tool heaven ...<<< www.mowtools.ourtoolbar.com from  novice beginner way up to xtreme pc elit power hungry users will find all the multimedia on and offline apps in this fine toolbar lifesavers get it while its f free peace out!


    Long time WinXP user, skipped Vista and starting to like 7

    Hi

    Try the Aero troubleshooter.

    Open Control Panel/Troubleshooting.
    Under Appearance and Personalization, select the Display Aero desktop effects.

    In the Troubleshooter dialog, click the Advanced link and place a check mark in the Apply Repairs Automatically option.

    Click Next to run the troubleshooter.

    Let us know the results.

    Thank You for testing Windows 7

    Ronnie Vernon MVP

    Wednesday, December 5, 2012 7:43 AM
  • My Aeropeek quit working after a Microsoft update, and when I run the test mentioned above, it says "Mirror drivers don't support Aero effects  -- not fixed" with no other options for repair. I also upgraded all my Intel Video drivers and still cant get it to work.
    Saturday, December 8, 2012 3:32 AM
  • THANKS A MILLION BOGUT!!!!!!!!!!!!!!!! i was trying everything with no luck, but this worked just fine. 
    Monday, March 3, 2014 10:18 AM
  • I had this problem: after a fresh install of windows the theme was on custom with " Windows Color" as the color. this makes everything xp like and pffft. Because of this aero can't work. When i clocked a normal theme the color changed to the nice looking block you can change with the sliders. : Aero working.
    Wednesday, June 11, 2014 1:52 PM
  • FOLKS, I had the same issue and I have fixed mine in 1 minute. I have no idea what the cause was, however, here is what I did.....

    1.  Copy the c:\windows\resources\Themes\AERO folder from a machine that AERO works on

    2.  Paste them into the same directory on the machine that the AERO does not work

    3.  Apply an AERO theme

    My AERO folder was labeled AERO.old for some reason.  When I pasted in the folder, making it a standard c:\windows\resources\Themes\AERO listing, then applied an AERO theme, glass effects and such were there instantly.

    Hope this helps.

    Greg C.

    Wednesday, December 16, 2015 5:58 PM
  • thanks a lot this worked for me :)
    Friday, July 28, 2017 1:15 PM